
Windows, like all operating systems, is a
launching pad for programs, or applications.
More programs from more software firms
are available for Windows than for any other
OS. Fortunately, Microsoft and sound design
enforce substantial consistency, so you can
apply knowledge of a few common operations
to many programs. Most programs share user-
interface elements—scroll bars, copy-and-paste
functions, menus, buttons, and so on—as well
as setup and management options.

In this chapter, you’ll learn how to install,
remove, launch, and manage Windows pro-
grams. You’ll also learn about documents,
which are self-contained pieces of work
(files) that you create with programs.
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Installing Programs
How you install a program depends on
where its installation files are located. Most
shrink-wrapped programs are installed from
a CD or DVD. Windows’s AutoPlay feature
runs the Setup program automatically when
you insert the disc into the drive. You also
can install programs from the internet or
from a network.

To install a program from CD or DVD:

1. Insert the program’s installation or 
setup disc.

If a security prompt appears, type an
administrator password or confirm 
the action.

2. If the program launches an install wizard,
the AutoPlay dialog box will appear, and
you can choose to run the wizard
(Figure 6.1).

or

If a program doesn’t start to install, check
the installation instructions that came
with the program (or on the publisher’s
website). If you can’t find instructions,
browse through the disc and open the
program’s setup file, usually named
setup.exe or install.exe.

3. Follow the onscreen instructions 
(Figure 6.2).
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Figure 6.1 When you insert a program’s disc, the
AutoPlay dialog box opens; click the option that runs
Setup. You may see a vague or puzzling message
when you try to install older programs made for
Windows 95/98.

Figure 6.2 This example is the first page of an install
wizard for an Adobe package. Install wizards usually
make you pick a language, specify a destination folder,
accept a license agreement, choose which components
to install, and type a serial number or product key from
the CD’s envelope or registration card.
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✔ Tips

■ During lengthy installations, you can
switch to other programs and hover your
mouse pointer over the install wizard’s
toolbar button to check its progress
(Figure 6.3).

■ If you’re installing an older DOS-based
program from a floppy disk, try running
it from a command prompt. See “Using
the Free Utility Programs” later in this
chapter.

■ Software publishers create install wizards
with third-party programs such as
InstallShield, Wise Installer, or
Microsoft’s Windows Installer, so you’ll
see those program names in title bars.

continues on next page
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Before You Install

Keeps these points in mind before you install a new program:

◆ You need Administrator credentials to install programs; see “Setting up User Accounts” in
Chapter 17.

◆ Your PC’s manufacturer may have added software—Microsoft Office or a virus scanner,
for example—at the factory. Check the Start > All Programs menu before you install new
stuff.

◆ Most installations go smoothly, though Windows’ security features won’t let some poorly
designed or malicious programs harm your system by installing outdated drivers or system
files that Microsoft knows to be dangerous.

◆ If you upgraded to Vista from Windows XP, Windows Setup configured your existing 
programs to run; you don’t have to reinstall them. If an older program doesn’t run in
Vista, see “Running Older Programs” later in this chapter. If you were a member of XP’s
Power Users group, which Vista has dropped, you still have the same privileges and can
install programs.

Figure 6.3 If you’re using the Aero color
scheme, a live progress bar appears in the
pop-up thumbnail on the taskbar.
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■ After installation, the program’s shortcuts
are highlighted in color in the Start > 
All Programs menu. To turn off high-
lighting, right-click the Start button and
choose Properties > Customize, uncheck
Highlight Newly Installed Programs, and
click OK.

■ To configure AutoPlay for program discs,
choose Start > Control Panel > Hardware
and Sound > AutoPlay > Software and
Games drop-down list (Figure 6.4).
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Figure 6.4 The Software and Games drop-down list
lets you choose what happens when you insert a
program disc. The default setting, Ask Me Every Time,
launches the AutoPlay dialog box shown in Figure 6.1.

Who Can Use the Program?

A program installed by you—or any administrator—is available to all users by default; its
shortcuts appear in everybody’s All Programs menu. Sometimes shortcuts end up in your
personal All Programs menu because you (inadvertently) told Setup to do so or because
Setup gave you no choice. Recall from “Using the Start Menu” in Chapter 2 that Windows
inspects two folders to build the All Programs menu: one for All Users and another for the
logged-on user. To make a program available to everyone (instead of only you), do the following:

1. Choose Start > All Programs.

2. Right-click the item (icon) that you want everyone to be able to access and choose Copy.

3. Right-click the Start button and choose Open All Users.

4. In the folder tree, right-click the Programs folder and choose Paste.

If a security prompt appears, type an administrator password or confirm the action.

Now the program appears in everyone’s All Programs menu. If this method doesn’t work, or if
a program requires per-user settings, log on to each user account and rerun Setup.
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The internet is the preferred (sometimes
only) distribution method for many software
vendors. You can use Internet Explorer
(Chapter 14) or any web browser to down-
load thousands of commercial, shareware,
demo, and free programs (and updates) from
vendors’ websites and from independent
sites such as www.download.com and
www.tucows.com.

To install a program from the internet:

1. In your web browser, click the link to 
the program.

2. To install the program immediately, click
Open or Run (Figure 6.5), and follow 
the onscreen instructions.

or

To install the program later, click Save
and download the installation file to your
computer. (To install the program, double-
click the file and follow the onscreen
instructions.)

In either case, if a security prompt
appears, type an administrator password
or confirm the action.
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Figure 6.5 The Save option is safer because you can
scan the downloaded file for viruses if you don’t trust
the website. It also leaves a copy of the program on
your hard disk if you have to reinstall.
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✔ Tips

■ By default, Internet Explorer and other
Vista-aware browsers store downloads in
the Downloads folder inside your personal
folder. You can use the Save As dialog box
to pick a different place (Figure 6.6).

■ Downloaded programs usually are exe-
cutable (.exe) files, which run when you
double-click them and start installation
automatically. If the download is a zip
archive, extract its files (see “Compressing
Files and Folders” in Chapter 5); then
look for a read-me file (readme.txt or
readme.html) or double-click the installer
program (usually named setup.exe or
install.exe) among the extracted
pieces. You can delete these pieces after
you install (keep the original zip file if
you need it).

If you’re on a large network at work or
school, your network administrator probably
set up an internal webpage with instructions
for installing licensed software from the net-
work. If not, you can use Control Panel.

To install a program from a network:

1. Choose Start > Control Panel > 
Programs > Get Programs.

2. Select a program from the list and click
Install.

3. Follow the onscreen instructions.

If a security prompt appears, type an
administrator password or confirm 
the action.
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Figure 6.6 This dialog box appears if you click Save 
in Figure 6.5. Your Downloads folder is the best place
for downloads—which are easy to “lose” if you’re not
consistent about where you put them.
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Removing Programs
When you install a program, it scatters its
components all over your folder structure,
not just in the Program Files subfolder it
creates. Only an unwanted program’s unin-
stall utility can remove it completely. Don’t
just delete the program’s folder; if you do,
you’ll leave behind shortcuts, support files,
hidden folders, registry entries, and other 
litter on your hard drive.

You can uninstall a program if you no longer
use it or if you want to free up space on your
hard disk. You also can change the program’s
configuration by adding or removing certain
options. (Some programs don’t offer this
option, in which case your only choice is 
to uninstall.)

✔ Tip

■ Always exit the program that you’re
going to remove. If you’re using Fast 
User Switching (see “Logging On and
Logging Off ” in Chapter 1), make sure
that no other logged-on users are using
the program.

To uninstall or change a program:

1. Choose Start > Control Panel > 
Programs > Programs and Features.

2. To uninstall the program, select
the program and then click Uninstall (on
the toolbar) (Figure 6.7).

or

To change or repair the program,
click Change or Repair (on the toolbar).

continues on next page
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Figure 6.7 The buttons on the toolbar change
depending on what uninstall/change/repair options
the selected program provides. Big packages like
Microsoft Office and Adobe Creative Suite provide the
most options.
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3. Confirm the removal or change if a dialog
box appears.

If a security prompt appears, type an
administrator password or confirm the
action.

Windows runs the program’s uninstall or
change utility (which varies by program).

4. Follow any onscreen instructions.

✔ Tips

■ The folder that contained the program
may persist after uninstall completes,
usually because it contains documents
created with the program. Games, for
example, often leave keyboard-binding
and saved-game files. If you don’t need
those documents, you can delete the
folder and its files safely.

■ Most uninstallers display a progress bar,
explain what they’re removing or not
removing, and tell you whether you must
restart your computer to complete the
removal.

■ If a program that you want to uninstall
isn’t listed, look for removal instructions
in the program’s read-me file (if any) or 
at the publisher’s website. Or search the
web for uninstall and the program’s
name. As a last resort, drag the program’s
folder into the Recycle Bin.

■ You may get a midprocess message ask-
ing whether Windows should remove a
shared file that other programs may
need. Warnings of this type can look a
bit dire, but I’ve always removed them
with no ill effects.
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Turning Windows Features
On or Off
Some programs and features that are
included with Windows must be turned on
before you can use them, whereas others,
turned on by default, can be turned off if
you don’t need them.

In earlier versions of Windows, turning off 
a feature uninstalled it. In Vista, all features
remain stored on disk, so you can turn them
back on when you want to. Turning off a 
feature doesn’t free hard-disk space.

To turn Windows features on or off:

1. Choose Start > Control Panel > 
Programs > Turn Windows Features On
or Off (in the Programs and Features 
category).

If a security prompt appears, type an
administrator password or confirm the
action.

2. In the list, check or uncheck the boxes 
to turn features on or off (Figure 6.8).

3. Click OK.

✔ Tip

■ To learn about a feature, hover the
mouse pointer over it for a pop-up
description.
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Figure 6.8 Some features are grouped in folders,
which you can double-click to see. If a check box is
partially checked or dark, some of the items inside
are turned on and others aren’t.
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Launching Programs
Windows gives you many ways to launch
(open) a program. Even Windows veterans
may not know all of them.

To start a program:

◆ Choose Start > All Programs and click
the program’s icon.

or

Choose Start, type the program’s name 
in the Search box, and then click it in the
results list (Figure 6.9).

or

On the left side of the Start menu, click
the program’s icon (if it appears).

or

On the Quick Launch toolbar, click the
program’s icon (if it appears).

or

Choose Start > Computer > Local Disk
(C:) > Program Files. In the program’s
subfolder, double-click the program’s icon
(.exe file).

or

Right-click the program’s icon and
choose Open.

or

Press the keyboard shortcut that you
assigned to the program’s icon.

or

Press Windows logo key+R, type the 
program’s name, and press Enter 
(Figure 6.10).

You may have to include the full path-
name. See “Navigating in Windows
Explorer” in Chapter 5.

260

Chapter 6
La

u
n

ch
in

g
 P

ro
g

ra
m

s

Figure 6.9 You need type only part of a
program’s name for it to appear in the
results list. Windows highlights the most
relevant result; if that’s the program
you’re looking for, just press Enter.

Figure 6.10 The Run dialog box may seem old-
fashioned, but for many experienced users and rapid
typists, it’s the fastest way to open a program or
document. Press F4 for a drop-down history of
previous commands.
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✔ Tips

■ You can use any of these methods to
open a document with its associated
program. If you created the document
stuff.doc in Microsoft Word, for example,
double-click the document’s icon to start
Word and open that file automatically.

■ Most Setup programs put an icon in the
All Programs menu or on the desktop. 
To move these icons, see “Using the Start
Menu” in Chapter 2.

■ To customize the Quick Launch toolbar,
see “Using the Quick Launch Toolbar” in
Chapter 2.

■ To assign a keyboard shortcut to a 
shortcut icon, change its Shortcut Key
property; see “Managing Shortcuts” in
Chapter 2.

■ You can open a program or document
from a command prompt just as you 
can from the Run dialog box. See “Using
the Free Utility Programs” later in this
chapter.
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Launching Programs
Automatically
The Start > All Programs > Startup folder
contains programs that open automatically
every time you start Windows. To save your-
self a few clicks or keystrokes every time you
log on, you can place your own shortcuts to
programs or documents in this folder.

To open an item each time you start
Windows:

1. Choose Start > All Programs, right-click
Startup, and then choose Open 
(Figure 6.11).

Choose Open All Users (instead of Open)
to change the Startup folder that applies
to all users, not only yourself.

2. In Windows Explorer or Computer, navigate
to the disk, folder, program, or document
that you want to open automatically.

3. Right-drag the item to the Startup folder
and choose Create Shortcuts Here.

From now on, the item opens each time
you start your computer or log on.

✔ Tips

■ For an uncluttered desktop, open startup
programs as taskbar buttons rather than
as windows. Right-click a Startup short-
cut, choose Properties > Shortcut tab,
and then choose Minimized from the
Run list.

■ To identify startup programs, press
Windows logo key+R; type msconfig.exe
and press Enter. (If a security prompt
appears, type an administrator password
or confirm the action.) You can use the
Startup tab’s check boxes to isolate
startup problems.
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ly Figure 6.11 Your All Users Startup folder probably has
a few icons already, put there by programs when they
were installed.

Unwelcome Startup Programs

Too many programs add their own short-
cuts silently to the All Users Startup folder
(or the registry). Many of these programs
are unnecessary, slow the boot process,
and run invisibly in the background,
chewing up processor time. If you know
that you can delete or move a Startup
shortcut without affecting your system or a
program adversely, do so. (You’ll want to
keep some programs, such as virus scan-
ners.) If you have trouble identifying a
startup item, visit www.pacs-portal.co.uk/
startup_index.htm for help.
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Running Older Programs
If you’re coming to Vista from an earlier
Windows version, you probably still need 
to run your older programs. Vista still can
run many of them, even those written for
Windows 3.1/95 and DOS, but if it has trou-
ble running a program that used to run fine
under your old copy of Windows, you can
try changing the compatibility mode.

To run a troublesome older program:

1. Right-click a program’s executable (.exe)
file or shortcut icon and choose
Properties > Compatibility tab 
(Figure 6.12).

2. Change the compatibility settings for 
the program.

3. Click OK.

The next time you open the program,
Vista tries to run it by using your settings.

✔ Tips

■ If you want to be stepped through the
process, use the Program Compatibility
wizard: Choose Start > Control Panel >
Programs > Use an Older Program with
This Version of Windows (in the
Programs and Features category).

■ Never try to coerce obsolete hardware-
dependent system utilities to run under
Vista. Upgrade to the latest version of
your virus scanner, backup program,
hard-disk partitioning tool, disc burner,
or whatever.

■ To run old LucasArts and SCUMM-
based adventure games (Monkey Island,
Day of the Tentacle, and Sam & Max), try
ScummVM (free; www.scummvm.org).
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Figure 6.12 Choose the previous version of Windows
that the old program was made for.

Running 16-Bit Programs

Windows 3.1 and DOS programs are
called 16-bit programs. Programs written
for Windows 95, NT, and later are called
32-bit programs. The 16-bit programs run
slowly because Vista runs them in a
leakproof, emulated space called a virtual
machine that draws on a common mem-
ory pool.

To run DOS programs, choose Start > 
All Programs > Accessories > Command
Prompt. See “Using the Free Utility
Programs” later in this chapter.

If Vista displays an incompatibility message
when you try to install or run a 16-bit pro-
gram, don’t ignore it. Either find a patch
(update) or scrap the program.
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Switching Programs
You’ll probably have multiple programs run-
ning simultaneously so that you can juggle,
say, a word processor, email program, and
web browser. You have several techniques 
for switching programs.

To switch among running programs:

◆ If the program’s window is visible in the
background, click it. (But click an empty
area, not a button or menu, lest you 
activate it accidentally.)

or

Click the program’s taskbar button. 
(The darkest button indicates the active
program.)

or

Hold down Alt, press Tab repeatedly until
the desired window is highlighted in the
pop-up list, and then release both keys
(or click an icon in the list to display that
window). This feature is called Alt-tabbing
(Figure 6.13).

or

Hold down the Windows logo key, press
Tab repeatedly until the desired window
comes to the front of the stack, and then
release both keys (or click any part of any
window in the stack to display that win-
dow). This feature, new in Vista, is called
Flip 3D and works only if you’re using the
Aero color scheme (Figure 6.14).

or

Hold down Alt, press Esc repeatedly until
the desired program appears, and then
release both keys.
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Figure 6.13 Alt-tabbing pops up a list of icons
representing open windows. If you’re using the Aero
color scheme, the icons are live previews. Hold down
Alt and press Tab repeatedly to highlight a window. If
you press and release Alt+Tab quickly, you swap
between only two windows instead of cycling through
them all.

Figure 6.14 Flip 3D shows a stack of open windows. If
you release the Tab key but keep the Windows logo
key pressed, you can use the arrow keys or mouse
wheel to cycle through open windows.
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✔ Tips

■ You also can invoke Flip 3D by
clicking the Switch Between

Windows button on the Quick Launch
toolbar (on the taskbar).

■ If you press and release Ctrl+Alt+Tab or
Ctrl+Windows logo key+Tab, you can use
the arrow keys or Tab to cycle through
open windows and then press Enter to
activate a window.

■ Flip 3D, Alt+Tab, and Alt+Esc cycle
backward through programs if you hold
down Shift.

■ Alt+Esc—unlike Alt+Tab and Flip 3D—
has no pop-up window, doesn’t cycle
through minimized programs, and doesn’t
swap between two programs. (It simply
sends the active program to the bottom
of the pile.)
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Exiting Programs
When you finish using a program, you
should exit (or quit or close) it to get it out
of your way and to let Windows reclaim its
memory for other use.

To exit a program:

◆ Choose File > Exit (Figure 6.15).

or

In Windows Explorer, choose File > Close.
(Press Alt if the File menu isn’t visible.)

or

Activate the program’s window and 
press Alt+F4.

or

Click the program’s close button ( ).

or

Double-click the program’s icon at the
left end of the title bar (if visible).

or

Right-click the program’s taskbar button
and choose Close.

or

Activate the program’s window, press
Alt+spacebar, and then press C.

✔ Tip

■ Before exiting, the program prompts you
to save any unsaved work.
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Figure 6.15 Pressing Alt+F4 is quicker
than choosing File > Exit.
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Killing Unresponsive
Programs
Programs that crash/freeze/lock up/hang
are said to be “not responding” in Microsoft
vernacular; you can move the mouse pointer
within the program’s window, but the program
itself won’t respond to clicks or keystrokes.
An unresponsive program rarely forces you
to restart your computer. Instead, use Task
Manager to send the frozen program to 
its grave.

✔ Tip

■ Before you kill a program, make sure that
it’s really not responding. Wait a minute
or two; Windows may be struggling to
allocate extra memory. If you’re running
a Visual Basic macro in Microsoft Excel
or Word, for example, the program may
appear frozen while VB has control.
Global reformatting or a find-and-replace
operation on a long document can keep
a word processor hypnotized for min-
utes. An open dialog box or message box
may prevent you from doing anything
else in the program; look for one hiding
behind another window.
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Desperate Measures

If killing an unresponsive program as described doesn’t work, you still have these options, in
order of preference:

◆ Click the Processes tab in Task Manager, click the program’s image name, and then click
End Process.

◆ Exit all other programs and log off.

◆ If you can’t log off but other users are logged on (via Fast User Switching), right-click
another user in Task Manager’s Users tab, choose Connect to switch to that user, and then
use Task Manager to log off (Disconnect) yourself.

◆ If none of these measures works, press your computer’s reset button.
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To kill an unresponsive program:

1. Right-click an empty area of the taskbar
and choose Task Manager.

or

Press Ctrl+Shift+Esc.

or

Press Ctrl+Alt+Delete and click Start
Task Manager.

or

Choose Start, type taskmgr in the Search
box, and then press Enter.

2. On the Applications tab, select the name
of the unresponsive task (Figure 6.16).

3. Click End Task.

4. In the dialog box that appears, click End
Now or Close the Program (Figure 6.17).

✔ Tip

■ As an alternative to killing programs via
Task Manager, you can use the tskill
command-line program, which allows
more control than Task Manager. For
usage and syntax, type the command fol-
lowed by /? or search for command-line
reference in Help and Support. To use the
command prompt, see “Using the Free
Utility Programs” later in this chapter.
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Figure 6.16 After Windows terminates the program,
you can launch it again immediately without
repercussions.
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Using the Free Utility
Programs
The All Programs menu teems with free pro-
grams that are part of the standard Windows
installation. Some of these programs (such
as Internet Explorer and Windows Mail) get
their own chapters. But Microsoft also includes
useful utility programs, described here.

Most utilities are available in the Start > All
Programs > Accessories menu (Figure 6.18).
Not every utility in the menu is described
here; I talk about others elsewhere in this
book, where they’re relevant.

To get program-specific help for a utility
program, use its Help menu (or press F1).
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Figure 6.17 Either of these dialog boxes may appear. 
It may take Windows a few seconds—or minutes—to
kill the program.

Figure 6.18 The Start > All Programs >
Accessories menu.
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Calculator
In Standard mode, Calculator offers add,
subtract, square root, invert, and other basic
functions. Scientific mode (Figure 6.19)
adds trigonometric, statistical, logarithmic,
and base functions. To operate Calculator,
click its buttons with your mouse or press
the corresponding keyboard keys. Help >
Help Topics gives keyboard shortcuts for
Scientific mode.

✔ Tips

■ A better calculator is Calc98 (free;
www.calculator.org), an engineering, 
scientific, statistical, and financial 
calculator.

■ On the web, you can type equations 
in the Google search box and press 
Enter (see www.google.com/help/
features.html#calculator).

Character Map
Character Map (Figure 6.20) displays all
characters and symbols for a particular font.
Use it to copy and paste diacritical marks,
currency symbols, copyright signs, and all
the other characters that don’t appear on
your keyboard. To open Character Map,
choose Start, type character map in the
Search box, and then press Enter.

✔ Tip

■ If you’re using Microsoft Word, the 
Insert > Symbol command is faster than
using Character Map.
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Figure 6.19 Choose View > Scientific to reveal
Calculator’s geeky secret identity.

Figure 6.20 Here are the characters for the Arial font.
Double-click characters to put them in the Characters
to Copy text box; then click Copy. Now you can Edit >
Paste them into any document. The pop-up tip is for
typography experts and programmers: It shows the
character’s name and hexadecimal code.
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Command Prompt
Command Prompt (formerly called DOS
Prompt) lets you type commands rather
than point and click (Figure 6.21). Rapid
typists, Unix junkies, and people impatient
with Windows safeguards love the com-
mand line, but new users find it cryptic and
intimidating (experience teaches them to
appreciate its efficiency).

Command Prompt is handy for many routine
tasks, but it shines when using a graphical
interface is impractical. (Network adminis-
trators don’t add 1,000 user accounts by
pointing and clicking, for example.) You also
can use Command Prompt to (try to) run
your old 16-bit DOS programs and games.

Scores of commands are available; search for
command prompt and command-line reference
in Help and Support. The basic commands
are cd (or chdir), cls, copy, del, dir, exit, md
(or mkdir), more, move, path, rename, rmdir,
set, tree, type, and xcopy.
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Figure 6.21 To quit Command Prompt, type exit and
then press Enter.
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✔ Tips

■ Command Prompt remembers the com-
mands you’ve typed. Press the up- and
down-arrow keys to review your com-
mand history.

■ To run a command as an administrator,
choose Start and type command prompt in
the Search box. In the results list, right-
click Command Prompt and choose Run
As Administrator.

■ To customize Command Prompt, right-
click its title bar and choose Properties.
A few recommendations: On the Options
tab, turn on QuickEdit mode, which lets
you drag over text and press Enter to
copy it to the clipboard. Font tab: Switch
the font to Lucida Console, bold, 14-point.
Layout tab: Set Window Size to 80 ✕ 40
and Screen Buffer Size to 80 ✕ 1000 (so
you can scroll a large results history).
Colors tab: Choose black text on a white
background. Click OK, and choose to mod-
ify the shortcut that started the window.

■ To open a command window for a par-
ticular folder quickly: In Windows
Explorer, hold down Shift, right-click the
folder in the file list, and then choose
Open Command Window Here.

■ A quick way to run a single command—
usually to open a program or file—without
opening a command window is to use
the Run dialog box. Press Windows logo
key+R, type the command, and then press
Enter. Or instead of typing a command,
press F4 for a list of your recent commands,
use the arrow keys to choose one, and
then press Enter.
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Connect to a Network Projector
This utility lets you give a presentation over
a network from any computer (desktop or
laptop). The Connect to a Network Projector
wizard connects to any available network
projector over a wireless or a wired network.
You can make a choice from a list of avail-
able projectors or enter a projector’s network
address. If the projector’s icon has a small
lock, you must enter a password to connect
to it. The wizard also lets you choose
whether all or part of your desktop appears
on the projected image.

After the wizard completes, the Network
Presentation dialog box opens. Use it to con-
figure more settings and then minimize it to
the taskbar when you give your presentation.

Games
The Start > Games window offers world-class
productivity killers Solitaire, FreeCell, and
Minesweeper—plus some new ones 
(Figure 6.22).
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Figure 6.22 The Games folder is the central location
for games on your computer. Newer Vista-aware
games will install their icons in this window. (Older
games create their own entries in the Start > All
Programs menu.) Click Options (on the toolbar) to set
up this folder.
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Meeting Space
Windows Meeting Space (Start > All
Programs > Windows Meeting Space) lets
you share documents, programs, or your
desktop with other people (Figure 6.23). 
It’s a peer-to-peer application that sets up an
ad hoc network automatically if it can’t find
an existing one. You can use it in a confer-
ence room, a wireless hotspot, or a place
where no network exists. With it, you can:

◆ Share your desktop or any program with
other meeting participants

◆ Distribute and co-edit documents with
other meeting participants

◆ Pass notes to other participants

◆ Connect to a network projector to give a
presentation

You can join a meeting that someone else
sets up, or you can start a new meeting and
invite other people to join it. The first time
you open Windows Meeting Space, it
prompts you to turn on some services and
sign in to People Near Me (which identifies
people using computers near you, letting
you use peer-to-peer programs).

✔ Tip

■ Windows Meeting Space replaces
NetMeeting from earlier Windows 
versions.
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Figure 6.23 The Windows Meeting Space wizard lets
you start a new meeting or join an existing one.
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Notepad
Notepad, a bare-bones text editor, is one of the
most useful tools in Windows (Figure 6.24).
Use it to open, create, or edit text files, which
contain only printable characters—no fonts,
formatting, invisible codes, colors, graphics,
or any of the clutter usually associated with
a word processor. Notepad is the default pro-
gram for .txt and .log files, but you can use it
to view or edit .html files (saved web pages),
.ini files (program initialization settings), or
any other text-based file types.

✔ Tips

■ Notepad does offer a few handy features:
Press F5 to insert a time stamp (useful 
for keeping logs); choose Format > Font
to set the display font; or choose File >
Page Setup to set headers and footers 
for printouts.

■ Notepad alternatives abound. A few of
the better ones are TextPad ($30 U.S.;
www.textpad.com), EditPlus ($30 U.S.;
www.editplus.com), and NoteTab Pro
($30 U.S.; www.notetab.com).

■ If you need an outliner to organize 
your thoughts, try KeyNote (free;
www.tranglos.com/free/index.html).
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Figure 6.24 If you find Notepad too limiting, you can
find many excellent shareware editors.

SourceForge and OpenSource

For lots of free, quality software,
browse around SourceForge.net (http://
sourceforge.net), a centralized location
for software developers to control and
manage open-source software projects.
Open-source software is free, not privately
owned, spyware-free, and dependable.
You can even have the source code. For
details, go to www.opensource.org.

It’s possible to set up your PC completely
while spending no money on programs or
utilities. Free alternatives to popular com-
mercial products include OpenOffice instead
of Microsoft Office, The GIMP for Adobe
Photoshop, gzip for WinZip, and AbiWord
for Word. Look for them and others at
SourceForge, or do a web search.
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Paint
Paint is a no-frills image editor with a few
drawing, color, and manipulation tools
(Figure 6.25). Use it to create your own
works of art or to view or touch up graphic
files that were created in other programs
(such as Adobe Photoshop) or that you
scanned or downloaded. Paint supports
bitmap (.bmp), JPEG, GIF, TIFF, and PNG 
file formats.

✔ Tip

■ Paint alternatives include Paint Shop Pro
($100 U.S.; www.corel.com), Adobe
Photoshop Elements ($90 U.S.;
www.adobe.com), Oriens Enhancer ($15
U.S.; www.oriens-solution.com), and 
The GIMP (free; www.gimp.org).

Windows Ultimate Extras
If you’re running the Ultimate edition of
Windows Vista, you can download exclusive
programs and services from Microsoft.
When these Extras are available, they appear
in the Windows Ultimate Extras section on
the Windows Update page.

WordPad
WordPad (Figure 6.26) is a simple,
stripped-down word processor associated
with .doc files (unless you’ve installed
Microsoft Word), .rtf files (Rich Text
Format), and .wri files (Microsoft Write).
You also can use it to edit plain-text files,
but Notepad is more appropriate for that
task.

✔ Tip

■ WordPad’s native file format is RTF (Rich
Text Format). If you open a Word file in
WordPad, you’ll get the raw text mixed
with some garbage symbols.
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Figure 6.25 The Image menu lets you flip, rotate, and
stretch images.

Figure 6.26 Like any other word processor, WordPad
lets you apply formatting (italic, justification, colors,
fonts, and so on) to text. The Insert > Object command
lets you embed images, sounds, movies, charts,
spreadsheets, and other objects in your document.
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Saving Documents
Most programs let you save your work as
documents, which you can return to later,
print, send to other people, back up, and so
on. Documents generally are thought of as
being word-processed materials, but here I’m
using the word to mean images, spreadsheets,
presentations, databases, email, webpages,
digital photos, text files, videos, or any other
user-created work.

Nearly all programs use Windows’ standard
Save dialog box. The first time that you save
a document, Windows asks you to name it
and pick a folder to store it in. (Two files in
the same folder can’t have the same name.)

To save a document:

1. Choose File > Save.

or

To save a copy of a file under a different
name or in a different folder, choose 
File > Save As.

(Press Alt if the File menu isn’t visible.)

2. Click Browse Folders to show the
Navigation pane (Figure 6.27).

3. Use the address bar or Navigation pane
to choose the folder to save the file to
(see “Navigating in Windows Explorer” 
in Chapter 5).

4. In the File Name box, type the name of
the file.

You can use the Cut, Copy, Paste, and
Undo keyboard shortcuts (Ctrl+X,
Ctrl+C, Ctrl+V, and Ctrl+Z, respectively)
while editing. For file-naming rules, see
“Naming Files and Folders” in Chapter 5.

continues on next page
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Figure 6.27 The Save dialog box appears the first time
you save a file or when you choose File > Save As. The
standard Save dialog box (top) expands to show the
Navigation pane (bottom) when you click Browse
Folders.
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5. To save a file in a format other than the
program’s default (native) format, choose
a target format from the Save As Type
drop-down list.

This feature lets you, say, save a Word
document as text (.txt), Rich Text
Format (.rtf), or HTML (.html) so that
users without Word can open it in a text
editor, WordPad, or a web browser.

6. Click Save.

✔ Tips

■ To bypass step 3, type the filename’s full
pathname in step 4. See “Navigating in
Windows Explorer” in Chapter 5.

■ In the file list, you can click a document
to make its name appear in the File
Name box; then click Save to overwrite
the existing document or edit the name
to save a new document. The latter tech-
nique saves typing when you’re saving
similarly named documents.

■ The file list acts like an Explorer window.
You can right-click any file or folder to,
say, rename or delete it. You even can
drag items into and out of this box or use
the standard navigation keys.

■ You must close the Save dialog box
before you can use another part of the
program.

■ Some older programs use the old-style
Save dialog box, with Windows XP–style
navigation features.

■ You can’t save your work in some utility
and game programs, such as Calculator
and Solitaire.

■ Some programs can autosave your work
at a regular time interval that you set.
Check the program’s Options or
Preferences dialog box.
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Read-Only Files

You can prevent yourself (and others)
from making accidental changes to a file
by making it read-only. To change a file to
read-only, right-click the file and choose
Properties > General tab, check Read-
Only (or uncheck it to make it read-
write), and click OK. Read-only files can’t
be changed, but they can be copied,
moved, renamed, or deleted.
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Opening Documents
You have several ways to reopen a document
that you’ve already named and saved.

To open a document:

◆ In the program that created the document,
choose File > Open, navigate to the docu-
ment, and then click Open (Figure 6.28).

(Press Alt if the File menu isn’t visible.)

or

Choose Start, type the document’s name
in the Search box, and then click it in the
results list.

or

In Windows Explorer or on the desktop,
double-click the document’s icon (or
select it and then press Enter).

or

If the document was opened recently,
choose it from the Start > Recent Items
menu.

or

Press Windows logo key+R, type or paste
the document’s name and path, and then
press Enter.

For details about pathnames, see “Navigating
in Windows Explorer” in Chapter 5.
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Figure 6.28 The Open dialog box works like the Save
dialog box described in the preceding section.
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✔ Tips

■ You also can open a document by using
any of the techniques described in
“Launching Programs” earlier in this
chapter.

■ Like the Save dialog box, the Open dialog
box must be closed before you can use
another part of the program.

■ To open a file that’s not associated with a
particular program, right-click the file,
choose Open With, and then select the
name of a program (Figure 6.29). See
“Associating Documents with Programs”
later in this chapter.

■ If you open a document that somebody
else already has open, the program usually
will warn you or open a read-only copy of
the document (unless it’s a multiuser
document such as a database).
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Access Denied

If Windows denies you access when you try to open a file or folder, it may be that:

◆ The file is encrypted. To check whether it’s encrypted, right-click the file and choose
Properties > General tab > Advanced. If Encrypt Contents to Secure Data is checked, see
the person who created the file. If you encrypted the file, you might have done so in
another user account. See “Encrypting Data” in Chapter 13.

◆ You don’t own the folder. To take ownership, right-click the folder and choose Properties >
Security tab > Advanced > Owner > Edit. If a security prompt appears, type an adminis-
trator password or confirm the action. Click your name or group in the Change Owner To
list. If you want to own the files and subfolders too, check Replace Owner on Subcontainers
and Objects. Click OK in each open dialog box.

Figure 6.29 If the Open With submenu doesn’t list the
program that you’re looking for, click Choose Default
Program to open this dialog box. Click Browse to find
the program.
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Associating Documents
with Programs
When you double-click a Word document,
Windows launches Word with that docu-
ment open. Windows knows to launch
Word—rather than, say, Paint or Windows
Mail—because a document’s file type is
embedded in its filename, as the (usually
three) characters appearing after the name’s
last dot. These characters, called an extension
or file extension, associate a document with
a particular program.

Table 6.1 gives a short list of common
extensions; go to www.filext.com for a com-
prehensive list.
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Table 6.1

Common File Extensions
E x t e n s i o n D e s c r i p t i o n  o r  P r o g r a m

.ai Adobe Illustrator

.avi Windows Media Player

.bmp Bitmap image

.dll System file (not a document)

.doc Microsoft Word (or WordPad)

.exe Program (not a document)

.gif GIF image

.htm/.html Webpage (Internet Explorer)

.indd Adobe InDesign

.jpg/.jpeg JPEG image (for photos)

.mdb Microsoft Access

.pdf Portable Document Format
(Adobe Reader)

.png PNG image

.ppt Microsoft PowerPoint

.psd, .pdd Adobe Photoshop

.qxd QuarkXPress

.tif TIFF image

.tmp Temporary file

.txt Text file (Notepad)

.wpd WordPerfect

.xls Microsoft Excel

.xps XML Paper Specification 
(Microsoft XPS Viewer)

.zip Compressed zip file
Viruses and Extensions

Viruses disguised as innocuous attach-
ments often arrive via email. A virus file
with the extension .exe is a program that
runs when you double-click it, infecting
you. (Some other extensions are danger-
ous too.) Virus writers will try to trick
you into thinking a file is safe by naming
it, say, iloveyou.txt.exe. If extensions
are hidden, you see only iloveyou.txt,
which appears to be a harmless text file.

Even with extensions showing, the file

FreeMP3s.txt                 .exe

will appear to be harmless if the embed-
ded spaces hide the .exe extension in a
narrow column.
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Microsoft hides extensions by default to
make Windows appear friendlier. But even
beginners should show extensions for these
reasons:

◆ An icon alone can be insufficient to 
distinguish a file’s type (particularly the
tiny icons in details and list views).

◆ Extensions impart the types of like-named
files quickly (resume.doc vs. resume.txt
vs. resume.html, for example) without
making you read the Type column in
Explorer.

◆ Extensions make it plainer to, say,
choose among Photoshop, Paint, Internet
Explorer, and Windows Photo Gallery to
open .jpg (JPEG) files.

◆ If a newly installed program hijacks an
extension’s association without asking
your permission (both rude and com-
mon), you can reassociate the extension
with your preferred program.

◆ If you don’t learn about extensions, you’ll
remain mired in beginner status and
pester people with trivial problems.

To show file extensions:

1. Choose Start > Control Panel >
Appearance and Personalization > 
Folder Options.

or

In a folder window, choose Organize >
Folder and Search Options.

or

Choose Start, type folder folder options
in the Search box, and then press Enter.

2. Click the View tab; then, in the Advanced
Settings section, uncheck Hide Extensions
for Known File Types (Figure 6.30 and
Figure 6.31).
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Figure 6.30 Uncheck this box to show file extensions in
folder windows, on the desktop, and in dialog boxes.

Figure 6.31 Folder windows that hide (top) and
show (bottom) extensions.
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To change the program associated
with a file extension:

1. In a folder window, select a file having
the desired extension.

or

Choose Start > Search; then search for a
file having the desired extension (see
“Searching for Files and Folders” in
Chapter 5).

2. Right-click the file and choose Open
With > Choose Default Program 
(Figure 6.32).

3. If the program that you want to use to
open this type of file is listed, select it.

or

If the program isn’t listed, click Browse,
select the program (.exe) file, and then
click Open.

4. Check Always Use the Selected Program
to Open This Kind of File.

5. Click OK.

When you double-click that type of file
in the future, the file will open in the pro-
gram you selected.
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Figure 6.32 The Open With dialog box lists programs
capable of opening the selected file. Click Browse to
pick a program that’s not in the list.
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✔ Tips

■ If you double-click a file with an unknown
extension, Windows lets you choose a
program or try to look up the extension
on Microsoft’s website (Figure 6.33).
You also can visit this website by clicking
Look for the Appropriate Program on the
Web in the Open With dialog box (refer
to Figure 6.32).

■ The Details pane in Windows Explorer
contains file-type information for the
selected file.

■ Some file types have multiple extensions
(.htm/.html and .jpg/.jpeg, for example).
Repeat the association for each form of
the extension.

■ To scroll through a (long) list of file
extensions and set them individually,
choose Start > Control Panel > Programs >
Default Programs > Associate a File Type
or Protocol with a Program (Figure 6.34).

284

Chapter 6
A

ss
o

ci
at

in
g

 D
o

cu
m

en
ts

 w
it

h
 P

ro
g

ra
m

s

Figure 6.34 To change the default program for an
extension, select the extension in the list, click
Change Program, and then choose a new program in
the Open With dialog box (refer to Figure 6.32).

Figure 6.33 This dialog box appears when you double-
click a file with an extension that Windows doesn’t
recognize. A file with an unknown extension (or no
extension) often is a text file; try opening it in Notepad
before asking Windows to hunt for a program.
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