CONTENTS

Contents

GETTING STARTED

About Classroom in a Book .................................................. 1
TinyURLs ................................................................. 1
Prerequisites ..................................................................... 2
Conventions used in this book .......................................... 2
Bolded text ................................................................. 2
Code font ............................................................... 2
Strikethrough ............................................................ 3
Missing punctuation .................................................. 3
Element references .................................................... 3
Windows vs. macOS instructions .................................. 3
Installing the program .................................................. 4
Updating Dreamweaver to the latest version ................. 5
Online content ........................................................... 6
Lesson files ............................................................ 6
Web Edition ............................................................. 6
Recommended lesson order .......................................... 8
Bonus material ............................................................ 8
On first launch ............................................................. 9
Choosing the program color theme .............................. 9
Setting up the workspace ........................................... 10
Defining a Dreamweaver site ...................................... 11
Checking for updates .................................................. 15
Additional resources .................................................. 16
Adobe Authorized Training Centers ............................. 16
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Touring the workspace</td>
<td>20</td>
</tr>
<tr>
<td>Using the Start Screen</td>
<td>21</td>
</tr>
<tr>
<td>Quick Start</td>
<td>22</td>
</tr>
<tr>
<td>Starter Templates</td>
<td>23</td>
</tr>
<tr>
<td>Create New and Open</td>
<td>23</td>
</tr>
<tr>
<td>Exploring New Feature guides</td>
<td>24</td>
</tr>
<tr>
<td>Setting interface preferences</td>
<td>25</td>
</tr>
<tr>
<td>Switching and splitting views</td>
<td>27</td>
</tr>
<tr>
<td>Code view</td>
<td>27</td>
</tr>
<tr>
<td>Design view</td>
<td>28</td>
</tr>
<tr>
<td>Live view</td>
<td>29</td>
</tr>
<tr>
<td>Split view</td>
<td>29</td>
</tr>
<tr>
<td>Live Source Code</td>
<td>31</td>
</tr>
<tr>
<td>Inspect mode</td>
<td>31</td>
</tr>
<tr>
<td>Selecting a workspace layout</td>
<td>32</td>
</tr>
<tr>
<td>Standard workspace</td>
<td>32</td>
</tr>
<tr>
<td>Developer workspace</td>
<td>33</td>
</tr>
<tr>
<td>Working with panels</td>
<td>33</td>
</tr>
<tr>
<td>Minimizing panels</td>
<td>34</td>
</tr>
<tr>
<td>Closing panels and panel groups</td>
<td>35</td>
</tr>
<tr>
<td>Dragging</td>
<td>35</td>
</tr>
<tr>
<td>Floating</td>
<td>36</td>
</tr>
<tr>
<td>Grouping, stacking, and docking</td>
<td>36</td>
</tr>
<tr>
<td>Personalizing Dreamweaver</td>
<td>37</td>
</tr>
<tr>
<td>Saving a custom workspace</td>
<td>38</td>
</tr>
<tr>
<td>Working with Extract</td>
<td>38</td>
</tr>
<tr>
<td>Working with toolbars</td>
<td>39</td>
</tr>
<tr>
<td>Document toolbar</td>
<td>39</td>
</tr>
<tr>
<td>Standard toolbar</td>
<td>39</td>
</tr>
<tr>
<td>Common toolbar</td>
<td>40</td>
</tr>
<tr>
<td>Creating custom keyboard shortcuts</td>
<td>40</td>
</tr>
<tr>
<td>Using the Property inspector</td>
<td>42</td>
</tr>
<tr>
<td>Using the HTML tab</td>
<td>42</td>
</tr>
<tr>
<td>Using the CSS tab</td>
<td>43</td>
</tr>
<tr>
<td>Accessing image properties</td>
<td>43</td>
</tr>
<tr>
<td>Accessing table properties</td>
<td>43</td>
</tr>
</tbody>
</table>
Using the Related Files interface ........................................ 43
Using tag selectors ............................................................. 45
Using the CSS Designer ....................................................... 46
Sources .............................................................................. 47
@Media .............................................................................. 47
Selectors ............................................................................. 47
Properties .......................................................................... 48
All and Current modes ......................................................... 50
Using the Visual Media Query (VMQ) interface ...................... 50
Using the DOM Viewer ........................................................ 51
Using element dialogs, displays, and inspectors ....................... 51
Position Assist dialog ............................................................ 52
Element Display .................................................................. 52
Image Display .................................................................... 52
Text Display ........................................................................ 53
Setting up version control in Dreamweaver ......................... 53
Exploring, experimenting, and learning ................................. 54
Review questions ................................................................. 55
Review answers ................................................................. 55

2 HTML BASICS ................................................................. 56

| What is HTML? ................................................................. | 58 |
| Where did HTML begin? .................................................... | 58 |
| Basic HTML code structure ............................................. | 60 |
| Frequently used HTML elements ...................................... | 60 |
| HTML tags ....................................................................... | 60 |
| HTML character entities .................................................. | 62 |
| What’s new in HTML5 ....................................................... | 63 |
| HTML5 tags ..................................................................... | 63 |
| Semantic web design ....................................................... | 64 |
| New techniques and technology ....................................... | 65 |
| Review questions ............................................................ | 66 |
| Review answers .............................................................. | 67 |

B2 HTML BASICS BONUS .................................................. B2-2
5  CREATING A PAGE LAYOUT  110
Evaluating page design options ............................................ 112
Working with predefined layouts ......................................... 114
Styling an existing layout .................................................... 117
Styling elements using the Extract panel ................................. 119
Extracting text from a Photoshop mockup ............................... 123
Troubleshooting CSS styling .................................................. 125
Extracting text styling from a Photoshop mockup ....................... 127
Creating a gradient background using Extract ............................ 128
Extracting image assets from a mockup .................................... 132
Adding CSS background effects in code ................................... 138
Finishing up the layout .......................................................... 142
Review questions .................................................................... 150
Review answers ..................................................................... 151

6  WORKING WITH TEMPLATES  152
Creating a template from an existing layout ............................. 154
Inserting editable regions ....................................................... 155
Building semantic content ..................................................... 158
Inserting HTML entities ......................................................... 163
Inserting metadata ................................................................ 164
Validating HTML code .......................................................... 167
Producing child pages ............................................................ 168
Creating a new page .............................................................. 168
Adding content to child pages ............................................... 170
Moving CSS styles to a linked file .......................................... 177
Updating a template ............................................................... 181
Formatting content in editable regions .................................... 186
Review questions .................................................................... 189
Review answers ..................................................................... 189

7  WORKING WITH TEXT, LISTS, AND TABLES  190
Previewing the completed file .................................................. 192
Creating and styling text ........................................................ 195
Importing text .................................................. 195
Creating semantic text structures ......................... 198
Creating headings ............................................. 201
Adding other HTML structures ............................ 202
Creating lists .................................................. 205
Creating indented text ........................................ 209
Creating and styling tables ................................... 214
Creating tables from scratch ................................. 215
Copying and pasting tables ................................... 219
Styling tables with CSS ....................................... 220
Styling table cells ............................................. 225
Controlling table display ..................................... 228
Inserting tables from other sources ...................... 230
Adding and formatting caption elements ................. 234
Spell-checking webpages ..................................... 236
Finding and replacing text .................................... 238
Optional self-paced exercise ................................. 243
Review questions .............................................. 244
Review answers ................................................ 245

8 WORKING WITH IMAGES ........................................ 246
Web image basics ............................................. 248
Vector graphics ................................................ 248
Raster graphics ................................................. 248
Raster image file formats .................................... 252
Previewing the completed files .............................. 253
Inserting an image ............................................. 255
Controlling image positions with CSS classes .......... 256
Working with the Insert panel ............................... 258
Using the Insert menu ......................................... 261
Inserting non-web file types ................................. 262
Working with Photoshop Smart Objects (optional) .... 266
Copying and pasting images from Photoshop (optional) . . 268
Inserting images by drag and drop ......................... 272
Optimizing images with the Property inspector .......... 273
Review questions .............................................. 277
Review answers .............................................. 277
Styling a jQuery accordion .................................................. 333
Applying a background effect to the accordion tab .......... 337
Formatting a conditional state for an accordion tab .......... 338
Using Live Code to identify dynamic styling .................. 341
Styling the background of the accordion content ............ 345
Review questions ............................................................... 348
Review answers ............................................................... 349

11 PUBLISHING TO THE WEB ............................................ 350
Defining a remote site ....................................................... 352
Setting up a remote FTP site .............................................. 353
Establishing a remote site on a local or network web server (optional) .............................................. 357
Cloaking folders and files .................................................. 360
Wrapping things up .......................................................... 362
Putting your site online (optional) ..................................... 364
Synchronizing local and remote sites .............................. 368
Review questions ............................................................... 372
Review answers ............................................................... 373

12 WORKING WITH CODE ................................................ 374
Creating HTML code ......................................................... 376
Writing code manually ...................................................... 376
Writing code automatically .............................................. 379
Working with multicursor support ................................. 383
Commenting your code ..................................................... 385
Working with CSS preprocessors .................................... 386
Enabling a preprocessor ................................................... 386
Creating the CSS source file ............................................. 389
Compiling CSS code ......................................................... 392
Nesting CSS selectors ....................................................... 395
Importing other style sheets ............................................. 397
Learn more about preprocessors .................................... 399
Linting support ................................................................. 399
Selecting code ................................................................. 401
Using line numbers .......................................................... 401
Using tag selectors .......................................................... 401
Using parent tags ............................................................. 403
Collapsing code ................................. 404
Expanding code ................................. 404
Accessing Split Code view ..................... 405
Previewing assets in Code view ............... 406
Review questions ............................... 408
Review answers ................................. 409

13 DESIGNING FOR MOBILE DEVICES 410
Responsive design .............................. 412
Mobile-first design .............................. 412
Testing responsiveness in Dreamweaver ..... 412
Media type properties ......................... 417
Media queries ................................. 418
Media query syntax ............................. 418
Testing responsiveness in Dreamweaver ..... 412
Working with the Visual Media Queries interface ... 419
Introducing web frameworks .................. 422
Identifying the Bootstrap structure .......... 423
Creating a Bootstrap layout .................. 425
Adding Bootstrap components ............... 426
Adding semantic elements to Bootstrap .... 430
Review questions ............................... 434
Review answers ................................. 435

APPENDIX: TINY URLS 437
INDEX 438

B14 WORKING WITH A WEB FRAMEWORK B14-2
B15 ADAPTING CONTENT TO RESPONSIVE DESIGN B15-2
B16 WORKING WITH WEB ANIMATION AND VIDEO B16-2
GETTING STARTED

Adobe® Dreamweaver CC is one of the leading web-authoring programs available. Whether you create websites for others for a living or plan to create one for your own business, Dreamweaver offers all the tools you need to get professional-quality results.

About Classroom in a Book

Adobe Dreamweaver CC Classroom in a Book® (2019 release) is part of the official training series for graphics and publishing software developed with the support of Adobe product experts.

The lessons are designed so that you can learn at your own pace. If you’re new to Dreamweaver, you’ll learn the fundamentals of putting the program to work. If you are an experienced user, you’ll find that Classroom in a Book teaches many advanced features, including tips and techniques for using the latest version of Dreamweaver.

Although each lesson includes step-by-step instructions for creating a specific project, you’ll have room for exploration and experimentation. You can follow the book from start to finish or complete only those lessons that correspond to your interests and needs. Each lesson concludes with a review section containing questions and answers on the subjects you’ve covered.

TinyURLs

At several points in the book, I reference external information available on the Internet. The uniform resource locators (URLs) for this information are often long and unwieldy, so I have provided custom TinyURLs in many places for your convenience. Unfortunately, the TinyURLs sometimes expire over time and no longer function. If you find that a TinyURL doesn’t work, look up the actual URL provided in the appendix.
Prerequisites

Before using Adobe Dreamweaver CC Classroom in a Book (2019 release), you should have a working knowledge of your computer and its operating system. Be sure you know how to use the mouse, standard menus, and commands, as well as how to open, save, and close files. If you need to review these techniques, see the printed or online documentation included with your Windows or macOS operating system.

Conventions used in this book

Working in Dreamweaver means you’ll be working with code. We have used several conventions in the following lessons and exercises to make working with the code in this book easier to follow and understand.

Bolded text

Certain names, words, and phrases will be bolded from time to time, usually when first cited in an instruction. This styling will include text, other than HTML or CSS code, that needs to be entered into program dialogs or into the body of a webpage, like this:

Type **Insert main heading here**

Filenames, like *mygreen-styles.css*, will also be bolded as needed to identify crucial resources or targets of a specific step or exercise. Be aware that these same names may not be bolded in introductory descriptions or general discussion. Be sure to identify all resources required in a specific exercise prior to commencing it.

Code font

In many instructions, you will be required to enter HTML code, CSS rules and properties, and other code-based markup. To distinguish the markup from the instructional text, the entries will be styled with a code font, like this:

Examine the following code: `<h1>Heading goes here</h1>`

In instances where you must enter the markup yourself, the entry will be formatted in color, like this:

Insert the following code: `<h1>Heading goes here</h1>`

Enter the code exactly as depicted, being careful to include all punctuation marks and special characters.
Strikethrough

In several exercises, you will be instructed to delete markup that already exists within the webpage or style sheet. In those instances, the targeted references will be identified with strikethrough formatting, like this:

Delete the following values:

```
margin: 10px 20px;
background-image: url(images/fern.png), url(images/stripe.png);
```

Be careful to delete only the identified markup so that you achieve the following result:

```
margin: 10px 10px;
background-image: url(images/fern.png);
```

In most cases, white space differences will not affect the resulting display or operation of the code, but you should always attempt to match the depicted code exactly.

Missing punctuation

HTML code, CSS markup, and JavaScript often require the use of various punctuation, such as periods (.), commas (,), and semicolons (;), and can be damaged by their incorrect usage or placement. Consequently, I have omitted periods and other punctuation expected in a sentence or paragraph from an instruction or hyperlink whenever it may cause confusion or a possible error, as in the following two instructions:

Enter the following code: `<h1>Heading goes here</h1>`

Type the following link: `https://adobe.com`

Element references

Within the body of descriptions and exercise instructions, elements may be referenced by name or by class or id attribute. When an element is identified by its tag name, it will appear as `<section>` or `section`. When referenced by its class attribute, the name will appear with a leading period (.) in a code-like font, like this: `.content` or `.sidebar1`. References to elements by their id attribute will appear with a leading hash (#) and in a code font, like this: `#top`. This practice matches the way these elements appear in Dreamweaver’s tag selector interface.

Windows vs. macOS instructions

In most cases, Dreamweaver performs identically in both Windows and macOS. Minor differences exist between the two systems, mostly because of platform-specific issues out of the control of the program. Most of these are simply
differences in keyboard shortcuts, how dialogs are displayed, and how buttons are named. In most cases, screen shots were made in the macOS version of Dreamweaver and may appear different from your own screen.

Where specific commands differ, they are noted within the text. Windows commands are listed first, followed by the macOS equivalent, such as Ctrl+C/Cmd+C. Common abbreviations are used for all commands whenever possible, as follows:

<table>
<thead>
<tr>
<th>Windows</th>
<th>macOS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control = Ctrl</td>
<td>Command = Cmd</td>
</tr>
<tr>
<td>Alternate = Alt</td>
<td>Option = Opt</td>
</tr>
</tbody>
</table>

As lessons proceed, instructions may be truncated or shortened to save space, with the assumption that you picked up the essential concepts earlier in the lesson. For example, at the beginning of a lesson you may be instructed to select Edit > Copy or “press Ctrl+C/Cmd+C.” Later, you may be told to “copy” text or a code element. These should be considered identical instructions.

If you find you have difficulties in any particular task, review earlier steps or exercises in that lesson. In some cases, if an exercise is based on concepts covered earlier you will be referred to the specific lesson.

**Installing the program**

Before you perform any exercises in this book, verify that your computer system meets the hardware requirements for Dreamweaver, that it’s correctly configured, and that all required software is installed.
If you do not have Dreamweaver, you will first have to install it from Creative Cloud. Adobe Dreamweaver must be purchased separately; it is not included with the lesson files that accompany this book. Go to helpx.adobe.com/dreamweaver/system-requirements.html to obtain the system requirements.

Go to www.adobe.com/creativecloud/plans.html to sign up for Adobe Creative Cloud. Dreamweaver may be purchased with the entire Creative Cloud family or as a standalone app. Adobe also allows you to try Creative Cloud and the individual applications for seven days for free.

Check out www.adobe.com/products/dreamweaver.html to learn more about the different options for obtaining Dreamweaver.
Recommended lesson order

The training in this book is designed to take you from A to Z in basic to intermediate website design, development, and production. Each new lesson builds on previous exercises, using supplied files and assets to create an entire website. We recommend you download all lesson files at once.

Start with Lesson 1 and proceed through the entire book to Lesson 12. Continue with the online Lessons 13 through 16 (refer to the “Bonus material” section for more information about the online material).

I recommend that you do not skip any lessons, or even individual exercises. Although ideal, this method may not be a practicable scenario for every user. So each lesson folder contains all the files needed to complete every exercise within it using partially completed or staged assets, allowing you to complete individual lessons out of order, if desired.

However, don’t assume that the staged files and customized templates in each lesson represent a complete set of assets. It may seem that these folders contain duplicative materials, but these “duplicate” files and assets, in most cases, cannot be used interchangeably in other lessons and exercises. Doing so will probably cause you to fail to achieve the goal or desired results of the exercise.

For that reason, you should treat each folder as a standalone website. Copy the lesson folder to your hard drive, and create a new site for that lesson using the Site Setup dialog. Do not define sites using subfolders of existing sites. Keep your sites and assets in their original folders to avoid conflicts.

One suggestion is to organize the lesson folders in a single web or sites master folder near the root of your hard drive. But avoid using the Dreamweaver application folder. In most cases, you’ll want to use a local web server as your testing server, which is described in Lesson 11, “Publishing to the Web.”

Bonus material

We’ve provided additional material for Lessons 2, 3, and 4 on the Peachpit website. This book has so much great material that we couldn’t fit it all in the printed pages, so we placed Lessons 14 through 16 on the Peachpit website as well:

Lesson 2, “HTML Basics Bonus”
Lesson 3, “CSS Basics Bonus”
Lesson 4, “Creating Web Assets Using Photoshop Generator Bonus”
Lesson 14, “Working with a Web Framework”
Lesson 15, “Adapting Content to Responsive Design”
Lesson 16, “Working with Web Animation and Video”
You will find these on your account page (Lessons & Update Files tab) once you register your book, as described earlier in “Accessing the lesson files and Web Edition.”

On first launch

Right after installation or upon first launch, Dreamweaver CC will display several introduction screens. First, the Sync Settings dialog will appear. If you are a user of previous versions of Dreamweaver, select Import Sync Settings to download your existing program preferences. If this is the first time you’ve used Dreamweaver, select Upload Sync Settings to sync your preferences to your Creative Cloud account.

![Sync Settings dialog]

In the book, I use the lightest interface themes for the screen shots. This was done both to save ink in printing and to place less stress on the environment. Feel free to pick the color themes you prefer.

Choosing the program color theme

If you purchased the book after you installed and launched Dreamweaver, you may be using a different color theme than the one pictured in most screen shots in the book. All exercises will function properly using any color theme, but if you want to configure your interface to match the one shown, complete the following steps.

1. Select Edit > Preferences in Windows or Dreamweaver CC > Preferences in macOS. The Preferences dialog appears.
2. Select the Interface category.
3 Select the lightest App Theme color. Select **Solarized Light** from the Code Theme menu.

The interface changes to the new theme. Depending on which app theme you select, the code theme may change automatically. The changes are not permanent yet. If you close the dialog, the theme will revert to the original colors.

4 Click the Apply button.

The theme changes are now permanent.

5 Click the Close button.

Feel free to change the color theme at any time. Often users select the theme that works best in their normal working environment. The lighter themes work best in well-lighted rooms, while the darker themes work best in indirect or controlled lighting environments used in some design offices. All exercises will work properly in any theme color.

**Setting up the workspace**

Dreamweaver CC (2019 release) includes two main workspaces to accommodate various computer configurations and individual workflows. For this book, the Standard workspace is recommended.

1 If the Standard workspace is not displayed by default, you can select it from the Window > Workspace menu.
If the default Standard workspace has been modified—where certain toolbars and panels are not visible (as they appear in the figures in the book)—you can restore the factory settings by choosing Reset ‘Standard’ from the Workspace drop-down menu.

These same options can be accessed from the Window > Workspace Layout menu.

Most of the figures in this book show the Standard workspace. When you finish the lessons in this book, experiment with each workspace to find the one that you prefer, or build your own configuration and save the layout under a custom name.

For a more complete description of the Dreamweaver workspaces, see Lesson 1, “Customizing Your Workspace.”

Defining a Dreamweaver site

In the course of completing the following lessons, you will create webpages from scratch and use existing files and resources that are stored on your hard drive. The resulting webpages and assets make up what’s called your local site. When you are ready to upload your site to the Internet (see Lesson 11, “Publishing to the Web”), you publish your completed files to a web-host server, which then becomes your remote site. The folder structures and files of the local and remote sites are usually mirror images of one another.

The first step is to define your local site.

⚠️ Warning: You must unzip the lesson files before you create your site definition.
1. Launch Adobe Dreamweaver CC (2019 release) or later.

2. Open the Site menu. The Site menu provides options for creating and managing standard Dreamweaver sites.

3. Choose New Site. The Site Setup dialog appears.

4. Type lesson01 or another name, as appropriate, in the Site Name field.

   Note: The main folder that contains the site will be referred to throughout the book as the site root folder.
5 Next to the Local Site Folder field, click the Browse For Folder icon.

6 Navigate to the appropriate folder containing the lesson files you downloaded from peachpit.com (as described earlier), and click Select/Choose.

You could click Save at this time and begin working on your new website, but you'll add one more piece of handy information.

7 Click the arrow next to the Advanced Settings category to reveal the categories listed there. Select Local Info.

Although it's not required, a good policy for site management is to store different file types in separate folders. For example, many websites provide individual folders for images, PDFs, videos, and so on. Dreamweaver assists in this endeavor by including an option for a default images folder.

Later, as you insert images from other locations on your computer, Dreamweaver will use this setting to automatically move the images into the site structure.

Note: Lesson files must be decompressed prior to defining the site.

Note: The folder that contains the image assets will be referred to throughout the book as the site default images folder or the default images folder.
Next to the Default Images Folder field, click the Browse For Folder icon. When the dialog opens, navigate to the appropriate images folder for that lesson or site and click Select/Choose.

The path to the images folder appears in the Default Images Folder field. The next step would be to enter your site domain name in the Web URL field.

Enter \url{http://green-start.org} for the lessons in this book, or enter your own website URL, in the Web URL field.

You’ve entered all the information required to begin your new site. In subsequent lessons, you’ll add information that will enable you to upload files to your remote and testing servers.

In the Site Setup dialog, click Save.

The Site Setup dialog closes.

Whenever a site is selected or modified, Dreamweaver will build, or rebuild, a cache of every file in the folder. The cache identifies relationships between the webpages and the assets within sites and will assist you whenever a file is moved, renamed, or deleted to update links or other referenced information.
11 Click OK to build the cache, if necessary.

In the Files panel, the new site name appears in the site list drop-down menu. As you add more site definitions, you can switch between the sites by selecting the appropriate name from this menu.

Setting up a site is a crucial first step in beginning any project in Dreamweaver. Knowing where the site root folder is located helps Dreamweaver determine link pathways and enables many sitewide options, such as orphaned-file checking and Find and Replace.

**Checking for updates**

Adobe periodically provides software updates. To check for updates in the program, choose Help > Updates in Dreamweaver. An update notice may also appear in the Creative Cloud update desktop manager.

For book updates and bonus material, visit your Account page on peachpit.com and select the Lesson & Update Files tab.
This page intentionally left blank
Lesson overview

In this lesson, you’ll learn how to work with images and include them in your webpages in the following ways:

• Insert an image into a webpage
• Use Photoshop Smart Objects
• Copy and paste an image from Photoshop
• Make images responsive to different device and screen sizes
• Use tools in Dreamweaver to resize, crop, and resample web-compatible images

This lesson will take about 1 hour to complete. Please log in to your account on peachpit.com to download the project files for this lesson, as described in the “Getting Started” section at the beginning of this book. Follow the instructions under “Accessing the Lesson Files and Web Edition.” Define a site based on the lesson08 folder.

Your Account page is also where you’ll find any updates to the lessons or to the lesson files. Look on the Lesson & Update Files tab to access the most current content.
Dreamweaver provides many ways to insert and adjust graphics, both within the program and in tandem with other Creative Cloud tools, such as Adobe Fireworks and Adobe Photoshop.
Web image basics

The web is not so much a place as it is an experience. Essential to that experience are the images and graphics—both still and animated—that populate most websites. In the computer world, graphics fall into two main categories: vector and raster.

Vector graphics

Vector graphics are created by math. They act as discrete objects, which you can reposition and resize as many times as you want without affecting or diminishing their output quality. The best application of vector art is wherever geometric shapes and text are used to create artistic effects. For example, most company logos are built from vector shapes.

Vector graphics are typically stored in the AI, EPS, PICT, or WMF file formats. Unfortunately, most web browsers don’t support these formats. The vector format that is supported is SVG (Scalable Vector Graphic). The simplest way to get started with SVG is to create a graphic in your favorite vector-drawing program—such as Adobe Illustrator or CorelDRAW—and then export it to this format. If you are a good programmer, you may want to try creating SVG graphics using XML (Extensible Markup Language). Check out www.w3schools.com/html/html5_svg.asp to find out more about creating SVG graphics.

Raster graphics

Although SVG has definite advantages, web designers primarily use raster-based images in their webpages. Raster images are built from pixels, which stands for picture elements. Pixels have three basic characteristics:

• They are perfectly square in shape.
• They are all the same size.
• They display only one color at a time.
Raster-based images are composed of thousands, even millions, of pixels arranged in rows and columns, in patterns that create the illusion of an actual photo, painting, or drawing. It’s an illusion, because there is no real photo on the screen, just a bunch of pixels that fool your eyes into seeing an image. And as the quality of the image increases, the illusion becomes more realistic. Raster image quality is based on three factors: resolution, size, and color.

**Resolution**

Resolution is the best known of the factors affecting raster image quality. It is the expression of image quality measured in the number of pixels that fit in 1 inch (ppi). The more pixels you can fit in 1 inch, the more detail you can depict in the image. But better quality comes at a price. An unfortunate byproduct of higher resolution is larger file size. That’s because each pixel must be stored as bytes of information within the image file—information that has real overhead in computer terms. More pixels means more information, which means larger files.

The inset image shows an enlargement of the flowers, revealing the pixels that compose the image itself.

\[ 	ext{Note: Printers and printing presses use round “dots” to create photographic images. Quality on a printer is measured in dots per inch, or dpi. The process of converting the square pixels used in your computer into the round dots used on the printer is called screening.} \]

Resolution has a dramatic effect on image output. The web image on the left looks fine in the browser but doesn’t have enough quality for printing.
Luckily, web images have to appear and look their best only on computer screens, which are based mostly on a resolution of 72 ppi. This is low compared to other applications or output—such as professional four-color printing—where 300 dpi is considered the lowest acceptable quality. The lower resolution of the computer screen is an important factor in keeping most web image files at a reasonable size for downloading from the Internet.

**Size**

*Size* refers to the vertical and horizontal dimensions of the image. As image size increases, more pixels are required to create it, and therefore the file becomes larger. Since graphics take more time to download than HTML code, many designers in recent years have replaced graphical components with CSS formatting to speed up the web experience for their visitors. But if you need or want to use images, one method to ensure snappy downloads is to keep image size small. Even today, with the proliferation of high-speed Internet service, many websites still avoid using full-screen graphics, although that too is changing.

Although these two images share the identical resolution and color depth, you can see how image dimensions can affect file size.

**Color**

*Color* refers to the color space, or *palette*, that describes each image. Most computer screens display only a fraction of the colors that the human eye can see. And different computers and applications display varying levels of color, expressed by the term *bit depth*. Monochrome, or 1-bit color, is the smallest color space, displaying only black and white, with no shades of gray. Monochrome is used mostly for line-art illustrations, for blueprints, and to reproduce handwriting or signatures.

The 4-bit color space describes up to 16 colors. Additional colors can be simulated by a process known as dithering, where the available colors are interspersed and juxtaposed to create an illusion of more colors. This color space was created for the first color computer systems and game consoles. Because of its limitations, this palette is seldom used today.
The 8-bit palette offers up to 256 colors or 256 shades of gray. This is the basic color system of all computers, mobile phones, game systems, and handheld devices. This color space also includes what is known as the web-safe color palette. Web-safe refers to a subset of 8-bit colors that are supported on both Mac and Windows computers. Most computers, game consoles, handheld devices, and even phones now support higher color palettes, so 8-bit is not as important anymore. Unless you need to support non-computer devices, you can probably disregard the web-safe palette altogether.

Today, only a few older cellphones and handheld games support the 16-bit color space. This palette is named high color and sports a grand total of 65,000 colors. Although this sounds like a lot, 16-bit color is not considered good enough for most graphic design purposes or professional printing.

The highest color space is 24-bit color, which is named true color. This system generates up to 16.7 million colors. It is the gold standard for graphic design and professional printing. Several years ago, a new color space was added to the mix: 32-bit color. It doesn’t offer any additional colors, but it provides an additional 8 bits of data for an attribute known as alpha transparency.

Alpha transparency enables you to designate parts of an image or graphic as fully or partially transparent. This trick allows you to create graphics that seem to have rounded corners or curves and can even eliminate the white bounding box typical of raster graphics.

As with size and resolution, color depth can dramatically affect image file size. With all other aspects being equal, an 8-bit image is more than seven times larger than a monochrome image. And the 24-bit version is more than three times larger than the 8-bit image. The key to the effective use of images on a website is finding the balance of resolution, size, and color to achieve the desired optimal quality.

Optimizing your images is essential, even as more people get smartphones and tablets, because there are still millions of people all across the United States, and around the world, who don’t have high-speed wired access to the Internet. In February of 2018, Pew research published a study reporting that only 65% of American...
households had access to broadband internet. Check out https://tinyurl.com/pew-broadband-report to see specific details. Using large images on your site is becoming more popular, but it could also cause problems for your target audience, depending on where they live.

**Raster image file formats**

Raster images can be stored in a multitude of file formats, but web designers have to be concerned with only three: GIF, JPEG, and PNG. These three formats are optimized for use on the Internet and compatible with virtually every browser. However, they are not equal in capability.

**GIF**

GIF (Graphics Interchange Format) was one of the first raster image file formats designed specifically for the web. It has changed only a little in the last 30 years. GIF supports a maximum of 256 colors (8-bit palette) and 72 ppi, so it’s used mainly for web interfaces—buttons and graphical borders and such. But it does have two interesting features that keep it pertinent for today’s web designers: index transparency and support for simple animation.

**JPEG**

JPEG, also written JPG, is named for the Joint Photographic Experts Group that created the image standard back in 1992 as a direct reaction to the limitations of the GIF file format. JPEG is a powerful format that supports unlimited resolution, image dimensions, and color depth. Because of this, most digital cameras use JPEG as their default file type for image storage. It’s also the reason most designers use JPEG on their websites for images that must be displayed in high quality. This may sound odd to you, since “high quality” (as described earlier) usually means large file size. Large files take longer to download to your browser. So why is this format so popular on the web? The JPEG format’s claim to fame comes from its patented user-selectable image compression algorithm, which can reduce file size as much as 95 percent. JPEG images are compressed each time they are saved and then decompressed as they are opened and displayed.

Unfortunately, all this compression has a downside. Too much compression damages image quality. This type of compression is called *lossy*, because it loses quality. In fact, the loss in quality is great enough that it can potentially render an image totally useless. Each time designers save a JPEG image, they face a trade-off between image quality and file size.
PNG

PNG (Portable Network Graphics) was developed in 1995 because of a looming patent dispute involving the GIF format. At the time, it looked as if designers and developers would have to pay a royalty for using the .gif file extension. Although that issue blew over, PNG has found many adherents and a home on the Internet because of its capabilities.

PNG combines many of the features of GIF and JPEG and adds a few of its own. For example, it offers support for unlimited resolution, 32-bit color, and full alpha transparency. It also provides lossless compression, which means you can save an image in PNG format and not worry about losing any quality when you save the file.

The only downside to PNG is that its most important feature—alpha transparency—is not fully supported in older browsers. Luckily, these browsers are retired year after year, so this issue is becoming of little concern to most web designers.

But as with everything on the web, your own needs may vary from the general trends. Before using any specific technology, it’s always a good idea to check your site analytics and confirm which browsers your visitors are actually using.

Previewing the completed files

To get a sense of the files you will work on in this lesson, let’s preview the completed pages in a browser.

1. Launch Adobe Dreamweaver CC (2019 release) or later.
2. Define a new site for the lesson08 folder, as described in the “Getting Started” section at the beginning of the book. Name the new site lesson08.

Note: If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.
3  Open **contactus-finished.html** from the lesson08/finished-files folder.

The page includes several images, as well as a Photoshop Smart Object.

4  Open **news-finished.html** from the lesson08/finished-files folder.

The news page contains images of varying sizes and composition.

5  Close all sample files.

In the following exercises, you will insert these images into these pages using a variety of techniques and format them to work on any screen.
Inserting an image

Images are key components of any webpage, both for developing visual interest and for telling stories. Dreamweaver provides numerous ways to populate your pages with images, using built-in commands and even using copy and paste from other Adobe apps. Let’s start with some of the tools built into Dreamweaver itself, such as the Assets panel.

1. In the Files panel, open contact-us.html in Live view.
2. Click the first paragraph under the heading Association Management.
   The Element Display appears focused on the p element.
3. Choose Window > Assets to display the Assets panel, if necessary. Click the Images category icon to display a list of all images stored within the site.
4. Locate and select elaine.jpg in the list.

A preview of elaine.jpg appears in the Assets panel. The panel lists the image's name, dimensions in pixels, size in kilo- or megabytes, and file type, as well as its full directory path.

5. Note the dimensions of the image: 150 pixels by 150 pixels.
6. At the bottom of the panel, click the Insert button.

The Position Assist dialog appears.

Note: When working with images in Dreamweaver, you should be sure that your site’s default images folder is set up according to the directions in the “Getting Started” section at the beginning of the book.

Tip: The Assets panel should be populated as soon as you define a site and Dreamweaver creates the cache. If the panel is empty, click the Refresh Site List icon.

Note: You may need to drag the edge of the panel to widen it to see all the asset information.

Note: The Images window shows all images stored anywhere in the defined site—even ones outside the site’s default images folder—so you may see listings for images stored in the lesson subfolders too.
Click Nest.

The image appears at the beginning of the paragraph. The Element Display now focuses on the `img` element. You can use the Quick Property inspector to add alt text to the image.

Click the Edit HTML Attribute icon 📖.

The Quick Property inspector’s HTML Attribute dialog appears.

In the Alt field in the Element Display, enter Elaine, Meridien GreenStart President and CEO as the alternate text.

Choose File > Save.

You inserted Elaine’s picture in the text, but it doesn’t look very nice at its current position. In the next exercise, you will adjust the image position using a CSS class.

**Controlling image positions with CSS classes**

The `<img>` element is an inline element by default. That’s why you can insert images into paragraphs and other elements. When the image is taller than the font size, the image will increase the vertical space for the line in which it appears. In the past, you could adjust its position using either HTML attributes or CSS,
but many of the HTML-based formatting attributes have been deprecated from the language as well as from Dreamweaver. Now you should rely completely on CSS-based techniques.

In this instance, the employee photos will alternate from right to left going down the page and the text will wrap around the image to use the space more effectively. To do this, you’ll create a custom CSS class to provide options for left and right alignment. You can use the Element Display to create and apply the new class at the same time.

1. If necessary, open contact-us.html in Live view.

2. Click the image of Elaine in the first paragraph of the Association Management section.

   The Element Display appears focused on the img element.

3. Click the Add Class/ID icon.

4. Type .flt-rgt in the text field.

   The new class name is short for “float right,” hinting at what CSS command you’re going to use to style the images.

5. Press Enter/Return.

   The CSS Source dialog appears.

6. If necessary, select mygreen-styles.css from the Select A Source drop-down menu.

7. Press Enter/Return to complete the class.

   The CSS Source dialog disappears, and a new class is created in the style sheet. Let’s take a look.

8. If necessary, select Elaine’s picture.

   In the CSS Designer, click the Current button.

   The new selector appears at the top of the Properties pane.
9. Create the following properties:

```
float: right
margin-left: 10px
```

The image moves to the right side of the `section` element; the text wraps around on the left. As you learned in Lesson 3’s online bonus content, “CSS Basics Bonus,” applying a float property removes an element from the normal flow of the HTML structure, although it still maintains its width and height.

The margin setting keeps the text from touching the edge of the image. You will create a similar rule to align images to the left in the next exercise.

**Working with the Insert panel**

The Insert panel duplicates key menu commands and makes inserting images and other code elements both quick and easy. You can even dock it to the top of the document window to have it available all the time. In this exercise, you will use the Insert panel to add an image to the layout.

1. In Live view, click the first paragraph under the heading *Education and Events*.

   The Element Display appears focused on the `p` tag.

2. Choose Window > Insert to display the Insert panel, if necessary.

3. In the Insert panel, choose the HTML category.

4. Click Image.

The Position Assist dialog appears.
5 Click Nest.

The Select Image Source dialog appears.

6 Select **sarah.jpg** from the site images folder. Click OK/Open.

7 In the Property inspector, enter **Sarah, GreenStart Events Coordinator** in the Alt field.

8 Now you’ll create a new rule for images aligned to the left. In the last exercise, you created the class in the Element Display first. You can also create classes in CSS Designer.

9 In CSS Designer, click the All button, if necessary. Select the class **flt-rgt** class.

If you select a class before creating a new selector, Dreamweaver inserts the new selector directly after the selected rule in the style sheet.

9 Click the Add Selector icon **+**.

Type **.flt-lft** and press Enter/Return.

The name is short for “float left.”
10 Create the following properties in the new rule:
   ```
   float: left
   margin-right: 10px
   ```

11 Select Sarah's image.

12 Click the Add Class/ID icon on Sarah's image.
   Type `.flt-lft` in the field and press Enter/Return.
   As you type, the new class name will appear in the hinting menu. Feel free to select the name when you see it in the list. After you apply the class, the image drops down into the paragraph on the left side, with the text wrapping to its right.

13 Save the file.
   Another way to insert images in your webpage is by using the Insert menu.
Using the Insert menu

The Insert menu duplicates all the commands you'll find in the Insert panel. Some users find the menu faster and easier to use. Others prefer the ready nature of the panel, which allows you to focus on one element and quickly insert multiple copies of it at once. Feel free to alternate between the two methods as desired or even use the keyboard shortcut. In this exercise, you will use the Insert menu to add images.

1. Click the first paragraph under the heading *Transportation Analysis*.

2. Choose Insert > Image or press Ctrl+Alt+I/Cmd+Option+I.
   The Position Assist dialog appears.

3. Click Nest.
   The Select Image Source dialog appears.

4. Navigate to the images folder in lesson08.
   Select the file *eric.png* and click Open.

The *eric.png* image appears in the Dreamweaver layout. Once the classes have been created and defined, you simply have to add the appropriate class using the Element Display.

5. Click the Add Class/ID icon and type the following:

   
   .flt-rgt

   As you type, the class will appear in the hinting menu. You can click the name or use the arrow keys to highlight it, and you can press Enter/Return to select it. As soon as the class is selected, the image floats to the right side of the paragraph.
6 In the Property inspector, type **Eric, Transportation Research Coordinator** in the Alt field.

7 Save all files.

So far, you have inserted only web-compatible image formats. But Dreamweaver is not limited to the file types GIF, JPEG, and PNG; it can work with other file types too. In the next exercise, you will learn how to insert a Photoshop document (PSD) into a webpage.

**Inserting non-web file types**

Although most browsers will display only the web-compliant image formats described earlier, Dreamweaver also allows you to use other formats; the program will then automatically convert the file to a compatible format on the fly.

1 Click the first paragraph under the heading *Research and Development*.

2 Choose Insert > Image.
   Nest the image in the first paragraph.
   Navigate to the lesson08/resources folder.
   Select **lin.psd**.

3 Click OK/Open to insert the image.
   The Image Optimization dialog appears; it acts as an intermediary that allows you to specify how and to what format the image will be converted.

4 Observe the options in the Preset and Format menus.
   The Preset menu allows you to select from six predetermined options that have a proven track record for web-based images. The Format menu allows you to specify your own custom settings from among five options: GIF, JPEG, PNG 8, PNG 24, and PNG 32.
5 Choose JPEG High For Maximum Compatibility from the Presets menu. Note the Quality setting.

This Quality setting produces a high-quality image with a moderate amount of compression. If you lower the Quality setting, you automatically increase the compression level and reduce the file size; increase the Quality setting for the opposite effect. The secret to effective design is to select a good balance between quality and compression. The default setting for the JPEG High preset is 80, which is sufficient for your purposes.

6 Click OK to convert the image.

The Save Web Image dialog appears with the name lin entered in the Save As field. Dreamweaver adds the .jpg extension to the file automatically. Be sure to save the file to the default site images folder. If Dreamweaver does not automatically point to this folder, navigate to it before saving the file.

**Note:** The Image Optimization dialog displays the final file size of the image at the bottom of the dialog.

**Note:** When an image has to be converted this way, Dreamweaver usually saves the converted image into the site's default images folder. This is not the case when the images inserted are web-compatible. So before you insert an image, you should be aware of its current location in the site and move it to the proper folder first, if necessary.
7. Click Save.

The Save Web Image dialog closes. The image appears in the layout and is now linked to the JPEG file saved in the default images folder.

8. Enter Lin, Research and Development Coordinator in the Alt field.

The image appears in Dreamweaver at the cursor position. The image has been resampled to 72 ppi but still appears at its original dimensions, so it's larger than the other images in the layout. You can resize the image in the Property inspector.

9. If necessary, click the Toggle Size Constrain icon to display the closed lock. Change the Width value to 150px and press Enter/Return.

- Tip: The Element Display and the Property inspector can be used interchangeably to enter alt text.

- Note: Whenever you change HTML or CSS properties, you may need to press Enter/Return to complete the modification.

When the lock icon appears closed, the relationship between width and height is constrained, and the two change proportionally to each other—change one and they both change. The change to the image size is only temporary at the moment, as indicated by the Reset and Commit icons. In other words, the HTML attributes specify the size of the image as 150 pixels by 150 pixels, but the JPEG file holds an image that’s still 300 pixels by 300 pixels—four times as many pixels as it needs to have.
10 Click the Commit icon ✓.

The image is now resized to 150 by 150 pixels permanently.

11 Apply the flt-lft class to this image using the Element Display. Save all files. In Live view, the image now appears like the others in the layout; however, this image has a difference. But you can't see it in Live view.

12 Switch to Design view.

In Design view, you can now see an icon in the upper-left corner of the image that identifies this image as a Photoshop Smart Object.

13 Save all files.
Right size, wrong size

Until the latest mobile devices appeared on the scene, deciding what size and resolution to use for web images was pretty simple. You picked a specific width and height and saved the image at 72 pixels per inch. That’s all you needed to do.

But today, web designers want their sites to work well for all visitors, no matter what type or size of device they want to use. So, the days of picking one size and one resolution may be gone forever. But what’s the answer? At the moment, there isn’t one perfect solution.

One trend simply inserts an image that is larger or has higher resolution and resizes it using CSS. This allows the image to display more clearly on high-resolution screens, like Apple’s Retina display. The downside is that lower-resolution devices are stuck downloading an image that’s larger than they need. This not only slows the loading of the page for no reason, but it can incur higher data charges for smartphone users.

Another idea is to provide multiple images optimized for different devices and resolutions and use JavaScript to load the proper image as needed. But many users object to using scripts for such basic resources as images. Others want a standardized solution.

So, W3C is working on a technique that uses a new element named `<picture>`, which will not require JavaScript at all. Using this new element, you would select several images and declare how they should be used, and then the browser would load the appropriate image. Unfortunately, this element is so new that Dreamweaver doesn’t support it yet, and few browsers even know what it is.

Implementing a responsive workflow for images is outside the scope of this course. In Lesson 14, “Working with a Web Framework,” you will learn how to adapt standard web images to a responsive template using CSS and media queries.

Working with Photoshop
Smart Objects (optional)

Unlike other images, Smart Objects maintain a connection to their original Photoshop (PSD) file. If the PSD file is altered in any manner and then saved, Dreamweaver identifies those changes and provides the means to update the web image used in the layout. The following exercise can be completed only if you have Photoshop installed on your computer along with Dreamweaver.

1. If necessary, open `contact-us.html` in Design view.
   Scroll down to the `lin.jpg` image in the Research and Development section.
   Observe the icon in the upper-left corner of the image.
The icon indicates that the image is a Smart Object. The icon appears only within Dreamweaver itself; visitors see the normal image in the browser, as you saw originally in Live view. If you want to edit or optimize the image, you can simply right-click the image and choose the appropriate option from the context menu.

To make substantive changes to the image, you will have to open it in Photoshop. (If you don’t have Photoshop installed, copy lesson08/resources/smartobject/lin.psd into the lesson08/resources folder to replace the original image, and then skip to step 6.) In this exercise, you will edit the image background using Photoshop.

2 Right-click the lin.jpg image. Choose Edit Original With > Adobe Photoshop CC 2019 from the context menu.

Photoshop launches—if it is installed on your computer—and loads the file.

3 In Photoshop, choose Window > Layers to display the Layers panel, if necessary. Observe the names and states of any existing layers.

The image has two layers: Lin and New Background. New Background is turned off.

4 Click the eye icon for the New Background layer to display its contents.

The background of the image changes to show a scene from a park.

**Note:** The exact name of the apps appearing in the menu may differ depending on your operating system and what version of Photoshop you have installed. If no version of Photoshop is installed at all, you may not see any program listed.
5 Save the Photoshop file.

6 Switch back to Dreamweaver. Position the cursor over the Smart Object icon.
A tool tip appears indicating that the original image has been modified. You don’t have to update the image at this time, and you can leave the out-of-date image in the layout for as long as you want. Dreamweaver will continue to monitor its status as long as it’s in the layout. But for this exercise, let’s update the image.

7 Right-click the image and choose Update From Original from the context menu.

This Smart Object, and any other instances of it, changes to reflect the new background. You can check the status of the Smart Object by positioning the pointer over the image. A tool tip should appear showing that the image is synced. You can also insert the same original PSD image multiple times in the site using different dimensions and image settings under different filenames. All the Smart Objects will stay connected to the PSD and will allow you to update them as the PSD changes.

8 Save the file.

As you can see, Smart Objects have several advantages over a typical image workflow. For frequently changed or updated images, using a Smart Object can simplify updates to the website in the future.

**Copying and pasting images from Photoshop (optional)**

As you build your website, you will need to edit and optimize many images before you use them in your site. Adobe Photoshop is an excellent program for performing these tasks. A common workflow is to make the needed changes to the images and then manually export the optimized GIF, JPEG, or PNG files to the default images folder in your website. But sometimes simply copying images and pasting them directly into your layout is faster and easier.
1 Launch Adobe Photoshop, if necessary.
Open *matthew.tif* from the lesson08/resources folder.
Observe the Layers panel.

The image has only one layer. In Photoshop, by default you can copy only one layer at a time to paste into Dreamweaver. To copy multiple layers, you have to merge or flatten the image first, or you have to use the command Edit > Copy Merged to copy images with multiple active layers.

2 Choose Select > All, or press Ctrl+A/Cmd+A, to select the entire image.

3 Choose Edit > Copy, or press Ctrl+C/Cmd+C, to copy the image.

4 Switch to Dreamweaver. Scroll down to the Information Systems section in *contact-us.html*. Insert the cursor at the beginning of the first paragraph in this section and before the name Matthew.

5 Press Ctrl+V/Cmd+V to paste the image from the clipboard.

The image appears in the layout with the Image Optimization dialog.

Note: You should be able to use any version of Photoshop for this exercise. But Creative Cloud subscribers can download and install the latest version at any time.

Tip: When inserting images that are outside the default site images folder, Dreamweaver may try to save the image in its original location, which may be outside the site folder. When in doubt, use the Site Root button in the Save As dialog to focus the dialog on the site folder. Then select the images folder from there.
Choose the preset PNG24 For Photos (Sharp Details), and choose PNG24 from the Format menu. Click OK.

The Save Image dialog appears.

If necessary, navigate to the default site images folder. Name the image `matthew.png` and select the default site images folder, if necessary. Click Save.

You have now saved the image as a web-compatible PNG file in the site images folder. Just like the image of Lin, Matthew’s image is larger than the others.

Click on the image to select it. In the Properties inspector, change the image dimensions to 150px by 150px. Click the Commit icon to apply the change. Click OK in the dialog that appears, acknowledging that the change is permanent.

**Note:** Raster images can be scaled down in size without losing quality, but the opposite is not true. Unless a graphic has a resolution higher than 72 ppi, scaling it larger without noticeable degradation may be impossible.

If necessary, select the image for Matthew and enter **Matthew, Information Systems Manager** in the Alt field in the Property inspector.
10 Apply the `flt-rgt` class to `matthew.png` using the Class menu in the Property inspector.

The image appears in the layout at the same size as the other images and aligned to the right. Although this image came from Photoshop, it’s not “smart” like a Photoshop Smart Object and can’t be updated automatically. It does, however, give you an easy way to load the image into Photoshop or another image editor to perform any modifications.

11 In the layout, right-click `matthew.png`. Choose Edit With > Photoshop CC 2019 from the context menu. If Photoshop CC 2019 is not installed, select the program that is displayed.

▶ Tip: If no image-editor program is displayed, you may need to browse for a compatible editor. The executable program file is usually stored in the Program Files folder in Windows and in the Applications folder on a Mac.

The program launches and displays the PNG file from the site images folder. If you make changes to this image, you merely have to save the file to update the image in Dreamweaver.

Note: The exact name displayed in the menu may differ depending on the program version or operating system installed.
In Photoshop, press Ctrl+L/Cmd+L to open the Levels dialog. Adjust the brightness and contrast. Save and close the image.

Switch back to Dreamweaver. Scroll down to view the matthew.png image in the Information Systems section. The image should be updated in the layout automatically. Since you saved the changes under the original filename, no other action is necessary. This method saves you several steps and avoids any potential typing errors.

Save all files.

In the next exercise, you will insert an image using drag and drop.

**Inserting images by drag and drop**

Most of the programs in Creative Cloud offer drag-and-drop capabilities. Dreamweaver is no exception.

1. Open news.html from the site root folder in Live view.
2. Choose Window > Assets to display the Assets panel, if necessary.
   
   The Assets panel may not be opened by default in the Dreamweaver workspace. You can leave it as a floating dialog or dock it to keep it out of the way.
3. If necessary, drag the Assets panel to dock it beside the Files or DOM tab.
4. In the Assets panel, click the Images category icon.

   **Tip:** If you don’t see specific image files listed in the Assets panel, click the Refresh icon to reload site images.
5 Drag the skyline.png icon from the panel and position the cursor between the first paragraph and the heading *Green Buildings earn more Green.*

If you position the cursor correctly, you will see a green line between the heading and the paragraph, indicating where the image will be inserted once you release the mouse.

Unlike the images used in the previous exercises, skyline.png was inserted between the `<h2>` and `<p>` elements. It is not part of any of the paragraphs, so no float command is needed.

6 Enter **Green buildings are top earners** in the Property inspector’s Alt field.

7 Save all files.

For users who do not have Photoshop or another image editor, Dreamweaver provides tools for basic image processing.

---

### Optimizing images with the Property inspector

Optimized web images try to balance image dimensions and quality against file size. Sometimes you may need to optimize graphics that have already been placed on the page. Dreamweaver has built-in features that can help you achieve the smallest possible file size while preserving image quality. In this exercise, you’ll use tools in Dreamweaver to scale, optimize, and crop an image for the web.

1 If necessary, open **news.html** in Live view or switch to it.

2 Click to select the first paragraph below the *Shopping green saves energy* heading.

3 Choose Insert > Image. Click Nest in the Position Assist dialog. Select farmersmarket.png from the site images folder. Click Open.

4 Enter **Buy local to save energy** in the Alt field.
Apply the .flt-rgt class to the image.

The image is too large, and there's barely any room for it in the column. It could really use some resizing and cropping. Dreamweaver's built-in tools work only in Design view.

Switch to Design view and observe the Property inspector.

Whenever an image is selected, image-editing tools appear below the Class menu in the Property inspector. The icons allow you to edit the image in Photoshop or Adobe Fireworks or to adjust several aspects in place. See the sidebar “Dreamweaver’s graphic tools” at the end of the lesson for an explanation of each tool.

There are two ways to reduce the dimensions of an image in Dreamweaver. The first method changes the size of the image temporarily by imposing user-defined dimensions.
7 Select `farmersmarket.png`. If necessary, click the Toggle Size Constrain icon in the Property inspector to lock the image proportions. Change the image width to **350 pixels** and press the Tab key.

When the size constraint is locked, the height automatically conforms proportionally to the new width. Note that Dreamweaver indicates that the new size is not permanent by displaying the current specifications in bold and by displaying the Reset and Commit icons.

8 Click the Commit icon ✓.

A dialog appears that indicates the change will be permanent.

9 Click OK.

Dreamweaver can also crop images.

10 With the image still selected, click the Crop icon in the Property inspector.

A dialog appears indicating that the action will permanently change the image.

11 Click OK.

Crop handles appear slightly inset from the edges of the image. You want to crop the width but not the height.

12 Drag the crop handles to set the image to a width of 300 pixels and a height of 312 pixels.

---

**Tip:** Dimensions may also be entered manually if you know the final proportions.
Press Enter/Return to apply the change.

Save all files.

Most designers edit and resize images prior to bringing them into Dreamweaver, but it’s nice to know that these tools are available for any last-minute changes or fast turnarounds.

In this lesson, you learned how to insert images and Photoshop Smart Objects into a Dreamweaver page, copy and paste from Photoshop, and use the Property inspector to edit and resample images.

There are numerous ways to create and edit images for the web. The methods examined in this lesson show but a few of them and are not meant to recommend or endorse one method over another. Feel free to use whatever methods and workflow you desire based on your own situation and expertise.

Dreamweaver’s graphic tools

All Dreamweaver’s graphic tools appear in the Property inspector when an image is selected in Design view. Here are the seven tools:

- **Edit**—Opens the selected image in the defined external graphics editor if you have one installed. You can assign a graphics-editing program to any given file type in the File Types/Editors category of the Preferences dialog. The button’s image changes according to the program chosen. For example, if Fireworks is the designated editor for the image type, a Fireworks icon is shown; if Photoshop is the editor, you’ll see a Photoshop icon. If neither app is installed, you will see a generic edit icon.

- **Edit Image Settings**—Opens the Image Optimization dialog, allowing you to apply user-defined optimization specifications to the selected image.

- **Update From Original**—Updates any placed Smart Object to match any changes to the original source file.

- **Crop**—Permanently removes unwanted portions of an image. When the Crop tool is active, a bounding box with a series of control handles appears within the selected image. You can adjust the bounding box size by dragging the handles or by entering the final dimensions. When the box outlines the desired portion of the image, press Enter/Return or doubleclick the graphic to apply the cropping.

- **Resample**—Permanently resizes an image. The Resample tool is active only when an image has been resized.

- **Brightness And Contrast**—Offers user-selectable adjustments to an image’s brightness and contrast; a dialog presents sliders for each value that can be adjusted independently. A live preview is available so that you can evaluate adjustments before committing to them.

- **Sharpen**—Affects the enhancement of image details by raising or lowering the contrast of pixels on a scale from 0 to 10. Like the Brightness And Contrast tool, Sharpen offers a real-time preview.

You can undo most graphics operations by choosing Edit > Undo until the containing document is closed or you quit Dreamweaver.
Review questions

1. What are the three factors that determine raster image quality?
2. What file formats are specifically designed for use on the web?
3. Describe at least two methods for inserting an image into a webpage using Dreamweaver.
4. True or false: All graphics have to be optimized outside of Dreamweaver.
5. What is the advantage of using a Photoshop Smart Object over copying and pasting an image from Photoshop?

Review answers

1. Raster image quality is determined by resolution, image dimensions, and color depth.
2. The compatible image formats for the web are GIF, JPEG, PNG, and SVG.
3. One method to insert an image into a webpage using Dreamweaver is to use the Insert panel. Another method is to drag the graphic file into the layout from the Assets panel. Images can also be copied and pasted from Photoshop and Fireworks.
4. False. Images can be optimized even after they are inserted into Dreamweaver by using the Property inspector. Optimization can include rescaling, changing format, or fine-tuning format settings.
5. A Smart Object can be used multiple times in different places on a site, and each instance of the Smart Object can be assigned individual settings. All copies remain connected to the original image. If the original is updated, all the connected images are immediately updated as well. When you copy and paste all or part of a Photoshop file, however, you get a single image that can have only one set of values applied to it.
INDEX

SYMBOLS

# (hash mark), appearance with attributes, 383
<!-- --> tag, 61

NUMBERS

0 dimension, entering, 160
4-bit color, 251
8-bit palette, 250–252
16.7 million colors, 251
24-bit color, 251
32-bit color, 251
72 ppi, 252
130K compression, 253
150K compression, 253
256 colors, 251–252
260K compression, 253

A

<a href=>, 280
</a> tag, 280
<a> tag, 61
a:active pseudo-class, 309
About Page, 116
aboutus-finished.html, 281
about-us.html, 170, 284
absolute hyperlinks, 280, 291–294
accordion widgets. See jQuery accordion widgets
Add Behavior icon, 323, 325, 327–329
Add Class/ID icon, 211, 214, 257, 260
Add New Server icon, 353
Add Selector icon, 176, 186, 259, 336
Adobe Add-ons, 16, 317
Adobe Authorized Training Centers, 16
Adobe Creative Cloud, 5
Adobe Dreamweaver CC product home page, 16
Adobe Dreamweaver Learn & Support, 16
Adobe Forums, 16
a:focus pseudo-class, 309
a:hover pseudo-class, 309
AI file format, 248
a:link pseudo-class, 309
a:visited pseudo-class, 309
All media type property, 417
All mode, CSS Designer, 50
alpha transparency, 251
Alt key. See keyboard shortcuts
alt text, 256
analytics, 101
anchor tag, HTML, 61
Apache/ColdFusion website, 358
Apache/PHP website, 358
App Theme window, 27
Apply Comment icon, 385
<article> tag, 64, 80, 114
<aside> tag, 64, 114
assets, previewing in Code view, 406–407
Assets panel, 20, 195, 272
attributes, hyperlinks, 280
<audio> tag, 64
aural media type property, 417
auto-backup feature, 185
a:visited pseudo-class, 309

B

background, HTML default, 74. See also CSS background effects; gradient background background effects, jQuery accordion tabs, 337–338
background layer, displaying contents, 267
background-color: property, 344, 347
background-image: property, 141, 344, 347
background-repeat command, 141
backing up files, 185
behaviors
  adding to hyperlinks, 327–329
  applying, 323–325
  overview, 316–317
  pages and templates, 319–323
  removing, 326
  Swap Image, 323–326
  Swap Image Restore, 325–326
Behaviors panel, 20
Berners-Lee, Tim, 58–59
bit depth, 250
block elements, HTML, 60
<blockquote> tag, 61, 159–160
Blog Post, 116
body text, HTML default, 74
<body> tag, 61
bolded text, 2
bonus material, 8–9
Bootstrap web framework
  components, 426–430
  features, 422
  grid structure, 423–425
  layout, 425–426, 433
  semantic content, 430–433
Bootstrap widgets, 329–330, 347
border effects, CSS3, 94
border-bottom-color, 308
border-left-color, 308
border-right-color, 308
borders
  CSS box model, 76
  tables, 216
border-top-color, 308
box model, CSS, 76–77
box shadows, CSS3, 94
boxmodel.html, 76
<br> tag, 61
braille media type property, 417
Brightness And Contrast tool, 276
Browse For File icon, 285
Browse For Folder icon, 388
browsers, 75
bullet character entity, 63
bulleted lists, 209

calendar.html, 219
<canvas> tag, 64
caption elements, adding and formatting, 234–235
cascade theory, CSS, 78, 80
CC Files option, Start Screen, 21
CC Libraries panel, 20
cells. See table cells
CERN (Conseil Européen pour la Recherche Nucléaire), 58
character entities, HTML, 62–63
checklist, prelaunch, 364
child pages. See also parent elements
  adding content, 170–177
  creating, 168–170
  updating links, 289–291
Chrome browser, 75
<cite> element, 204
class attribute, CSS, 92–93
“class” element modifier, 77–78
class names, 211–212
classes, CSS rules, 335
clipboard, 197, 269
cloaking folders and files, 360–361
closing tag, hyperlinks, 280
Cmd key. See keyboard shortcuts
code. See also HTML code; Split Code view
  collapsing, 404
  expanding, 404–405
  font, 2
  selecting, 401–403
Code Navigator, CSS, 83–87
code structure, HTML, 60
Code Theme window, 27
  See also Live Code
code-hinting window, 377–378
code-troubleshooting display, 31
Coding toolbar, 40
ColdFusion, 352, 358
Collapse icon, 369, 404
collapsing
code, 404
panels, 34
color: property, 309, 328, 338, 369, 391
color space, 250
color theme, choosing for Dreamweaver, 9–10
colors, CSS (cascading style sheets), 91
columns
  adding to tables, 219
  selecting in tables, 228–229
commands, 77. See also keyboard shortcuts;
  menu commands
Commands pop-up menu, 41
comment tag, HTML, 61
commenting code, 385–386
Commit icon, images, 264–265, 270
Common toolbar, 40, 342, 384
compiling CSS code, 392–395
compression algorithms, images, 252–253
COMPUTED option, Properties panel, 49, 90
Connect To Remote Server icon, 365
contactus-finished.html, 192, 254
contact-us.html
  absolute links, 292
  checking pages, 311
  email links, 295
  id-based link destinations, 304
  image positions, 257
  image-based links, 297
  inserting images, 255
  locking elements on screen, 305
  navigation menu, 307
Smart Objects, 266
spell-checking, 236
text links, 298
content. See also semantic content
  injecting, 412
  vs. presentation, 77
  replacing, 174
Contrast and Brightness tool, 276
&copy; character entity, 63
copying and pasting
  images from Photoshop, 268–272
  selections, 241
  styles, 46
  tables, 219–220
  text, 143–144, 146, 172
copyright character entity, 63
Create New button, 23
Crop tool, 275–276
CSS (cascading style sheets)
  box model, 76–77
  cascade theory, 78, 80
  class attribute, 92–93
  class selector, 93
  Code Navigator, 83–87
  colors, 91
  declarations, 77
  descendant theory, 81
  embedded formatting, 77
  formatting elements, 91
  id attribute, 93–94
  inheritance theory, 80
  inline formatting, 77
  linked formatting, 77
  overview, 70
  rules and properties, 77–78, 80, 82, 92
  selectors, 77, 81
  shorthand, 92
  specificity theory, 81–82
  styling, 77
  typefaces vs. fonts, 221
CSS background effects, 138–142. See also
  background
CSS classes, image positions, 256–258
CSS code, compiling, 392–395
CSS Designer, 20, 46–50, 87–91, 120–121, 128,
  334. See also tag selectors
CSS formatting vs. HTML, 70–72
CSS layouts, 114–116
CSS preprocessors
  enabling, 386–389
  resources, 399
  source files, 389–391
CSS Primer, 84, 86, 89–91
CSS rules
  creating, 145
  displaying, 212
  formatting text, 128
  media queries, 418
  nav, 121–122
  table cells, 225–227
  using, 77–78, 80, 82, 92
CSS selectors, nesting, 395–397
CSS source file, 389–392
CSS Source pop-up window, 212, 303
CSS styles. *See also* styling
classes, 335
Extract panel, 120
Extract workflow, 38–39
moving to linked files, 177–181
navigation menu, 307–311	
tables, 220–225
troubleshooting, 125–127
CSS tab, Property inspector, 43
CSS troubleshooting, 31
css basics finished.html, 83, 87
css formatting.html, 71
CSS3
features and effects, 94–95
overview and support, 95
css3 demo.html, 94
ctr selector, 301
Ctrl key. *See* keyboard shortcuts
Current button, CSS Designer, 50, 121, 128, 334
cursor movement, 217. *See also* multicursor support
Customize Toolbar icon, 342, 384
cutting
keyboard shortcut, 174
tables, 85

d declarations, CSS, 77–78
default images folder, 255. *See also* images
dependent files, 364–366. *See also* files
deprecated, defined, 71
descendant
CSS rule, 78
theory, 81
description, including, 165. *See also* meta
description element
descriptive metadata, 256
Design view, 20, 28–29, 288
desktop page design, 104–105
destination links, 303–304, 312, 282.
*See also* hyperlinks
Developer workspace, 33
dimensions, pixels and percentages, 129
displays, 51–53
dithering, 250

div tag, 61, 113
doc and .docx (Microsoft Word) files, cloaking, 360
docking panels, 36–37
Document tab, 20
Document Title field, 165
document toolbar, 20, 39
documents, creating, 115, 169
DOM (Document Object Model), 51, 200
dpi (dots per inch), 249
drag and drop, inserting images, 272–273
dragging panels, 35
Dreamweaver
color theme, 9–10
Help, 16
installing, 4–5
launching, 9
updating, 5–6
Dreamweaver site, defining, 11–15
drop zone, 36
Duplicate Set icon, 40
duplicating menu commands, 258
.dwt file extension, 155. *See also* templates
e
Edge/IE browser, 75
Edit icon, 387
Edit Image Settings tool, 276
Edit tool, 276
editable regions. *See also* templates
formatting content, 186–188
inserting, 155–158
semantic content, 158–163
using, 170
editing
HTML tags, 159
hyperlinks, 285
text, 144
editing mode, Live view, 197
elaine.jpg, 255
element dialogs, 51–53
Element Display
destination links, 303–304
entering text, 264
image-based links, 297–298
using, 52, 130, 198, 211, 213–214, 346
element references, 3

elements. See also HTML elements
formatting in CSS, 91
locking on screen, 305–307
Em Dash, replacing hyphen, 171
em measurements, 306
<em> tag, 61
email links, 295–296. See also spam
embedded formatting, CSS, 77
embossed media type property, 417
Emmet web-developer toolkit, 379, 382
en dash character entity, 63
EPS file format, 248
error checking, 399–400
events-finished.html, 192
events.html
caption elements, 234
finding and replacing text, 238
internal targeted links, 300, 302
Expand icon, 365, 404–405
expressions, media queries, 418
external hyperlinks, 280, 291–294
Extract Asset icon, 137
Extract panel
gradient backgrounds, 128–132
image assets from mockups, 132–138
styling elements, 119–123
text from Photoshop mockup, 123–125
text styling from mockup, 127–128
Extract workflow, 38–39, 117–118
eye icon, 267

F
farmersmarket.png, 275
<figcaption> tag, 64
figure andfigcaption elements, 320–321
figure tag selector, 174–176
<figure> tag, 64
File Activity tag, 367
file browser, 388
files. See also dependent files; linked files; non-web
file types; opening files; Related Files interface
cloaking, 360–361
opening, 192
saving, 167, 185
Files panel, 20, 26, 281
Find and Filter options, 240
finding and replacing text, 238–239, 241–242
Firefox browser, 75
 fla (Flash) files, cloaking, 360
float property, 258–259
floating panels, 36–37
folders
browsing, 388–389
cloaking, 360–361
organizing, 14
font-family: property, 328
fonts
HTML default, 74
managing, 222–224
stacks, 222
vs. typefaces, 221
footer, 112–113
footer styling, accordion tab, 337–338
<footer> tag, 64, 114
<form> tag, 61
Format menu, images, 262–263
formatting
caption elements, 234–235
content in editable regions, 186–188
formatting elements, CSS, 91
FTP (File Transfer Protocol), 352. See also remote
FTP site
FTP connection
testing, 355
troubleshooting, 356
FTP over SSL/TLS, 352
FTP Performance Optimization, 355
FTPS (secure FTP), 352

G
Get icon, 367–368
GIF (Graphics Interchange Format), 252
Git version control, 53–54
Google Analytics, 101
Google Maps, 282–283
gradient background, creating, 128–132. See also
background
cloaking, 360–361
collection, 84
gradient fills, CSS3, 94
graphic tools, 276
graphics operations, undoing, 276
graphics programs, using to create wireframes, 106–107
GreenStart_mockup.html, 112, 423
GreenStart_mockup.psd, 106, 118–119
green-styles.scss, 390
grouping panels, 36–37

H
<h1> to <h6> tags, 61, 201
handheld media type property, 417
hanging quotation mark, 160
hash mark (#), appearance with attributes, 383
header, 112–113
header element, completing styling, 142–143
<header> tag, 64, 114
headings
   creating, 201
   HTML default, 74
height and width, constraining for images, 264
<hgroup> tag, 64
high color, palette, 251
high compression, 253
home links, 287–289
home pages, 362–366
horizontal rule tag, HTML, 61
href="" attribute, 393
HTML (HyperText Markup Language)
   character entities, 62–63
   code structure, 60
   vs. CSS formatting, 70–72
defaults, 72–74
elements, 59–63
navigation menus, 379
overview, 58–59
tags, 60–63
HTML 4.01, targeting page elements, 299
HTML code. See also code
   adding lines, 381
   commenting, 385–386
   validating, 167–168
   writing automatically, 379–383
   writing manually, 376–379
HTML elements, 78. See also elements hyperlinks, 280
   <img>, 256
   page design, 113
HTML entities, inserting, 163–164
HTML structures, 202–205
HTML tab, Property inspector, 42–43
HTML tags. See also Quick Tag Editor
   <!--.--> , 61
   <a>, 61
   <blockquote>, 61
   <body>, 61
   <br>, 61
   <div>, 61
editing, 159
   <em>, 61
   <form>, 61
   <h1> to <h6>, 61, 201
   <html>, 61
   <input>, 61
   <li>, 209
   <link>, 61
   <meta>, 61, 166
   <ol>, 62, 208–209
   <p>, 62
   <script>, 62
   <section>, 207
   <span>, 62
   <strong>, 62
   <style>, 62
   <table>, 62
   <td>, 62
   <textarea>, 62
   <th>, 62, 226
   <title>, 62
   <tr>, 62
   <ul>, 62
html_defaults.html, 73
html_formatting.html, opening, 71
<html>, 61
HTML5
defaults, 73–74
   semantic web design, 64–65
tags, 63–64
techniques and technology, 65
Commit icon, 264–265, 270
compression algorithms, 252–253
constraining width and height, 264
copying and pasting from Photoshop, 268–272
entering dimensions manually, 275
folder, 14
Format menu, 262–263
Insert menu, 261–262
Insert panel, 258–260
inserting, 255–256
inserting by drag and drop, 272–273
naming ids, 322
Nest option, 256, 259, 261
optimizing with Property inspector, 273–276
pasting from clipboard, 269
Position Assist dialog, 258
Preset menu, 262–263
quality, 253
Quality setting, 263
raster graphics, 248–252
Reset icon, 264
size, 250
vector graphics, 248
Images category icon, 255, 272
<img>, 61, 256
importing
style sheets, 397–399
text, 195–198
indented text, 209–214. See also text
index home pages, 362–366
index.html, opening, 25
inheritance theory, CSS, 80
injected content, 412
inline elements, HTML, 60
inline formatting, CSS, 77
<input>, 61
Insert menu, images, 261–262
Insert panel
duplicating menu commands, 258
images, 258–260
inserting
editable regions, 155–158
HTML entities, 163–164
images, 255–256
images by drag and drop, 272–273
jQuery accordion widgets, 330–332

hyperlinks. See also destination links
absolute, 291–294
adding behaviors, 327–329
attributes, 280
closing, 280
destinations, 282, 312
editing and removing, 285
e-mail, 295–296
external, 291–294
home links, 287–289
HTML elements, 280
image-based, 297–298
internal, 284–291
internal and external, 280
pseudo-classes, 309
relative vs. absolute, 280–281, 284–287
Target menu, 294
testing, 291
text, 280
updating in child pages, 289–291
URLs (uniform resource locators), 280–281
values, 280
hyphen, replacing with Em Dash, 171

id attribute, CSS, 93–94, 299
“id” element modifier, 77–78
id unique identifiers, 303
id-based link destinations, targeting, 304–305
ids for images, naming, 322
IIS/ASP website, 358
image assets, 38–39, 132–138
Image Display, 52–53
image formats, 105
Image Optimization dialog, 263, 269
image positions, CSS classes, 256–258
image properties, 43
image-based links, 297–298
image-editor program, 271
Images, window, 255
images. See also default images folder; Preload
Images option; Swap Image behavior;
web images
alt text, 256
color space, 250
Quick Editor, 144, 161, 199
selecting all text, 172
undoing actions, 380
using, 40–42

L
Launching Dreamweaver, 9
layout.html, 116–117
layouts. See also predefined layouts
completing, 142–149
styling, 117–119
Learn tab, Start Screen, 21
LESS CSS preprocessor, 386, 388
lessons
files, 6
order, 8
<1i> element, 209, 379–380
line numbers, selecting code, 401
lines
adding to code, 381
cutting in Code Navigator, 85
lin.jpg image, 266–267
Link Checker panel, 311
link field, 298
<link>, 61
linked files, moving CSS styles to, 177–181.
See also files
linked formatting, CSS, 77
links. See hyperlinks
lin.psd, inserting, 262
Linting support, 399–400
lists, creating, 205–209
Live Code, dynamic styling, 341–345. See also
Code view
Live Source Code, 31
Live view
absolute links, 291–294
editing mode, 197
pasting paragraphs, 197
selecting text, 293
using, 20, 29, 71
local and remote sites, synchronizing, 368–371
local site, 11, 352, 358
Local Web Fonts, 223
local/network connection, 352

J
JavaScript vs. jQuery, 333
JPEG (Joint Photographic Experts Group), 252
jQuery accordion tabs
  background effects, 337–338
  conditional state, 338–341
  styling, 333–337
jQuery accordion widgets
  background content, 345–347
  classes, 335
  conditional state for tabs, 338–341
  inserting, 330–332
  Live Code and dynamic styling, 341–345
  styling, 333–338
  working with, 329
jQuery Mobile web framework, 422
jQuery vs. JavaScript, 333
jQuery widgets, 347

K
keyboard shortcuts. See also commands
copying and pasting, 144, 146, 172, 241
cutting, 174
cutting lines, 85
editing, 159
Files panel, 26, 281
<h2> element, 201
inserting images, 261
New Document dialog, 169
opening files consecutively, 192
Quick Editor, 144, 161, 199
selecting all text, 172
undoing actions, 380
using, 40–42

L
Launching Dreamweaver, 9
layout.html, 116–117
layouts. See also predefined layouts
completing, 142–149
styling, 117–119
Learn tab, Start Screen, 21
LESS CSS preprocessor, 386, 388
lessons
files, 6
order, 8
<1i> element, 209, 379–380
line numbers, selecting code, 401
lines
adding to code, 381
cutting in Code Navigator, 85
lin.jpg image, 266–267
Link Checker panel, 311
link field, 298
<link>, 61
linked files, moving CSS styles to, 177–181.
See also files
linked formatting, CSS, 77
links. See hyperlinks
lin.psd, inserting, 262
Linting support, 399–400
lists, creating, 205–209
Live Code, dynamic styling, 341–345. See also
Code view
Live Source Code, 31
Live view
absolute links, 291–294
editing mode, 197
pasting paragraphs, 197
selecting text, 293
using, 20, 29, 71
local and remote sites, synchronizing, 368–371
local site, 11, 352, 358
Local Web Fonts, 223
local/network connection, 352

J
JavaScript vs. jQuery, 333
JPEG (Joint Photographic Experts Group), 252
jQuery accordion tabs
  background effects, 337–338
  conditional state, 338–341
  styling, 333–337
jQuery accordion widgets
  background content, 345–347
  classes, 335
  conditional state for tabs, 338–341
  inserting, 330–332
  Live Code and dynamic styling, 341–345
  styling, 333–338
  working with, 329
jQuery Mobile web framework, 422
jQuery vs. JavaScript, 333
jQuery widgets, 347

K
keyboard shortcuts. See also commands
copying and pasting, 144, 146, 172, 241
cutting, 174
cutting lines, 85
editing, 159
Files panel, 26, 281
<h2> element, 201
inserting images, 261
New Document dialog, 169
opening files consecutively, 192
lock icon, 264
locking elements on screen, 305–307
logical operators, media queries, 418
logo, creating, 143–146
Lorem generator, Emmet, 382
lossy compression, 252
low compression, 253

M
macOS
   Terminal, 59
   vs. Windows instructions, 3–4
mailto:, 296–298
main content, 112–113
<main>, 64, 382
MAMP local server, 358
Manage Fonts dialog, 222
Manage Sites dialog, 386–387
map links, sharing, 292
margin: property, 391
margin-bottom: property, 328
margins, HTML default, 74
margin-top: property, 306, 328
matthew.tif, 269
media queries, 418–420. See also VMQ (Visual Media Query) interface
media type properties, 417
@media window, CSS Designer, 47
medium compression, 253
menu bar, 20
menu commands, 41, 258. See also commands
Meridien GreenStart sample website, 103
meta description element, 205–206, 256.
   See also description
<meta>, 61, 166–167
metadata, inserting, 164–167
minimizing panels, 34
mobile page design, 104–105. See also smartphones; responsive web design
mobile-first design, 412
mockups
   creating, 106–107, 112
   extracting image assets, 132–138
   extracting text, 123–125
   extracting text styling, 127–128
MS DOS, 59
multicolumn text elements, CSS3, 94
multicursor support, 383–384. See also cursor movement
myBootstrap.html, 426, 431
myfirstpage.html
   assets in Code view, 406
   combining style sheets, 398
   commenting code, 385
   CSS source file, 389
   Linting support, 399
   multicursor support, 383
   writing code automatically, 379
mygreen_temp.dwt
   behaviors, 319
   editable regions, 156
   home links, 287
   HTML entities, 163
   metadata, 165
   semantic content, 158
   validating HTML code, 167
mygreen-styles.css, 228
mylayout.html
   finishing layout, 142
   styling layouts, 117
   template from layout, 154

N
named anchor, 299
named entities, 163
nav rule, 121
<nav>, 64, 114
navigation, 112–113
navigation menu
   HTML, 379
   styling, 307–311
&nbsp; character entity, 63
Nest option, images, 256, 259, 261
nesting CSS selectors, 395–397
New Document dialog, 169
New Features, 20, 24
news-finished.html, 192, 254
news.html
   dragging and dropping images, 272
   HTML structures, 202
optimization with Property inspector, 273
relative links, 285
semantic text structures, 198
nonbreaking space character entity, 63
non-web file types, inserting, 262–265. See also
files; webpages
numbered entities, 163
numbered lists, 209

O

<ol>, 62, 208–209
online content, 6–7
onMouseOver attribute, 324
Open button, 23
opening files. See also files
aboutus-finished.html, 281
about-us.html, 170, 284
boxmodel.html, 76
calendar.html, 219
contactus-finished.html, 192, 254
contact-us.html, 236, 255, 257, 266, 292, 295,
297–298, 304–305, 307, 311
css_basics_finished.html, 83, 87
css_formatting.html, 71
css3_demo.html, 94
events-finished.html, 192
events.html, 234, 238, 300, 302
farmersmarket.png, 275
GreenStart_mockup.html, 112, 423
GreenStart_mockup.psd, 106, 118–119
html_defaults.html, 73
html_formatting.html, 71
layout.html, 116–117
matthew.tif, 269
myBootstrap.html, 426, 431
myfirstpage.html, 379, 383, 385, 389,
398–399, 406
mygreen_temp.dwt, 156, 158, 163, 165, 167,
287, 319
mygreen-styles.css, 228
mylayout.html, 142, 154
news-finished.html, 192, 254
news.html, 198, 202, 272–273, 285
quotes07.txt, 202–203
sidebars06.html, 173
sidebars10.html, 319
tips-finished.html, 192, 329
tips.html, 330, 338, 345
travel_finished.html, 318
Opera browser, 75
Opt key. See keyboard shortcuts
ordered lists, 208–209
outdent, 160
overflow: property, 396

P

<p>, 62
padding
CSS rule, 79
HTML default, 74
page description, 165
page design
component scheme, 112–113
creating, 104–105
HTML elements, 113
options, 112
page elements, targeting, 299–305
page title, 164
pages. See webpages
palettes, 250–251
panels, 33–37
paragraphs
HTML default, 74
pasting into Live view, 197
parent elements, CSS, 80. See also child pages
parents, selecting code, 403
Passive FTP, 355–356
Paste Special command, 173
Paste Styles, 122
pasting. See copying and pasting
percentages and pixels, 129
photos. See copying and pasting images
Photoshop, copying and pasting images, 268–272
Photoshop mockup
extracting text, 123–125
extracting text styling, 127–128
Photoshop Smart Objects, 266–268
PICT file format, 248
pictures. See images pixels
  and percentages, 129
raster graphics, 248–249
PNG (Portable Network Graphics), 253
Point To File icon, 287
Position Assist dialog, 52, 258, 261
position property, 305
ppi (pixels per inch), 249
predefined layouts, 114–116. See also layouts preferences, 24–27
prelaunch checklist, 364
Preload Images option, 324. See also images preprocessors. See CSS preprocessors
presentation vs. content, 77
Preset menu, images, 262–263
previewing pages, 192–194
print media type property, 417
program vs. technology, 58
projection media type property, 417
properties, CSS rules, 78, 92
Properties pane, 48–49, 131
Property inspector, 20, 42–43, 165, 195, 218,
  273–276
  optimizing images, 273–276
Proxy host connection, 355
.psd (Photoshop) files, cloaking, 360
pseudo-classes, hyperlinks, 309
punctuation, 3
Put icon, 366, 368
putting web pages online, 364–368

Q
Quality setting, images, 263
Quick Property inspector, 52
Quick Start tab, Start Screen, 22
Quick Editor, 144, 159, 161, 199, 203–204.
  See also HTML tags
quotation mark, hanging, 160
quotation, HTML, 61
quotes07.txt, 202–203

R
raster graphics, 248–252
RDS (Remote Development Services), 352
Recent option, Start Screen, 21
Refresh button, Code view, 333
&reg; character entity, 63
registered trademark character entity, 63
Related Files interface, 20, 43–44. See also files
relative hyperlinks, 280, 284–287
remote and local sites, synchronizing, 368–371
remote FTP site, setting up, 353–357. See also FTP
  (File Transfer Protocol)
remote site
  connecting, 365
  connection methods, 352
  explained, 11
  local server, 357–359
  network web server, 357–359
  setting up, 353–357
Remove Event icon, 326
removing, behaviors, 326
Replace field, 242
replacing content, 174
Resample tool, 276
Reset icon, images, 264
Resig, John, 333
resolution
  raster graphics, 249–250
  web images, 266
resources, 16
Responsive Starters template, 115–116
responsive web design, 102, 412–417. See also
  mobile page design
root directory, 354
root element, HTML, 61
rounded corners, CSS3, 94
rows, adding to tables, 218–219
rules. See CSS rules

S
Safari browser, 75
sample website, 103
sandwich icon, 227
sarah.jpg, 259
Sass CSS preprocessor, 386, 388
Sass folder, contents, 392
Save All command, 185
Save As dialog, 170
Save Web Image dialog, 263
saving
    custom workspaces, 38
    files, 167
screen media type property, 417
<source>, 64
scrubber
    dragging, 413, 415–416
    locating, 20
SCSS CSS preprocessor, 386, 389–390
<section>, 64, 77, 207, 330–331
Select Image Source dialog, 259
Select Parent icon, 403
selecting
    all text, 172
    code, 401–403
    columns in tables, 228–229
    text in Live view, 293
selections, copying and pasting, 241
selectors, CSS, 77, 81, 93, 145, 186. See also selectors
    Selectors window, CSS Designer, 47–48, 121, 128, 184, 336
semantic content, 158–163. See also content
semantic text structures, 198–200. See also text
semantic web design, HTML5, 64–65
server, adding, 353
SFTP (Secure File Transfer Protocol), 352
sharing map links, 292
Sharpen tool, 276
Show Set option, 213, 224
sidebar content, 112–113
sidebars06.html, 173
sidebars10.html, behaviors, 319
Site Root folder, 388
Site Setup dialog, 12, 14, 360
sites. See websites
skyline.png, 273
Smart Objects, Photoshop, 266–268
smartphones, responsive design, 102. See also mobile page design
<source>, 64
Sources pane, 47, 184, 335
spam, limiting, 299. See also email links
<span>, 62
specifications, creating manually, 213
specificity theory, CSS, 81–82
spell-checking, webpages, 236–238
Split Code view, 405–406. See also code
Split view, 29
stacking panels, 36–37
stacks of fonts, 222
Standard toolbar, 39
Standard workspace, 10–11, 32
Start Screen, 21–24
Starter Templates option, Start Screen, 23
strikethrough, 3
stripe.png, 135
<strong>, 62
Style Rendering command, 77
style sheets, importing, 397–399
<style>, 62
styles
    copying and pasting, 46
    displaying, 49
styling. See also CSS styles
    elements, 119–123
    navigation menu, 307–311
    text, 195–200
SVG (Scalable Vector Graphics), 248
Swap icon, 136
Swap Image behavior, 323–326. See also images
Synchronize icon, 370
synchronizing local and remote sites, 368–371
system requirements, 5

T
table cell text, HTML default, 74
table cells, styling, 225–227
table display, 228–230
table header, HTML default, 62, 74
table properties, 43
table row, HTML, 62
<table>, 62
table-editing mode, 228
tables
  adding data, 217
  adding rows, 218–219
  borders, 216
  copying and pasting, 219–220
  creating, 215–219
  cursor movement, 217
  inserting, 230–233
  inserting columns, 219
  navigating, 217
  selecting columns, 228–229
  styling with CSS, 220–225
tag selectors, 20, 45, 173, 176, 401–403. See also
CSS Designer; selectors
tags. See HTML tags; HTML5
Target attribute, 294
Target menu, hyperlinks, 294
targeting
  id-based link destinations, 304–305
  page elements, 299–305
<td>, 62
technology vs. program, 58
Template category, relative links, 285
templates. See also .dwt file extension;
  editable regions
  basing pages on, 195
  updating, 289
  updating Dreamweaver, 181–188
  using, 21, 115, 154–155, 170
testing links, 291
testing server, installing, 358
text. See also indented text; semantic text
  structures
  copying and pasting, 143–144, 146
  creating and styling, 195–200
  displaying for lists, 207
  editing, 144
  entering, 264
  extracting from Photoshop mockup, 123–125
  finding and replacing, 238–239, 241–242
  hyperlinks, 280
  importing, 195–198
  indenting, 209–214
  selecting, 172, 293
Text Display, 53, 298
text shadows, CSS3, 94
text styling, extracting from mockups, 127–128
<textarea>, 62
<th>, 62, 226
thumbnails, creating, 103–104
TinyURLs, 1
tips-finished.html, 192, 329
tips.html
  accordion tabs, 338
  background of accordion content, 345
  creating lists, 205
  jQuery accordion widgets, 330
title, including, 164
<title>, 62, 166
Toggle Size Constrain icon, 264, 275
toolbars, 39–40, 342
<tr>, 62
trademark character entity, 63
transparency and translucency, CSS3, 94
travel_finished.html, behaviors, 318
troubleshooting
  CSS styling, 125–127
  FTP connection, 356
true color, 251
tty media type property, 417
tv media type property, 417
.txt files, cloaking, 360
typeface vs. font, 221

U

<u>, 62, 379–380
undoing actions, 276, 380
unordered lists, 209, 379
Update Pages function, 183
updates, checking, 15
updating
  Dreamweaver, 5–6
  links in child pages, 289–291
  templates, 181–188, 289
URLs (uniform resource locators), 1, 281
  hyperlinks, 280
V
validating HTML code, 167–168
values
  CSS rules, 78
  hyperlinks, 280
vector graphics, 248
version control, 53–54
<video>, 64
views, switching and splitting, 27–31
VMQ (Visual Media Query) interface, 20, 50–51, 419–421. See also media queries

W
W3C, web resource, 65
W3Schools website, 101
WAMP local server, 358
Web 2.0, 316
web design, responsive, 102
Web Edition, 6–7
web frameworks, 422
web images, size and resolution, 266.
  See also images
webpages. See also non-web file types
  Link Checker panel, 311
  putting online, 364–368
web standards, 77
WebDav (Web Distributed Authoring and Versioning), 352
webpages. See also non-web file types
  previewing, 192–194
  spell-checking, 236–238
web-safe color palette, 251
websites
  Adobe Add-ons, 16, 317
  Adobe Authorized Training Centers, 16
  Adobe Creative Cloud, 5
  Adobe Dreamweaver CC product home page, 16
  Adobe Dreamweaver Learn & Support, 16
  Apache/ColdFusion, 358
Apache/PHP, 358
  audience, 100
  box model, 77
  character entities, 63
  customers, 100–101
  Dreamweaver Help, 16
  Emmet web-developer toolkit, 383
  HTML5, 63, 65
  IIS/ASP, 358
  LESS CSS preprocessor, 388
  media queries, 418
  purpose, 100
  putting on line, 364–368
  Sass CSS preprocessor, 388
  SVG (Scalable Vector Graphics), 248
  system requirements, 5
  traffic, 100–101
  W3C, 65
  W3Schools, 101
wide and height, constraining for images, 264
width property, 306
Window menu, 32
Windows desktop computers, statistics, 101
Windows vs. macOS instructions, 3–4
wireframes, creating, 105–107
WMF file format, 248
workspace, 20–21
  customizing, 37–38
  layouts, 32–33
  setting up, 10–11
Workspace menu, 20
Wrap option, tables, 216–217

X
XML (Extensible Markup Language), 248

Z
Zip archives, 7
zooming out, 414