This page intentionally left blank
## CONTENTS AT A GLANCE

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>GETTING ACQUAINTED</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>CREATING GRAPHICS AND TEXT</td>
<td>36</td>
</tr>
<tr>
<td>3</td>
<td>CREATING AND EDITING SYMBOLS</td>
<td>84</td>
</tr>
<tr>
<td>4</td>
<td>ANIMATING SYMBOLS</td>
<td>122</td>
</tr>
<tr>
<td>5</td>
<td>ADVANCED MOTION TWEENING</td>
<td>162</td>
</tr>
<tr>
<td>6</td>
<td>CLASSIC TWEENING</td>
<td>196</td>
</tr>
<tr>
<td>7</td>
<td>CONTROLLING THE CAMERA</td>
<td>234</td>
</tr>
<tr>
<td>8</td>
<td>ANIMATING SHAPES AND USING MASKS</td>
<td>264</td>
</tr>
<tr>
<td>9</td>
<td>NATURAL AND CHARACTER ANIMATION</td>
<td>298</td>
</tr>
<tr>
<td>10</td>
<td>CREATING INTERACTIVE NAVIGATION</td>
<td>340</td>
</tr>
<tr>
<td>11</td>
<td>WORKING WITH SOUND AND VIDEO</td>
<td>386</td>
</tr>
<tr>
<td>12</td>
<td>PUBLISHING</td>
<td>422</td>
</tr>
</tbody>
</table>

INDEX 446
This page intentionally left blank
## CONTENTS

### GETTING STARTED

1. GETTING ACQUAINTED

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting Adobe Animate CC and Opening a File</td>
<td>2</td>
</tr>
<tr>
<td>Understanding Document Types</td>
<td>4</td>
</tr>
<tr>
<td>Getting to Know the Workspace</td>
<td>5</td>
</tr>
<tr>
<td>Working with the Library Panel</td>
<td>9</td>
</tr>
<tr>
<td>Understanding the Timeline</td>
<td>11</td>
</tr>
<tr>
<td>Organizing Layers in a Timeline</td>
<td>19</td>
</tr>
<tr>
<td>Using the Properties Panel</td>
<td>23</td>
</tr>
<tr>
<td>Using the Tools Panel</td>
<td>27</td>
</tr>
<tr>
<td>Undoing Steps in Animate</td>
<td>30</td>
</tr>
<tr>
<td>Previewing Your Movie</td>
<td>31</td>
</tr>
<tr>
<td>Modifying the Content and Stage</td>
<td>32</td>
</tr>
<tr>
<td>Saving Your Movie</td>
<td>34</td>
</tr>
</tbody>
</table>

2. CREATING GRAPHICS AND TEXT

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Getting Started</td>
<td>38</td>
</tr>
<tr>
<td>Understanding Strokes and Fills</td>
<td>38</td>
</tr>
<tr>
<td>Creating Shapes</td>
<td>39</td>
</tr>
<tr>
<td>Making Selections</td>
<td>40</td>
</tr>
<tr>
<td>Editing Shapes</td>
<td>41</td>
</tr>
<tr>
<td>Using Gradient and Bitmap Fills</td>
<td>45</td>
</tr>
<tr>
<td>Using Variable-Width Strokes</td>
<td>49</td>
</tr>
<tr>
<td>Using Swatches and Tagged Swatches</td>
<td>51</td>
</tr>
<tr>
<td>Creating Curves</td>
<td>55</td>
</tr>
<tr>
<td>Using Transparency to Create Depth</td>
<td>59</td>
</tr>
<tr>
<td>Being Expressive with the Paint Brush</td>
<td>61</td>
</tr>
<tr>
<td>Creating and Editing Text</td>
<td>69</td>
</tr>
<tr>
<td>Aligning and Distributing Objects</td>
<td>77</td>
</tr>
<tr>
<td>Converting and Exporting Art</td>
<td>79</td>
</tr>
</tbody>
</table>
# CONTENTS

## 3 CREATING AND EDITING SYMBOLS  
### Getting Started ........................................... 86  
### Importing Adobe Illustrator Files ......................... 87  
### About Symbols ........................................... 91  
### Creating Symbols ........................................ 92  
### Importing Adobe Photoshop Files ......................... 94  
### Editing and Managing Symbols ............................ 98  
### Changing the Size and Position of Instances .............. 104  
### Changing the Color Effect of an Instance .................. 108  
### Understanding Display Options ............................ 110  
### Applying Filters for Special Effects ...................... 111  
### Positioning Objects in 3D Space .......................... 112

## 4 ANIMATING SYMBOLS  
### Getting Started ........................................... 124  
### About Animation .......................................... 125  
### Understanding the Project File ............................ 125  
### Animating Position ........................................ 126  
### Changing the Pacing and Timing ............................ 129  
### Animating Transparency .................................... 135  
### Animating Filters ......................................... 137  
### Animating Transformations .................................. 140  
### Changing the Path of the Motion ........................... 143  
### Swapping Tween Targets ................................... 147  
### Creating Nested Animations ............................... 148  
### Easing ........................................................ 151  
### Frame-by-Frame Animation .................................. 154  
### Animating 3D Motion ....................................... 156  
### Exporting Your Final Movie ................................. 159

## 5 ADVANCED MOTION TWEENING  
### Getting Started ........................................... 164  
### About the Motion Editor .................................... 165  
### Understanding the Project File ............................ 166  
### Adding Motion Tweens ..................................... 167
Editing Property Curves .............................................. 168
Viewing Options for the Motion Editor ....................... 174
Copying and Pasting Curves ........................................ 175
Adding Complex Eases .............................................. 179

6  CLASSIC TWEENING .................................................. 196
Getting Started .......................................................... 198
Using Classic Tweens .................................................. 199
Motion Guides for Classic Tweens ............................... 211
Copying and Pasting Tweens ...................................... 220
Classic Tween Eases .................................................. 222
Graphic Symbols ....................................................... 226

7  CONTROLLING THE CAMERA .................................... 234
Animating Camera Moves .......................................... 236
Getting Started .......................................................... 236
Using the Camera ........................................................ 239
Creating Depth ........................................................... 249
Attaching Layers to the Camera for Fixed Graphics ........ 255
Exporting Your Final Movie .......................................... 260

8  ANIMATING SHAPES AND USING MASKS ..................... 264
Getting Started .......................................................... 266
Animating Shapes ....................................................... 266
Understanding the Project File ..................................... 267
Creating a Shape Tween .............................................. 267
Changing the Pace ....................................................... 270
Adding More Shape Tweens ........................................ 271
Creating a Looping Animation ..................................... 274
Using Shape Hints ....................................................... 278
Previewing Animations with Onion Skinning .................. 282
Animating Color .......................................................... 285
Creating and Using Masks .......................................... 289
Animating the Mask and Masked Layers ..................... 292
Easing a Shape Tween .................................................. 296
9  NATURAL AND CHARACTER ANIMATION  298
Getting Started ........................................... 300
Natural Motion and Character Animation 
with Inverse Kinematics ................................. 300
Creating a Walk Cycle .................................... 311
Disabling and Constraining Joints ...................... 315
Adding Poses ............................................. 322
Inverse Kinematics with Shapes ......................... 325
Simulating Physics with Springiness .................. 333

10  CREATING INTERACTIVE NAVIGATION  340
Getting Started ........................................... 342
About Interactive Movies ............................... 343
ActionScript and JavaScript ............................ 343
Creating Buttons ......................................... 344
Preparing the Timeline ................................... 355
Creating Destination Keyframes ....................... 356
Navigating the Actions Panel ......................... 359
Add JavaScript Interactivity 
with the Actions Panel Wizard ......................... 360
Creating a Home Button ................................ 370
Playing Animation at the Destination ................ 375
Animated Buttons ....................................... 379

11  WORKING WITH SOUND AND VIDEO  386
Getting Started ........................................... 388
Understanding the Project File ......................... 389
Using Sounds ............................................ 391
Understanding Video .................................... 402
Using Adobe Media Encoder CC ...................... 404
Understanding Encoding Options ..................... 408
Playback of External Video in Your Project ............ 411
Adding a Video Without Playback Controls ........... 418
12  PUBLISHING  422

Understanding Publishing ...........................................424
Converting to HTML5 Canvas .......................................425
Publishing for HTML5 ..................................................428
Publishing a Desktop Application .................................432
Publishing to Mobile Devices .......................................440
Next Steps .................................................................444

INDEX  446
This page intentionally left blank
GETTING STARTED

The 2018 release of Adobe Animate CC provides a comprehensive authoring environment for creating sophisticated animations and interactive, media-rich applications that you can publish to a variety of platforms. Animate CC is widely used in the creative industry to develop engaging projects integrating video, sound, graphics, and animation. You can create original content in Animate CC or import assets from other Adobe applications such as Photoshop CC or Illustrator CC, quickly design animation and multimedia, and use code to integrate sophisticated interactivity.

Use Animate CC to generate graphics and animation assets, to build innovative and immersive websites, to create stand-alone applications for the desktop, or to create apps to distribute to mobile devices running on the Android or iOS system.

With extensive controls for animation, intuitive and flexible drawing tools, and output options for HD video, HTML5, WebGL, SVG, mobile apps, desktop applications, and Flash Player, Adobe Animate CC is a robust multimedia authoring environment that enables your imagination to become reality.

About Classroom in a Book

Adobe Animate CC Classroom in a Book (2018 release) is part of the official training series for Adobe graphics and publishing software developed with the support of Adobe product experts. The lessons are designed so you can learn at your own pace. If you’re new to Animate, you’ll learn the fundamental concepts and features you’ll need to use the program. Classroom in a Book also teaches many advanced features, including tips and techniques for using the latest version of this application.

Although each lesson provides step-by-step instructions for creating a specific project, there’s room for exploration and experimentation. You can follow the book from start to finish or do only the lessons that correspond to your interests and needs. Each lesson concludes with review questions to reinforce what you’ve learned.
What’s New

The 2018 release of Adobe Animate CC provides more expressive tools, powerful controls for animation, and robust support for a wider variety of playback platforms.

The lessons in this book provide opportunities to use some of the updated features and improvements in Animate CC, including

- A new Layer Depth panel that allows you to establish a realistic sense of space by changing the depth level of individual layers
- The ability to fix individual layers to the camera to keep them from being affected by the camera movement
- Improvements to the Camera tool, which puts you in the director’s chair to frame the action with camera moves such as zooming and panning
- Timeline enhancements, including easier ways to navigate between keyframes, scrub through the animation, and display both second and frame-number markers
- Property-level eases for classic tweens
- An integrated wizard in the Actions panel so that you can quickly and easily add JavaScript code into your HTML5 Canvas document

Prerequisites

Before you begin using Adobe Animate CC Classroom in a Book (2018 release), make sure your system is set up correctly and that you’ve installed the required software. You should have a working knowledge of your computer and operating system. You should know how to use the mouse and standard menus and commands, and also how to open, save, and close files. If you need to review these techniques, see the printed or online documentation included with your Microsoft Windows or Apple macOS software.

In addition, you need to download the free Adobe AIR runtime, available at get.adobe.com/air/, to publish desktop applications in Lesson 12.
Installing Animate CC

You must purchase the Adobe Animate CC application as part of Adobe Creative Cloud. The following specifications are the minimum required system configurations.

**Windows**
- Intel® Pentium 4, Intel Centrino®, Intel Xeon®, or Intel Core™ Duo (or compatible) processor
- Microsoft® Windows® 7 (64 bit), Windows 8.1 (64 bit), or Windows 10 (64 bit)
- 2 GB of RAM (8 GB recommended)
- 1024x900 display (1280x1024 recommended)
- 4 GB of available hard-disk space for installation; additional free space required during installation (cannot install on removable flash storage devices)
- Broadband Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.

**macOS**
- Multicore Intel® processor
- macOS v10.10 (64-bit), 10.11 (64-bit), or 10.12 (64-bit)
- 2 GB of RAM (8 GB recommended)
- 1024x900 display (1280x1024 recommended)
- QuickTime 12.x software recommended
- 4 GB of available hard-disk space for installation; additional free space required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)
- Broadband Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.

For updates on system requirements and complete instructions on installing the software, visit helpx.adobe.com/animate/system-requirements.html.

Install Animate CC from Adobe Creative Cloud at creative.adobe.com and make sure that you have your login and password accessible.
Online Content

Your purchase of this Classroom in a Book includes online materials provided by way of your Account page on peachpit.com. These include:

Lesson files
To work through the projects in this book, you will need to download the lesson files from peachpit.com. You can download the files for individual lessons, or it may be possible to download them all in a single file.

Web Edition
The Web Edition is an online interactive version of the book providing an enhanced learning experience. Your Web Edition can be accessed from any device with a connection to the Internet and it contains:

- The complete text of the book
- Hours of instructional video keyed to the text
- Interactive quizzes

In addition, the Web Edition may be updated when Adobe adds significant feature updates between major Creative Cloud releases. To accommodate the changes, sections of the online book may be updated or new sections may be added.

Accessing the lesson files and Web Edition
If you purchased an eBook from peachpit.com or adobepress.com, your Web Edition will automatically appear under the Digital Purchases tab on your Account page. Click the Launch link to access the product. Continue reading to learn how to register your product to get access to the lesson files.

If you purchased an eBook from a different vendor or you bought a print book, you must register your purchase on peachpit.com in order to access the online content:

2. Sign in or create a new account.
4. Answer the questions as proof of purchase.
5 The **Web Edition** will appear under the Digital Purchases tab on your Account page. Click the **Launch** link to access the product.

The **lesson files** can be accessed through the Registered Products tab on your Account page. Click the **Access Bonus Content** link below the title of your product to proceed to the download page. Click the lesson file links to download them to your computer.

## How to Use the Lessons

Each lesson in this book provides step-by-step instructions for creating one or more specific elements of a real-world project. Some lessons build on projects created in preceding lessons; most stand alone. All the lessons build on one another in terms of concepts and skills, so the best way to learn from this book is to proceed through the lessons in sequential order. In this book, some techniques and processes are explained and described in detail only the first few times you perform them.

You will create and publish final project files, such as SWF files, HTML files, videos, or AIR desktop applications, in some lessons in this book. The files in the End folders (01End, 02End, and so on) within the Lesson folders are samples of completed projects for each lesson. Use these files for reference if you want to compare your work in progress with the project files used to generate the sample projects.

The organization of the lessons is also project-oriented rather than feature-oriented. That means, for example, that you’ll work with symbols on real-world design projects over several lessons rather than in just one chapter.

## Additional Resources

*Adobe Animate CC Classroom in a Book (2018 release)* is not meant to replace documentation that comes with the program or to be a comprehensive reference for every feature. Only the commands and options used in the lessons are explained in this book. For comprehensive information about program features and tutorials, refer to these resources, which you can reach by choosing commands on the Help menu or by clicking links in the Welcome Screen:

**Adobe Animate Learn and Support**: helpx.adobe.com/animate.html is where you can find and browse Help and Support content on Adobe.com. You can also reach that page by choosing Help > Animate Help, by clicking Designers on the
Welcome Screen > Introduction, or by pressing F1. On the Learn & Support page, click User Guide for documentation on individual features, or visit helpx.adobe.com/animate/topics.html.

**Animate tutorials:** For a wide range of interactive tutorials on Animate CC features, choose Help > Animate Tutorial, or click Getting Started on the Welcome Screen > Introduction, or visit helpx.adobe.com/animate/tutorials.html.

**Adobe Creative Cloud Learn:** For inspiration, key techniques, cross-product workflows, and updates on new features, go to the Creative Cloud Learn page, helpx.adobe.com/creative-cloud/learn/tutorials.html. Available to all.

**Adobe forums:** forums.adobe.com lets you tap into peer-to-peer discussions, questions, and answers on Adobe products. The Adobe Animate CC forum is accessible by choosing Help > Adobe Online Forums.

**Adobe Create:** create.adobe.com offers thoughtful articles on design and design issues, a gallery showcasing the work of top-notch designers, tutorials, and more.

**Resources for educators:** www.adobe.com/education and edex.adobe.com offer a treasure trove of information for instructors who teach classes on Adobe software. Find solutions for education at all levels, including free curricula that use an integrated approach to teaching Adobe software and can be used to prepare for the Adobe Certified Associate exams.

Also check out these useful sites:

**Adobe Add-ons:** creative.adobe.com/addons is a central resource for finding tools, services, extensions, code samples, and more to supplement and extend your Adobe products.

**Adobe Animate CC product home page:** http://www.adobe.com/products/animate.html

---

**Adobe Authorized Training Centers**

Adobe Authorized Training Centers offer instructor-led courses and training on Adobe products. A directory of AATCs is available at training.adobe.com/trainingpartners.
Contributor

Russell Chun is an assistant professor at the L. Herbert School of Communication at Hofstra University, where he teaches multimedia storytelling, data journalism, and information design.
Lesson Overview

In this lesson, you’ll learn how to do the following:

• Animate the position, scale, and rotation of objects
• Adjust the pacing and timing of your animation
• Animate transparency and special effects
• Change the path of an object’s motion
• Create nested animation
• Split a motion tween
• Change the easing of an object’s motion
• Animate in 3D space

This lesson will take about two hours to complete. Please log in to your account on peachpit.com to download the lesson files for this chapter, or go to the Getting Started section at the beginning of this book and follow the instructions under “Accessing the Lesson Files and Web Edition.”
Use Adobe Animate CC to change almost any aspect of an object—position, color, transparency, size, rotation, and more—over time. Motion tweening is the basic technique of creating animation with symbol instances.
Getting Started

Start by viewing the finished movie file to see the animated title page that you'll create in this lesson.

1. Double-click the 04End.mp4 file in the Lesson04/04End folder to play the final animation, which was exported as a video file.

The project is an animated opener that would be placed on a website for an imaginary soon-to-be-released motion picture. In this lesson, you'll use motion tweens to animate several components on the page: the cityscape, the main actors, several old-fashioned cars, and the main title.

2. Close the 04End.mp4 file.

3. Double-click the 04Start.fla file in the Lesson04/04Start folder to open the initial project file in Animate. This file is an ActionScript 3.0 document that is partially completed and already contains many of the graphic elements imported into the library for you to use. You'll use all the animation functionality available in an ActionScript 3.0 document, but instead of using the Flash Player for playback in a browser, you'll export an MP4 video file.

4. From the view options above the Stage, choose Fit In Window, or choose View > Magnification > Fit In Window, so that you can see the entire Stage on your computer screen.

5. Choose File > Save As. Name the file 04_workingcopy.fla, and save it in the 04Start folder.

Saving a working copy ensures that the original start file will be available if you want to start over.

Note: If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.
About Animation

Animation is the movement, or change, of objects through time. Animation can be as simple as moving a box across the Stage from one frame to the next. It can also be much more complex. As you’ll see in this lesson, you can animate many different aspects of a single object. You can change an object’s position on the Stage, change its color or transparency, change its size or rotation, or animate the special filters that you saw in the previous lesson. You also have control over an object’s path of motion and even its easing, which is the way an object accelerates or decelerates.

In Animate, the basic workflow for animation goes like this: Select an object on the Stage, right-click, and choose Create Motion Tween from the context menu. Move the red playhead to a different point in time and move the object to a new position or change one of its properties. Animate takes care of the rest by smoothly interpolating the changes between the two points in time.

Motion tweens create animation for changes in position on the Stage and for changes in size, color, or other attributes. Motion tweens require you to use a symbol instance. If the object you’ve selected is not a symbol instance, Animate will automatically ask to convert the selection to a symbol.

Animate also automatically separates motion tweens onto their own layers, which are called tween layers. There can be only one motion tween per layer, and there can be no other element on the layer. Tween layers allow you to change various attributes of your instance at different key points over time. For example, a spaceship could be on the left side of the Stage at the beginning keyframe and at the far-right side of the Stage at an ending keyframe, and the resulting tween would make the spaceship fly across the Stage.

The term “tween” comes from the world of classic animation. Senior animators would be responsible for drawing the beginning and ending poses for their characters. The beginning and ending poses were the keyframes of the animation. Junior animators would then come in and draw the “in-between” frames, or do the “in-betweening.” Hence, “tweening” refers to the smooth transitions between keyframes.

Understanding the Project File

The 04Start.fla file contains a few of the animated elements already or partially completed. Each of the six layers—man, woman, Middle_car, Right_car, footer, and ground—contains an animation. The man and woman layers are in a folder called actors, and the Middle_car and Right_car layers are in a folder called cars.
You’ll be adding more layers to create an animated cityscape, refining the animation of one of the actors and adding a third car and a 3D title. All the necessary graphic elements have been imported into the library. The Stage is set at 1280 pixels by 787 pixels, and the Stage color is black. You might need to choose a different view option to see the entire Stage. Choose View > Magnification > Fit In Window, or choose Fit In Window from the view options at the upper-right corner of the Stage, to view the Stage at a magnification percentage that fits your screen.

**Animating Position**

You’ll start this project by animating the cityscape. It will begin slightly lower than the top edge of the Stage and then rise slowly until its top is aligned with the top of the Stage.

1. Lock all the existing layers so you don’t accidentally modify them. Create a new layer above the footer layer and rename it **city**.
2 Drag the bitmap image called cityBG.jpg from the bitmaps folder in the Library panel to the Stage.

3 In the Properties panel, set the value of X to 0 and the value of Y to 90.

This positions the cityscape image just slightly below the top edge of the Stage.

4 Right-click the cityscape image and choose Create Motion Tween, or choose Insert > Motion Tween.
A dialog box appears warning you that your selected object is not a symbol. Motion tweens require symbols. Animate asks if you want to convert the selection to a symbol so it can proceed with the motion tween. Click OK.

Animate automatically converts your selection to a symbol, with the default name **Symbol 1**, and stores it in your Library panel. Animate also converts the current layer to a tween layer so you can begin to animate the instance. Tween layers are distinguished by a special icon in front of the layer name, and the frames are tinted blue. The range of frames covered by the tween is the **tween span**. The tween span is represented by all the colored frames from the first keyframe to the last keyframe. Tween layers are reserved for motion tweens; hence, no drawing is allowed on a tween layer.

Move the red playhead to the end of the tween span, at frame 191.

Select the instance of the cityscape on the Stage, and while holding down the Shift key, move the instance up the Stage.

Holding down the Shift key constrains the movement to right angles.

For more precision, set the value of Y to 0 in the Properties panel.

A small black diamond appears in frame 191 at the end of the tween span. This indicates a keyframe at the end of the tween.

Animate smoothly interpolates the change in position from frame 1 to frame 191 and represents that motion with a motion path on the Stage.
Drag the red playhead back and forth at the top of the Timeline to see the smooth motion. You can also choose Control > Play (or press Enter/Return) to make Animate play the animation.

Animating changes in position is simple because Animate automatically creates keyframes at the points where you move your instance to new positions. If you want to have an object move to many different points, simply move the red playhead to the desired frame and then move the object to its new position. Animate takes care of the rest.

### Preview the animation

Integrated into the bottom of the Timeline is a set of playback controls. These controls allow you to play, rewind, or go step by step backward or forward through your Timeline to review your animation in a controlled manner. You can also use the playback commands on the Control menu.

1. Click any of the playback buttons on the controller below the Timeline to go to the first frame, go to the last frame, play, stop, or move forward or backward one frame.

2. Select Loop option (to the right of the controller), and then click the Play button.

    The playhead loops, allowing you to see the animation over and over for careful analysis.

3. Move the start or end markers in the Timeline header to define the range of frames that you want to see looped.

    The playhead loops within the marked frames. Click Loop Option again to turn it off.

### Changing the Pacing and Timing

You can change the duration of the entire tween span or change the timing of the animation by dragging keyframes on the Timeline.

### Changing the animation duration

If you want the animation to proceed at a slower pace (and thus take up a much longer period of time), you need to lengthen the entire tween span between the beginning and end keyframes. If you want to shorten the animation, you need to decrease the tween span. Lengthen or shorten a motion tween by dragging its ends on the Timeline.
1. Move your mouse pointer close to the end of the tween span in the city layer. Your pointer’s cursor changes to a double-headed arrow, indicating that you can lengthen or shorten the tween span.

2. Drag the end of the tween span back to frame 60. Your motion tween shortens to 60 frames, reducing the time it takes the cityscape to move.

3. Move your mouse pointer close to the beginning of the tween span (at frame 1).

4. Drag the beginning of the frame span forward to frame 10. Your motion tween begins at an earlier time, so it now plays only from frame 10 to frame 60.

**Note** If you have multiple keyframes in a tween, changing the length of the tween span by dragging one end or the other will distribute all your keyframes uniformly. The timing of your entire animation remains the same; only the length changes.

**Adding frames**

You’ll want the last keyframe of your motion tween to hold for the remainder of the animation. Add frames by Shift-dragging the end of a tween span.

1. Move your mouse cursor close to the end of the tween span.
2 Hold down the Shift key and drag the end of the tween span forward to frame 191.

The last keyframe in the motion tween remains at frame 60, but Animate adds frames through frame 191.

Moving keyframes

If you want to change the pacing of an animation, you can select individual keyframes and then drag them to new positions.

1 Click the keyframe at frame 60.

   The keyframe at frame 60 is selected. A tiny box appears next to your mouse pointer, indicating that you can move the keyframe.

2 Drag the keyframe to frame 40.

   The last keyframe in the motion tween moves to frame 40, so the motion of the cityscape proceeds more quickly.

Tip You can also add individual frames by choosing Insert > Timeline > Frame (F5), or remove individual frames by choosing Edit > Timeline > Remove Frames (Shift+F5).
Span-based vs. frame-based selection

By default, Animate uses frame-based selection, which means you can select individual keyframes within a motion tween. However, if you prefer to click a motion tween and have the entire span (the beginning and end keyframes, and all the frames in between) be selected, you can enable Span Based Selection from the Options menu on the upper-right corner of the Timeline (or you can Shift-click to select the entire span).

With Span Based Selection enabled, you can click anywhere within the motion tween to select it, and move the whole animation backward or forward along the Timeline as a single unit.

If you want to select individual keyframes while Span Based Selection is enabled, hold down the Ctrl/Command key and click a keyframe.

Moving keyframes vs. changing time in tween spans

Managing the timing of your animation by moving keyframes and stretching or squashing tween spans can sometimes be frustrating because you will get different outcomes depending on what you’ve selected on the Timeline and how you drag those selections.

If you want to simply move the location of a keyframe within a tween span, make sure that only a single keyframe is selected, and that the tiny box appears next to your mouse cursor before you begin dragging the keyframe to a new location.

If you want to select individual keyframes while Span Based Selection is enabled, hold down the Ctrl/Command key and click a keyframe.

Consider the following animation, where a ball moves from the left side of the Stage to the bottom edge and then to the right side, making a figure “V.” On the Timeline, three keyframes mark the three positions of the ball.
Moving the middle keyframe changes the timing of when the ball hits the bottom of the Stage.

When you select a span of frames within a tween, you can compress or expand its duration by dragging the selection when the double-headed arrow appears near the right edge of the selection.
Finally, a double-headed arrow with a vertical break indicates that you can change the position of the separation between two different tweens.

Understanding frame rate

The speed of your animation is tied to the frame rate of your document (shown in the Properties section of the Properties panel), but do not modify the frame rate in order to change the speed or duration of your animation.

The frame rate determines how many frames on the Timeline make up one second of time. The default is 24 frames per second (fps). The seconds are marked on the Timeline. Frame rate is a measure of how smooth an animation appears—the higher the frame rate, the more frames there are to show the action. Animations at slower frame rates appear choppy because there are fewer frames to show the action. Slow-motion videography depends on very high frame rates in order to capture action that happens very quickly, such as a speeding bullet or a falling water droplet.

If you want to modify the overall duration or speed of your animation, don’t change the frame rate. Instead, add or delete frames from your Timeline.

If you want to change the frame rate but keep the overall duration constant, select the Scale Frame Spans option in the Properties panel before you modify the frame rate.
**Animating Transparency**

In the previous lesson, you learned how to change the color effect of any symbol instance to change the transparency, tint, or brightness. You can change the color effect of an instance in one keyframe and change the value of the color effect in another keyframe, and Animate will automatically display a smooth change, just as it does with changes in position.

You’ll change the cityscape in the beginning keyframe to be totally transparent but keep the cityscape in the ending keyframe opaque. Animate will create a smooth fade-in effect.

1. Move the red playhead to the first keyframe of the motion tween (frame 10).

2. Select the cityscape instance on the Stage.

3. In the Color Effect section of the Properties panel, choose Alpha from the Style menu.

4. Set the Alpha value to 0%.

The cityscape instance on the Stage becomes totally transparent.
5 Move the red playhead to the last keyframe of the motion tween (frame 40).

6 Make sure that the cityscape instance on the Stage is still selected.

7 In the Properties panel, in the Color Effect section, set the Alpha value to 100%. The cityscape instance on the Stage becomes totally opaque.

8 Preview the effect by choosing Control > Play (or pressing Enter/Return). Animate interpolates the changes in both position and transparency between the two keyframes.
Animating Filters

Filters, which give instances special effects such as blurs and drop shadows, can also be animated. You’ll next refine the motion tween of the actors by applying a blur filter to one of them to make it appear as if the camera changes focus. Animating filters is no different from animating changes in position or changes in color effect. You simply set the values for a filter at one keyframe and set different values for the filter at another keyframe, and Animate creates a smooth transition.

1. Make sure that the actors layer folder on the Timeline is visible.
2. Unlock the woman layer.
3. Move the red playhead to the beginning keyframe of the motion tween in the woman layer, at frame 23.

4. Select the instance of the woman on the Stage. You won’t be able to see her because she has an alpha value of 0% (totally transparent). Click the upper-right side of the Stage to select the transparent instance. Or, click the woman layer in the Timeline to highlight it; then click within the outline that appears on the Stage.

**Note** Filters can not be animated in an HTML5 Canvas document.
5 In the Properties panel, expand the Filters section.

6 Click the Add Filter (+) button in the Filters section, and choose Blur from the menu to add a blur to the instance.

7 In the Filters section of the Properties panel, make sure that the link icons are selected in order to apply equal values to the $x$ and $y$ directions. Set the Blur X value to 20 pixels.

The Blur Y value also changes to 20 pixels.

8 Move the red playhead across the entire Timeline to preview the animation.

The woman instance is blurred throughout the motion tween.

9 Right-click the woman layer at frame 140, and choose Insert Keyframe > Filter.

Animate establishes a keyframe for filters at frame 140.
10 Move the red playhead to frame 160, right-click the woman layer, and choose Insert Keyframe > Filter to add another filter keyframe.

11 Select the instance of the woman on the Stage at frame 160.

12 In the Properties panel, change the value of the Blur filter to X=0 and Y=0.

The Blur filter changes from the keyframe at frame 140 to the keyframe at 160. Animate creates a smooth transition from a blurry instance to an in-focus instance.

Understanding property keyframes

Changes in properties are independent of one another and do not need to be tied to the same keyframes. That is, you can have a keyframe for position, a different keyframe for the color effect, and yet another keyframe for a filter. Managing many different kinds of keyframes can become overwhelming, especially if you want different properties to change at different times during the motion tween. Fortunately, Animate CC provides a few helpful tools for keyframe management.
When viewing the tween span, you can choose to view the keyframes of only certain properties. For example, you can choose to view only the Position keyframes so that you can see when your object moves. Or, you can choose to view only the Filter keyframes so that you can see when a filter changes. Right-click a motion tween in the Timeline, choose View Keyframes, and then select the desired property from the list. You can also choose All or None to see all the properties or none of the properties.

When inserting a keyframe, you can also insert a keyframe specific to the property you want to change. Right-click a motion tween in the Timeline, choose Insert Keyframes, and then select the desired property.

You can also view an advanced panel, called the Motion Editor, to see and edit how the different properties of your object change over the course of the motion tween. You’ll learn more about the Motion Editor in the next lesson.

**Animating Transformations**

Now you’ll learn how to animate changes in scale or rotation. These kinds of changes are made with the Free Transform tool or with the Transform panel. You’ll add a third car to the project. The car will start small, and then become larger as it appears to move forward toward the viewer.

1. Lock all the layers on the Timeline.
2. Insert a new layer inside the cars folder, and rename it **Left_car**.
3. Select frame 75 and insert a new keyframe (F6).
4. Drag the movie clip symbol called carLeft from the Library panel to the Stage at frame 75.
5 Select the Free Transform tool.

   The transformation handles appear around the instance on the Stage.

6 While holding down the Shift key, drag a corner handle inward to make the car smaller.

7 In the Properties panel, make sure that the width of the graphic is about 400 pixels.

   Alternatively, you can use the Transform panel (Window > Transform) and change the scale of the car to about 29.4%.

8 Move the car to its starting position at about X=710 and Y=488.

9 In the Properties panel, in the Color Effect section, choose Alpha from the Style menu.
10 Set the Alpha value to 0%.

![Alpha Setting](image1)

The car becomes totally transparent.

11 Right-click the car on the Stage and choose Create Motion Tween.

The current layer becomes a tween layer.

12 Move the red playhead on the Timeline to frame 100.

![Timeline](image2)

13 Select the transparent instance of the car on the Stage, and in the Properties panel, change the Alpha value to 100%.

A new keyframe is automatically inserted at frame 100 to indicate the change in transparency.

14 While holding down the Shift key, drag a corner handle outward to make the car larger. For more precision, use the Properties panel and set the dimensions of the car to width= 1380 pixels and height= 445.05 pixels.

15 Position the car at X= 607 and Y= 545.

![Positioning](image3)

You have used Animate to tween the change in position and the change in scale as well as the change in transparency from frame 75 to frame 100.
Move the Left_car layer in between the Middle_car and Right_car layers so that the car in the center overlaps the cars on the side.

Save your progress so far in this document, 04_workingcopy.fla. In the next section, you’ll work with a different file.

Changing the Path of the Motion

The motion tween of the left car that you just animated shows a colored line with dots indicating the path of the motion. You can easily edit the path of the motion to make the car travel in a curve, or you can move, scale, or rotate the path just like any other object on the Stage.

To better demonstrate how you can edit the path of the motion, open the sample file 04MotionPath.fla in the Lesson04/04Start folder. The file contains a single tween layer with a rocket ship moving from the top left of the Stage toward the bottom right.

Tip: Holding down the Alt/Option key while dragging one corner handle of the bounding box causes the box to resize relative to the opposite corner rather than relative to the object’s transformation point (usually the center).
Moving the path of the motion
You will move the path of the motion so that the relative movement of the rocket ship remains the same but its starting and ending positions change.

1 Select the Selection tool.
2 Click the path of the motion to select it.
   The path of the motion becomes highlighted.
3 Drag the motion path to move it to a different place on the Stage.
   The relative motion and timing of the animation remain the same, but the starting and ending positions are relocated.

Changing the scale or rotation of the path
You can also manipulate the path of the object's motion using the Free Transform tool.
1 Select the path of the motion.
2 Select the Free Transform tool.
Transformation handles appear around the path of the motion.

3 Scale or rotate the path of the motion as desired. You can make the path smaller or larger, or rotate the path so that the rocket ship starts from the bottom left of the Stage and ends at the top right.

**Editing the path of the motion**

Making your objects travel on a curved path is a simple matter. You can edit the path with Bezier precision using anchor point handles, or you can edit the path in a more intuitive manner with the Selection tool.

1 Select the Convert Anchor Point tool, which is hidden under the Pen tool.
2 Click the starting point or the ending point of the motion path on the Stage, and drag the control handle out from the anchor point.

The handle on the anchor point controls the curvature of the path.

3 Select the Subselection tool.

4 Drag the handle at each end of the path to edit its curve. Make the rocket ship travel in a wide curve.

Tip You can also directly manipulate the path of the motion with the Selection tool. Select the Selection tool and make sure the path is deselected. Move your pointer close to the path of the motion. A curved icon appears next to your pointer, indicating that you can edit the path. Drag the path of the motion to change its curvature. Choose the spots where you drag carefully! Each drag breaks the path into smaller segments, making it harder to achieve a smooth curve. Mastery will come with practice.

Orienting objects to the path

Sometimes the orientation of the object traveling along the path is important. In the motion picture promotional project, the orientation of the car is constant as it moves forward. However, in the rocket ship example, the rocket ship should follow the path with its nose pointed in the direction in which it is heading. Orient To Path in the Properties panel gives you this option.
1 Select the motion tween on the Timeline (Shift-click to select the whole tween).

2 In the Properties panel, under Rotation, select the Orient To Path option.

Animate inserts keyframes for rotation along the motion tween to orient the nose of the rocket ship to the path of the motion.

Swapping Tween Targets

The motion tween model in Animate CC is object based. This means that an object and its motion are independent of each other, and you can easily swap out the target of a motion tween. If, for example, you’d rather see an alien moving around the Stage instead of a rocket ship, you can replace the target of the motion tween with an alien symbol from your Library panel and still preserve the animation.

1 Drag the movie clip symbol of the alien from the Library panel onto the rocket ship.

Tip To direct the nose of the rocket ship, or any other object, along the path of its motion, you must orient its position so that it is facing in the direction that you want it to travel. Use the Free Transform tool to rotate its initial position so that it is oriented correctly.
Animate asks if you want to replace the existing tween target object with a new object.

2 Click OK.

Animate replaces the rocket ship with the alien. The motion remains the same, but the target of the motion tween has changed.

Creating Nested Animations

Often, an object that is animated on the Stage will have its own animation. For example, the wings of a butterfly moving across the Stage may flap as it moves. Or the alien that you swapped with the rocket ship could be waving his arms. These kinds of animations are called *nested animations* because they are contained inside the movie clip symbols. Movie clip symbols have their own timeline that is independent of the main Timeline.

In this example, you'll give the alien his own independent movement so he can wave as he flies across the Stage.

Creating animations inside movie clip symbols

We'll animate some of the symbols that make up the alien's body to allow him to wave.
1. In the Library panel, double-click the alien movie clip symbol icon.

You are now in symbol-editing mode for the alien movie clip symbol. The alien appears in the middle of the Stage. In the Timeline, the parts of the alien are separated in layers.

2. Select the Selection tool.

3. Right-click the alien’s left arm and choose Create Motion Tween.

Animate converts the current layer into a tween layer and inserts 1 second’s worth of frames so that you can begin to animate the instance.

4. Select the Free Transform tool.

5. Move the mouse pointer near the corner transformation handle until the cursor changes to the rotation icon. Drag the corner handle near the hand to rotate the arm upward to the alien’s shoulder height.
A keyframe is inserted at the end of the motion tween. The left arm rotates smoothly from the resting position to the outstretched position.

6 Move the red playhead back to frame 1.

7 Now create a motion tween for the alien's other arm. Right-click his right arm and choose Create Motion Tween.

The current layer is converted into a tween layer, and 1 second’s worth of frames are inserted.

8 Choose the Free Transform tool if it’s not selected already.

9 As you did for the left arm, drag the corner transformation handle near the right hand to rotate the arm upward to the alien's shoulder height.

Animate inserts a keyframe at the end of the motion tween. The arm rotates smoothly from the resting position to the outstretched position.

10 Select the last frame in all the other layers and insert frames (F5) so that the head, body, and feet all remain on the Stage for the same amount of time as the moving arms.

11 Click the Scene 1 button in the Edit bar at the top of the Stage to exit symbol-editing mode.

Your animation of the alien raising his arms is complete. Wherever you use the movie clip symbol, the alien’s nested animation will continue to play.
Preview the animation by choosing Control > Test.

Animate opens a window showing the exported animation. The alien moves along the motion path while the nested animation of his arms moving plays and loops.

Save your project and close it. You’ll return to your previous animation in the next section.

Easing

Easing refers to the way in which a motion tween proceeds. You can think of easing as acceleration or deceleration. An object that moves from one side of the Stage to the other side can start off slowly, then build up speed, and then stop suddenly. Or the object can start off quickly and then gradually slow to a halt. Your keyframes indicate the beginning and end points of the motion, but the easing determines how your object gets from one keyframe to the next.

A simple way to apply easing to a motion tween is to use the Properties panel. Easing values range from −100 to 100. A negative value creates a more gradual change from the starting position (known as an ease-in). A positive value creates a gradual slowdown (known as an ease-out).

A more advanced way of applying eases to a motion tween is to use the new Motion Editor, which you’ll learn about in the next lesson.

Splitting a motion tween

Easing affects the entire span of a motion tween. If you want the easing to affect only frames between keyframes of a longer motion tween, you should split the motion tween. For example, return to the 04_workingcopy.fla file of the cinematic animation. The motion tween of the car in the Left_car layer begins at frame 75 and ends at frame 191, at the very end of the Timeline. However, the actual movement of the car starts at frame 75 and ends at frame 100. You’ll split the motion tween so that you can apply an ease to the tween just from frame 75 to frame 100.

In the Left_car layer, select frame 101, which is the frame just after the second keyframe, where the car ends its movement.
2 Right-click frame 101 and choose Split Motion.

The motion tween is cut into two separate tween spans. The end of the first tween is identical to the beginning of the second tween.

3 In the Middle_car layer, select frame 94, right-click, and choose Split Motion to cut the motion tween into two separate tween spans.

4 In the Right_car layer, select frame 107, right-click, and choose Split Motion to cut the motion tween into two spans.

The motion tweens of all three cars have now been split.

Applying eases to motion tweens

You’ll apply an ease-in to the motion tweens of the approaching cars to give them a sense of weight and to make them decelerate, as real cars would.

1 In the Middle_car layer, select any frame between the first and second keyframes of the first motion tween (frame 70 to frame 93).
2 In the Ease section of the Properties panel, enter **100** for the Ease value.

![](image1.png)

This applies an ease-out to the motion tween.

3 In the Left_car layer, select any frame between the first and second keyframes of the first motion tween (frame 75 to frame 100).

![](image2.png)

4 In the Properties panel, enter **100** for the Ease value to apply an ease-out to the motion tween.

5 In the Right_car layer, select any frame between the first and second keyframes of the first motion tween (frame 78 to frame 106).

![](image3.png)

6 In the Properties panel, enter **100** for the Ease value to apply an ease-out to the motion tween.

7 Select Loop at the bottom of the Timeline and move the start and end markers in the Timeline header to frames 60 and 115, respectively.

![](image4.png)
Click Play (Enter/Return).
Animate plays the Timeline in a loop between frames 60 and 115 so you can examine the ease-out motion of the three cars.

Frame-by-Frame Animation

Frame-by-frame animation is a technique that creates the illusion of movement by making incremental changes between every keyframe. Frame-by-frame animation in Animate is similar to traditional hand-drawn cel animation, where each drawing is on a separate sheet of paper, and it’s just as tedious.

Frame-by-frame animations increase your file size rapidly because Animate has to store the contents for each keyframe. Use frame-by-frame animation sparingly.

In the next section, you'll insert a frame-by-frame animation inside the carLeft movie clip symbol to make it move up and down in a jittery fashion. When the movie clip loops, the car will rumble slightly to simulate the idle of the motor.

Inserting a new keyframe

The frame-by-frame animations inside the carMiddle and carRight movie clip symbols have already been done. You’ll finish the animation for the carLeft symbol.

1 In the Library panel, double-click the carRight movie clip symbol to examine its completed frame-by-frame animation.

Inside the carRight movie clip, three keyframes establish three different positions for the car and its headlights. The keyframes are spaced unevenly to provide the unpredictable up and down motion.

2 In the Library panel, double-click the carLeft movie clip symbol. You enter symbol-editing mode for the carLeft symbol.
3 Select frame 2 in both the lights layer and the smallRumble layer.

4 Right-click and choose Insert Keyframe (F6).

Animate inserts a keyframe in frame 2 of the lights layer and the smallRumble layer. The contents of the previous keyframes are copied into the new keyframes.

Changing the graphics

In the new keyframe, change the appearance of the contents to create the animation.

1 In frame 2, select all three graphics (the car and its two headlights) on the Stage (Edit > Select All, or Ctrl+A/Command+A) and move them down the Stage by 1 pixel. Use the Properties panel to decrease the Y-position value by 1 pixel, or press the Down Arrow key to nudge the graphics by 1 pixel.

The car and its headlights move down slightly.

2 Next, repeat the process of inserting keyframes and changing the graphics. For a random motion like an idling car, using at least three keyframes is ideal.

Select frame 4 in both the lights layer and the smallRumble layer.

3 Right-click and choose Insert Keyframe (F6).

Keyframes are inserted into frame 4 of the lights and smallRumble layers. The contents of the previous keyframes are copied into the new keyframes.

4 Select all three graphics on the Stage (Edit > Select All, or Ctrl+A/Command+A) and move them up the Stage by 2 pixels. You can use the Properties panel or press the Up Arrow key twice to nudge the graphics by 2 pixels.

The car and its headlights move up slightly.

Tip If the image of the car isn’t visible, select Fit In Window from the Zoom menu in the upper-right corner of the Stage.
5 Test the idling motion by enabling the Loop Playback option at the bottom of the Timeline and clicking Play (Enter/Return).

### Animating 3D Motion

Finally, you’ll add a title and animate it in 3D space. Animating in 3D presents the added complication of a third axis (z). When you choose the 3D Rotation or 3D Translation tool, you need to be aware of the Global Transform option at the bottom of the Tools panel. (The tools and the Global Transform option were introduced in the Lesson 3 section “Positioning Objects in 3D Space.”) Global Transform toggles between a global option (button selected) and a local option (button deselected). Moving an object with the global option selected makes the transformation relative to the global coordinate system, whereas moving an object with the local option on makes the transformation relative to itself.

1 Click Scene 1 in the Edit bar to return to the main Timeline. Insert a new layer at the top of the layer stack and rename it **title**.

2 Lock all the other layers.

3 Insert a new keyframe at frame 120.

4 Drag the movie clip symbol called movietitle from the Library panel onto the Stage.

---

**Note** In this section, you created the car’s idling motion by manually moving the car’s position frame by frame. In the next lesson, you’ll learn to use the Refine Tween panel, which can automatically modify your motion tween to simulate natural movements such as bounces or random jitters (as in the idling of a car).

**Tip** You can navigate quickly between multiple keyframes by choosing Control > Step Forward To Next Keyframe (Ctrl/Cmd+) or Control > Step Backward To Previous Keyframe (Ctrl/Cmd-). You can also click the forward-pointing or backward-pointing arrow in front of your layer name on the Timeline to move to the next or previous keyframe, respectively.
The movietitle instance appears in your new layer in the keyframe at frame 120.

5 Position the title in the empty sky at x=180 and y=90.

6 Right-click the movie title and choose Create Motion Tween.
   Animate converts the current layer to a tween layer so that you can begin to animate the instance.

7 Move the red playhead to frame 140.

8 Select the 3D Rotation tool 🤹.
   The 3D rotation control appears on the selected movie clip.
9 Deselect the Global Transform option ( ) at the bottom of the Tools panel to put the 3D Rotation tool into local mode.

10 Drag upward on the left arm of the green Y control to rotate the title around the y axis to angle it so that it seems to recede into the distance. Its angle is at about −50 degrees. You can check the rotation values in the Transform panel (Window > Transform).

11 Move the red playhead to the first keyframe, at frame 120.

12 Drag upward on the Y control to rotate the title around the y axis in the opposite direction so that the instance looks like just a sliver.
The change in the 3D rotation becomes a motion tween, so the title appears to swing in three dimensions.

**Exporting Your Final Movie**

You can quickly preview your animation by “scrubbing” the red playhead back and forth on the Timeline, by choosing Control > Play, or by using the Time Scrub tool from the Tools panel. You can also use the integrated controller at the bottom of the Timeline. But to create your final project as a movie, you must export it.

Create an MP4 movie file by exporting the project and converting it in Media Encoder, a freestanding application that comes packaged with Animate (you’ll learn more about Media Encoder in Lesson 11).

   
   The Export Video dialog box opens.

2. Keep the Render Size at its original dimensions. Select the Convert Video In Adobe Media Encoder option. Click Browse to select the destination filename and location. Click Export.

   ![Export Video dialog box](image)

Animate generates a SWF file (.swf) and then saves a MOV (.mov) file from it. Adobe Media Encoder automatically launches.

- **Note** Animating the 3D rotation or translation of a symbol is not currently supported in HTML5 Canvas documents or in WebGL documents.
3 In Adobe Media Encoder, notice that your MOV file is already added to the Queue panel.

![Queue panel with MOV file added]

4 In the Queue panel’s Preset menu, choose Match Source – Medium Bitrate. The Match Source – Medium Bitrate setting keeps the dimensions of the source file and balances file size and quality.

5 Click the Start Queue button (the green triangle) or press Enter/Return to begin the encoding process.

6 Media Encoder converts the MOV file into an H.264-formatted video with the standard .mp4 extension.

![Encoding process]

Congratulations—you’re done! The final file can be uploaded to Facebook, YouTube, or other video sharing sites, or put up on a promotional website for the fictional cinematic release.
Review Questions

1. What are two requirements of a motion tween?
2. What kinds of properties can a motion tween change in an ActionScript 3.0 document?
3. What are property keyframes, and why are they important?
4. How can you edit the path of an object’s motion?
5. What does easing do to a motion tween?

Review Answers

1. A motion tween requires a symbol instance on the Stage and its own layer, which is called a tween layer. No other tween or drawing object can exist on the tween layer.
2. A motion tween creates between different keyframes smooth transitions of an object’s location, scale, rotation, transparency, brightness, tint, filter values, or 3D rotation or translation.
3. A keyframe marks a change in one or more properties of an object. Keyframes are specific to each property, so a motion tween can have keyframes for position that are different from keyframes for transparency.
4. To edit the path of an object’s motion, choose the Selection tool and drag directly on the path to bend it. You can also choose the Convert Anchor Point tool and Subselection tool to pull out handles at the anchor points. The handles control the curvature of the path.
5. Easing changes the rate of change in a motion tween. Without easing, a motion tween proceeds linearly, where the same amount of change happens over time. An ease-in makes an object begin its animation slowly, and an ease-out makes an object end its animation slowly.
INDEX

SYMBOL
* (asterisk), to show unsaved changes in a document, 34

NUMBERS
3D motion, animating, 156–159
3D position, changing for objects, 115–116
3D rotation changing for objects, 113–114 tool, 157
3D space, positioning objects, 112–119
3D Translation tool, 115

A
Actions panel navigating, 359–360 pinning code in, 379
Actions panel wizard actions for button click, 364–369 stopping Timeline, 361–364
ActionScript support, 4–5 video, 403
ActionScript 3.0 documents converting to HTML5 Canvas, 425–427 publishing content, 424–425
ActionScript and JavaScript, interactive movies, 343–344
Adobe CC Library. See libraries
Adobe Illustrator files, importing, 87–90
Adobe Media Encoder CC. See also video adding files, 404–405 converting videos for Animate, 405–408 using, 410–411
Adobe Photoshop files, importing, 94–97
AIR applications choosing, 5 creating, 433–437 installing, 437–439
AIR Debug Launcher, 441
AIR documents, video, 403
aligning objects, 78–79
Alpha value decreasing, 109 of fill, 59–60
Alt key. See keyboard shortcuts anchor points controlling with arrow keys, 173 deleting, 173–174
anchor points (continued)
deleting and adding, 57
moving, 173
removing direction handles, 173–174
Animate CC
keeping up to date, 34
starting, 2
animated buttons, 379–383.
See also buttons
animating
3D motion, 156–159
bounces, 185–188
color, 285–288
filters, 137–139
mask and masked layers, 292–296
objects along paths, 212–216
position, 126–129
satellite trajectory, 216–219
scale, 206–209
shapes, 266–267
transformations, 140–143
transparency, 135–136
animating position, 126–129
animations.
See also transition animations
changing duration, 129–130
closing, 389
creating inside movie clip symbols, 148–151
frame by frame, 154–156
inserting into movie clips, 276–277
looping, 274–277
nesting, 148–151
overview, 125
playing at destination, 375–378
previewing, 129
previewing with onion skinning, 282–285
stopping, 377–378
Application bar, identifying
in workspace, 5
apps, testing, 441
armatures
building, 301–304
extending, 304–305
hierarchy, 306
moving bones of, 306
posing, 311–312
stacking order, 309–310
art
converting and exporting, 79–81
editing and creating, 65–66
exporting, 119
exporting to file formats, 80–81
assets
accessing, 9
sharing, 120
asterisk (*), appearance, 34
audio, preventing
overlapping, 420
audio options, setting and saving,
410–411
audio splitting, 397.
See also sounds
B
background, adding, 331–333
background color, setting
for stage, 9
bitmap art, converting
to vectors, 79–80
bitmap fills, 48
bitmaps.
See also Export As Bitmap
converting to vector graphics,
97–98
swapping with symbols, 350–352
blend types, 270
blending effects, 110
Blur filter, applying, 111–112
Bone tool, 301
bones
in armature hierarchy, 306
defining for armature, 334–335
defining in shapes, 326–327
isolating rotation, 312–313
moving in armatures, 306–307
pinning, 313–314
removing and adding, 307
setting spring strength, 335–336
BounceIn ease, using, 189–190
bounces, animating, 185–188
bounding boxes, resizing, 143
brightness, changing, 108
Brush library, 61–63.
  See also paint brushes
button instances
  adding for home button, 370
  naming, 354–355
  placing, 352–354
button symbols
  creating, 344–348
  using, 91
buttons.
  See also animated buttons
adding sounds, 400–402
duplicating, 349–350
invisibility, 349
Lock Fill, 46
New Folder, 98

C
camera
  animating pans, 243–244
  animating rotation, 246
  animating zoom-in, 244–245
  animating zoom-out, 242–243
  characteristics, 240
  color effects, 260
  enabling, 239
  finishing moves, 246–248
  layers for fixed graphics, 255–259
  zoom mode, 241–243
camera frame, setting, 240–241
Camera layer
  adding attached layer, 255–256
  hiding, 240
camera moves, finishing, 246–248
Camera tool, 239–240
captions, adding, 259–259
CC Library.
  See libraries
classic tweens.
  See also tweens
adding filters, 209–210
adding movie clip instance,
  205–206
  animating scale, 206–209
  applying, 203–205
eases, 222–225
features, 199–200
inserting keyframes, 202
motion guides, 211–219
movie clip symbol, 200–202
repositioning instances, 202
code
  copying to Script window, 369
  entering, 359–360
  pinning in Actions panel, 379
Code Snippets panel, 374–375
color
  animating, 285–288
  hexadecimal numbers, 39
  matching for objects, 77
Color Effects
  applying for camera, 260
  resetting, 109
Command key.
  See keyboard shortcuts
content, modifying, 32–33
control points
clearing, 225
deleting, 225
moving, 40
Copy and Paste, using, 41–42
copying.
See also duplicating
art from Illustrator, 90
and pasting curves, 175–178
and pasting tweens, 220–221
corners, adding, 42
CreateJS libraries, 428
Ctrl key.
See keyboard shortcuts
curvature, changing, 172–173
curves.
See also ease curves; property
curves
copying and pasting, 175–178
creating, 55–57
D
damping effects, adding, 337–338
debugging, 369
deleting
anchor points, 57, 173–174
or changing sound files, 399–400
control points, 225
property curves, 174
depth, creating, 249–254
desktop applications, publishing, 432–440
destination keyframes,
creating, 356–358.
See also keyframes
display options, 110–112
dock, explained, 26–27
Document Settings
dialog box, 33
document types, 4–5
documents, creating, 3–4
domain, identifying, 73–74
dragging motion,
constraining, 173
drawing modes, 44
drawing tools, 27
duplicating.
See also copying
buttons, 349–350
keyframes, 274–275
layers, 22
motion tweens, 177–178
symbols in libraries, 101
duration, changing, 129–130
E
earth revolutions, adding, 220–221
ease curves, vs. property
curves, 185.
See also curves
ease types, navigating in
Motion Editor, 183
ease-in, adding, 182–184, 296
EaseJS library, 428
eases
adding motion tweens, 180–182
adding to inverse
kinematics, 324
animating bounces, 185–188
applying, 296
applying to motion tweens,
152–154
applying to property curve,
192–193
Bouncein ease, 189–191
classic tweens, 222–225
ease-in, 182–184
motion tweens, 180–182
removing, 185
easing
    process, 151–154
    properties, 225
    shape tweens, 296
Edit bar, 5
Edit Document keyboard shortcut, 277
Edit Envelope dialog box, 397
editing
    and creating art, 65–66
    and managing symbols, 98–104
    path of motion, 145–146, 219
    poses, 324
    property curves, 168–174
    shapes, 41–43, 331
    symbols in place, 102–103
    tools, 27
effects. See special effects
encoding options.
    See also video
    adjusting video length, 409
    overview, 408
    video and audio, 410
errors, checking for, 369
Export As Bitmap, 110–111.
    See also bitmaps
    art, 119
    to HTML5, 428–429
    movies, 159–160, 260–262
external video, playing back, 411–418.
    See also video
Eyedropper tool, 77

F
fills, defined, 45
fills and strokes
    changing, 43
    modifying Alpha value, 59–60
    selecting, 40
    using, 38–39
filters
    adding to classic tweens, 209–210
    animating, 137–139
    applying for special effects,
        111–112
    Blur, 111–112
Find And Replace
    command, 377
fixed graphics, 255–259.
    See also graphic symbols
FLA files, 4, 436
FLVPlayback, 416
folders
    using, 98–99
    using with layers, 20–21
fonts, searching for, 75.
    See also web fonts
Frame Picker, using for phonemes, 226–231
frame rate
    explained, 134
    viewing in Timeline, 11
frame-by-frame animation, 154–156
frames
    adding, 130–131
    inserting, 15–16
    and keyframes, 18
    selecting, 16
Free Transform tool, 41

G
GIF, exporting art as, 80–81
gotoAndPlay command,
    using, 377
gradient fills, adjusting, 286–288
Gradient Transform tool, 47
gradient transitions, creating, 45–47
graphic symbols, 91–92, 226–231.
    See also fixed graphics; symbols
    graphics, changing, 155–156
graphics tablets, pressure-sensitive, 68

grouping objects, 48–49
groups, using, 26–27
guides
  locking, 108
  and rulers, 107–108

H

hexadecimal numbers, using with colors, 39, 46

hiding
  Camera layer, 240
  contents of layers, 14

Hit keyframe, 349

home button, creating, 370–374

horizontal lines, drawing, 64

HTML5 Canvas
  choosing, 4
  exporting to, 428–429
  features, 428
  Publish Settings dialog box, 428–432
  supported features, 430
  video component, 417

I

Illustrator files, importing, 87–90
image formats, 97
images, smoothing, 25
Import Video wizard, 411.
  See also video
importing
  Adobe Illustrator files, 87–90
  Adobe Photoshop files, 94–97
  items into Library panel, 9–10
  sound files, 391–392
  SVG files, 90
  Ink Bottle tool, 43
inserting
  animations into movie clips, 276–277
  frames, 15–16
  keyframes, 154–155
  keyframes for shape tweens, 271–272
  keyframes with different content, 356–358
  poses, 322–324
  poses for Spring feature, 336–337
  symbols, 206
instances
  changing color effects, 108–109
  naming, 355
  resizing and repositioning, 104–108
  swapping, 148

interactive movies.
  See also movies
  ActionScript and JavaScript, 343–344
  buttons, 344–355
  destination keyframes, 356–359
  Home button, 370–375
  navigating Actions panel, 359–360
  testing, 354

  Timeline preparation, 355–356
interface, lightening, 7
inverse kinematics
  adding eases, 324
  building armatures, 301–304
  extending armatures, 304
  modifying joint position, 308–309
  moving bones of armatures, 306–307
  overview, 300–301
  rearranging stack order, 309–310
  with shapes, 325–333
iOS Simulator, 441
J

jagged images, smoothing, 25
Java

JavaScript and ActionScript, 343–344
interactivity, adding, 360–369
libraries, 428
joint position, modifying, 308–309
joint speed, changing, 325
joints

constraining, 320–321
constraining range of rotation, 317–318
constraining translation, 318–319
disabling rotation, 315–317
JPG, exporting art as, 80–81
Juno’s trajectory, 237

K

keyboard shortcuts

closing animations, 389
copying and pasting, 41
copying property curves, 177
Edit Document, 277
importing to library, 10
inserting symbols, 206
keyframe navigation, 156
Redo, 30
Send To Back, 309–310
Undo, 30
ungrouping shapes, 49
keyframes.

See also destination keyframes;
property keyframes
creating, 16–18
with differing content, 356–358
distributing uniformly, 130
duplicating, 274–275
establishing with shapes, 267–269
and frames, 18

inserting, 154–155
inserting for shape tweens,
271–272
labels, 358–359
moving, 19, 131, 270–271
navigating between, 156
versus poses, 322
Properties panel, 23
stop command, 378

L

labels, using on keyframes, 358–359
Layer Depth panel, 249, 252–254
layer folders, creating, 20–21
layers

adding, 13–14
adding to layer folders, 21–22
attaching to camera, 255–259
copying and pasting, 22
cutting, 22
duplicating, 22
hiding contents, 14
identifying in workspace, 5
manipulating in Timeline, 11
renaming, 12–13
of stars, 249–252
working with, 15

libraries

organizing, 98–99
sharing assets, 120
Library panel, 9–10
Line tool, 64
lines, creating with Pen tool, 58. See
also variable-width lines
Lock Fill button, 46
locking guides, 108
looping animation, 274–277
loops, previewing, 275
M
mask and masked layers, animating, 292–296
mask layer, defining, 289–290
masked layer
  adding tweens, 292–296
  creating, 290–291
masks
  creating and using, 289–291
  seeing effects, 291
  traditional example, 292
Merge drawing mode, 44
mobile devices, publishing to, 440–444
modifying, content and stage, 32–33
Motion Editor.
  See also path of motion
  anchor points, 170–172
  navigating ease types, 183
  using, 165–166
  values, 170
  viewing options, 174–175
motion guides.
  See also tweens
  animating satellite trajectory, 216–219
  animating on path, 212–216
  classic tweens, 211–219
  project files, 211
motion tweens
  adding, 167–168, 180–182
  applying eases, 152–154
  duplicating, 177–178
  removing, 129
  splitting, 151–152
mouth position, storing, 226–231
movie clip symbols
  animated buttons, 379–383
  classic tweens, 200–202
  creating animations in, 148–151
  using, 91
movie clips, removing and adding, 307
movies.
  See also interactive movies; video
  exporting, 159–160, 260–262
  previewing, 31–32
  saving, 34
  testing, 416
moving
  anchor points, 173
  control points, 40
  keyframes, 19, 131, 270–271
  path of motion, 144–145
N
nesting animations, 148–151
New Folder button, 98
O
Object drawing mode, 44
objects
  aligning, 78–79
  aligning and distributing, 77–79
  animating along paths, 212–216
  changing 3D position, 115–116
  changing 3D rotation, 113–114
  grouping, 48–49
  orienting to path of motion, 146–147
  positioning in 3D space, 112–119
  positioning on Stage, 23–25
onion skinning, 282–285
Option key.
  See keyboard shortcuts
options on Tools panel, 27
Oval tool, using, 39–40
pace, changing, 270–271
pacing and timing, changing, 129–131
Paint Brush tool, 61–68
paint brushes, managing, 67. See also Brush library
Paint Bucket tool, 43
panels, working with, 25–27
Paste options, 177.
   See also Copy and Paste
path of motion.
   See also Motion Editor
   animating objects, 212–216
   changing, 143–147
   changing scale or rotation, 144–145
   editing, 145–146
   manipulating, 146
   moving, 144–145
   orienting objects, 146–147
paths, creating with Pen tool, 58
Pattern Brush, editing and creating, 65–66
patterns, creating, 63–64
Pen tool, 55–58
Pencil tool, 49
perspective angle, 117–118
phonemes, using Frame Picker, 226–231.
   See also sounds
Photoshop files, importing, 94–97
physics, simulating with Spring feature, 333–333
playback environment, 4–5
PNG, exporting art as, 80–81
PolyStar tool, using, 27–30
poses
   editing, 324
   inserting, 322–324
inserting for Spring feature, 336–337
   versus keyframes, 322
posing armatures, 311–312
position, animating, 126–129
posterization, 97
PreloadJS library, 428
previewing
   animations, 129
   animations with onion skinning, 282–285
   loops, 275
   movies, 31–32
   with onion skinning, 282–285
Primitive drawing mode, 44
project files, 125–126, 166
projector, creating, 439–440
properties, identifying in workspace, 5
Properties panel, 23–27
property curves.
   See also curves
   applying eases, 192–193
   deleting, 174
   vs. ease curves, 185
   editing, 168–174
property easing, 225
property keyframes, 139–140. See also keyframes
PSD files, 94, 97
publishing
   converting to HTML5 Canvas, 425–427
desktop applications, 432–440
document types, 424
for HTML5, 428–432
to mobile devices, 440–444
runtime environments, 424–425
WebGL animations, 440
R
Rectangle tool, 39
redoing steps, 30
removing
and adding bones, 307
and adding movie clips, 307
eases, 185
motion tweens, 129
shape hints, 282
web fonts, 74, 76
renaming layers, 12–13
replacements, making, 377
resizing
bounding boxes, 143
Stage, 32–33
rotation.
See 3D rotation
rulers and guides, using, 107–108
S
sans serif fonts, 75
satellite trajectory, animating,
216–219
saving
movies, 34
swatches, 51–52
workspace, 6–7
scaling content, 32–33
script elements, displaying in Actions
panel, 360
Script window, copying
code to, 369
selecting
frames, 16
PSD files, 94
strokes and fills, 40
and using tools, 27–30
Selection tool
editing curves, 56–57
and path of motion, 146
and shapes, 39–40
selections
making, 40
span-based vs.
frame-based, 132
Send To Back, 309–310
serif fonts, 75
shadows, adding, 60–61
shape contours, changing, 42
shape hints, 278–282
shape tweens
adding, 271–274
animating colors, 288
applying, 269–270
changing pace, 270–271
creating, 267–270
easing, 296
extending, 273–274
inserting keyframes, 271–272
modifying, 270
variable width strokes, 277
shapes
animating, 266–267
creating, 39–40
editing, 41–43, 331
establishing keyframes, 267–269
inverse kinematics, 325–333
ungrouping, 49
sharing assets, 120
Shift key.
See keyboard shortcuts
smoothing images, 25
sound files
deleting or changing, 399–400
importing, 391–392
sound sync options, 395
SoundJS library, 428
sounds.
  See also audio splitting; phonemes
  adding to buttons, 400–402
  changing volume, 397–399
  clipping ends, 395–397
  Edit Envelope dialog box, 397
  playing on Timeline, 393–394
  preventing overlapping, 420
  special effects, applying filters, 111–112
  Spring feature, 333–338
  spring strength, setting for bones, 335–336
  stack, using, 26–27
  stacking order, rearranging for armatures, 309–310
Stage
  background color, 9
  features, 7–8
  full-screen mode, 8
  identifying in workspace, 5
  modifying, 32–33
  positioning objects, 23–25
  properties, 8–9
  rotating for drawing, 68
  scaling, 8
  stars, adding layers, 249–252
  steps, undoing, 30
  stop command, adding for keyframes, 378
strokes and fills.
  See also variable-width strokes
  changing, 43
  selecting, 40
  using, 38–39
Subselection tool, 56–57
SVG files
  exporting art as, 81
  importing, 90
swatches.
  See also tagged swatches, saving, 51–52
  symbol instances, breaking apart, 104
symbols.
  See also graphic symbols
  buttons, 91–92
  creating, 92–93
  duplicating in libraries, 101
  editing and managing, 98–104
  editing in place, 102–103
  entering from libraries, 99–101
  inserting, 206
  movie clips, 91
  swapping with buttons, 350–352
synchronizing settings, 440–444

T
tagged swatches, 52–54.
  See also swatches
tail
  animating, 328–329
  combining with walk cycle, 329–331
text, creating and editing, 69–77
Text tool, dynamic text, 69–70
Time Scrub tool, 129
Timeline
  adding layers, 13–15
  changing appearance, 12
  creating keyframes, 16–18
  elapsed time, 11
  frame rate, 11
  frames, 11
  identifying in workspace, 5
  inserting frames, 15–16
  keyframes, 16–18
  layers, 11
  moving keyframes, 19
  organizing layers, 19–22
Timeline (continued)
overview, 11
preparing, 355–356
removing keyframes, 19
renaming layers, 12–13
timing and pacing, changing, 129–131
tools
3D rotation, 157
3D Translation, 115
Bone, 301
Camera, 239–240
Eyedropper, 77
Free Transform, 41
Gradient Transform, 47
Ink Bottle, 43
Line, 64
Oval, 39–40
Paint Brush, 61
Paint Bucket, 43
Pen, 55–56, 58
Pencil, 49
PolyStar, 27–30
Rectangle, 39
Selection, 39, 56–57, 146
Subselection, 56–57
Text, 69–70
Time Scrub, 129
Width, 50
Tools panel, 27–30
touch layer, changing
opacity, 444
transformations
animating, 140–143
global vs. local, 115
resetting, 116–117
transition animations,
creating, 375–377.
See also animations
transparency
animating, 135–136
changing, 109
creating depth, 59–61
tween eases, adding, 222–225
tween spans, changing time in,
132–134
tween targets, swapping, 147–148
TweenJS library, 428
tweens.
See also classic tweens; motion
guides; shape tweens
adding filters, 209–210
adding keyframe, 202
adding to masked layers, 292–296
animating scale, 206–209
applying, 203–205
breaking, 274
copying and pasting, 220–221
features, 199
movie clip instance, 205–206
movie clip symbol, 200–202
project files, 199–200
repositioning instances, 202
Typekit font, adding, 70–73
typography, 75

U
undoing steps, 30
ungrouping objects, 49

V
vanishing point, 117–118
variable-width lines.
See also lines
variable-width strokes, 49–51. See
also strokes and fills
vector art, converting to bitmaps,
79–80
vector graphics, converting bitmaps
to, 97–98
vertical lines, drawing, 64
video.

See also Adobe Media Encoder CC; encoding options; external video; Import Video wizard; movies
ActionScript 3.0 documents, 403
adding to Adobe Media Encoder, 404–405
AIR documents, 403
coded, 403
converting for Animate, 405–408
encoding, 403
encoding options, 408–411
H.264 standard, 403, 415
HTML5 Canvas
documents, 403
without playback controls, 418–420
video length, adjusting, 409
video options, setting and saving, 410–411

W
walk cycle
combining tail with, 329–331
creating, 311–314
enhancing, 324

web fonts.

See also fonts
adding, 70–73
removing, 74, 76
WebGL environment
features, 4
publishing, 440
Width tool, 50
workspace
choosing, 6
choosing and saving, 6–7
features, 5
saving, 6–7
Stage, 7–9

X
XFL files, 4

Z
z-depth
changing, 259
setting in Layer Depth panel, 252–254