CONTENTS

GETTING STARTED

About Classroom in a Book .............................................. 1
TinyURLs ........................................................................ 1
Prerequisites .................................................................... 2
Conventions used in this book .......................................... 2
Bolded text ........................................................................ 2
Code font ......................................................................... 2
Strikethrough ................................................................. 3
Missing punctuation .......................................................... 3
Element references ............................................................ 3
Windows vs. macOS instructions ....................................... 3
Installing the program ....................................................... 4
Updating Dreamweaver to the latest version ....................... 5
Online content ................................................................... 6
Recommended lesson order .............................................. 7
Bonus material .................................................................. 8
On first launch .................................................................. 9
Choosing the program color theme .................................... 9
Setting up the workspace ................................................ 10
Defining a Dreamweaver site ............................................ 11
Checking for updates ....................................................... 14
Additional resources ....................................................... 15
Adobe Authorized Training Centers ................................. 15

1 CUSTOMIZING YOUR WORKSPACE ................................. 16

Touring the workspace .................................................... 18
Using the Start Screen .................................................... 19
Recent ........................................................................... 20
CC Files ........................................................................ 20
Quick Start ................................................................. 21
Starter Templates ...................................................... 21
Create New and Open ................................................... 22
Learn ............................................................................ 22
Exploring New Feature guides ........................................... 23
Setting interface preferences .......................................... 23
Switching and splitting views ......................................... 26
Code view ....................................................................... 26
Design view ..................................................................... 26
Live view ......................................................................... 27
Split view ......................................................................... 28
Live Source Code ............................................................ 29
Inspect mode .................................................................... 29
Selecting a workspace layout .......................................... 30
Standard workspace ....................................................... 30
Developer workspace ..................................................... 31
Working with panels ....................................................... 31
Minimizing panels .......................................................... 32
Closing panels and panel groups ...................................... 33
Dragging .......................................................................... 33
Floating ............................................................................ 34
Grouping, stacking, and docking ...................................... 34
Personalizing Dreamweaver ............................................. 35
Saving a custom workspace ............................................. 36
Working with Extract ...................................................... 36
Working with toolbars ..................................................... 37
Document toolbar .......................................................... 37
Standard toolbar ............................................................ 37
Common toolbar ............................................................ 38
Creating custom keyboard shortcuts ................................. 38
Using the Property inspector .......................................... 40
Using the HTML tab ........................................................ 40
Using the CSS tab ........................................................... 41
Accessing image properties ........................................... 41
Accessing table properties .............................................. 41
Using the Related Files interface ..................................... 41
Using tag selectors .......................................................... 43
# CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the CSS Designer</td>
<td>44</td>
</tr>
<tr>
<td>Sources</td>
<td>44</td>
</tr>
<tr>
<td>@Media</td>
<td>45</td>
</tr>
<tr>
<td>Selectors</td>
<td>45</td>
</tr>
<tr>
<td>Properties</td>
<td>46</td>
</tr>
<tr>
<td>All and Current modes</td>
<td>47</td>
</tr>
<tr>
<td>Using the Visual Media Query (VMQ) interface</td>
<td>48</td>
</tr>
<tr>
<td>Using the DOM Viewer</td>
<td>49</td>
</tr>
<tr>
<td>Using Element dialogs, displays, and inspectors</td>
<td>49</td>
</tr>
<tr>
<td>Position Assist dialog</td>
<td>49</td>
</tr>
<tr>
<td>Element Display</td>
<td>50</td>
</tr>
<tr>
<td>Image Display</td>
<td>50</td>
</tr>
<tr>
<td>Text Display</td>
<td>51</td>
</tr>
<tr>
<td>Setting up version control in Dreamweaver</td>
<td>51</td>
</tr>
<tr>
<td>Exploring, experimenting, and learning</td>
<td>52</td>
</tr>
<tr>
<td>Review questions</td>
<td>53</td>
</tr>
<tr>
<td>Review answers</td>
<td>53</td>
</tr>
</tbody>
</table>

## 2 HTML BASICS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What is HTML?</td>
<td>56</td>
</tr>
<tr>
<td>Where did HTML begin?</td>
<td>56</td>
</tr>
<tr>
<td>Basic HTML code structure</td>
<td>58</td>
</tr>
<tr>
<td>Frequently used HTML elements</td>
<td>58</td>
</tr>
<tr>
<td>HTML tags</td>
<td>58</td>
</tr>
<tr>
<td>HTML character entities</td>
<td>60</td>
</tr>
<tr>
<td>What’s new in HTML5</td>
<td>61</td>
</tr>
<tr>
<td>HTML5 tags</td>
<td>61</td>
</tr>
<tr>
<td>Semantic web design</td>
<td>62</td>
</tr>
<tr>
<td>New techniques and technology</td>
<td>63</td>
</tr>
<tr>
<td>Review questions</td>
<td>64</td>
</tr>
<tr>
<td>Review answers</td>
<td>65</td>
</tr>
</tbody>
</table>

## B2 HTML BASICS BONUS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What is CSS?</td>
<td>68</td>
</tr>
<tr>
<td>HTML vs. CSS formatting</td>
<td>68</td>
</tr>
<tr>
<td>HTML defaults</td>
<td>70</td>
</tr>
<tr>
<td>HTML5 defaults?</td>
<td>71</td>
</tr>
</tbody>
</table>
## B3 CSS BASICS BONUS

### 4 WEB DESIGN BASICS

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Developing a new website</td>
<td>98</td>
</tr>
<tr>
<td>What is the purpose of the website?</td>
<td>98</td>
</tr>
<tr>
<td>Who is the audience?</td>
<td>98</td>
</tr>
<tr>
<td>How do they get here?</td>
<td>98</td>
</tr>
<tr>
<td>Scenario</td>
<td>101</td>
</tr>
<tr>
<td>Working with thumbnails and wireframes</td>
<td>101</td>
</tr>
<tr>
<td>Creating thumbnails</td>
<td>101</td>
</tr>
<tr>
<td>Creating a page design</td>
<td>102</td>
</tr>
<tr>
<td>Creating wireframes</td>
<td>103</td>
</tr>
<tr>
<td>Review questions</td>
<td>105</td>
</tr>
<tr>
<td>Review answers</td>
<td>105</td>
</tr>
</tbody>
</table>

## B4 CREATING WEB ASSETS USING PHOTOSHOP GENERATOR BONUS

### 5 CREATING A PAGE LAYOUT

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluating page design options</td>
<td>108</td>
</tr>
<tr>
<td>Working with predefined layouts</td>
<td>110</td>
</tr>
<tr>
<td>Styling an existing layout</td>
<td>113</td>
</tr>
</tbody>
</table>
Styling elements using the Extract panel .........................115
Extracting text from a Photoshop mockup .......................119
Troubleshooting CSS styling ........................................121
Extracting text styling from a Photoshop mockup ...........123
Creating a gradient background using Extract ...............124
Extracting image assets from a mockup .........................128
Adding CSS background effects in code .........................134
Finishing up the layout .............................................138
Review questions .....................................................146
Review answers .......................................................147

6 WORKING WITH TEMPLATES .............................................148
Creating a template from an existing layout .................150
Inserting editable regions ...........................................151
Building semantic content ..........................................153
Inserting HTML entities .............................................158
Inserting metadata ...................................................159
Validating HTML code ...............................................162
Producing child pages ...............................................164
Creating a new page ................................................164
Adding content to child pages ....................................166
Moving CSS styles to a linked file .................................172
Updating a template ................................................176
Formatting content in editable regions .........................181
Review questions .....................................................184
Review answers .......................................................185

7 WORKING WITH TEXT, LISTS, AND TABLES .......................186
Previewing the completed file .....................................188
Creating and styling text ............................................191
Importing text .........................................................191
Creating semantic text structures ...............................194
Creating headings ....................................................196
Adding other HTML structures ..................................197
Creating lists .........................................................201
Creating indented text ..............................................205
Creating and styling tables .......................................210
Creating tables from scratch ........................................ 210
Copying and pasting tables ........................................ 215
Styling tables with CSS .............................................. 216
Styling table cells .................................................... 221
Controlling table display ........................................... 223
Inserting tables from other sources .............................. 226
Adding and formatting caption elements ....................... 229
Spell-checking webpages .......................................... 231
Finding and replacing text .......................................... 233
Optional self-paced exercise ....................................... 238
Review questions .................................................... 239
Review answers ...................................................... 239

8 WORKING WITH IMAGES ........................................ 240
Web image basics ..................................................... 242
Vector graphics ....................................................... 242
Raster graphics ....................................................... 242
Raster image file formats .......................................... 246
Previewing the completed files ................................... 247
Inserting an image .................................................... 248
Controlling image positions with CSS classes ................ 250
Working with the Insert panel ..................................... 252
Using the Insert menu .............................................. 254
Inserting non-web file types ...................................... 256
Working with Photoshop Smart Objects (optional) ......... 260
Copying and pasting images from Photoshop (optional) .... 262
Inserting images by drag and drop .............................. 266
Optimizing images with the Property inspector .............. 267
Review questions .................................................... 271
Review answers ...................................................... 271

9 WORKING WITH NAVIGATION ................................ 272
Hyperlink basics ....................................................... 274
Internal and external hyperlinks ................................. 274
Relative vs. absolute hyperlinks ................................. 274
Previewing the completed file ................................... 275
Creating internal hyperlinks ..................................... 278
Creating relative links .............................................. 278
Creating a home link ........................................ 282
Updating links in child pages .......................... 283
Creating an external link ................................. 286
Creating an absolute link in Live view ............... 286
Setting up email links .................................... 289
Creating an image-based link ......................... 291
Creating image-based links using the Element Display ... 291
Creating text links using the Text Display ......... 292
Targeting page elements ................................ 294
Creating internal targeted links ...................... 294
Creating a destination link in the Element Display ... 297
Targeting id-based link destinations ................. 298
Locking an element on the screen .................... 299
Styling a navigation menu ............................. 301
Checking your page ...................................... 305
Adding destination links (optional) .................. 306
Review questions ....................................... 307
Review answers ....................................... 307

10 ADDING INTERACTIVITY .......................... 308
Learning about Dreamweaver behaviors ............. 310
Previewing the completed file ....................... 312
Working with Dreamweaver behaviors .............. 313
Applying a behavior .................................. 316
Applying a Swap Image Restore behavior ........... 318
Removing applied behaviors ....................... 320
Adding behaviors to hyperlinks ................... 320
Working with jQuery Accordion widgets .......... 323
Inserting a jQuery Accordion widget ............... 324
Styling a jQuery Accordion ......................... 327
Applying a background effect to the Accordion tab ... 331
Formatting a conditional state for an accordion tab ... 332
Using Live Code to identify dynamic styling .... 335
Styling the background of the accordion content ... 339
Review questions ...................................... 342
Review answers ....................................... 343
11 PUBLISHING TO THE WEB

Defining a remote site ........................................ 346
Setting up a remote FTP site ................................ 347
Establishing a remote site on a local or network
web server (optional) ........................................... 351
Cloaking folders and files ..................................... 354
Wrapping things up ............................................. 356
Putting your site online (optional) ......................... 359
Synchronizing local and remote sites ..................... 363
Review questions .............................................. 366
Review answers ............................................... 367

12 WORKING WITH CODE

Creating HTML code ........................................ 370
Writing code manually ..................................... 370
Writing code automatically ................................ 373
Working with multicursor support ....................... 377
Commenting your code ..................................... 379
Working with CSS preprocessors ......................... 380
Enabling a preprocessor ................................... 380
Creating the CSS source file ............................... 383
Compiling CSS code ........................................ 386
Nesting CSS selectors ....................................... 389
Importing other style sheets ............................... 391
Learn more about preprocessors ......................... 393
Linting support ................................................ 393
Selecting code ................................................ 395
Using line numbers .......................................... 395
Using tag selectors .......................................... 395
Using parent tags ............................................ 397
Collapsing code .............................................. 398
Expanding code .............................................. 398
Accessing Split Code view ................................. 399
Previewing assets in Code view ......................... 400
Review questions ............................................ 402
Review answers ............................................. 403
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>B13</td>
<td>DESIGNING FOR MOBILE DEVICES</td>
<td>B13-1</td>
</tr>
<tr>
<td>B14</td>
<td>WORKING WITH A WEB FRAMEWORK</td>
<td>B14-1</td>
</tr>
<tr>
<td>B15</td>
<td>ADAPTING CONTENT TO RESPONSIVE DESIGN</td>
<td>B15-1</td>
</tr>
<tr>
<td>B16</td>
<td>WORKING WITH WEB ANIMATION AND VIDEO BONUS</td>
<td>B15-1</td>
</tr>
</tbody>
</table>

APPENDIX: TINY URLS  405

INDEX  407
Adobe® Dreamweaver CC is one of the leading web-authoring programs available. Whether you create websites for others for a living or plan to create one for your own business, Dreamweaver offers all the tools you need to get professional-quality results.

About Classroom in a Book

Adobe Dreamweaver CC Classroom in a Book® (2018 release) is part of the official training series for graphics and publishing software developed with the support of Adobe product experts.

The lessons are designed so you can learn at your own pace. If you’re new to Dreamweaver, you’ll learn the fundamentals of putting the program to work. If you are an experienced user, you’ll find that Classroom in a Book teaches many advanced features, including tips and techniques for using the latest version of Dreamweaver.

Although each lesson includes step-by-step instructions for creating a specific project, you’ll have room for exploration and experimentation. You can follow the book from start to finish or complete only those lessons that correspond to your interests and needs. Each lesson concludes with a review section containing questions and answers on the subjects you’ve covered.

TinyURLs

At several points in the book, I reference external information available on the Internet. The uniform resource locators (URLs) for this information are often long and unwieldy, so I have provided custom TinyURLs in many places for your convenience. Unfortunately, the TinyURLs sometimes expire over time and no longer function. If you find that a TinyURL doesn't work, look up the actual URL provided in the appendix.
Prerequisites

Before using *Adobe Dreamweaver CC Classroom in a Book (2018 release)*, you should have a working knowledge of your computer and its operating system. Be sure you know how to use the mouse, standard menus and commands, as well as how to open, save, and close files. If you need to review these techniques, see the printed or online documentation included with your Windows or macOS operating system.

Conventions used in this book

Working in Dreamweaver means you’ll be working with code. We have used several conventions in the following lessons and exercises to make working with the code in this book easier to follow and understand.

**Bolded text**

Certain names, words, and phrases will be bolded from time to time, usually when first cited in an instruction. This styling will include text, other than HTML or CSS code, that needs to be entered into program dialogs or into the body of a webpage, like this:

Type: **Insert main heading here**

Filenames, like *mygreen-styles.css*, will also be bolded as needed to identify crucial resources or targets of a specific step or exercise. Be aware that these same names may not be bolded in introductory descriptions or general discussion. Be sure to identify all resources required in a specific exercise prior to commencing it.

**Code font**

In many instructions, you will be required to enter HTML code, CSS rules and properties, and other code-based markup. To distinguish the markup from the instructional text, the entries will be styled with a code font, like this:

Examine the following code: `<h1>Heading goes here</h1>`

In instances where you must enter the markup yourself, the entry will be formatted in color, like this:

Insert the following code: `<h1>Heading goes here</h1>`
Strikethrough

In several exercises, you will be instructed to delete markup that already exists within the webpage or style sheet. In those instances, the targeted references will be identified with strikethrough formatting, like this:

Delete the following values:

```css
margin: 10px 20px 10px 20px;
background-image: url(images/fern.png), url(images/stripe.png);
```

Be careful to delete only the identified markup so that you achieve the following result:

```css
margin: 10px 10px;
background-image: url(images/fern.png);
```

Missing punctuation

HTML code, CSS markup, and JavaScript often require the use of various punctuation, such as periods (.), commas (,), and semicolons (;), and can be damaged by their incorrect usage or placement. Consequently, I have omitted periods and other punctuation expected in a sentence or paragraph from an instruction or hyperlink whenever it may cause confusion or a possible error, as in the following two instructions:

Enter the following code: `<h1>Heading goes here</h1>`

Type the following link: `http://adobe.com`

Element references

Within the body of descriptions and exercise instructions, elements may be referenced by name or by class or ID attribute. When an element is identified by its tag name, it will appear as `<section>` or `section`. When referenced by its class attribute, the name will appear with a leading period (.) in a code-like font, like this: `.content` or `.sidebar1`. References to elements by their ID attribute will appear with a leading hash (#) and in a code font, like this: `#top`. This practice matches the way these elements appear in Dreamweaver’s tag selector interface.

Windows vs. macOS instructions

In most cases, Dreamweaver performs identically in both Windows and macOS. Minor differences exist between the two versions, mostly because of platform-specific issues out of the control of the program. Most of these are simply differences in keyboard shortcuts, how dialogs are displayed, and how buttons are named. In most cases, screen shots were made in the macOS version of Dreamweaver and may appear different from your own screen.
Where specific commands differ, they are noted within the text. Windows commands are listed first, followed by the macOS equivalent, such as Ctrl+C/Cmd+C. Common abbreviations are used for all commands whenever possible, as follows:

<table>
<thead>
<tr>
<th>Windows</th>
<th>macOS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control = Ctrl</td>
<td>Command = Cmd</td>
</tr>
<tr>
<td>Alternate = Alt</td>
<td>Option = Opt</td>
</tr>
</tbody>
</table>

As lessons proceed, instructions may be truncated or shortened to save space, with the assumption that you picked up the essential concepts earlier in the lesson. For example, at the beginning of a lesson you may be instructed to “press Ctrl+C/Cmd+C.” Later, you may be told to “copy” text or a code element. These should be considered identical instructions.

If you find you have difficulties in any particular task, review earlier steps or exercises in that lesson. In some cases, if an exercise is based on concepts covered earlier, you will be referred to the specific lesson.

### Installing the program

Before you perform any exercises in this book, verify that your computer system meets the hardware requirements for Dreamweaver, that it’s correctly configured, and that all required software is installed.

If you do not have Dreamweaver, you will first have to install it from Creative Cloud. Adobe Dreamweaver must be purchased separately; it is not included with the lesson files that accompany this book. Go to helpx.adobe.com/dreamweaver/system-requirements.html to obtain the system requirements.
Go to [www.adobe.com/creativecloud/plans.html](http://www.adobe.com/creativecloud/plans.html) to sign up for Adobe Creative Cloud. Dreamweaver may be purchased with the entire Creative Cloud family or as a standalone app. Adobe also allows you to try Creative Cloud and the individual applications for seven days for free.

Check out [www.adobe.com/products/dreamweaver.html](http://www.adobe.com/products/dreamweaver.html) to learn more about the different options for obtaining Dreamweaver.

### Updating Dreamweaver to the latest version

Although Dreamweaver is downloaded and installed on your computer hard drive, periodic updates are provided via Creative Cloud. Some updates provide bug fixes and security patches, while others supply amazing new features and capabilities.

The lessons in this book are based on Dreamweaver CC (2018 release) and may not work properly in any earlier version of the program. To check which version is installed on your computer, choose Help > About Dreamweaver in Windows or Dreamweaver > About Dreamweaver on macOS. A window will display the version number of the application and other pertinent information.

If you have an earlier version of the program installed, you will have to update Dreamweaver to the latest version. You can check the status of your installation by opening the Creative Cloud manager and logging in to your account.

Check out [helpx.adobe.com/creative-cloud/help/download-install-trial.html](http://helpx.adobe.com/creative-cloud/help/download-install-trial.html) to learn how to download and install a limited-period trial of Creative Cloud to your computer or laptop.
Online content

Your purchase of this Classroom in a Book includes online materials provided by way of your Account page on peachpit.com.

Lesson files

To work through the projects in this book, you will need to download the lesson files from peachpit.com. You can download the files for individual lessons, or it may be possible to download them all in a single file.

Web Edition

The Web Edition is an online interactive version of the book providing an enhanced learning experience. Your Web Edition can be accessed from any device with a connection to the Internet; it contains the following:

- The complete text of the book
- Hours of instructional video keyed to the text
- Interactive quizzes

In addition, the Web Edition may be updated when Adobe adds significant feature updates between major Creative Cloud releases. To accommodate the changes, sections of the online book may be updated or new sections may be added.

Accessing the lesson files and Web Edition

If you purchased an ebook from peachpit.com or adobepress.com, your Web Edition will automatically appear under the Digital Purchases tab on your Account page. Click the Launch link to access the product. Continue reading to learn how to register your product to get access to the lesson files.

If you purchased an ebook from a different vendor or you bought a print book, you must register your purchase on peachpit.com to access the online content:

2. Sign in or create a new account.
4. Answer the questions as proof of purchase.
5. The Web Edition will appear on the Digital Purchases tab on your Account page. Click the Launch link to access the product.

The lesson files can be accessed through the Registered Products tab on your Account page. Click the Access Bonus Content link below the title of your product to proceed to the download page. Click the lesson file links to download them to your computer.

Warning: Do not copy one lesson folder into any other lesson folder. The files and folders for each lesson cannot be used interchangeably.

Note: The files are updated from time to time, so the date may be different than the one shown.
The files are compressed into ZIP archives to speed up download time and to protect the contents from damage during transfer. You must uncompress (or “unzip”) the files to restore them to their original size and format before you use them with the book. Modern Mac and Windows systems are set up to open ZIP archives by simply double-clicking.

6 Do one of the following:

- If you downloaded DWCC2018_lesson_files.zip, unzipping the archive will produce a folder named DWCC2018_Lesson_Files containing all the lesson files used by the book.

- If you downloaded the lessons individually, create a new folder on your hard drive and name it DWCC2018. Unzip the individual lesson files to this folder. That way, all the lesson files will be stored in one location. Do not share or copy files between lessons.

Recommended lesson order

The training in this book is designed to take you from A to Z in basic to intermediate website design, development, and production. Each new lesson builds on previous exercises, using supplied files and assets to create an entire website. We recommend you download all lesson files at once.

Start with Lesson 1 and proceed through the entire book to Lesson 12. Continue with the online Lessons 13 through 16 (refer to the “Online content” section for more information about the online material).
We recommend that you do not skip any lessons, or even individual exercises. Although ideal, this method may not be a practicable scenario for every user. So each lesson folder contains all the files needed to complete every exercise within it using partially completed or staged assets, allowing you to complete individual lessons out of order, if desired.

However, don’t assume that the staged files and customized templates in each lesson represent a complete set of assets. It may seem that these folders contain duplicative materials, but these “duplicate” files and assets, in most cases, cannot be used interchangeably in other lessons and exercises. Doing so will probably cause you to fail to achieve the goal of the exercise.

For that reason, you should treat each folder as a standalone website. Copy the lesson folder to your hard drive, and create a new site for that lesson using the Site Setup dialog. Do not define sites using subfolders of existing sites. Keep your sites and assets in their original folders to avoid conflicts.

One suggestion is to organize the lesson folders in a single web or sites master folder near the root of your hard drive. But avoid using the Dreamweaver application folder. In most cases, you’ll want to use a local web server as your testing server, which is described in Lesson 11, “Publishing to the Web.”

**Bonus material**

We’ve provided additional material for Lessons 2, 3, and 4 on the Peachpit website. This book has so much great material that we couldn’t fit it all in the printed pages, so we placed Lessons 13 through 16 on the Peachpit website as well:

Lesson 2, “HTML Basics Bonus”
Lesson 3, “CSS Basics Bonus”
Lesson 4, “Creating Web Assets Using Adobe Generator Bonus”
Lesson 13, “Designing for Mobile Devices”
Lesson 14, “Working with a Web Framework”
Lesson 15, “Adapting Content to Responsive Design”
Lesson 16, “Working with Web Animation and Video”

You will find these on your account page (Lessons & Update Files tab) once you register your book, as described earlier in “Accessing the Classroom in a Book files.”
On first launch

Right after installation or upon first launch, Dreamweaver CC will display several introduction screens. First, the Sync Settings dialog will appear. If you are a user of previous versions of Dreamweaver, select Import Sync Settings to download your existing program preferences. If this is the first time you’ve used Dreamweaver, select Upload Sync Settings to sync your preferences to your Creative Cloud account.

In the book, I use the lightest interface themes for the screen shots. This was done both to save ink in the printing and to place less stress on the environment. Feel free to pick the color themes you prefer.

Choosing the program color theme

If you purchased the book after you installed and launched Dreamweaver, you may be using a different color theme than the one pictured in most screen shots in the book. All exercises will function properly using any color theme, but if you want to configure your interface to match the one shown, complete the following steps.

1. Select Edit > Preferences in Windows or Dreamweaver CC > Preferences in macOS.
   The Preferences dialog appears.
2. Select the Interface category.
3. Select the lightest App Theme color.
   Select Solarized Light from the Code Theme menu.
The interface changes to the new theme. Depending on which app theme you select, the code theme may change automatically. The changes are not permanent yet. If you close the dialog, the theme will revert to the original colors.

4 Click the Apply button.

The theme changes are now permanent.

5 Click the Close button.

Feel free to change the color theme at any time. Often users select the theme that works best in their normal working environment. The lighter themes work best in well-lighted rooms, while the darker themes work best in indirect or controlled lighting environments used in some design offices. All exercises will work properly in any theme color.

Setting up the workspace

Dreamweaver CC (2018 release) includes two main workspaces to accommodate various computer configurations and individual workflows. For this book, the Standard workspace is recommended.

1 If the Standard workspace is not displayed by default, you can select it from the Window > Workspace menu.

2 If the default Standard workspace has been modified—where certain toolbars and panels are not visible (as they appear in the figures in the book)—you can restore the factory setting by choosing Reset ‘Standard’ from the Workspace drop-down menu.

These same options can be accessed from the Window > Workspace Layout menu.
Most of the figures in this book show the Standard workspace. When you finish the lessons in this book, experiment with each workspace to find the one that you prefer, or build your own configuration and save the layout under a custom name. For a more complete description of the Dreamweaver workspaces, see Lesson 1, “Customizing Your Workspace.”

Defining a Dreamweaver site

In the course of completing the following lessons, you will create webpages from scratch and use existing files and resources that are stored on your hard drive. The resulting webpages and assets make up what’s called your local site. When you are ready to upload your site to the Internet (see Lesson 11, “Publishing to the Web”), you publish your completed files to a web-host server, which then becomes your remote site. The folder structures and files of the local and remote sites are usually mirror images of one another.

The first step is to define your local site.

1. Launch Adobe Dreamweaver CC (2018 release) or later.
2. Open the Site menu.

   The Site menu provides options for creating and managing standard Dreamweaver sites.

3. Choose New Site.

   The Site Setup dialog appears.

   ◆ Warning: You must unzip the lesson files before you create your site definition.
To create a standard website in Dreamweaver, you need only name it and select the local site folder. The site name should relate to a specific project or client and will appear in the Files panel Site drop-down menu. This name is intended for your own purposes only; it will not be seen by the public, so there are no limitations to the name you can create. Use a name that clearly describes the purpose of the website. For the purposes of this book, use the name of the lesson you intend to complete, such as lesson01, lesson02, lesson03, and so on.

4 Type lesson01 or another name, as appropriate, in the Site Name field.

![Site Setup for lesson01](image)

- **Note:** The main folder that contains the site will be referred to throughout the book as the site root folder.

5 Next to the Local Site Folder field, click the Browse For Folder icon.

6 Navigate to the appropriate folder containing the lesson files you downloaded from Peachpit.com (as described earlier), and click Select/Choose.

- **Note:** Lesson files must be decompressed prior to defining the site.

![Site Setup for lesson01](image)

You could click Save at this time and begin working on your new website, but you'll add one more piece of handy information.

7 Click the arrow next to the Advanced Settings category to reveal the categories listed there.
Select Local Info.
Although it’s not required, a good policy for site management is to store different file types in separate folders. For example, many websites provide individual folders for images, PDFs, videos, and so on. Dreamweaver assists in this endeavor by including an option for a default images folder.

Later, as you insert images from other locations on your computer, Dreamweaver will use this setting to automatically move the images into the site structure.

8 Next to the Default Images Folder field, click the Browse For Folder icon. When the dialog opens, navigate to the appropriate images folder for that lesson or site and click Select/Choose.

The path to the images folder appears in the Default Images Folder field. The next step would be to enter your site domain name in the Web URL field.

9 Enter http://green-start.org for the lessons in this book, or enter your own website URL, in the Web URL field.

Note: The Web URL is not needed for most static HTML sites, but it’s required for working with sites using dynamic applications or to connect to databases and a testing server.

You’ve entered all the information required to begin your new site. In subsequent lessons, you’ll add more information to enable you to upload files to your remote and testing servers.
10 In the Site Setup dialog, click Save.
   The Site Setup dialog closes.

   ![Image of Site Setup dialog]

In the Files panel, the new site name appears in the site list drop-down menu. As you add more site definitions, you can switch between the sites by selecting the appropriate name from this menu.

Whenever a site is selected or modified, Dreamweaver will build, or rebuild, a cache of every file in the folder. The cache identifies relationships between the webpages and the assets within sites and will assist you whenever a file is moved, renamed, or deleted to update links or other referenced information.

11 Click OK to build the cache, if necessary.

Setting up a site is a crucial first step in beginning any project in Dreamweaver. Knowing where the site root folder is located helps Dreamweaver determine link pathways and enables many sitewide options, such as orphaned-file checking and Find and Replace.

Checking for updates

Adobe periodically provides software updates. To check for updates in the program, choose Help > Updates in Dreamweaver. An update notice may also appear in the Creative Cloud update desktop manager.
For book updates and bonus material, visit your Account page on Peachpit.com and select the Lesson & Update Files tab.

**Additional resources**

*Adobe Dreamweaver CC Classroom in a Book (2018 release)* is not meant to replace documentation that comes with the program or to be a comprehensive reference for every feature. Only the commands and options used in the lessons are explained in this book. For comprehensive information about program features and tutorials, refer to these resources:

**Adobe Dreamweaver Learn & Support: [https://helpx.adobe.com/dreamweaver/tutorials.html](https://helpx.adobe.com/dreamweaver/tutorials.html)** (accessible in Dreamweaver by choosing Help > Dreamweaver Tutorial) is where you can find and browse tutorials, help, and support on Adobe.com.

**Dreamweaver Help: [helpx.adobe.com/support/dreamweaver.html](https://helpx.adobe.com/support/dreamweaver.html)** is a reference for application features, commands, and tools (press F1 or choose Help > Dreamweaver Help).

**Adobe Forums: [forums.adobe.com](https://forums.adobe.com)** lets you tap into peer-to-peer discussions and questions and answers on Adobe products.

**Resources for educators: [adobe.com/education](https://adobe.com/education) and [edex.adobe.com](https://edex.adobe.com)** offer a treasure trove of information for instructors who teach classes on Adobe software. You'll find solutions for education at all levels, including free curricula that use an integrated approach to teaching Adobe software and that can be used to prepare for the Adobe Certified Associate exams.

Also check out these useful links:

**Adobe Add-ons: [exchange.adobe.com/addons](https://exchange.adobe.com/addons)** is a central resource for finding tools, services, extensions, code samples, and more to supplement and extend your Adobe products.

**Adobe Dreamweaver CC product home page: [adobe.com/products/dreamweaver.html](https://adobe.com/products/dreamweaver.html)** has more information about the product.

**Adobe Authorized Training Centers**

Adobe Authorized Training Centers offer instructor-led courses and training on Adobe products. Go to [training.adobe.com/training/partner-finder.html](https://training.adobe.com/training/partner-finder.html) to find a directory of AATCs.
Lesson overview

In this lesson, you’ll familiarize yourself with the Dreamweaver CC (2018 release) program interface and learn how to do the following:

- Use the program Welcome screen
- Switch document views
- Work with panels
- Select a workspace layout
- Adjust toolbars
- Personalize preferences
- Create custom keyboard shortcuts
- Use the Property inspector
- Use the Extract workflow

This lesson will take about 1 hour and 15 minutes to complete. If you have not already done so, please log in to your account on peachpit.com to download the project files for this lesson as described in the “Getting Started” section at the beginning of this book and follow the instructions under “Accessing the Lesson Files and Web Edition.” Define a site based on the lesson01 folder.
You'd probably need a dozen programs to perform all the tasks that Dreamweaver can do—and none of them would be as fun to use.
Touring the workspace

Dreamweaver is the industry-leading Hypertext Markup Language (HTML) editor, with good reasons for its popularity. The program offers an incredible array of design and code-editing tools. Dreamweaver offers something for everyone. Coders love the range of enhancements built into the Code view environment, and developers enjoy the program’s support for a variety of programming languages and code hinting. Designers marvel at seeing their text and graphics appear in an accurate What You See Is What You Get (WYSIWYG) depiction as they work, saving hours of time previewing pages in browsers. Novices certainly appreciate the program’s simple-to-use and power-packed interface. No matter what type of user you are, if you use Dreamweaver, you don’t have to compromise.

The Dreamweaver interface features a vast array of user-configurable panels and toolbars. Take a moment to familiarize yourself with the names of these components.
You’d think a program with this much to offer would be dense, slow, and unwieldy, but you’d be wrong. Dreamweaver provides much of its power via dockable panels and toolbars that you can display or hide and arrange in innumerable combinations to create your ideal workspace. In most cases, if you don’t see a desired tool or panel, you’ll find it in the Window menu.

This lesson introduces you to the Dreamweaver interface and gets you in touch with some of the power hiding under the hood. We don’t spend a lot of time in the upcoming lessons teaching you how to perform basic activities within the interface; that’s the intention of this lesson. So take some time to go through the following descriptions and exercises to familiarize yourself with the basic operations of the program interface. Feel free to refer to this lesson anytime you need a refresher on the program’s many dialogs and panels and how they function.

**Using the Start Screen**

Once the program is installed and the initial setup is completed, you’ll see the new Dreamweaver Start Screen. This screen provides quick access to recent pages, easy creation of a variety of page types, and a direct connection to several key Help resources and tutorials. The Start Screen appears when you first start the program or when no other documents are open. The Start Screen has gotten a facelift in this version of Dreamweaver and deserves a quick review to check out what it offers. For example, it now has four main options: Recent, CC Files, Quick Start, and Starter Templates. Click the name of each option to access these features.
Recent

When you select the Recent option, Dreamweaver will provide a list of the files you last worked on. The list is dynamic. To reopen a file, simply click its name.

CC Files

The CC Files option shows a list of any files that you have copied to your Creative Cloud Files folder and that can be edited by or used in Dreamweaver. This will include HTML, CSS, JavaScript, and text files, among others. Files incompatible to Dreamweaver will simply be hidden from view.
Quick Start

If the Quick Start tab looks familiar, it’s because it has been around in one form or another for many versions of Dreamweaver. As it has always done, it provides instant access to a list of basic web-compatible file types, such as HTML, CSS, JS, PHP, and so on. Just click the file type to start a new document.

Starter Templates

The Starter Templates option enables you to access predefined starter templates that provide responsive styling to support smartphones and mobile devices, as well as the popular Bootstrap framework.
Create New and Open

The Create New and Open buttons enable you to access the New Document and Open dialogs, respectively. Previous users of Dreamweaver may be more comfortable using these options, which open familiar interfaces for creating new documents or opening existing ones.

Learn

When you select the Learn tab in the Start Screen, you will see a list of help topics that will provide guided tours and video overviews of the program overall, as well as a selection of new tools and workflows that you may review. This option is updated dynamically as new features are added to Dreamweaver or improved.

If you do not want to see the Start Screen anymore, you can disable it by accessing the option in General settings in Dreamweaver Preferences and deselecting the checkbox.
Exploring New Feature guides

In Dreamweaver CC, the New Feature guides pop up from time to time as you access various tools, features, or interface options. The pop-ups call your attention to new features or workflows that have been added to the program and provide handy tips to help you get the most out of them.

When a tip appears, it may provide more extensive information or a tutorial you can access by following the prompts in the pop-up window. When you are finished, you can close the pop-up by clicking the Close icon in the upper-right corner of each tip. When you close the tip, it will not appear again. You can display the tips again by selecting Help > Reset Contextual Feature Tips.

Setting interface preferences

Dreamweaver provides users with extensive controls over the basic program interface. You can set up, arrange, and customize the various panels and menus to your own liking. One of the first places you should visit before you begin the lessons in this book is the Dreamweaver Preferences dialog.

As with other Adobe applications, the Preferences dialog provides specific settings and specifications that dictate how the program looks and functions. Preference settings are normally persistent, meaning that they remain in effect even after the program is shut down and relaunched. There are far too many options in this dialog to cover in one lesson, but let’s make a couple of changes to give you a taste of what you can do. Some features of the program are not visible until you create or open a file for editing.
1 Define a new site based on the lesson01 folder as described in the “Getting Started” section at the beginning of the book.

2 Select Window > Files or press F8 to display the Files panel.

3 In the File panel, select lesson01 from the drop-down menu and reveal the site file list in the panel, if necessary.

4 Right-click the file index.html from the lesson01 folder and choose Open from the context menu. You can also double-click a file in the list to open it.

The file opens in the document window. If the program has not been used previously, the file should open in Live view. To get the full appreciation of the upcoming changes, let’s also display the code-editing interface at the same time.

5 Select Split view at the top of the document window, if necessary.
Dreamweaver is sporting a new dark color scheme in Code view. Some users love it; some hate it. You can change it completely or merely tweak it in Preferences. If you have already changed your interface theme skip to the next exercise.

6 In Windows, select Edit > Preferences.
   In macOS, select Dreamweaver CC > Preferences.

The Preferences dialog appears.

7 Select the Interface category.

As you see from the dialog, Dreamweaver gives you control over the overall color theme as well as the code-editing window. You may change one or both.

Many designers work in controlled lighting environments and prefer the dark interface themes that are now the default in most Adobe applications. For the purposes of this book, all screen shots from this point forward are taken in the lightest theme. This saves ink during printing, for less impact on the environment. You may continue to use the dark theme if you prefer, or switch now so your own screen will match the illustrations in the book.

8 In the App Theme window, select the lightest theme.

The theme of the entire interface changes to light gray. You will notice that the Code Theme setting changes to Light at the same time. If you prefer, you can switch the code theme back to Dark or choose another. The screen shots for code editing use the Solarized Light theme.

9 Select Solarized Light in the Code Theme window.

At the moment, the changes are not permanent. If you click the Close button in the dialog, the theme would revert to dark.
10 Click Apply in the lower-right corner of the dialog.
    The changes have now been applied.
11 Click Close.

Saved preferences persist from session to session and through each workspace.

Switching and splitting views

Dreamweaver offers dedicated environments for coders and designers.

**Code view**

Code view focuses the Dreamweaver workspace exclusively on the HTML code and a variety of code-editing productivity tools. To access Code view, click the Code view button in the Document toolbar.

![Code view](index.html)

**Design view**

Design view shares the document window with Live view and focuses the Dreamweaver workspace on its classic WYSIWYG editor. In the past, Design view provided a reasonable facsimile of the webpage as it would appear in a browser, but with the advancements in CSS and HTML, it is no longer as WYSIWYG as it once was. Although it can be difficult to use in some situations, you’ll find that it does offer an interface that speeds up the creation and editing of your content. And at the moment, it’s also the only way to access certain Dreamweaver tools or workflows, as you will see in the upcoming lessons.

To activate Design view, choose it from the Design/Live view drop-down menu in the Document toolbar. Most HTML elements and basic cascading style sheets (CSS) formatting will be rendered properly within Design view, with the major exceptions being CSS3 properties; dynamic content; interactivity, such as link behaviors, video, audio, and jQuery widgets; and some form elements. In previous versions of Dreamweaver, you spent most of your time in Design view. That will no longer be the case.
Live view

Live view is the default workspace of Dreamweaver CC. It speeds up the process of developing modern websites by allowing you to visually create and edit webpages and web content in a browser-like environment, and it supports and previews most dynamic effects and interactivity.

To use Live view, choose it from the Design/Live view drop-down menu in the Document toolbar. When Live view is activated, most HTML content will function as it would in an actual browser, allowing you to preview and test most dynamic applications and behaviors.

In previous versions of Dreamweaver, the content in Live view was not editable. That has changed. You can edit text, add and delete elements, create classes and IDs, and even style elements, all in the same window. It’s like working on a live webpage right inside Dreamweaver.

Live view is integrally connected to the CSS Designer, allowing you to create and edit advanced CSS styling and build fully responsive webpages without having to switch views or waste time previewing the page in a browser.
Split view

Split view provides a composite workspace that gives you access to both the design and the code simultaneously. Changes made in either window update in the other in real time.

To access Split view, click the Split view button in the Document toolbar. Dreamweaver splits the workspace horizontally by default. When using Split view, you can display Code view with either Live view or Design view.

Note: Split view can pair Code view with either Design view or Live view.

Split view (horizontal)

You can split the screen vertically by selecting the Split Vertically option on the View menu. When the window is split, Dreamweaver also gives you options for how the two windows display. You can put the code window on the top, bottom, left, or right. You can find all these options in the View menu. Most screen shots in the book that show Split view show Design or Live view at top or right.

Split view (vertical)
Live Source Code

Live Source Code is an HTML code-troubleshooting display mode available whenever Live view is activated. To access Live Source Code, activate Live view and then click the Live Source Code icon in the toolbox at the left side of the document window. While active, Live Source Code displays the HTML code as it would appear in a live browser on the Internet and gives you a peek at how the code changes when the visitor interacts with various parts of the page.

You can see this interaction firsthand by clicking the Green Events menu item to open the drop-down menu. In Code view, you will see that the menu item starts with the class dropdown and that the class open is then added to the code interactively. The open class is then removed when you close the menu. Without the Live Source Code, you would not be able to see this interaction and behavior.

Be aware that while Live Source Code is active, you will not be able to edit the HTML code, although you can still modify external files, such as linked style sheets. To disable Live Source Code, click the Live Source Code icon again to toggle the mode off.

Inspect mode

Inspect mode is a CSS troubleshooting display mode that is available whenever Live view is activated. It is integrated with the CSS Designer and allows you to rapidly identify CSS styles applied to content within the page by moving the mouse cursor over elements in the webpage. Clicking an element freezes the focus on that item.
The Live view window highlights the targeted element and displays the pertinent CSS rules applied or inherited by that element. You can access Inspect mode at any time by clicking the Live view icon whenever an HTML file is open and then clicking the Inspect icon in the Common toolbar.

Selecting a workspace layout

A quick way to customize the program environment is to use one of the prebuilt workspaces in Dreamweaver. Experts have optimized these workspaces to put the tools you need at your fingertips.

Dreamweaver CC (2018 release) includes two prebuilt workspaces: Standard and Developer. To access these workspaces, choose them from the Workspace menu, located at the upper-right side of the program window.

Standard workspace

Developer workspace

The Developer workspace provides a code-centric layout of tools and panels ideal for coders and programmers. The workspace is focused on Code view.

Working with panels

Although you can access most commands from the menus, Dreamweaver scatters much of its power in user-selectable panels and toolbars. You can display, hide, arrange, and dock panels at will around the screen. You can even move them to a second or third video display if you desire.

The Window menu lists all the panels available in the program. If you do not see a desired panel on the screen, choose it from the Window menu. A checkmark appears next to its name in the menu to indicate that the panel is open. Occasionally, one panel may lie behind another on the screen and be difficult to locate. In such situations, simply choose the desired panel from the Window menu and the panel will rise to the top of the stack.
Minimizing panels

To create room for other panels or to access obscured areas of the workspace, you can minimize or expand individual panels in place. To minimize a standalone panel, double-click the tab containing the panel name. To expand the panel, click the tab once.

To recover more screen real estate, you can minimize panel groups or stacks down to icons by double-clicking the title bar. You can also minimize the panels to icons by clicking the double-arrow icon in the panel title bar. When panels are minimized to icons, you access an individual panel by clicking its icon. The selected panel will appear on the left or right of the icon, wherever room permits.
Closing panels and panel groups

Each panel or panel group may be closed at any time. You can close a panel or panel group in several ways; the method often depends on whether the panel is floating, docked, or grouped with another panel.

To close an individual panel that is docked, right-click in the panel tab and choose Close from the context menu. To close an entire group of panels, right-click any tab in the group and choose Close Tab Group.

To close a floating panel or panel group, click the Close icon that appears in the left corner of the title bar of the panel or panel group. To reopen a panel, choose the panel name from the Window menu. Reopened panels will sometimes appear floating in the interface. You may use them this way or attach, or dock, them to the sides, top, or bottom of the interface. You will learn how to dock panels later.

Dragging

You can reorder a panel tab by dragging it to the desired position within the group.

Dragging a tab to change its position
**Floating**

A panel that is grouped with other panels can be floated separately. To float a panel, drag it from the group by its tab.

---

**Grouping, stacking, and docking**

You can create custom groups by dragging one panel into another. When you’ve moved the panel to the correct position, Dreamweaver highlights the area, called the *drop zone*, in blue. Release the mouse button to create the new group.
In some cases, you may want to keep both panels visible simultaneously. To stack panels, drag the desired tab to the top or bottom of another panel. When you see the blue drop zone appear, release the mouse button.

Creating panel stacks

Floating panels can be docked to the right, left, or bottom of the Dreamweaver workspace. To dock a panel, group, or stack, drag its title bar to the edge of the window on which you wish to dock. When you see the blue drop zone appear, release the mouse button.

Personalizing Dreamweaver

As you continue to work with Dreamweaver, you'll devise your own optimal workspace of panels and toolbars for each activity. You can store these configurations in a custom workspace of your own naming.
Saving a custom workspace

To save a custom workspace, create your desired configuration of panels, choose New Workspace from the Workspace menu, and then give it a custom name.

Working with Extract

Extract is a newer workflow that allows you to create CSS styles and image assets from a Photoshop-based mockup. You can create your webpage design using text and linked or embedded image layers and post the file to Creative Cloud, where Dreamweaver can access the styles, colors, and images to help you build your basic site design.
Access the various layers from the Extract panel inside Dreamweaver, copy styles and text, and even download image assets.

Try these features yourself by uploading **GreenStart_mockup.psd**, in the lesson01 resources folder, to your Creative Cloud account online folder. Go to helpx.adobe.com/creative-cloud/help/sync-files.html to learn how to upload files to your Creative Cloud account. In Lesson 5, “Creating a Page Layout,” you will learn how to extract CSS styling and image assets from a Photoshop mockup to build a layout for your site template.

**Working with toolbars**

Some program features are so handy you may want them to be available all the time in toolbar form. Two of the toolbars—Document and Standard—appear horizontally at the top of the document window. The Common toolbar, however, appears vertically on the left side of the screen. You can display the desired toolbar by choosing it from the Window menu.

**Document toolbar**

The document toolbar appears at the very top of the program interface and provides onscreen commands for switching views from Live, Design, Code, and Split views. You can enable this toolbar by selecting Window > Toolbars > Document when a document is open.

**Standard toolbar**

The Standard toolbar appears between the Related Files interface and the document window and provides handy commands for various document and editing tasks, such as creating, saving, or opening documents; copying, cutting, and pasting content; and so on. You can enable this toolbar by selecting Window > Toolbars > Standard when a document is open.
Common toolbar

The Common toolbar appears on the left side of the program window and provides a variety of commands for working with code and HTML elements. The toolbar displays six tools by default in Live and Design view. But insert the cursor in the code window and you may see several more.

The Common toolbar was named the Coding toolbar in previous version of Dreamweaver, and in CC 2018 it is now user customizable. You can add and remove tools by selecting the Customize Toolbar icon. Be aware that some tools will be displayed and active only when using the Code view window.

Creating custom keyboard shortcuts

Another powerful feature of Dreamweaver is the ability to create your own keyboard shortcuts as well as edit existing ones. Keyboard shortcuts are loaded and preserved independently of workspaces.

Is there a command you can't live without that doesn't have a keyboard shortcut or uses one that's inconvenient? Create one of your own.

1. Choose Edit > Keyboard Shortcuts (Windows) or Dreamweaver CC > Keyboard Shortcuts (macOS).
   
   You cannot modify the default shortcuts, so you have to create a list of your own.

2. Click the Duplicate Set icon to create a new set of shortcuts.
3 Enter a name in the Name Of Duplicate Set field. Click OK.

4 Choose Menu Commands from the Commands pop-up menu.

5 In the Commands window, choose File > Save All.

Note that the Save All command does not have an existing shortcut, although you'll use this command frequently in Dreamweaver.

6 Insert the cursor in the Press Key field.
   Press Ctrl+Alt+S/Cmd+Opt+S.

   Note the error message indicating that the keyboard combination you chose is already assigned to a command. Although we could reassign the combination, let's choose a different one.

7 Press Ctrl+Alt+Shift+S/Control+Cmd+S.

   This combination is not currently being used, so let's assign it to the Save All command.
8  Click the Change button.

The new shortcut is now assigned to the Save All command.

9  Click OK to save the change.

You have created your own keyboard shortcut—one you can use in upcoming lessons. Whenever an instruction in one of the lessons says “save all files” use this keyboard shortcut.

Using the Property inspector

One tool vital to your workflow is the Property inspector. In the predefined Dreamweaver workspaces, the Property inspector is no longer a default component. If it is not visible in your program interface, you can display it by selecting Window > Properties and then dock it to the bottom of the document window, as described earlier. The Property inspector is context-driven and adapts to the type of element you select.

Using the HTML tab

Insert the cursor into any text content on your page and the Property inspector provides a means to quickly assign some basic HTML codes and formatting. When the HTML button is selected, you can apply heading or paragraph tags as well as bold, italics, bullets, numbers, and indenting, among other formatting and attributes. The Document Title metadata field is also available in the bottom half of the Property inspector. Enter your desired document title in this field, and Dreamweaver adds it automatically to the document <head> section. If you don't see the full Property inspector, click the triangle icon in the lower-right corner of the panel to expand its display.
Using the CSS tab

Click the CSS button to quickly access commands to assign or edit CSS formatting.

CSS Property inspector

Accessing image properties

Select an image in a webpage to access the image-based attributes and formatting controls of the Property inspector.

Image Property inspector

Accessing table properties

To access table properties, insert your cursor in a table and then click the table tag selector at the bottom of the document window.

Table Property inspector

Using the Related Files interface

Webpages are often built with multiple external files that provide styling and programming assistance. Dreamweaver enables you to see all the files linked to, or referenced by, the current document by displaying the filenames in the Related Files interface at the top of the document window. This interface displays the name of any external file and will actually display the contents of each file—if the contents are available—when you simply select the filename in the display.

The Related Files interface lists all external files linked to a document.
To view the contents of the referenced file, click the name. If you are in Live or Design view, Dreamweaver splits the document window and shows the contents of the selected file in the Code view window. If the file is stored locally, you'll even be able to edit the contents of the file when it's selected.

Use the Related Files interface to edit locally stored files.

To view the HTML code contained within the main document, click the Source Code option in the interface.

Choose the Source Code option to see the contents of the main document.
Using tag selectors

One of the most important features of Dreamweaver is the tag selector interface that appears at the bottom of the document window. This interface displays the tags and element structure in any HTML file pertinent to the insertion point of, or that is selected by, the cursor. The display of tags is hierarchical, starting at the document root at the left of the display and listing each tag or element in order based on the structure of the page and the selected element.

The display in the tag selector interface mimics the structure of the HTML code based on your selection.

The tag selectors also enable you to select any of the elements displayed by simply clicking a tag. When a tag is selected, all the content and child elements contained within that tag are also selected.

Use the tag selectors to select elements.

The tag selector interface is closely integrated with the CSS Designer panel. You may use the tag selectors to help you style content or to cut, copy, paste, and delete elements.

The tag selector is closely integrated with the styling and editing of elements.
Using the CSS Designer

The CSS Designer is a powerful tool for visually creating, editing, and troubleshooting CSS styling. CSS Designer has gained new productivity enhancements for copying and pasting CSS styles from one rule to another. You can also decrease or increase the specificity of new selector names by pressing the up or down arrow keys, respectively.

Copy and paste styles from one rule to another (left). Make selectors more or less specific by using the arrow keys (right).

The CSS Designer panel consists of four windows: Sources, @Media, Selectors, and Properties.

Sources

The Sources window allows you to create, attach, define, and remove internal embedded and external linked style sheets.
@Media

The @Media window is used to define media queries to support various types of media and devices.

Selectors

The Selectors window is used to create and edit the CSS rules that format the components and content of your page. Once a selector, or rule, is created, you define the formatting you wish to apply in the Properties window.

In addition to allowing you to create and edit CSS styling, the CSS Designer can also be used to identify styles already defined and applied, and to troubleshoot issues or conflicts with these styles.
Properties

The Properties window features two basic modes. By default, the Properties window displays all available CSS properties in a list, organized in five categories: Layout, Text, Borders, Background, and More. You can scroll down the list and apply styling as desired or click the icon to jump to that category of the Properties panel.

Note: Deselect the Show Set option to see all the CSS Designer categories.

The second mode can be accessed by selecting Show Set at the upper-right edge of the window. In this mode, the Properties panel will then filter the list down to only the properties actually applied to the rule chosen in the Selectors window. In either mode, you can add, edit, or remove style sheets, media queries, rules, and properties.
The Properties panel also features a COMPUTED option that displays the aggregated list of styles applied to the selected element when the Current button in CSS Designer is selected. The COMPUTED option will then appear anytime you select an element or component on the page. When you're creating any type of styling, the code created by Dreamweaver complies with industry standards and best practices.

All and Current modes

The CSS Designer has two buttons at the top of the panel, All and Current, that enable specific functions and workflows within the panel.

When the All button is selected, the panel allows you to create and edit CSS style sheets, media queries, rules, and properties. When the Current button is selected, the CSS troubleshooting functions are enabled, allowing you to inspect individual elements in a webpage and assess existing styling properties applied to a selected element. In this mode, however, you will notice that some of the normal features in the CSS Designer are disabled. For example, when in Current mode you are able to edit existing properties and add new style sheets, media queries, and rules that apply to the selected element, but you cannot delete existing style sheets, media queries, or rules. This interaction works the same way in all document views modes.
When the Current button is selected, the CSS Designer displays all styling associated with a selected element.

In addition to using the CSS Designer, you may also create and edit CSS styling manually within Code view while taking advantage of many productivity enhancements, such as code hinting and auto-completion.

Using the Visual Media Query (VMQ) interface

The Visual Media Query (VMQ) interface is another newer feature of Dreamweaver. Appearing above the document window, the VMQ interface allows you to visually inspect and interact with existing media queries, as well as create new ones on the fly using a simple point-and-click interface.

Open any webpage that is formatted by a style sheet with one or more media queries. If necessary, enable the VMQ interface by toggling the VMQ icon. The VMQ interface will appear above the document window and display color-coded bars that specify the type of media query that has been defined. Media queries using only a max-width specification will be displayed in green. Media queries using only a min-width specification will be displayed in purple. Ones that use both will be displayed in blue.
Using the DOM Viewer

The DOM Viewer allows you to view the Document Object Model (DOM) to quickly examine the structure of your webpage as well as interact with it to select, edit, and move existing elements and insert new ones. You’ll find that it makes working in complex HTML structures simple.

Using Element dialogs, displays, and inspectors

As Dreamweaver moves to make Live view the default workspace, it has driven the development of new methods for editing and managing HTML elements. You will find a handful of new dialogs, displays, and inspectors that provide instant access to important element properties and specifications. All of them, except the Text Display, allow you to add class or ID attributes to the selected element and even insert references to those attributes into your CSS style sheets and media queries.

Position Assist dialog

The Position Assist dialog appears whenever new elements are being inserted in Live view, using either the Insert menu or Insert panel. Typically, the Position Assist dialog will offer the options Before, After, Wrap, and Nest. Depending on what type of element is selected and what item is targeted by the cursor, one or more of the options may be grayed out.

The Position Assist dialog allows you to control how elements and components are inserted in Live view.
Element Display

The Element Display appears whenever you select an element in Live view. When an element is selected in Live view, you can change the selection focus by pressing the up and down arrow keys; the Element Display will then highlight each element in the page, in turn, based on its position in the HTML structure.

The Element Display features a Quick Property Inspector icon where you can instantly access properties such as formats, links, and alignment. The Element Display also allows you to add a class or ID to the selected element or to edit a class or ID.

The Element Display enables you to quickly apply classes, IDs, and links, as well as perform basic formatting.

Image Display

The Image Display provides a Quick Property inspector from which you can access the image source, alt text, and width and height attributes; it also contains a field from which you can add a hyperlink.

The Image Display gives you quick access to the image source and allows you to add hyperlinks.
Text Display

The Text Display appears whenever you select a portion of text in Live view. The Text Display allows you to apply bold `<strong>`, italic `<em>`, and hyperlink `<a>` markup to the selected text. Double-click the text to open the orange editing box. When you select some text, the Text Display will appear. When you are finished editing the text, click just outside the orange box to complete the changes. Press Esc to cancel the changes and return the text to its previous state.

The Text Display lets you apply bold, italics, and hyperlink markup to selected text.

Setting up version control in Dreamweaver

New to Dreamweaver CC (2018 release) is support for Git, a popular open source version control system for managing the source code of your websites. Such systems are very valuable for preventing conflicts and loss of work when you have a number of people working together on a project.

You set up a Git repository within your site definition dialog. After that, you can connect your site to your remote repository and push and pull changes as needed.
Go to https://helpx.adobe.com/dreamweaver/using/git-support.html for full instructions on how to set up Git version control for your own project.

Exploring, experimenting, and learning

The Dreamweaver interface has been carefully crafted over many years to make the job of webpage design and development fast and easy. It’s a design in progress. It’s always changing and evolving. If you think you already know the program, you’re wrong. Install the latest version and check it out. Feel free to explore and experiment with various menus, panels, and options to create the ideal workspace and keyboard shortcuts to produce the most productive environment for your own purposes. You’ll find the program endlessly adaptable, with power to spare for any task. Enjoy.
Review questions

1. Where can you access the command to display or hide any panel?
2. Where can you find the Code, Split, Design, and Live view buttons?
3. What can be saved in a workspace?
4. Do workspaces also load keyboard shortcuts?
5. What happens in the Property inspector when you insert the cursor into various elements on the webpage?
6. What features in the CSS Designer make it easy to build new rules from existing ones?
7. What can you do with the DOM Viewer?
8. Does the Element Display appear in Design or Code view?
9. What is Git?

Review answers

1. All panels are listed in the Window menu.
3. Workspaces can save the configuration of the document window, the open panels, and the panels’ size and position on the screen.
4. No. Keyboard shortcuts are loaded and preserved independently of a workspace.
5. The Property inspector adapts to the selected element, displaying pertinent information and formatting commands.
6. The CSS Designer allows you to copy and paste styles from one rule to another.
7. The DOM Viewer allows you to visually examine the DOM and select and insert new elements and edit existing ones.
8. No. The Element Display is visible only in Live view.
9. Git is an open source version control system that enables you to manage your website source code.
INDEX

A

<a> (anchor) element, 59
   hyperlinks enabled by, 274
   pseudo-classes, 303
a:active pseudo-class, 303
a:focus pseudo-class, 303
a:hover pseudo-class, 303
a:link pseudo-class, 303
a:visited pseudo-class, 303
absolute hyperlinks, 275, 286–288
Accordion widgets. See jQuery Accordion widgets
active state, 303
Add Behavior icon, 310, 317, 319, 321
Add Class/ID icon, 207, 251, 295, 297
Add CSS Source icon, 175
Add New Server icon, 347, 351
Add Selector icon, 140, 154, 171, 330
Adobe Add-ons, 15, 310, 311
Adobe Authorized Training Centers, 15
Adobe Creative Cloud, 5
Adobe Dreamweaver. See Dreamweaver
Adobe Edge Web Fonts, 218–219
Adobe forums, 15
Adobe Muse, 57
Adobe Omniture, 99
Adobe Photoshop. See Photoshop
All mode, CSS Designer, 47, 86
alpha transparency, 245, 247
alt text, 250
anchor element, 59, 274, 303
animation, bonus chapter on, 8
App Theme window, 25
Applications folder, 265
Apply Comment icon, 379
<article> element, 62, 77, 193, 194
<aside> element, 62, 154, 199
Assets panel, 191, 201, 249, 266
Attach Existing CSS File dialog, 175
attributes
   class, 90
   id, 91, 294, 298–299
   target, 289
audience for website, 98
<audio> tag, 62
automatic uploads, 350
automatically writing code, 373–377

B

background effects
   adding in CSS code, 134–138
   applying to jQuery Accordion, 331–332, 339–341
backgrounds
   color, 72, 332, 334
   gradient, 124–128
Beginning CSS Preprocessors: With SASS, Compass.js, and Less.js (Prabhu), 393
behaviors, 310–311, 313–322
   accessing, 310
   adding to hyperlinks, 320–322
   applying, 316–319
   functions of, 310–311
   removing applied, 320
   review questions/answers on, 342–343
   Swap Image behavior, 316–318
   Swap Image Restore behavior, 318–319
Behaviors panel, 310, 316
Berners-Lee, Tim, 56
bit depth, 244
_blank target option, 288, 289
block elements, 58
<br>element, 59, 154–157, 200
<body> element, 59, 371
body text defaults, 72
bolded text in book, 2
bonus material, 8
jQuery Accordion, 329
pseudo-classes and, 303
Classroom in a Book series, 1
clipboard, 193
cloaking process, 354–356
closing panels, 33
code, 368–403
automatically writing, 373–377
background effects added in, 134–138
collapsing/expanding, 398
comments added to, 379–380
Common toolbar for, 378
compiling CSS, 386–389
creating HTML, 370–377
manually writing, 370–373
multicursor support for, 377–378
previewing assets for, 400–401
review questions/answers on, 402–403
selection options for, 395–397
Split Code view option, 399
See also CSS; HTML
Code Hinting menu, 154
Code Navigator, 81–84
Code Theme setting, 25
Code view, 26
CSS styling in, 48, 88
Find and Replace feature, 235–236
previewing assets in, 400–401
Refresh button, 327
selecting code in, 395–397
Split Code view option, 399
writing code in, 370–377
code-hinting window, 372
Coding toolbar, 38
Collapse icon, 398
collapsing/expanding code, 398
color
background, 72, 332, 334
table header, 221–222
color picker, 88
color space, 244–245
color themes, 9–10, 25

C

cache, 14, 351
calculating specificity, 80
<canvas> tag, 62
<caption> element, 229, 230
captions
image, 182–183
table, 229–231
cascade theory, 76, 78
cascading style sheets. See CSS
CC Files option, 20
cells
classes applied to, 224–226
column width for, 225
defaults for text in, 72
moving between table, 213
styling table, 221–223
cgi-bin folders, 348
color picker, 88
columns, table, 215, 225–226
comma-separated values (CSV) file, 226
comments, 59, 379–380
Commit icon, 258, 264, 268
Common toolbar, 38, 336, 378
Compare option, 365
compiling CSS code, 386–389
compression, image file, 246–247
COMPUTED option, 47, 87–88
Connect to Remote Server icon, 359
Connect Using pop-up menu, 348
content placeholders, 376
converting image files, 256–257
Copy All Styles option, 227
Copy Dependent Files dialog, 326
Copy Text option, 142
copying/pasting
code to find/replace, 235–236
consistent view required for, 314
images from Photoshop, 262–265
styles, 227–228, 331
tables, 215–216
text, 167–168, 193
copyright symbol, 158–159
courses, Adobe, 15
Create New button, 22
Creative Cloud, 5
Crop tool, 270
cropping images, 268–269
CSS (cascading style sheets), 66–95
background effects, 134–138
bonus lesson on, 68, 70
box model, 74–75
cascade theory, 76, 78
class attributes, 90
code compilation, 386–389
Code Navigator tool, 81–84
CSS Designer tool, 44–48, 85–88
current version, 91–93
descendant theory, 79
description of, 68
HTML comparison, 68–70
id attributes, 91
inheritance theory, 78
linked files with, 172–176
multiple element formatting, 89
new features and effects, 91–92
positioning images using, 250–252
preprocessors, 380–393
Property inspector, 41
pseudo-classes, 303
resources on, 93, 393
review questions/answers on, 94–95
rules and rule syntax, 75–76, 77, 339
selector nesting, 389–391
shorthand techniques, 89–90
specificity theory, 79–80
style sheet imports, 391–393
styling tables with, 216–221
troubleshooting, 121–123
See also code
CSS3, 91–93
features and effects, 91–92
overview and support, 92–93
(McFarland), 93
CSS Designer, 44–48, 85–88
All and Current modes, 47–48, 86
@Media window, 45
Properties window, 46–47, 87
Selectors window, 45, 86, 87
Sources window, 44
CSS preprocessors, 380–393
code compilation, 386–389
enabling, 380–383
resources on, 382, 393
selector nesting, 389–391
source file creation, 383–386
style sheet imports, 391–393
CSS Secrets: Better Solutions to Everyday Web Design Problems (Verou), 93
CSS Source dialog, 251
CSS Source icon, 175
CSS Source pop-up window, 208
Current mode, CSS Designer, 47–48, 86, 343
custom classes, 207–208, 251
Custom Font Stacks, 219
Customize Toolbar dialog, 38, 336, 378
Customize Toolbar icon, 29, 38, 336, 378
D

declarations, 75
default images folder, 13
default target option, 289
degrading gracefully, 218
Delete icon, 365
deleting. See removing
dependent files, 359, 360
deprecated tags, 69
descendant theory, 79
description, page, 160–162
Description dialog, 160–161
Design view, 26–27, 150, 213, 259
designing webpages. See web design
destination links
adding to the same page, 306
creating in Element Display, 297–298
id attributes for, 298–299
Developer workspace, 31, 370–371
disabling
Live Source Code, 29
Start Screen, 22
displays
Element Display, 50, 208, 288, 291–292, 297–298
Image Display, 50
Text Display, 51, 287, 293, 298
dithering process, 244
<div> element, 59, 109, 325
docking panels, 35
Document Object Model (DOM), 49
Document toolbar, 37
DOM Viewer, 49
dpi (dots per inch), 243
dragging panel tabs, 33
dragging-and-dropping images, 266
Dreamweaver
color themes, 9–10
graphic tools, 270
installing, 4–5
introduction screens, 9
prerequisites, 2
resources, 15
site setup, 11–14
updating, 5–6, 14

version control, 51–52
workspaces, 10–11
drop zone, 34
Duplicate Set icon, 38
.dwt file extension, 151
dynamic templates, 151

E

Edge Web Fonts, 218–219
Edit HTML Attributes icon, 250, 291, 296
Edit Image Settings tool, 270
Edit image tool, 270
editable regions
formatting content in, 181–183
inserting into templates, 151–158
editing
hyperlinks, 279
images, 270
tables, 223
educator resources, 15
effects
background, 134–138
rollover, 310
Element Display, 50, 208, 288, 291–292, 297–298
elements, 57, 58–61
HTML character entities as, 60–61
HTML tags as, 57, 58–60
locking on screen, 299–301
text conventions for, 3
<em> tag, 59, 287
em dash character, 167
em measurements, 301
Email Link dialog, 289–290
e-mail links, 277, 289–293
creating, 289–291
image-based, 291–292
text-based, 292–293
warning about, 293
embedded formatting, 75
Emmet toolkit, 373–377
encryption options, 346
entities, HTML, 158–159
error checking, 393–394
Expand icon, 398
expanding code, 398
explicit encryption, 346
external hyperlinks, 274, 286–288
Extract Asset icon, 130, 133
Extract panel
  accessing, 113–115
  gradient background creation, 124–128
  image asset extraction, 128–134
  mockup text extraction, 119–121
  styling elements using, 115–119
  text styling extraction, 123–124
Extract workflow, 36–37
extracting
  image assets from mockups, 128–134
  styling of text from mockups, 123–124
  text from mockups, 119–121
eye icon (Photoshop), 261

F
<figcaption> tag, 62, 171, 182–183
<figure> tag, 62, 171, 181
File Activity icon, 361
file formats
  for raster images, 246–247
  for vector graphics, 242
File Transfer Protocol. See FTP sites
files
  cloaking, 354
  opening, 188
  uploading, 350
Files panel, 281, 347, 355, 386
Find and Replace feature, 233–238
Firefox browser, 99
flattening images, 262
floating panels, 34
focus state, 303
folders
  cloaking, 354
  resource, 13
  site root, 12
fonts
  HTML defaults for, 72
  indicating code, 2
  managing, 218–219
  predefined stacks of, 218
  typefaces vs., 217
Typekit, 104
  web or web-safe, 218–219
<footer> element, 62, 158
<form> tag, 59
Format menu, 197
forums, Adobe, 15
freezing navigation menus, 299–301
FTP (File Transfer Protocol), 346
FTP over SSL/TLS connections, 346
FTP Performance Optimization, 349, 350
FTP sites
  connection options, 349
  steps for setting up, 347–351
  troubleshooting connections to, 350

G
Get icon, 362, 365
GIF file format, 133, 246
Giraudel, Hugo, 393
Git version control, 51–52
Goldstein, Alexis, 93
Google Analytics, 99
Google Chrome, 99
Google Maps, 276, 277, 286–288
gradient backgrounds
  creating using Extract panel, 124–128
  web browser support for, 127
Gradient color picker, 128, 305
graphic tools, 270
graphics
  raster, 242–247
  vector, 242
  See also images
grouping panels, 34

H
<h1> to <h6> tags, 59, 196
hash symbol (#), 122, 280, 296, 297, 377
<head> tag, 59, 151, 159
<header> element, 62, 126
headers, table, 72
headings
  creating, 196–197
  HTML defaults for, 72
Help reference, 15
hex colors, 138
<hgroup> tag, 62
high color, 245
hinting menu, 208, 209, 372
home page
  hyperlinks to, 282–283
  setting up, 356–358
hover state, 303
<hr> tag, 59
HTML (HyperText Markup Language), 54–65
  automatically writing, 373–377
  bonus exercises on, 58
  character entities, 60–61
  code validation, 162–163
  comments added to, 379–380
  CSS comparison, 68–70
  current version, 61–63
  defaults, 70–72
  description of, 56
  elements, 57, 58–61
  Emmet toolkit for, 373–377
  entity insertion, 158–159
  historical origins of, 56–57
  manually writing, 370–373
  Property inspector, 40
  review questions/answers on, 64–65
  structure of webpage using, 58
  table formatting and, 211
  tags, 57, 58–60
  web browsers and, 73
See also code
HTML5, 61–63
  lack of defaults for, 71–72
  quote attribution in, 200
  semantic web design, 62–63
  tags, 61–62
HTML5 & CSS3 for the Real World (2nd Edition)
  (Goldstein, Lazaris, and Weyl), 93
HTML Attribute dialog, 250
HTML structures, 197–201
<html> tag, 59
Hyperlink icon, 287, 293
hyperlinks, 274–307
  absolute, 275, 286–288
  adding behaviors to, 320–322
  checking on pages, 305–306
  defined, 274
  destination, 297–299, 306
  editing/removing, 279
  email, 277, 289–293
  external, 274, 286–288
  home page, 282–283
  image-based, 291–292
  internal, 274, 278–285
  placeholder for, 279, 320, 321
  pseudo-classes for, 303
  relative, 274, 275, 278–281
  targeted, 294–299
  testing, 285
  text-based, 292–293
  updating in child pages, 283–285
HyperText Markup Language. See HTML
icons
  minimizing panels to, 32
  See also specific icons
id attributes
  creating, 91, 298, 372
  targeted links and, 294, 298–299
<i frame> tag, 59
Ignore option, 365
Image Display, 50
Image Optimization dialog, 256, 263, 270
image-based links, 291–292
image-editing programs, 265
images, 240–271
  captions for, 182–183
  color spaces used for, 244–245
  converting files for, 256–257
  cropping/pasting from Photoshop, 262–265
  cropping with Crop tool, 268–269
  dragging-and-dropping, 266
  extracting from mockups, 128–134
  file formats for, 242, 246–247
  inserting on a webpage, 248–250, 252–259
  non-web file type, 256–259
  optimizing with Property inspector, 267–269
  Photoshop Smart Objects as, 260–262
positioning with CSS classes, 250–252
Property inspector controls for, 41
Quality setting for, 256
raster graphics as, 242–247
resolution of, 243–244, 259
review questions/answers on, 271
size of, 244, 259, 268
swapping/restoring, 316–319
tools for editing, 270
unique ids recommended for, 316
vector graphics as, 242
Images category icon, 249, 266
Images window, 249
<img> element, 59, 250
implicit encryption, 346
Import Tabular Data dialog, 226
importing
  CSS style sheets, 391–393
tabular data, 226–227
text, 191–194
indented text, 205–210
inheritance theory, 78
inline elements, 58
inline formatting, 75
<input> tag, 59
Insert menu, 254–255, 341
Insert panel, 252–254, 324, 341
Insert Rows or Columns dialog, 215
Insert Section dialog, 227
inserting
  editable regions into templates, 151–158
  images on a webpage, 248–250, 252–259
  jQuery Accordion widgets, 324–326
  metadata into templates, 159–162
  rows or columns into tables, 215
  tables from other sources, 226–229
Inspect mode, 29–30, 337
Inspect Mode icon, 337
installing
  Dreamweaver, 4–5
testing servers, 352
Instant LESS CSS Preprocessor How-to (Libby), 393
interactivity, 308–343
Dreamweaver behaviors for, 310–311, 313–322
jQuery Accordion widgets for, 323–341
review questions/answers on, 342–343
interface components, 16–53
CSS Designer, 44–48
DOM Viewer, 49
Element Display, 50
Extract workflow, 36–37
Image Display, 50
keyboard shortcuts, 38–40
New Feature guides, 23
overview of, 18–19
panels, 31–35
personalizing, 35–36
Position Assist dialog, 49
preferences for, 23–26
Property inspector, 40–41
Related Files interface, 41–42
review questions/answers on, 53
Start Screen, 19–22
tag selectors, 43
Text Display, 51
toolbars, 37–38
views, 26–30
VMQ interface, 48
workspaces, 30–31
internal hyperlinks, 274, 278–285
  home link creation, 282–283
  relative link creation, 278–281
  targeted link creation, 294–297
  updating in child pages, 283–285
Internet, pre-HTML, 57
Internet Explorer/Edge browser, 99
Internet service provider (ISP), 348
introduction screens, 9
IPV6-based servers, 349
J
JavaScript, 327
JPEG file format, 133, 246–247
jQuery Accordion widgets, 323–341
  background effects for, 331–332, 339–341
  conditional states for, 332–335
  identifying dynamic styling in, 335–339
  inserting into layouts, 324–326
  overview of working with, 323
  styling, 327–341
Jump Start Sass: Get Up to Speed with Sass in a Weekend (Giraudel and Suzanne), 393
K

keyboard shortcuts, 38–40

L

layouts
predefined, 110–112
template creation from, 150–151
workspace, 30–31
See also page layouts

Lazaris, Louis, 93

Learn tab, 22

LESS CSS preprocessor, 380, 382

lesson files
downloading and accessing, 6–7
recommended order for using, 8

Levels dialog (Photoshop), 265

<1i> element, 59, 204

Libby, Alex, 393

line numbers, 395

<link> element, 59

Link Checker panel, 306

link state, 303

linked CSS formatting, 75

links. See hyperlinks

Linting support, 393–394

lists, 201–210
creating, 201–205
indented text in, 205–210
ordered and unordered, 204–205

Live Code mode, 336–339

Live Source Code mode, 29

Live view, 27
ertering editing mode in, 193
Live Code feature in, 336–339
previewing pages in, 189, 286
selecting text in, 287

Live View Options pop-out menu, 339

local sites, 11, 346
process of setting up, 11–14
synchronizing with remote sites, 363–365

Local Web Fonts, 219

local web servers, 351–354

locked elements, 299–301

Locked icon, 166

Lorem generator, 376

lossy compression, 247

M

macOS vs. Windows instructions, 3–4
Maintain Synchronization Information option, 350, 351
Manage Fonts dialog, 218–220
Manage Sites dialog, 348, 351, 380
manually writing code, 370–373
map links, 287
Marcotte, Ethan, 100
margins, 72, 182
max-width specification, 48
McFarland, David Sawyer, 93
media queries
CSS Designer window for, 45
VMQ interface and, 48

@media window, CSS Designer, 45

menus. See navigation menus

merged images, 262

<meta> tag, 59, 161, 162

metadata
image-related, 250
inserting into templates, 159–162

minification, 77

minimizing panels, 32

min-width specification, 48

mockups
creating wireframes and, 103–104
image assets extracted from, 128–134
text extracted from, 119–121
text styling extracted from, 123–124

monochrome, 244

multicursor support, 377–378

Muse, Adobe, 57

N

named anchors, 294, 297

named entities, 158

<1nav> element, 62, 117, 301

navigation, 272–307
basics of, 274–275
checking on pages, 305–306
e-mail links for, 289–293
external hyperlinks for, 286–288
image-based links for, 291–292
internal hyperlinks for, 278–285
finishing touches provided for, 138–145
gradient backgrounds created for, 124–128
image assets extracted for, 128–134
predefined in Dreamweaver, 110–112
review questions/answers on, 146–147
styling existing, 113–115
template creation from, 150–151
text styling extracted for, 123–124

palettes, color, 244–245
panels, 31–35
closing, 33
docking, 35
dragging, 33
floating, 34
grouping, 34
minimizing, 32
stacking, 35
See also specific panels
parent tag selector, 397
_parent target option, 289
Passive FTP connections, 349
passwords, FTP site, 348
Paste command, 168
Paste Special command, 168
Paste Styles option, 228, 331
path element notation, 280
pathname issues, 176

Photoshop
bonus lesson on using, 104
copying/pasting images from, 262–265
Smart Objects from, 260–262
Photoshop mockups. See mockups
<picture> element, 62, 259
pixels, 242–243
placeholders
content, 376
hyperlink, 279, 320, 321
text, 202
webpage, 361
PNG file format, 133, 247
Point to File icon, 281, 307
pointer cursor, 278
Position Assist dialog, 49, 211, 212, 324
position property, 300
positioning images, 250–252
ppi (pixels per inch), 243
R
raster graphics, 242–247
  color spaces for, 244–245
  file formats for, 246–247
  resolution of, 243–244
  scaling issues, 264
  size of, 244
RDS (Remote Development Services), 346
Recent option, 20
Refresh button, 327, 394
Refresh Site List icon, 249
refreshing browsers, 265
regular expressions, 233
Related Files interface, 41–42, 388, 403
relative hyperlinks, 274, 275, 278–281
remote servers, 347, 359
remote sites, 11, 346–354
  connection methods, 346
  definition of, 346, 367
  setting up for FTP, 347–351
  synchronizing local and, 363–365
  testing servers for, 351–354
  troubleshooting connections to, 350
  uploading files to, 359–362
Remove Comment icon, 380
Remove Event icon, 320
removing
  applied behaviors, 320
  comments, 380
  hyperlinks, 279
  placeholder text, 202
reordering panel tabs, 33
Resample tool, 270
Reset icon, 258
Resig, John, 327
resolution, 243–244
resource folders, 13
resources
  on Adobe Dreamweaver, 15
  on CSS, 93
  on CSS preprocessors, 382, 393
responsive web design, 100
images and, 259
  starter layouts for, 111, 147
rollover effects, 310
rows, table, 213–215
rules, CSS, 75–76, 77, 339
S

sandwich icon, 223
Sass CSS preprocessor, 380, 382, 384
Save All command, 39, 180
Save As dialog, 165
Save As Template dialog, 150
Save Log button, 361
Save Web Image dialog, 257, 263
saving
custom workspaces, 36
pages as templates, 150
remote server setup, 351
scaling raster images, 264
<script> tag, 60
SCSS preprocessor, 380, 384
<section> element, 62, 152, 194, 203, 227
Select Image Source dialog, 253, 254, 317
Select Parent Tag icon, 397
selecting code, 395–397
line numbers for, 395
parent tags for, 397
tag selectors for, 395–397
selectors
CSS, 75, 77, 80, 389–391
tag, 43, 395–397
Selectors window, 45, 86, 87, 179
_self target option, 289
semantic content
building, 153–158
creating for text, 194–196
semantic web design, 62–63
SFTP (Secure FTP), 346
Sharpen tool, 270
shortcuts, keyboard, 38–40
shorthand, CSS, 89–90
Show Log option, 284
Show Set option, 46, 87, 209, 220
sidebars, 153–158
Site Definition dialog, 130, 381
Site menu, 11
Site Root button, 263
site root folder, 12
Site Setup dialog, 11, 347, 351, 354
Smart Objects, 260–262, 271
Solarized Light theme, 25, 371
<source> tag, 62
Sources window, 44
<span> tag, 60, 140
special characters, 158
specificity theory, 79–80
spell-checking webpages, 231
Split Code view, 399
Split view, 28
stacking panels, 35
stacks, font, 218
staging servers, 346, 351
Standard toolbar, 37
Standard workspace, 10–11, 30
Start Screen, 19–22
CC Files option, 20
Create New and Open buttons, 22
disabling, 22
Learn tab, 22
Quick Start option, 21
Recent option, 20
Starter Templates option, 21
starter templates, 21, 111
statistics on web usage, 99
strikethrough formatting, 3
<strong> tag, 60, 287
structural elements, 58
<style> tag, 60, 172–173, 179
Style Rendering command, 75
Stylin' with CSS: A Designers Guide (3rd Edition)
(Wyke-Smith), 93
styling
copying/pasting, 227–228, 331
existing page layouts, 113–115
Extract panel used for, 115–119
extracting from text mockups, 123–124
indented text, 207–210
jQuery Accordions, 327–341
moving to a linked file, 172–176
tables and cells, 216–223
Suzanne, Miriam, 393
SVG graphics, 242
Swap icon, 132
Swap Image behavior, 316–318
Swap Image Restore behavior, 318–319
Sync Settings dialog, 9
synchronization information, 350
synchronization process, 363–365
Synchronize dialog, 365
Synchronize icon, 364, 365
Synchronize pop-up menu, 364
Synchronize With Remote Server dialog, 364
syntax, CSS rule, 77

T

tabbed panels, 323
Table dialog, 211, 212
tables, 210–231
  borders for, 212, 221
caption elements in, 229–231
cell styling for, 221–223
column width in, 225–226
controlling the display of, 223–226
copying and pasting, 215–216
creating from scratch, 210–215
editing mode for, 223
HTML defaults for, 72
inserting from other sources, 226–229
moving between cells in, 213
Property inspector for, 41
review questions/answers on, 239
styling with CSS, 216–221
text styling for, 216–220
<table> tag, 60, 214, 229
tag selectors, 43, 395–397
tags
  HTML, 57, 58–60
  HTML5, 61–62
target attributes, 289
Target menu, 288, 289
targeted links, 294–299
  creating internal, 294–297
  Element Display for creating, 297–298
  id attributes for, 294, 298–299
<td> tag, 60, 221, 222
templates, 148–185
  adding content to, 166–172
  child pages produced from, 164–172
cloaking the folder of, 354, 355–356
creating from existing layouts, 150–151
editable regions in, 151–158
formatting content in, 181–183
how they work, 150
HTML entities in, 158–159
linked style sheets for, 172–176
metadata added to, 159–162
review questions/answers on, 184–185
semantic content in, 153–158
starter, 21, 111
updating, 176–180
validating code in, 162–163
views for using, 201
Templates category icon, 191
testing
  FTP connections, 349
  hyperlinks, 285
  site functionality, 353
testing server, 351–354
text, 191–201
  conventions used in book, 2–3
  copying and pasting, 167–168, 193
  extracting from mockups, 119–121
  finding and replacing, 233–238
  headings created for, 196–197
  review questions/answers on, 239
  styling extracted from, 123–124
  table styling of, 216–220
  typefaces vs. fonts for, 217
  web fonts for, 218–220
Text Display, 51, 287, 293, 298
<textarea> element, 60
text-based links, 292–293
<th> tag, 60, 221, 222
themes, color, 9–10, 25
thumbnails, 101–102
TinyURLs, 1
title, page, 160
<title> tag, 60, 151, 161
Toggle Size Constrain icon, 258, 268
toolbars, 37–38
  Common toolbar, 38
  Document toolbar, 37
  Standard toolbar, 37
_top target option, 289
<tr> tag, 60, 236
training centers, 15
troubleshooting
  CSS styling, 121–123
  FTP connections, 350
true color, 245
tutorials, 15
type. See text
typefaces vs. fonts, 217
  See also fonts
Typekit fonts, 104

U
<u> tag, 60, 205
Undo command, 270, 374
Unordered List icon, 205
unordered lists, 205
Update from Original menu option, 261
Update from Original tool, 270
Update Pages dialog, 178, 284
Update Template Files dialog, 178, 283
updating
  child pages, 176–180, 283–285
  Dreamweaver, 5–6, 14
  hyperlinks, 283–285
  images, 261
  templates, 176–180
uploading files, 350, 359–362
usernames, FTP site, 348

V
validating HTML code, 162–163
variables, 384–385
vector graphics, 242
Verou, Lea, 93
version control, 51–52
video, bonus chapter on, 8
<video> tag, 62
views, 26–30
  Code view, 26
  Design view, 26–27
  Inspect mode, 29–30
  Live Source Code mode, 29
Live view, 27
Split view, 28, 399
visited state, 303
Visual Media Query (VMQ) interface, 48

W
W3C Validator Notification dialog, 163
W3Schools website, 99
Web 2.0 functionality, 310
web animation/video bonus chapter, 8
web browsers
  hyperlink info in, 276
  popularity of specific, 73, 99
  previewing pages in, 284–285
  refreshing, 265
web design, 96–105
  desktop vs. mobile, 102–103
  important questions for, 98
  mockups for, 103–104
  page design and, 102–103
  responsive, 100
  review questions/answers on, 105
  scenario illustrating, 101
  statistics relevant to, 99
  thumbnails for, 101–102
  wireframes for, 103–104
Web Edition of book, 6, 7
web fonts, 218–219
web resources
  on Adobe Dreamweaver, 15
  on CSS preprocessors, 382
WebDav system, 346
webpages
  placeholders for, 361
  spell-checking, 231–233
web-safe colors, 245
web-safe fonts, 219
websites
  questions for developing, 98
  testing servers for, 351–354
  uploading files to, 359–362
weight of rules, 79, 80
Weyl, Estelle, 93
widgets. See jQuery Accordion widgets

ADOBE DREAMWEAVER CC CLASSROOM IN A BOOK (2018 RELEASE) 419
Windows vs. macOS instructions, 3–4
wireframes, 103–104
workspaces
  Developer workspace, 31
  prebuilt, 30–31
  saving custom, 36
  setting up, 10–11
  Standard workspace, 10–11, 30
See also interface components
writing code
  automatically, 373–377
  manually, 370–373
Wyke-Smith, Charles, 93
WYSIWYG view, 18

X
X icon, 394

Y
Your Sites window, 381

Z
ZIP archives, 7