Adobe Animate CC
2017 release

CLASSROOM IN A BOOK®
The official training workbook from Adobe
Russell Chun

FREE SAMPLE CHAPTER
SHARE WITH OTHERS
# CONTENTS

## GETTING STARTED

1  GETTING ACQUAINTED  

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting Adobe Animate CC and Opening a File</td>
<td>2</td>
</tr>
<tr>
<td>Understanding Document Types</td>
<td>4</td>
</tr>
<tr>
<td>Getting to Know the Workspace</td>
<td>5</td>
</tr>
<tr>
<td>Working with the Library Panel</td>
<td>9</td>
</tr>
<tr>
<td>Understanding the Timeline</td>
<td>11</td>
</tr>
<tr>
<td>Organizing Layers in a Timeline</td>
<td>19</td>
</tr>
<tr>
<td>Using the Properties Panel</td>
<td>23</td>
</tr>
<tr>
<td>Using the Tools Panel</td>
<td>27</td>
</tr>
<tr>
<td>Undoing Steps in Animate</td>
<td>30</td>
</tr>
<tr>
<td>Previewing Your Movie</td>
<td>31</td>
</tr>
<tr>
<td>Modifying the Content and Stage</td>
<td>32</td>
</tr>
<tr>
<td>Saving Your Movie</td>
<td>33</td>
</tr>
</tbody>
</table>

2  CREATING GRAPHICS AND TEXT  

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Getting Started</td>
<td>40</td>
</tr>
<tr>
<td>Understanding Strokes and Fills</td>
<td>40</td>
</tr>
<tr>
<td>Creating Shapes</td>
<td>41</td>
</tr>
<tr>
<td>Making Selections</td>
<td>42</td>
</tr>
<tr>
<td>Editing Shapes</td>
<td>43</td>
</tr>
<tr>
<td>Using Gradient and Bitmap Fills</td>
<td>47</td>
</tr>
<tr>
<td>Using Variable-Width Strokes</td>
<td>51</td>
</tr>
<tr>
<td>Using Swatches and Tagged Swatches</td>
<td>53</td>
</tr>
<tr>
<td>Creating Curves</td>
<td>57</td>
</tr>
<tr>
<td>Using Transparency to Create Depth</td>
<td>61</td>
</tr>
<tr>
<td>Being Expressive with the Paint Brush</td>
<td>63</td>
</tr>
<tr>
<td>Creating and Editing Text</td>
<td>71</td>
</tr>
<tr>
<td>Aligning and Distributing Objects</td>
<td>79</td>
</tr>
<tr>
<td>Converting and Exporting Art</td>
<td>81</td>
</tr>
</tbody>
</table>
3  CREATING AND EDITING SYMBOLS  86
Getting Started ............................................. 88
Importing Adobe Illustrator Files ......................... 88
About Symbols ........................................... 93
Creating Symbols ......................................... 94
Importing Adobe Photoshop Files ....................... 96
Editing and Managing Symbols ......................... 101
Changing the Size and Position of Instances .......... 106
Changing the Color Effect of an Instance ............... 110
Understanding Display Options ......................... 112
Applying Filters for Special Effects .................... 114
Positioning in 3D Space .................................. 116

4  ANIMATING SYMBOLS  124
Getting Started ............................................. 126
About Animation .......................................... 127
Understanding the Project File ......................... 127
Animating Position ....................................... 128
Changing the Pacing and Timing ....................... 131
Animating Transparency .................................. 134
Animating Filters ......................................... 136
Animating Transformations ............................. 139
Changing the Path of the Motion ....................... 142
Swapping Tween Targets ................................. 146
Creating Nested Animations ......................... 147
Graphic Symbols .......................................... 150
Easing ...................................................... 156
Frame-by-Frame Animation ............................. 159
Animating 3D Motion .................................... 161
Animating Camera Moves .............................. 164
Testing Your Movie ....................................... 173

5  ADVANCED MOTION TWEENING  176
Getting Started ............................................. 178
About the Motion Editor .................................. 179
Understanding the Project File ......................... 180
Adding Motion Tweens ............................................. 181
Editing Property Curves ......................................... 182
Viewing Options for the Motion Editor ....................... 188
Copying and Pasting Curves .................................... 189
Adding Complex Eases ......................................... 193

6 ANIMATING SHAPES AND USING MASKS 210
Getting Started ..................................................... 212
Animating Shapes .................................................. 212
Understanding the Project File .................................. 213
Creating a Shape Tween ........................................... 213
Changing the Pace .................................................. 216
Adding More Shape Tweens ..................................... 217
Creating a Looping Animation ............................... 220
Using Shape Hints .................................................. 223
Previewing Animations with Onion Skinning ............... 227
Animating Color .................................................... 230
Creating and Using Masks ....................................... 234
Animating the Mask and Masked Layers ................. 237
Easing a Shape Tween ............................................. 241

7 NATURAL AND CHARACTER ANIMATION 244
Getting Started ..................................................... 246
Natural Motion and Character Animation with Inverse Kinematics ........................................... 246
Creating a Walk Cycle ............................................. 257
Disabling and Constraining Joints ............................ 261
Inverse Kinematics with Shapes ............................ 271
Simulating Physics with Springiness ....................... 279

8 CREATING INTERACTIVE NAVIGATION 286
Getting Started ..................................................... 288
About Interactive Movies ....................................... 289
Creating Buttons ................................................. 290
Understanding ActionScript 3.0 ......................... 301
Preparing the Timeline ........................................... 305
Adding a Stop Action ............................................. 305
GETTING STARTED

The 2017 release of Adobe Animate CC provides a comprehensive authoring environment for creating sophisticated animations and interactive, media-rich applications that you can publish to a variety of platforms. Animate CC is widely used in the creative industry to develop engaging projects integrating video, sound, graphics, and animation. You can create original content in Animate CC or import assets from other Adobe applications such as Photoshop or Illustrator, quickly design animation and multimedia, and use code to integrate sophisticated interactivity.

Use Animate CC to generate graphics and animation assets, to build innovative and immersive websites, to create stand-alone applications for the desktop, or to create apps to distribute to mobile devices running on the Android or iOS system.

With extensive controls for animation, intuitive and flexible drawing tools, and output options for HD video, HTML5, mobile apps, desktop applications, and Flash Player, Adobe Animate CC is a rare example of a robust multimedia authoring environment that enables your imagination to become reality.

About Classroom in a Book

Adobe Animate CC Classroom in a Book (2017 release) is part of the official training series for Adobe graphics and publishing software developed with the support of Adobe product experts. The lessons are designed so you can learn at your own pace. If you’re new to Animate, you’ll learn the fundamental concepts and features you’ll need to use the program. Classroom in a Book also teaches many advanced features, including tips and techniques for using the latest version of this application.

Although each lesson provides step-by-step instructions for creating a specific project, there’s room for exploration and experimentation. You can follow the book from start to finish, or do only the lessons that correspond to your interests and needs. Each lesson concludes with review questions to reinforce what you’ve learned.

What’s New

The 2017 release of Adobe Animate CC provides more expressive tools, powerful controls for animation, and robust support for a wider variety of playback platforms.

The lessons in this book provide opportunities to use some of the updated features and improvements in Animate CC, including

- The new Camera tool that puts you in the director’s chair to frame the action with camera moves such as zooming and panning
• The expanded Paintbrush tool featuring flexible controls and customizations of Art and Pattern brushes for vector-based painterly effects
• Integration of Typekit and Google Web fonts in HTML5 Canvas projects
• Support for HTML5 video
• A new Framepicker for graphic symbols to provide better controls for character lip syncing
• Tagged swatches that allow quick and easy editing of colors
• Collaboration with other designers and with other Adobe applications through Creative Cloud libraries

Prerequisites

Before you begin using Adobe Animate CC Classroom in a Book (2017 release), make sure your system is set up correctly and that you’ve installed the required software. You should have a working knowledge of your computer and operating system. You should know how to use the mouse and standard menus and commands, and also how to open, save, and close files. If you need to review these techniques, see the printed or online documentation included with your Microsoft Windows or Apple Mac OS software.

In addition, you need to download the free Adobe AIR runtime, available at get.adobe.com/air/, to publish desktop applications in Lesson 10.

Installing Animate CC

You must purchase the Adobe Animate CC application as part of Adobe Creative Cloud. The following specifications are the minimum required system configurations.

Windows
• Intel® Pentium 4, Intel Centrino®, Intel Xeon®, or Intel Core™ Duo (or compatible) processor
• Microsoft® Windows® 7 (64 bit), Windows 8.1 (64 bit), or Windows 10 (64 bit)
• 2 GB of RAM (8 GB recommended)
• 1024x900 display (1280x1024 recommended)
• 4 GB of available hard-disk space for installation; additional free space required during installation (cannot install on removable flash storage devices)
• Broadband Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.
Mac OS

- Multicore Intel® processor
- Mac OS X v10.10 (64-bit), 10.11 (64-bit), or 10.12 (64-bit)
- 2 GB of RAM (8 GB recommended)
- 1024x900 display (1280x1024 recommended)
- QuickTime 12.x software recommended
- 4 GB of available hard-disk space for installation; additional free space required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)
- Broadband Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.

For updates on system requirements and complete instructions on installing the software, visit helpx.adobe.com/animate/system-requirements.html.

Install Animate CC from Adobe Creative Cloud at creative.adobe.com and make sure that you have your login and password accessible.

Online Content

Your purchase of this Classroom in a Book includes online materials provided by way of your Account page on peachpit.com. These include:

Lesson files

To work through the projects in this book, you will need to download the lesson files from peachpit.com. You can download the files for individual lessons or it may be possible to download them all in a single file.

Web Edition

The Web Edition is an online interactive version of the book providing an enhanced learning experience. Your Web Edition can be accessed from any device with a connection to the Internet and it contains:

- The complete text of the book
- Hours of instructional video keyed to the text
- Interactive quizzes

In addition, the Web Edition may be updated when Adobe adds significant feature updates between major Creative Cloud releases. To accommodate the changes, sections of the online book may be updated or new sections may be added.
Accessing the Lesson files and Web Edition

If you purchased an eBook from peachpit.com or adobepress.com, your Web Edition will automatically appear under the Digital Purchases tab on your Account page. Click the Launch link to access the product. Continue reading to learn how to register your product to get access to the lesson files.

If you purchased an eBook from a different vendor or you bought a print book, you must register your purchase on peachpit.com in order to access the online content:

2. Sign in or create a new account.
4. Answer the questions as proof of purchase.
5. The Web Edition will appear under the Digital Purchases tab on your Account page. Click the Launch link to access the product.

The Lesson Files can be accessed through the Registered Products tab on your Account page. Click the Access Bonus Content link below the title of your product to proceed to the download page. Click the lesson file links to download them to your computer.

Bonus material

We’ve provided additional material for both Lessons 9 and 10 on peachpit.com. You’ll find “Working with Sound and Video—Supplement” for Lesson 9 and “Publishing—Supplement” for Lesson 10 in your account once you register your book as described earlier in “Accessing the Lesson files and Web Edition”. Download the supplements from the same page as the lesson files.

How to Use the Lessons

Each lesson in this book provides step-by-step instructions for creating one or more specific elements of a real-world project. Some lessons build on projects created in preceding lessons; most stand alone. All the lessons build on one another in terms of concepts and skills, so the best way to learn from this book is to proceed through the lessons in sequential order. In this book, some techniques and processes are explained and described in detail only the first few times you perform them.

You will create and publish final project files, such as SWF files, HTML files, videos, or AIR desktop applications, in some lessons in this book. The files in the End folders (01End, 02End, and so on) within the Lesson folders are samples of completed projects for each lesson. Use these files for reference if you want to compare your work in progress with the project files used to generate the sample projects.
The organization of the lessons is also project-oriented rather than feature-oriented. That means, for example, that you'll work with symbols on real-world design projects over several lessons rather than in just one chapter.

Additional Resources

*Adobe Animate CC Classroom in a Book (2017 release)* is not meant to replace documentation that comes with the program or to be a comprehensive reference for every feature. Only the commands and options used in the lessons are explained in this book. For comprehensive information about program features and tutorials, refer to these resources:

**Adobe Animate Learn and Support**: helpx.adobe.com/animate.html is where you can find and browse Help and Support content on Adobe.com. You can also reach that page by choosing Help > Animate Help or Help > Animate Support Center or pressing F1. Visit helpx.adobe.com/animate/topics.html for documentation on individual features and to download a PDF of the Help file.

**Adobe Creative Cloud Learn**: For inspiration, key techniques, cross-product workflows, and updates on new features, go to the Creative Cloud Learn page, helpx.adobe.com/creative-cloud/learn/tutorials.html. Available to all.

**Adobe Forums**: forums.adobe.com lets you tap into peer-to-peer discussions, questions, and answers on Adobe products. The Adobe Animate CC forum is accessible by choosing Help > Adobe Online Forums.

**Adobe Create**: create.adobe.com/ offers thoughtful articles on design and design issues, a gallery showcasing the work of top-notch designers, tutorials, and more.

**Resources for educators**: www.adobe.com/education and edx.adobe.com offer a treasure trove of information for instructors who teach classes on Adobe software. Find solutions for education at all levels, including free curricula that use an integrated approach to teaching Adobe software and can be used to prepare for the Adobe Certified Associate exams.

Also check out these useful sites:

**Adobe Add-ons**: creative.adobe.comaddons is a central resource for finding tools, services, extensions, code samples, and more to supplement and extend your Adobe products.

**Adobe Animate CC product home page**: www.adobe.com/products/animate.html

Adobe Authorized Training Centers

Adobe Authorized Training Centers offer instructor-led courses and training on Adobe products. A directory of AATCs is available at training.adobe.com/trainingpartners.
Contributor

Russell Chun is an assistant professor at the L. Herbert School of Communication at Hofstra University where he teaches multimedia storytelling, data journalism, and information design.
Lesson Overview

- Animate the position, scale, and rotation of objects
- Adjust the pacing and timing of your animation
- Animate transparency and special effects
- Change the path of an object’s motion
- Create nested animation
- Split a motion tween
- Change the easing of an object’s motion
- Animate in 3D space
- Animate camera moves with the Camera tool

This lesson will take approximately 2 hours to complete. Download the project files for this lesson from the Registered Products tab on your Account page at www.peachpit.com (click the Access Bonus Content link) and store them on your computer in a convenient location, as described in the Getting Started section of this book. Your Account page is also where you’ll find any updates to the lessons or to the lesson files.
Use Adobe Animate CC to change almost any aspect of an object—position, color, transparency, size, rotation, and more—over time. Motion tweening is the basic technique of creating animation with symbol instances.
Getting Started

Start by viewing the finished movie file to see the animated title page that you’ll create in this lesson.

1. Double-click the 04End.html file in the Lesson04/04End folder to play the animation in a browser.

The project is an animated splash page for an imaginary soon-to-be-released motion picture. In this lesson, you’ll use motion tweens to animate several components on the page: the cityscape, the main actors, several old-fashioned cars, and the main title.

2. Close the 04End.html file.

3. Double-click the 04Start.fla file in the Lesson04/04Start folder to open the initial project file in Animate. This file is an ActionScript 3.0 document that is partially completed and already contains many of the graphic elements imported into the library for you to use.

4. From the view options above the Stage, choose Fit In Window, or View > Magnification > Fit In Window, so that you can see the entire Stage on your computer screen.

5. Choose File > Save As. Name the file 04_workingcopy.fla, and save it in the 04Start folder.

Saving a working copy ensures that the original start file will be available if you want to start over.
About Animation

Animation is the movement, or change, of objects through time. Animation can be as simple as moving a box across the Stage from one frame to the next. It can also be much more complex. As you’ll see in this lesson, you can animate many different aspects of a single object. You can change an object’s position on the Stage, change its color or transparency, change its size or rotation, or animate the special filters that you saw in the previous lesson. You also have control over an object’s path of motion, and even its easing, which is the way an object accelerates or decelerates.

In Animate, the basic workflow for animation goes like this: Select an object on the Stage, right-click, and choose Create Motion Tween from the context menu. Move the red playhead to a different point in time and move the object to a new position or change one of its properties. Animate takes care of the rest.

Motion tweens create animation for changes in position on the Stage and for changes in size, color, or other attributes. Motion tweens require you to use a symbol instance. If the object you’ve selected is not a symbol instance, Animate will automatically ask to convert the selection to a symbol.

Animate also automatically separates motion tweens on their own layers, which are called tween layers. There can be only one motion tween per layer without any other element in the layer. Tween layers allow you to change various attributes of your instance at different key points over time. For example, a spaceship could be on the left side of the Stage at the beginning keyframe and at the far-right side of the Stage at an ending keyframe, and the resulting tween would make the spaceship fly across the Stage.

The term “tween” comes from the world of classic animation. Senior animators would be responsible for drawing the beginning and ending poses for their characters. The beginning and ending poses were the keyframes of the animation. Junior animators would then come in and draw the “in-between” frames, or do the “in-betweening.” Hence, “tweening” refers to the smooth transitions between keyframes.

Understanding the Project File

The 04Start.fla file contains a few of the animated elements already or partially completed. Each of the six layers—man, woman, Middle_car, Right_car, footer, and ground—contains an animation. The man and woman layers are in a folder called actors, and the Middle_car and Right_car layers are in a folder called cars.
You’ll be adding more layers to create an animated cityscape, refining the animation of one of the actors, as well as adding a third car and a 3D title. All the necessary graphic elements have been imported into the library. The Stage is set at a generous 1280 pixels by 787 pixels, and the Stage color is black. You might need to choose a different view option to see the entire Stage. Choose View > Magnification > Fit In Window, or choose Fit In Window from the view options at the upper-right corner of the Stage, to view the Stage at a magnification percentage that fits your screen.

**Animating Position**

You’ll start this project by animating the cityscape. It will begin slightly lower than the top edge of the Stage, and then rise slowly until its top is aligned with the top of the Stage.

1. Lock all the existing layers so you don’t accidentally modify them. Create a new layer above the footer layer and rename it **city**.

2. Drag the bitmap image called cityBG.jpg from the bitmaps folder in the Library panel to the Stage.
3 In the Properties panel, set the value of X to 0 and the value of Y to 90.

![Properties panel](image)

This positions the cityscape image just slightly below the top edge of the Stage.

4 Right-click the cityscape image and choose Create Motion Tween or choose Insert > Motion Tween.

![Create Motion Tween dialog box](image)

5 A dialog box appears warning you that your selected object is not a symbol. Motion tweens require symbols. Animate asks if you want to convert the selection to a symbol so it can proceed with the motion tween. Click OK.

![Conversion warning dialog box](image)

Animate automatically converts your selection to a symbol with the default name **Symbol 1**, and stores it in your Library panel. Animate also converts the current layer to a tween layer so you can begin to animate the instance. Tween layers are distinguished by a special icon in front of the layer name, and the frames are tinted blue. The range of frames covered by the tween is the **tween span**. The tween span is represented by all the colored frames from the first keyframe to the last keyframe. Tween layers are reserved for motion tweens, and hence, no drawing is allowed on a tween layer.
6 Move the red playhead to the end of the tween span at frame 191.

7 Select the instance of the cityscape on the Stage, and while holding down the Shift key, move the instance up the Stage.

Holding down the Shift key constrains the movement to right angles.

8 For more precision, set the value of Y to 0 in the Properties panel.

A small black diamond appears in frame 191 at the end of the tween span. This indicates a keyframe at the end of the tween.

Animate smoothly interpolates the change in position from frame 1 to frame 191 and represents that motion with a motion path.

9 Drag the red playhead back and forth at the top of the Timeline to see the smooth motion. You can also choose Control > Play (or press Enter/Return) to make Animate play the animation.

Animating changes in position is simple, because Animate automatically creates keyframes at the points where you move your instance to new positions. If you want to have an object move to many different points, simply move the red playhead to the desired frame, and then move the object to its new position. Animate takes care of the rest.

Tip Hide all the other layers to isolate the cityscape and to better see the results of the motion tween.

Tip Remove a motion tween by right-clicking the motion tween on the Timeline or the Stage and choosing Remove Tween.

Preview the animation

Integrated into the bottom of the Timeline is a set of playback controls. These controls allow you to play, rewind, or go step-by-step backward or forward through
your Timeline to review your animation in a controlled manner. You can also use the playback commands on the Control menu.

1  Click any of the playback buttons on the Controller below the Timeline to go to the first frame, go to the last frame, play, stop, or move forward or backward one frame.

2  Select Loop Option (to the right of the Controller) and then click the Play button. The playhead loops, allowing you to see the animation over and over for careful analysis.

3  Move the start or end markers in the Timeline header to define the range of frames that you want to see looped.

   The playhead loops within the marked frames. Click Loop Option again to turn it off.

### Changing the Pacing and Timing

You can change the duration of the entire tween span or change the timing of the animation by dragging keyframes on the Timeline.

#### Changing the animation duration

If you want the animation to proceed at a slower pace (and thus take up a much longer period of time), you need to lengthen the entire tween span between the beginning and end keyframes. If you want to shorten the animation, you need to decrease the tween span. Lengthen or shorten a motion tween by dragging its ends on the Timeline.

1  Move your mouse pointer close to the end of the tween span in the city layer.

   Your pointer’s cursor changes to a double-headed arrow, indicating that you can lengthen or shorten the tween span.

2  Drag the end of the tween span back to frame 60.

   Your motion tween shortens to 60 frames, reducing the time it takes the cityscape to move.
3  Move your mouse pointer close to the beginning of the tween span (at frame 1).

![Image](image1)

4  Drag the beginning of the frame span forward to frame 10.

Your motion tween begins at an earlier time, so it now plays only from frame 10 to frame 60.

![Image](image2)

**Note**  If you have multiple keyframes in a tween, changing the length of the tween span by dragging one end or the other will distribute all your keyframes uniformly. The timing of your entire animation remains the same; only the length changes.

**Adding frames**

You'll want the last keyframe of your motion tween to hold for the remainder of the animation. Add frames by Shift-dragging the end of a tween span.

1  Move your mouse cursor close to the end of the tween span.

2  Hold down the Shift key and drag the end of the tween span forward to frame 191.

![Image](image3)

The last keyframe in the motion tween remains at frame 60, but Animate adds frames through frame 191.

**Tip**  You can also add individual frames by choosing Insert > Timeline > Frame (F5), or remove individual frames by choosing Edit > Timeline > Remove Frames (Shift+F5).
Moving keyframes

If you want to change the pacing of an animation, you can select individual keyframes, and then drag the keyframes to new positions.

1. Click the keyframe at frame 60.
   
   The keyframe at frame 60 is selected. A tiny box appears next to your mouse pointer, indicating that you can move the keyframe.

2. Drag the keyframe to frame 40.
   
   The last keyframe in the motion tween moves to frame 40, so the motion of the cityscape proceeds more quickly.

Span-based vs. frame-based selections

By default, Animate does not use span-based selection, which means you can select individual keyframes within a motion tween. However, if you prefer to click a motion tween and have the entire span (the beginning and end keyframes, and all the frames in between) be selected, you can enable Span Based Selection from the Options menu on the upper-right corner of the Timeline (or you can Shift-click to select the entire span).

With Span Based Selection enabled, you can click anywhere within the motion tween to select it, and move the whole animation backward or forward along the Timeline as a single unit.

If you want to select individual keyframes while Span Based Selection is enabled, hold down the Ctrl/Command key and click a keyframe.
Animating Transparency

In the previous lesson, you learned how to change the color effect of any symbol instance to change the transparency, tint, or brightness. You can change the color effect of an instance in one keyframe and change the value of the color effect in another keyframe, and Animate will automatically display a smooth change, just as it does with changes in position.

You'll change the cityscape in the beginning keyframe to be totally transparent but keep the cityscape in the ending keyframe opaque. Animate will create a smooth fade-in effect.

1. Move the red playhead to the first keyframe of the motion tween (frame 10).

2. Select the cityscape instance on the Stage.

3. In the Properties panel, Color Effect section, choose Alpha from the Style menu.

4. Set the Alpha value to 0%.

The cityscape instance on the Stage becomes totally transparent.
5 Move the red playhead to the last keyframe of the motion tween (frame 40).

6 Make sure that the cityscape instance on the Stage is still selected.

7 In the Properties panel, in the Color Effect section, set the Alpha value to 100%.
   The cityscape instance on the Stage becomes totally opaque.

8 Preview the effect by choosing Control > Play (Enter/Return).
   Animate interpolates the changes in both position and transparency between the two keyframes.
Animating Filters

Filters, which give instances special effects such as blurs and drop shadows, can also be animated. You'll refine the motion tween of the actors next by applying a blur filter to one of them to make it appear as if the camera changes focus. Animating filters is no different from animating changes in position or changes in color effect. You simply set the values for a filter at one keyframe and set different values for the filter at another keyframe, and Animate creates a smooth transition.

1. Make sure that the actors layer folder on the Timeline is visible.
2. Unlock the woman layer.
3. Move the red playhead to the beginning keyframe of the motion tween in the woman layer, at frame 23.
4. Select the instance of the woman on the Stage. You won't be able to see her because she has an alpha value of 0% (totally transparent). Click the upper-right side of the Stage to select the transparent instance. Or, click the woman layer in the Timeline to highlight it; then click within the outline that appears on the Stage.
5. In the Properties panel, expand the Filters section.
6. Click the Add Filter button in the Filters section and choose Blur from the menu to add a blur to the instance.
7. In the Filters section of the Properties panel, make sure that the link icons are selected in order to constrain the blur values to both the $x$ and $y$ directions equally. Set the Blur X and Blur Y values to 20 pixels.
8 Move the red playhead across the entire Timeline to preview the animation. The woman instance is blurred throughout the motion tween.

9 Right-click the woman layer at frame 140, and choose Insert Keyframe > Filter.

Animate establishes a keyframe for filters at frame 140.

10 Move the red playhead to frame 160, and right-click the woman layer and choose Insert Keyframe > Filter to add another filter keyframe.

11 Select the instance of the woman on the Stage at frame 160.
12 In the Properties panel, change the value of the Blur filter to X=0 and Y=0.

The Blur filter changes from the keyframe at frame 140 to the keyframe at 160. Animate creates a smooth transition from a blurry instance to an in-focus instance.

### Understanding property keyframes

Changes in properties are independent of one another and do not need to be tied to the same keyframes. That is, you can have a keyframe for position, a different keyframe for the color effect, and yet another keyframe for a filter. Managing many different kinds of keyframes can become overwhelming, especially if you want different properties to change at different times during the motion tween. Fortunately, Animate CC provides a few helpful tools for keyframe management.

When viewing the tween span, you can choose to view the keyframes of only certain properties. For example, you can choose to view only the Position keyframes to see when your object moves. Or, you can choose to view only the Filter keyframes to see when a filter changes. Right-click a motion tween in the Timeline, choose View Keyframes, and then select the desired property among the list. You can also choose All or None to see all the properties or none of the properties.

When inserting a keyframe, you can also insert a keyframe specific to the property you want to change. Right-click a motion tween in the Timeline, choose Insert Keyframes, and then select the desired property.

You can also view an advanced panel, called the Motion Editor, to see and edit how the different properties of your object change over the course of the motion tween. You’ll learn more about the Motion Editor in the next lesson.
Animating Transformations

Now you’ll learn how to animate changes in scale or rotation. These kinds of changes are made with the Free Transform tool or with the Transform panel. You’ll add a third car to the project. The car will start small, and then become larger as it appears to move forward toward the viewer.

1. Lock all the layers on the Timeline.
2. Insert a new layer inside the cars folder and rename it Left_car.
3. Select frame 75 and insert a new keyframe (F6).
4. Drag the movie clip symbol called carLeft from the Library panel to the Stage at frame 75.
5. Select the Free Transform tool.
   The transformation handles appear around the instance on the Stage.
6. While holding down the Shift key, click and drag a corner handle inward to make the car smaller.
7. In the Properties panel, make sure that the width of the graphic is about 400 pixels.
8. Alternatively, you can use the Transform panel (Window > Transform) and change the scale of the car to about 29.4%.
9  Move the car to its starting position at about X=710 and Y=488.

10 In the Properties panel, Color Effect section, choose Alpha from the Style menu.

11 Set the value of the Alpha to 0%.

The car becomes totally transparent.

12 Right-click the car on the Stage and choose Create Motion Tween.

The current layer becomes a tween layer.

13 Move the red playhead on the Timeline to frame 100.

14 Select the transparent instance of the car on the Stage, and in the Properties panel, change the Alpha value to 100%.

A new keyframe is automatically inserted at frame 100 to indicate the change in transparency.
15 While holding down the Shift key, drag a corner handle outward to make the car larger. For more precision, use the Properties panel and set the dimensions of the car to width=1380 pixels and height=445.05 pixels.

16 Position the car at X=607 and Y=545.

You have used Animate to tween the change in position and the change in scale as well as the change in transparency from frame 75 to frame 100.

17 Move the Left_car layer in between the Middle_car and Right_car layers so that the car in the center overlaps the cars on the side.
Save your progress so far in this document 04_workingcopy.fla. In the next section, you’ll work with a different file.

**Motion presets**

If your project involves creating identical motion tweens repeatedly, Animate allows you to save and reuse motion tweens as presets. The Motion Presets panel (Window > Motion Presets) can store any motion tween so you can apply it to different instances on the Stage.

For example, if you want to build a slideshow where each image fades out in the same manner, you can save that transition as a motion preset.

1. Create your transition using the first slide in your show.
2. Select that slide’s motion tween on the Timeline or the slide’s instance on the Stage.
3. In the Motion Presets panel, click the Save Selection As Preset button at the bottom of the panel. Alternatively, right-click the motion tween and choose Save As Motion Preset.
4. Name your motion preset, and it will be saved in the Motion Presets panel.
5. Select a new instance on the Stage and choose the motion preset.
6. Click Apply, and Animate will apply your saved motion preset to the new instance.

Animate provides a number of motion presets that you can use to quickly build sophisticated animations without much effort.

**Changing the Path of the Motion**

The motion tween of the left car that you just animated shows a colored line with dots indicating the path of the motion. You can edit the path of the motion easily to make the car travel in a curve, or you can move, scale, or rotate the path just like any other object on the Stage.

To better demonstrate how you can edit the path of the motion, open the sample file 04MotionPath.fla in the Lesson04/04Start folder. The file contains a single
tween layer with a rocket ship moving from the top left of the Stage toward the bottom right.

![Rocket ship moving from top left to bottom right](image)

**Moving the path of the motion**

You will move the path of the motion so the relative movement of the rocket ship remains the same but its starting and ending positions change.

1. Select the Selection tool.
2. Click the path of the motion to select it.
   The path of the motion becomes highlighted.
3. Drag the motion path to move it to a different place on the Stage.
   The relative motion and timing of the animation remain the same, but the starting and ending positions are relocated.
Changing the scale or rotation of the path

You can also manipulate the path of the object’s motion using the Free Transform tool.

1. Select the path of the motion.
2. Select the Free Transform tool.
   Transformation handles appear around the path of the motion.
3. Scale or rotate the path of the motion as desired. You can make the path smaller or larger, or rotate the path so the rocket ship starts from the bottom left of the Stage and ends at the top right.

Editing the path of the motion

Making your objects travel on a curved path is a simple matter. You can either edit the path with Bezier precision using anchor point handles, or you can edit the path in a more intuitive manner with the Selection tool.
1. Select the Convert Anchor Point tool, which is hidden under the Pen tool.

2. Click the starting point or the ending point of the motion path on the Stage and drag the control handle out from the anchor point.

   The handle on the anchor point controls the curvature of the path.

3. Choose the Subselection tool.

4. Drag the handle at each end of the path to edit its curve. Make the rocket ship travel in a wide curve.

   Tip: You can also directly manipulate the path of the motion with the Selection tool. Select the Selection tool and make sure the path is deselected. Move your pointer close to the path of the motion. A curved icon appears next to your pointer, indicating that you can edit the path. Drag the path of the motion to change its curvature. Choose the spots where you drag carefully! Each drag breaks the path into smaller segments, making it harder to achieve a smooth curve. Mastery will come with practice.
Orienting objects to the path

Sometimes the orientation of the object traveling along the path is important. In the motion picture splash page project, the orientation of the car is constant as it moves forward. However, in the rocket ship example, the rocket ship should follow the path with its nose pointed in the direction in which it is heading. Orient To Path in the Properties panel gives you this option.

1. Select the motion tween on the Timeline (Shift-click to select the whole tween).
2. In the Properties panel, under Rotation, select the Orient To Path option.

Animate inserts keyframes for rotation along the motion tween to orient the nose of the rocket ship to the path of the motion.

Tip: To direct the nose of the rocket ship, or any other object, along the path of its motion, you must orient its position so that it is facing in the direction that you want it to travel. Use the Free Transform tool to rotate its initial position so that it is oriented correctly.

Swapping Tween Targets

The motion tween model in Animate CC is object based. This means that an object and its motion are independent of each other, and you can easily swap out the target of a motion tween. If, for example, you’d rather see an alien moving around the Stage instead of a rocket ship, you can replace the target of the motion tween with an alien symbol from your Library panel and still preserve the animation.

1. Drag the movie clip symbol of the alien from the Library panel onto the rocket ship.
Animate asks if you want to replace the existing tween target object with a new object.

![Dialog box showing the option to replace the existing tween target object](image)

2 Click OK.

Animate replaces the rocket ship with the alien. The motion remains the same, but the target of the motion tween has changed.

![Alien replacing the rocket ship](image)

Creating Nested Animations

Often, an object that is animated on the Stage will have its own animation. For example, the wings of a butterfly moving across the Stage may flap as it moves. Or the alien that you swapped with the rocket ship could be waving his arms. These kinds of animations are called **nested animations**, because they are contained inside the movie clip symbols. Movie clip symbols have their own Timeline that is independent of the main Timeline.

In this example, you’ll give the alien his own independent movement, so he can wave as he flies across the Stage.

Creating animations inside movie clip symbols

We’ll animate some of the symbols that make up the alien’s body to allow him to wave.

1 In the Library panel, double-click the alien movie clip symbol icon.
You are now in symbol-editing mode for the alien movie clip symbol. The alien appears in the middle of the Stage. In the Timeline, the parts of the alien are separated in layers.

2 Select the Selection tool.

3 Right-click the alien's left arm and choose Create Motion Tween.

Animate converts the current layer into a tween layer and inserts 1 second's worth of frames so you can begin to animate the instance.

4 Select the Free Transform tool.

5 Move the mouse pointer near the corner transformation handle until the cursor changes to the rotation icon. Drag the corner handle near the hand to rotate the arm upward to the alien's shoulder height.

A keyframe is inserted at the end of the motion tween. The left arm rotates smoothly from the resting position to the outstretched position.
6 Move the red playhead back to frame 1.

7 Now create a motion tween for the alien's other arm. Right-click his right arm and choose Create Motion Tween.

The current layer is converted into a tween layer and 1 second's worth of frames are inserted.

8 Choose the Free Transform tool if it's not selected already.

9 As you did for the left arm, drag the corner transformation handle near the right hand to rotate the arm upward to the alien's shoulder height.

Animate inserts a keyframe at the end of the motion tween. The arm rotates smoothly from the resting position to the outstretched position.

10 Select the last frame in all the other layers and insert frames (F5) so that the head, body, and feet all remain on the Stage for the same amount of time as the moving arms.

11 Click the Scene 1 button in the Edit bar at the top of the Stage to exit symbol-editing mode.

Your animation of the alien raising his arms is complete. Wherever you use the movie clip symbol, the alien's nested animation will continue to play.

12 Preview the animation by choosing Control > Test.

Animate opens a window showing the exported animation. The alien moves along the motion path while the nested animation of his arms moving plays and loops.

- **Note** Animations inside movie clip symbols will loop automatically. To prevent the looping, you need to add code to tell the movie clip Timeline to stop on its last frame. You'll learn to control the Timeline with ActionScript or JavaScript in later lessons.

- **Note** Animations inside of movie clip symbols won't play on the main Timeline. Choose Control > Test to preview nested animations.
Graphic Symbols

You’ve been using movie clip symbols for your animation, and you’ve seen how they allow for independent, nested animations. But you can also have nested animations and graphics inside of graphic symbols, although they work a little differently.

An animation inside a graphic symbol doesn’t play independently as it does in a movie clip symbol. It will only play if there are sufficient frames on the main Timeline where the instance is placed. And while you can control the internal playhead of a movie clip’s Timeline with ActionScript, you can control the playhead of a graphic symbol directly in the Properties panel. Because of the ease with which you can pick and choose what frame inside a graphic symbol shows, graphic symbols are ideal for lip syncing or other character variations.

Using the Frame Picker for phonemes

If animated characters talk, their mouth will be synchronized with their words. Each sound, or phoneme, is produced by a different mouth shape. For example, an explosive “p” or “b” sound will be made by closing the lips, or an “o” sound will be made by a rounded open mouth. Animators draw a collection of these mouth positions to be used to synchronize to the soundtrack.

You can store each mouth position as a keyframe in a graphic symbol. Animate’s Frame Picker panel lets you choose the frame in the graphic symbol’s Timeline that matches each sound.

In this task, you’ll animate the alien’s mouth using the Frame Picker.

1. Open the sample file 04FramePicker_start.fla in the Lesson04/04Start folder. The file contains your familiar alien character on the Stage.

The alien is not animated on a path, but his head is a graphic symbol with multiple keyframes inside of its Timeline.
2 Double-click the alien_head graphic symbol in the library.

Animate takes you to symbol-editing mode for the alien_head graphic symbol. Notice that the Timeline contains five keyframes in the mouth layer.

3 Examine each keyframe in the mouth layer by advancing the playhead from frame 1 to frame 5.

Each keyframe shows the mouth in a different position. Frame 1 has a small closed mouth, frame 2 a rounded mouth, frame 3 a wide open mouth, and so on.

4 Return to Scene 1 and choose Control > Test.

Animate creates a SWF to play the animation. Nothing happens because there is only a single frame on the main Timeline, and a graphic symbol needs frames on the main Timeline to play its own Timeline.

5 Close the test movie panel and return to your Animate document.
6 Select frames 45 in the head and body layer and choose Insert > Timeline > Frame (F5).

Frames are added to both layers up to frame 45.

![Timeline screenshot](image)

7 Choose Control > Play (Enter/Return).

Animate plays the animation. Your alien now can’t stop talking! The graphic symbol plays all of its five keyframes repeatedly during the 45 frames of the main Timeline. The graphic symbol is, by default, set to loop, but you’ll select a single frame to play instead.

8 Select the alien’s head on the Stage and in the Properties panel, Looping section, select Single Frame from the Options menu. Leave the value of the First field at 1.

![Properties panel screenshot](image)

Now the Stage displays only one frame from the alien_head graphic symbol, which is frame 1.

9 Select frame 10 of the head layer and insert a new keyframe (F6).

![Timeline screenshot](image)

10 With the playhead at your new keyframe on frame 10, select the alien head on the Stage. In the Properties panel, Looping section, click Use Frame Picker.

![Properties panel screenshot](image)

The Frame Picker panel opens. The Frame Picker shows thumbnail images of all the frames inside the graphic symbol.
11 You’ll have the alien mouth the word “hello.” For the first part of the word, select frame 3 in the Frame Picker.

Now, when the animation reaches frame 10 the alien head symbol will switch from displaying frame 1 (the closed mouth) to frame 3 for the beginning of the word, “h”.

12 Insert a new keyframe in frame 12 of the main Timeline.
13 In the Frame Picker, select frame 4.

When the animation plays frame 12, the alien head graphic symbol will change to frame 4. His mouth opens a little wider for the “eh” part of “hello.”

14 Insert a new keyframe in frame 14 of the main Timeline.

15 In the Frame Picker, select frame 2.

When the animation reaches frame 14, the head symbol will switch to displaying frame 2. His mouth is rounded for the “oh” sound.
16 In a new keyframe at frame 17, use the Frame Picker to change the mouth back to frame 1.

17 Finally, in a new keyframe at frame 30, use the Frame Picker to change the mouth to frame 5 so the alien gives us a broad smile.
Choose Control > Play (Enter/Return).

Animate plays the animation. Your alien lip syncs “hello,” pauses, and then smiles.

You're done with this document, so you can save and close it.

### Easing

_Easing_ refers to the way in which a motion tween proceeds. You can think of easing as acceleration or deceleration. An object that moves from one side of the Stage to the other side can start off slowly, then build up speed, and then stop suddenly. Or, the object can start off quickly and then gradually slow to a halt. Your keyframes indicate the beginning and end points of the motion, but the easing determines how your object gets from one keyframe to the next.

A simple way to apply easing to a motion tween is to use the Properties panel. Easing values range from −100 to 100. A negative value creates a more gradual change from the starting position (known as an ease-in). A positive value creates a gradual slowdown (known as an ease-out).

A more advanced way of applying easing is to use the new Motion Editor, which you'll learn about in the next lesson.

### Splitting a motion tween

Easing affects the entire span of a motion tween. If you want the easing to affect only frames between keyframes of a longer motion tween, you should split the motion tween. For example, return to the 04_workingcopy.fla file of the cinematic animation. The motion tween of the car in the Left_car layer begins at frame 75 and ends at frame 191, at the very end of the Timeline. However, the actual movement of the car starts at frame 75 and ends at frame 100. You'll split the motion tween so you can apply an ease to the tween just from frame 75 to frame 100.

1 In the Left_car layer, select frame 101, which is the frame just after the second keyframe where the car ends its movement.
2 Right-click frame 101 and choose Split Motion.

The motion tween is cut into two separate tween spans. The end of the first tween is identical to the beginning of the second tween.

3 In the Middle_car layer, select frame 94, right-click, and choose Split Motion to cut the motion tween into two separate tween spans.

4 In the Right_car layer, select frame 107, right-click, and choose Split Motion to cut the motion tween into two spans.

The motion tweens of all three cars have now been split.

**Applying eases to motion tweens**

You'll apply an ease-in to the motion tweens of the approaching cars to give them a sense of weight and to make them decelerate as real cars would.

1 In the Middle_car layer, select any frame between the first and second keyframes of the first motion tween (frame 70 to frame 93).
2 In the Properties panel, Ease section, enter **100** for the Ease value.

![Properties panel](image)

This applies an ease-out to the motion tween.

3 In the Left_car layer, select any frame between the first and second keyframes of the first motion tween (frame 75 to frame 100).

![Timeline](image)

4 In the Properties panel, enter **100** for the Ease value to apply an ease-out to the motion tween.

5 In the Right_car layer, select any frame between the first and second keyframes of the first motion tween (frame 78 to frame 106).

![Timeline](image)

6 In the Properties panel, enter **100** for the Ease value to apply an ease-out to the motion tween.

7 Select Loop at the bottom of the Timeline and move the start and end markers in the Timeline header to frames 60 and 115, respectively.

![Timeline](image)
8 Click Play (Enter/Return).

Animate plays the Timeline in a loop between frames 60 and 115 so you can examine the ease-out motion of the three cars.

**Frame-by-Frame Animation**

Frame-by-frame animation is a technique that creates the illusion of movement by making incremental changes between every keyframe. Frame-by-frame animation in Animate is similar to traditional hand-drawn cel animation where each drawing is on a separate sheet of paper, and it’s just as tedious.

Frame-by-frame animations increase your file size rapidly because Animate has to store the contents for each keyframe. Use frame-by-frame animation sparingly.

In the next section, you’ll insert a frame-by-frame animation inside the carLeft movie clip symbol to make it move up and down in a jittery fashion. When the movie clip loops, the car will rumble slightly to simulate the idle of the motor.

**Inserting a new keyframe**

The frame-by-frame animations inside the carMiddle and carRight movie clip symbols have already been done. You’ll finish the animation for the carLeft symbol.

1 In the Library panel, double-click the carRight movie clip symbol to examine its completed frame-by-frame animation.

   Inside the carRight movie clip, three keyframes establish three different positions for the car and its headlights. The keyframes are spaced unevenly to provide the unpredictable up and down motion.

![Timeline](image)

2 In the Library panel, double-click the carLeft move clip symbol.

   You enter symbol-editing mode for the carLeft symbol.

   ▶ Tip If the image of the car isn’t visible, select Fit In Window from the Zoom menu in the upper-right corner of the Stage.
3 Select frame 2 in both the lights layer and the smallRumble layer.

4 Right-click and choose Insert Keyframe (F6).
   Animate inserts a keyframe in frame 2 of the lights layer and the smallRumble layer. The contents of the previous keyframes are copied into the new keyframes.

Changing the graphics

In the new keyframe, change the appearance of the contents to create the animation.

1 In frame 2, select all three graphics (the car and its two headlights) on the Stage (Edit > Select All, or Ctrl+A/Command+A) and move them down the Stage by 1 pixel. You can use the Properties panel to decrease the Y-position value by 1 pixel or press the Down Arrow key to nudge the graphics by 1 pixel.
   The car and its headlights move down slightly.
Next, repeat the process of inserting keyframes and changing the graphics. For a random motion like an idling car, at least three keyframes are ideal.

Select frame 4 in both the lights layer and the smallRumble layer.

Right-click and choose Insert Keyframe (F6).

Keyframes are inserted into frame 4 of the lights and smallRumble layers. The contents of the previous keyframes are copied into the new keyframes.

Select frame 4 in both the lights layer and the smallRumble layer.

Right-click and choose Insert Keyframe (F6).

Keyframes are inserted into frame 4 of the lights and smallRumble layers. The contents of the previous keyframes are copied into the new keyframes.

Select all three graphics on the Stage (Edit > Select All, or Ctrl+A/Command+A) and move them up the Stage by 2 pixels. You can use the Properties panel or press the Up Arrow key twice to nudge the graphics by 2 pixels.

The car and its headlights move up slightly.

Test the idling motion by enabling the Loop Playback option at the bottom of the Timeline and click Play (Enter/Return).

Animating 3D Motion

Finally, you’ll add a title and animate it in 3D space. Animating in 3D presents the added complication of a third (z) axis. When you choose the 3D Rotation or 3D Translation tool, you need to be aware of the Global Transform option at the bottom of the Tools panel. (The tools and the Global Transform option were introduced in the previous lesson, in “Positioning in 3D Space.”) Global Transform toggles between a global option (button depressed) and a local option (button raised). Moving an object with the global option selected makes the transformation relative to the global coordinate system, whereas moving an object with the local option on makes the transformation relative to itself.

Click Scene 1 in the Edit bar to return to the main Timeline. Insert a new layer at the top of the layer stack and rename it title.

Lock all the other layers.
3 Insert a new keyframe at frame 120.

4 Drag the movie clip symbol called movietitle from the Library panel onto the Stage. The movietitle instance appears in your new layer in the keyframe at frame 120.

5 Position the title in the empty sky at x=180 and y=90.

6 Right-click the movie title and choose Create Motion Tween. Animate converts the current layer to a tween layer so you can begin to animate the instance.

7 Move the red playhead to frame 140.
8 Select the 3D Rotation tool.

The 3D rotation control appears on the selected movie clip.

9 Deselect the Global Transform option at the bottom of the Tools panel to put the 3D Rotation tool into local mode.

10 Drag downward on the green Y control to rotate the title around the y axis to angle it so that it seems to recede into the distance. Its angle is at about −50 degrees. You can check the rotation values in the Transform panel (Window > Transform).
11 Move the red playhead to the first keyframe at frame 120.

12 Drag upward on the Y control to rotate the title around the y axis in the opposite direction so that the instance looks like just a sliver.

The change in the 3D rotation becomes a motion tween, so the title appears to swing in three dimensions.

### Animating Camera Moves

So far, you’ve learned to animate different properties of symbol instances on the Stage—their position, scale, rotation, transparency, filters, and 3D position.

However, as an animator, you’re not just directing the motion of your characters and objects on the Stage like a play. You’re also in control of the camera, making you more like the director of a movie. That means controlling where to point the camera to frame the action, zooming in or out, panning, or even rotating the camera for special effect. All of these camera movements are available in Animate with the Camera tool.

### Enabling the camera

Enable the camera with the Camera tool in the Tools panel or with the Add/Remove Camera button below the Timeline. You’ll be animating the camera to simulate a zoom-out and a pan effect to focus on different parts of a larger static version of the movie opener that you worked on in this lesson.

Choose File/Open and navigate to Lesson04/04Start folder to open 04CameraStart.fla. This file is an ActionScript 3.0 document that is partially

---

**Note** Animating the 3D rotation or translation of a symbol is currently not supported in HTML5 Canvas documents or in WebGL documents.
completed and contains the graphic elements already in place on the Stage. The Timeline contains added frames and a motion tween in the title layer.

2 Select the Camera tool on the Tools panel, or click Add Camera at the bottom of the Timeline.

A Camera layer is added to the top of your Timeline and becomes active. On the Stage, the camera controls appear.
Characteristics of the camera

The Camera layer operates a little differently than a normal layer in which you are accustomed to adding graphics.

- The size of your Stage becomes the frame of your camera view.
- You can only have one Camera layer, and it is always at the top of all your other layers.
- You cannot rename the Camera layer.
- You can’t add objects or draw in the Camera layer, but you can add classic or motion tweens to the layer, which allows you to animate the camera motion and camera filters.
- When your Camera layer is active, you cannot move or edit objects in other layers. Disable the Camera layer by choosing your Selection tool, or by clicking the Remove Camera button at the bottom of the Timeline.

Zooming the camera

First, you’ll use the camera to zoom into a small part of the Stage to focus on the woman on the left. Your camera will initially hide a part of her face to create a little bit of mystery.

1 Make sure your Camera layer is active and the on-Stage controls are present. There are two modes on the controls, one for Rotate and another for Zoom. The Zoom mode should be highlighted.

Note Clicking the Remove Camera button at the bottom of the Timeline doesn’t actually delete your Camera layer; it only hides it from view. You can click the button again to restore the Camera layer. To delete the Camera layer entirely, select it and click the Delete button (trash can icon).
2 Drag the slider to the right.

The Camera view zooms closer into the Stage.

3 When your slider reaches the edge of the slider, release your mouse.

The slider snaps back to the center, allowing you to continue dragging to the right to continue zooming.

You can also enter a numerical value for the zoom in the Properties panel in the Camera Properties section.

4 Continue zooming the camera until you’ve reached about 270%.

Your Stage shows a close-up view of the cityscape between the two main characters.

*Note* When using the camera zoom mode, be aware of the image resolution. As with any bitmap, zooming in too dramatically will reveal the limitations of the original embedded image.
Moving the camera

You don't want the camera to focus on the empty space between the two characters, so you'll move the camera to focus on the woman.

1 With your pointer on the Stage, drag the camera to the left.

The contents of the Stage move to the right. It may feel a little counterintuitive, but remember, you're moving the camera and not the contents of the Stage. So if you point your camera to the left, the objects in view will move to the right.

2 Continue dragging the camera to frame the woman so that she's in the middle with her eyes cut off at the top edge of the camera.

Animating a pan

A pan is the motion of the camera left to right or up and down. In this next step, you'll pan the camera slowly upward to reveal the woman's face. You'll use a motion tween to animate the camera movement.

1 On the Timeline, select any frame in the Camera layer and right-click. In the context menu that appears, choose Create Motion Tween.

A motion tween is added to the Camera layer, indicated by the blue-colored frames. You currently only have a single keyframe, so you'll be adding additional keyframes further along the Timeline to complete the motion.

2 Move the playhead to frame 25.
3 With your pointer over the Stage, drag the camera upward to reveal the woman’s face. Hold down the Shift key to constrain the motion to a straight vertical line.

A new keyframe is established at frame 25, and Animate creates a smooth motion of the camera between the two keyframes.

4 Select Loop at the bottom of your Timeline and move the start marker to the first of the Camera layer keyframes and move the end marker a few frames beyond the second keyframe.

5 Press Enter/Return to preview the motion tween, which animates your camera panning upward to reveal the woman’s face.

**Panning across the Stage**

Your viewers now see this mystery woman, who is looking to her left. But who or what is she looking at? Next, you’ll animate the camera to pan across the Stage to reveal the target of her gaze.

1 On the Timeline, still in the Camera layer, create a keyframe (F6) at frame 40.
The camera will hold its position from frame 25 to frame 40.

**2** Move the playhead to frame 70.

**3** Hold down Shift and drag the camera to the right to reveal the man's face.

A new keyframe is automatically created at frame 70 with the camera in its new position. The camera pans across the Stage from left to right between frames 40 and 70.

However, the man's face isn't completely in view. Next, you'll zoom the camera out slightly and Animate will tween both the pan and the zoom together.

**4** Drag the slider on the on-Stage camera control to the left to zoom out slightly.

The zoom positions the man's face off-center, so you'll have to adjust the framing slightly.

**5** Drag the camera to re-center the man's face.
6 Deselect the Loop option and preview your animation by pressing Enter/Return. The Camera slowly pans upward on the woman's face. It pauses a moment, and then pans to the right while slightly zooming out to show the man's face.

**Zooming out**

To complete the animation, you’ll zoom the camera all the way out to reveal both characters and the whole Stage.

1 On the Timeline, create a keyframe (F6) at frame 90.
   The camera will hold its position from frame 70 to frame 90.

2 Move the playhead to frame 140.

3 In the Properties panel, in the Camera Properties section, enter 100% for the Zoom.

4 Drag the camera on the Stage to re-center the view.
1. On the Timeline, create a keyframe (F6) at frame 160.

2. In the Properties panel in the Camera Color Effects section, select Adjust Color. The Brightness, Contrast, Saturation, and Hue values appear, all of them with a value of 0.

3. Move the playhead to frame 190 and create a new keyframe (F6).

4. Change the Saturation to −100 by dragging on the value, or by double-clicking on the value and entering the number.

The view through the camera becomes desaturated and all the graphics on the Stage appear black and white. Animate creates a motion tween of the camera becoming more desaturated from frame 160 to frame 190.
Testing Your Movie

You can quickly preview your animation by “scrubbing” the red playhead back and forth on the Timeline or by choosing Control > Play. You can also use the integrated Controller at the bottom of the Timeline.

However, to preview your animation as your audience will see it and to preview any nested animations within movie clip symbols, you should test your movie. Choose Control > Test.

Animate exports the published files—in this case, a SWF file—and saves them in the same location as your FLA file. The SWF file is the compressed, final Animate media that you would embed in an HTML page to play in a browser with the Flash Player. Animate displays the SWF file in a new window with the exact Stage dimensions and plays your animation.

Test your movie for both your 04CameraStart.fla document and your 04_working-copy.fla document.

To exit Test Movie mode, click the Close window button.

You can also preview your animation by choosing Control > Test Movie > In Browser, and Animate will export a SWF file and open it automatically in your default browser.

**Note** If you’ve targeted a different publishing platform with a different document type (such as Adobe AIR), those playback options will be available for you in the Control > Test Movie menu.

**Tip** The exported SWF in Test Movie mode will loop automatically. To prevent the looping in Test Movie mode, choose Control > Loop Playback while the movie is playing to deselect the Loop option.
Generating PNG sequences and sprite sheets

While you can create sophisticated animations to play as a SWF file with the Flash Player, you can also use powerful tools in Animate to create your animation and export it as a series of images for use in other environments. For example, animations with HTML5 or on mobile devices often rely on sequential PNG files or a single file that packs all the images organized in rows and columns, known as a sprite sheet. The sprite sheet is accompanied by a data file that describes the position of each image, or sprite, in the file.

Generating either PNG sequences or a sprite sheet of your animation is easy. First, your animation must be within a movie clip symbol. In the Library panel, right-click the symbol and choose Export PNG Sequence.

In the next steps, you select the destination on your hard drive for your images and the dimensions of your images.

For a sprite sheet, right-click the symbol and choose Generate Sprite Sheet. The Generate Sprite Sheet dialog box that appears provides different options, such as sizing, background color, and the particular data format.

Click Export to output the sprite sheet and data file. The data file determines what kind of development environment you’ll use your sprite sheet in. JSON, Starling, Cocos2D, and Adobe Edge Animate are some of the data formats available.
Review Questions

1. What are two requirements of a motion tween?
2. What kinds of properties can a motion tween change in an ActionScript 3.0 document?
3. What are property keyframes, and why are they important?
4. How can you edit the path of an object’s motion?
5. What does easing do to a motion tween?
6. What kind of animation is possible with the Camera tool?

Review Answers

1. A motion tween requires a symbol instance on the Stage and its own layer, which is called a tween layer. No other tween or drawing object can exist on the tween layer.

2. A motion tween creates smooth transitions between different keyframes of an object’s location, scale, rotation, transparency, brightness, tint, filter values, or 3D rotation or translation.

3. A keyframe marks a change in one or more properties of an object. Keyframes are specific to each property, so that a motion tween can have keyframes for position that are different from keyframes for transparency.

4. To edit the path of an object’s motion, choose the Selection tool and click and drag directly on the path to bend it. You can also choose the Convert Anchor Point tool and Subselection tool to pull out handles at the anchor points. The handles control the curvature of the path.

5. Easing changes the rate of change in a motion tween. Without easing, a motion tween proceeds linearly, where the same amount of change happens over time. An ease-in makes an object begin its animation slowly, and an ease-out makes an object end its animation slowly.

6. The Camera tool can change the view of the Stage. Use the Camera tool to zoom in to a different part of the Stage, zoom out to show more, rotate, or pan. You can also use the Camera tool to adjust the tint or color effect of the view.
SYMBOLS
" " (quotation marks), scripting syntax, 303, 313
. (dot) operator, scripting syntax, 303
; (semicolon), scripting syntax, 303
() (parentheses), scripting syntax, 303
{} (curly brackets), scripting syntax, 303, 307

NUMBERS
3D
animating motion, 161–164
changing symbol position, 118
perspective creating 3D feel, 120–121
positioning symbols, 116–118
3D Position, Properties panel, 120–121
3D Rotation tool
animating motion, 163–164
changing object rotation, 116–118
global vs. local transformations, 119
positioning objects in 3D space, 116
resetting transformation, 119–120
3D Translation tool
changing object position, 118–119
global vs. local transformations, 119
positioning objects in 3D space, 116
resetting transformation, 119–120

A
Accessibility section, Properties panel, 114
Actions panel
adding event listeners, 307–309
adding stop action, 305–306
assistance for writing scripts, 303
controlling Timeline, 384–385
Find And Replace command, 322
inserting JavaScript, 381
navigating, 304
pinning code in, 324
ActionScript 3.0
adding code using Code Snippets panel, 315–317
adding event listeners, 307–309
choosing playback environment, 4
commands for Timeline navigation, 309
controlling movie clips, 93
converting to HTML5 Canvas, 386
creating code snippets, 317–318
creating event handlers, 306–307
creating masks that allow transparencies, 235
creating mouse events, 308
document types, 368
Flash Player settings, 369–372
interactivity, 289–290
overview of, 301
scripting syntax, 303
sharing code snippets, 318–319
terminology of, 301–302
video, 368
video code with, 344
writing code, 304
Add Anchor Point On Graph, Motion Editor, 185
Add Ease button, 197
Add Filter button, 136
Add/Remove Camera button, 164
Add Shape Hint, 224–225
Add Web Fonts dialog box, 77
Adobe After Effects, importing elements from, 5
Adobe Color Picker, 28–29
Adobe Illustrator
copying and pasting artwork from, 92
importing elements from, 5
importing Illustrator files for use with symbols, 88–92
Adobe Integrated Runtime. See AIR (Adobe Integrated Runtime) documents
Adobe Media Encoder
adding video file to, 345–346
compressing and converting video, 329
converting video to FLV, 344
encoding process in, 348–349
preferences, 346
saving advanced options as presets, 351–352
Video tab, 361
Adobe Photoshop
importing elements from, 5
importing Photoshop file for background, 96–99
Adobe SimController, 398–401
AI format, 89
AIR (Adobe Integrated Runtime) documents
ActionScript 3.0 and, 301
choosing playback environment, 5
creating AIR applications, 389–394
document types, 368
installing AIR applications, 394–395
project file for audio and video, 331–332
runtime environments, 369
testing movies, 173
video with, 344
AIR Debug Launcher, 397–398
Align panel
aligning objects, 79–81
organizing buttons, 298
Alpha slider, 111
Alpha style, Style menu options, 134–135, 140, 320

alpha values
adding shadows, 62–63
animating transparency, 134–135
changing symbol transparency, 111
creating animation in movie clip symbols, 325–326
mask layer and, 235
modifying fills, 61–62
transparency indicated by, 51–52
video and, 358
Alt/Option key
resizing objects, 141
working with anchor points, 187
AME. See Adobe Media Encoder
anchor points
adding/deleting, 53, 59, 184–187, 277
changing curvature, 186–187
Convert Anchor Point tool, 145
moving, 187
smooth curves and, 60
Angular, Blend options, 216
animating cameras
characteristics of camera, 166
color effects, 172–173
enabling, 164–166
moving, 168
overview of, 164
panning, 168–171
zooming in, 166–167
zooming out, 171–172
animating movie clips
adding frames, 132
changing duration, 131–132
changing path of motion, 142–143
changing scale or rotation of path, 144
creating nested animations, 147–149
editing path of motion, 144–145
moving keyframes, 133
moving path of motion, 143
orienting objects to path, 146
previewing, 130–131
swapping tween targets, 146–147
testing movie, 173
working with filters, 136–138
working with position, 128–130
working with transformations, 139–142
working with transparency, 134–135
animating natural motion and characters
adding background, 277–279
adding damping effects, 283–284
armature hierarchy, 252
building first armature, 247–250
changing joint speed, 271
combining tail movement with walk cycle, 275–277
animating shapes

adding ease-in, 241–242
adding keyframes, 217–218
adding shape hints, 227
adding tween to masked layer, 237–240
adjusting gradient fills, 231–234
animating color, 230–231
applying shape tween, 215
Blend options, 216
broken shape tweens, 220
creating and using masks, 234
creating keyframes, 213–214
creating mask layer, 235–236
creating shape tween, 213
defining mask layer, 234–235
duplicating keyframes to create looping, 220–221
easing shape tweens, 241
extending shape tweens, 219–220
inserting animation into movie clip, 222–223
moving keyframes to change pace, 216–217
overview of, 210–213
previewing animations with onion skinning, 227–230
previewing loop, 221
project file, 213
removing shape hints, 227
review, 243
variable widths for shape tweens, 223
viewing mask effects, 236
animating symbols
3D motion and, 161–164
about animation, 127
applying eases to motion tweens, 157–159
changing appearance of graphics, 160–161
easing, 156
frame-by-frame animation, 159
Frame Picker for selecting frames to align sounds, 150–156
generating PNG sequences and sprite sheets, 174
graphic symbols, 150
inserting new keyframe, 159–160
motion tweening in, 125
movie clips. See animating movie clips overview of, 124, 126
project file contents, 127–128
review, 175
splitting motion tweens, 156–157
animation (generally)
overview of, 127
uses of symbols, 93
Application bar, 5
applications/apps
creating AIR applications, 389–394
installing AIR applications, 394–395
publishing desktop applications, 389
simulating mobile apps, 398–401
testing mobile apps, 397–398
arguments, scripting terminology, 302
armatures, for character animation
adding/removing bones, 253
animating tail shape, 274–275
building, 247–250
changing joint speed, 271
constraining translation of joints, 264–265
defined, 247
defining bones for springiness simulation, 280–281
defining bones inside a shape, 272–273
disabling joint rotation, 272–273
dragging to Stage, 128
extends, 250–251
hierarchy of, 252
inserting poses, 282–283
isolating rotation of individual bones, 258–259
modifying joint position, 254–255
moving bones, 252–253
moving tail, 274–275
overview of, 250–251
pinning individual bones, 259–260
posing armature to create walk cycle, 257–258
rearranging armature stacking order, 255–256
review, 285
setting spring strength for each bone, 281–282
simulating physics with springiness, 279
Stage controls for joint constraints, 266–267
animating shapes

Arrow keys
navigating ease types, 197
working with anchor points, 187
Art brushes, 67–68, 70
artwork, importing, 88–92
AS3 documents, converting to HTML5 Canvas, 386–388
assets
accessing in CC Libraries panel, 9
publishing image assets, 388–389
sharing, 122
audio (sound)
adding to button symbol, 293
adding to buttons, 342–343
adding to Timeline, 334–335
advanced options, 351–352
changing volume, 338–341
clipping, 336–338
deleting or changing sound files, 341–342
Flash Player settings, 371
importing, 332–334
inserting frames for, 336
overview of, 328–331
project file contents, 331–332
review, 365
Sound Properties, 333
SoundJS library, 373
sync options, 335
Audio splitting, 339
Auto-Recovery feature, for backup and recovery, 33–34
B
backgrounds
adding to character animation, 277–279
for bitmaps, 114
importing Photoshop file for, 96–99
backup and recovery, 34
Bitmap Background menu, 114
Bitmap Properties dialog box, 25
bitmaps
adding fills, 50
backgrounds, 114
converting vector art to, 81–82
dragging to Stage, 128
formats supported in Animate, 100
importing to Stage, 236
JPEG compression levels and, 371
swapping bitmaps and symbols, 295–297
Blend options, Properties panel, 113, 216
blur filters
animating, 136–138
applying to symbols, 114–116
Bone tool
building first armature, 247–250
defining bones, 272–273
extending armature, 250–251
use for inverse kinematics, 245

ANIMATE CC CLASSROOM IN A BOOK (2017 RELEASE) 409
bones, in character animation
  adding/removing, 253
building armature, 247–250
constraining range of joint rotation, 263–264
constraining translation of joints, 264–265
defining generally, 280–281
defining inside a shape, 272–273
definition of, 247
disabling joint rotation, 261–263
editing shapes containing, 277
extending armature, 250–251
hierarchy of, 252
isolating rotation of, 258–259
modifying joint position, 254–255
moving, 252–253
pinning, 259–260
rearranging armature stacking order, 255–256
setting spring strength for, 281–282
Stage controls for constraints, 266–267
borders, adding decorative, 65
bounce effects
  animating, 199–202
  BounceIn ease, 203–205
brackets, curly ({}), scripting syntax, 303, 307
Break Apart command, returning symbols to original form, 106
Bright slider, 110–111
brightness
  Camera Color Effects, 172
  of symbol, 110–111
Brush library panel. See also paint brushes
  exploring, 63–65
  managing paint brushes, 69
  pattern brushes, 66
button symbols
  adding instances, 314–315
  adding sounds, 342–343
  animating, 324
  creating, 290–294
  duplicating, 294–295
  event handlers for, 306–307
  home button, 314
  naming instances, 299–300
  placing instances, 298–299
types of symbols, 93–94
C
  cache, clearing, 369
Camera Color Effects, Properties panel, 172–173
Camera Properties, Properties panel, 171
Camera tool, 164–165
cameras
  characteristics of, 166
  color effects, 172–173
  enabling, 164–166
  moving, 168
  panning, 168–171
  zooming in, 166–167
  zooming out, 171–172
Canvas document. See HTML5 Canvas documents
CC Libraries. See Creative Cloud Libraries
color.
  See also
  Alpha style, 140
color animation. See character animation
  See also animating natural motion and characters
classic tweens
  applying, 375–377
  overview of, 373
Clear Guides command, 110
clip handling
  adding next motion tween, 194–196
  applying to selection, 43–44
  duplicating keyframes, 220–221
  duplicating layers, 22
  duplicating motion tweens, 191–192
  duplicating property curves, 189–191
  filter options, 116
  overview of, 129
Create JS, 372–373
Create Motion Tween command
  adding motion tweens, 181–182
  adding next motion tween, 194–196
  applying to selection, 43–44
  animating motion, 162
  creating custom snippets, 137–138
  creating motion tweens, 181–182
  creating nested animations, 148–149
  creating transition animations, 320
  creating AVI video, 345
  creating Flash video, 345
  creating HTML5 Canvas code snippets, 381
  creating motion tweens, 181–182
  creating nested animations, 148–149
  overview of, 129
Create New Library dialog box, 122
Create New Symbol dialog box, 222
Create Shape Tween dialog box, 215, 219–220, 240
Creative Cloud Libraries, accessing assets, 9
  sharing assets, 122
curves. See also property curves
  creating, 57–58
  editing, 58–59
Cut command
  frames, 221
  layers, 22
D
damping effects, applying to spring effect, 283–284
debugging code, 309–310
Delete command
  anchor points, 59, 184–188, 277
  audio (sound) file, 341–342
  keyframes, 19
  property curves, 188
desktop applications, publishing. See also AIR (Adobe Integrated Runtime)
documentation, 389
Display, Properties panel
  Blend menu, 113
  Export As Bitmap in Render menu, 113–114
  Visible option, 112
E
Ease panel, 206
eases/easing
adding ease-in, 196–198, 241–242
adding ease to inverse kinematics, 270
adding second ease to different property curve, 206–207
animating bounces, 199–202
applying easings to motion tweens, 157–159
applying easings to shape tweens, 241
BounceIn ease, 203–205
complex easings, 193
overview of, 156
removing easings, 199
splitting motion tweens, 156–157
Edit bar, on Stage, 5, 105
Edit Document command, 223
Edit Envelope dialog box, 337–338
editing
curves using Selection tools, 58–59
line width, 52–53
Photoshop files, 99
property curves, 182–184
shapes, 43, 277
symbols in library, 101–103
symbols in place, 103–105
text, 71
embedding video
in ActionScript or AIR documents, 344
overview of, 361–362
using embedded video, 362–364
Enable/Disable Filter button, 116
encoding video
adding video file to Adobe Media Encoder, 345–346
converting video files, 346–349
overview of, 344
understanding encoding options, 349
error checking, 309–310
event handlers
adding click response, 382–384
adding event listeners, 307–309
creating, 306–307
Export As Bitmap, in Render menu, 113–114
Export Settings dialog box
advanced video and audio options, 351
encoding options, 349
saving advanced video and audio options as presets, 351–352
exporting
art as PNG, JPEG, or GIF file, 82–83
art as SVG file, 83
to HTML5, 378–379
symbols as bitmap, 113–114
Eyedropper tool, for color matching, 79–81
File
file formats
audio formats, 332
document formats, 4
Illustrator files, 5
Illustrator files (AI), 89
image formats, 82–83, 100
SWF files, 369–372
video formats, 358, 361–362, 368
files
adding video file to Adobe Media Encoder, 345–346
converting video files, 344, 346–349
deleting or changing sound files, 341–342
exporting SWF files, 173
finding video files, 345
importing Photoshop file for background, 96–99
importing sound files, 332–334
importing SVG files for use with symbols, 92
importing to Library panel, 9–10
importing to Stage, 89
opening, 2
fills
adding bitmap fills, 50
adding gradient fills, 237–239
adjusting gradient fills, 231–234
applying new fill color, 102–103, 105
changing, 45
defining bones inside a shape, 272–273
editing shapes containing bones, 277
mask layer and, 235
modifying alpha values of, 61–62
Paint Brush tool, 63
selecting, 42
understanding, 40–41
using gradient and bitmap fills, 47–49
filters
animating, 136–138
applying to symbols, 114–116
Filters section, Properties panel, 115–116, 136–138
Find And Replace command, Actions panel, 322
FLA files
saving documents, 4
saving projects, 368
setting frame rate to match FLV file, 361
Flash Player
converting AS3 to HTML5 Canvas, 387
converting to HTML5 Canvas, 386
runtime environments for ActionScript 3.0, 368
settings, 369–372
viewing movie clips, 88
FLV files
converting video to, 344
embedding video and, 361–362
video and transparency and, 358
FLVPlayback
controlling video playback, 356–358
playing H.264 video, 355
folders
adding layers to layer folders, 21–22
creating layer folders, 20–21
fonts, 116
Format Code command, 385
formats. See file formats
frame-by-frame animation
changing appearance of graphics, 160–161
inserting new keyframe, 159–160
overview of, 159
frame labels, 312–314
Frame Picker, 152–156
frame rate, viewing on Timeline, 11
Frame View menu, 12
frames. See also keyframes
adding to movie clip, 132
align sounds to graphics, 150–156
changing animation duration, 131–132
creating, 16–18
inserting, 15–16, 213–214
inserting audio frames, 336
inserting keyframes, 194
moving keyframes, 19, 133
removing keyframes, 19
selecting multiple, 16
Free Transform tool
animating transformations, 139–142
changing scale or rotation of path, 144
(continued)
INDEX

changing size and position of symbol, 107–108
creating nested animations, 148–149
editing shapes, 43–44
modifying position of joint in armature, 254–255
moving bones of armature, 252–253
rotating movie clip, 201

functions
creating, 307
scripting terminology, 302

G
Gap Size menu, fills, 45
GIF files
bitmap formats supported in Animate, 100
exporting art as, 82–83
Global Transform, 3D options
animating motion, 163
vs. local transformations, 119
Google, using dynamic text, 71
GotoAndPlay command, 319, 322
gotoAndStop command, 313–314
gradient fills
adding tween to masked layer, 237–239
adjusting, 231–234
creating transitions, 47–49
overview of, 47
Gradient Transform tool, 49, 231–234, 237–239
graphic symbols
animating, 150
Frame Picker for selecting frames to align sounds, 150–156
scaling, 139
types of symbols, 94
graphics
adding bitmap fills, 50
adding/deleting anchor points, 59
adding dynamic text, 71–72
adding shadows, 62–63
adding variable-width lines, 51–52
adding web fonts, 72–75
aligning and distributing objects, 79–81
changing appearance of, 160–161
changing shape contours, 44
changing strokes and fills, 45
converting vector art to bitmap, 81–82
copying and pasting, 43–44
creating and editing text, 71
creating and using tagged swatches, 54–56
creating curves, 57–58
creating decorative patterns, 65–66
creating depth using transparency, 61
creating gradient transitions, 47–49
creating paths, 60
creating shapes, 41
drawing modes, 46
editing curves, 58–59
editing line width, 52–53
editing or creating Art or Pattern brushes, 67–68
editing shapes, 43
exploring Brush library, 63–65
exporting art, 82–83
Free Transform tool, 43
getting started, 40
Gradient Transform tool, 49
grouping objects, 50–51
identifying your domain, 75–76
managing paint brushes, 69
matching color, 79
modifying alpha values, 61–62
Oval tool, 41–42
overview of, 38–39
Paint Brush tool, 63
pressure-sensitive tablets, 70
Rectangle tool, 41
removing web fonts, 76–78
review, 84–85
rotating Stage for easier drawing, 70
saving swatches, 53–54
selecting strokes and fills, 42
understanding strokes and fills, 40–41
updating tagged swatches, 56
grids
aligning and distributing objects, 79–81
positioning objects on Stage, 7
groups
as collection of panels, 26–27
of objects, 50–51
guides, for placing symbols, 109–110

H
H.264
converting video for use in Animate, 346–347
embedding, 353
FLVPlayback, 355
History panel, 30–31
hit keyframe, buttons and, 294
Home button, 314
HTML5
choosing playback environment, 4
identifying your domain where project hosted, 75–76
HTML5 Canvas documents
adding click response, 382–384
converting AS3 to, 386–388
document types, 368
exporting to, 378–379
interactive navigation, 290
publishing, 372–373
runtime environments, 368
supported features, 379
using code snippets, 381
video with, 344, 357
hue, Camera Color Effects, 172

I
Illustrator. See Adobe Illustrator
ing images
exporting, 82–83
formats, 100
publishing, 388–389
Import To Library, 9–10, 334
Import To Stage, 10, 96–99, 236
Import Video, 353, 358–360
importing
advanced options, 89–91, 96–97
artwork, 92
bitmap to Stage, 236
Illustrator files, 5, 88–92
items to Library panel, 9–10
items to Library panel and adding to Stage, 10
Photoshop file for background, 96–99
simple options, 91, 99
sound files, 332–334
SVG files, 92
symbols, 94
video clips, 358–360
Ink Bottle tool, changing strokes and fills, 45, 277
interactivity. See also navigation, interactive
ActionScript 3.0 for, 289–290
adding stop action to interactive movie, 305–306
button symbols for, 93–94
interactive movies, 289–290
inverse kinematics. See also animating
natural motion and characters
adding eases, 270
animating natural motion, 246–247
defined, 245
with shapes, 271
invisible buttons, 294
iOS devices
mobile apps and, 401–402
publishing to, 397

J
JavaScript
adding interactivity to HTML5 Canvas documents, 368
adding to Action panel, 381
controlling Timeline, 384–385
Create JS, 372–373
exporting to HTML5 and, 378–379
joints, of character armature
changing joint speed, 271
constraining range of rotation, 263–264
constraining translation, 264–265
defined, 247
disabling rotation, 261–263
modifying joint position, 254–255
Stage controls for constraints, 266–267
JPEG images
adding bitmap fills, 50
bitmap formats supported in Animate, 100
compression levels and, 371
exporting art as, 82–83
symbols containing, 93

K
keyframes
adding sounds to Timeline, 334–335
aligning sounds, 150–156
animating filters, 136–138
animating tail shape, 274–275
animating transparency, 134–135
changing animation duration, 131–132
changing appearance of graphics, 160–161
color effects, 172–173
creating, 16–18
creating destination keyframes, 310
creating for different shapes, 213–214
duplicating to create looping, 220–221
fixing broken tween, 220
inserting additional, 217–218
inserting for different content, 310–312
inserting for movie clip, 375
inserting for shape, 214
inserting new, 159–160
inserting poses for walk cycle, 268–270
inserting tween to masked layer, 239
labeling, 312–314
moving, 19, 133
moving to change pace, 216–217
panning with camera and, 169–171
removing, 19
span-based selection of, 133
tweening, 127
understanding property keyframes, 138
zooming in, 166–167
zooming out, 171–172
keywords, scripting terminology, 302

L
Lasso tool, 42
Layer Properties dialog box, 14, 234
layers
adding, 13–14
adding to layer folders, 21–22
creating layer folders, 20–21
creating mask layer, 235–236
cut, copy, paste, duplicate, 22
defining mask layer, 234–235
hiding content or making transparent, 14
import options, 91–92, 99
locking, 139
renaming, 12–13
viewing on Timeline, 11
working with, 15
workspace and, 5
libraries
for asset sharing, 122
brush library, 63–65
creating, 122
editing symbols, 101–103
organizing symbols, 101
Library Options menu, 122
Library panel
adding items to Stage, 10
creating new library, 122
dragging movie clip from, 146
dragging symbol from, 106
Duplicate command, 294–295
editing symbols, 101–103
importing items to, 9–10, 332–334
organizing symbols, 101
overview of, 9
storing symbols, 87, 93
Line tool, 65
lines
adding variable-width lines, 51–52
editing line width, 52–53
Lock Fill option, 48–49
Lock Guides command, 110
Lock Option, Timeline, 131, 158–159
Loop Playback, Timeline, 173, 221, 270
Looping section, Properties panel, 152
loops/looping
controlling Loop Playback, 173
duplicating keyframes to create, 220–221
movie clips, 220
previewing, 221
walk cycle as looping animation, 257
LZMA, for SWF compression, 371

M
magnification. See zooming
markers, adjusting for onion skinning, 230
masks
adding tween to masked layer, 237–240
creating and using, 234
creating mask layer, 235–236
defining mask layer, 234–235
function of, 211
traditional, 237
viewing mask effects, 236
Media Browser, finding video files, 345
Merge Drawing mode, 46
methods, scripting terminology, 302
Microsoft Active Accessibility (MSAA), 114
mobile apps
publishing, 401–404
simulating, 398–401
testing, 397–398
mobile devices, publishing to, 397
Modify Marker button, Timeline, 221
Motion Editor
adding anchor points, 184–186
adding complex eases, 193
adding ease-in, 196–198
adding second ease to different property curve, 206–207
BounceIn ease, 203–205
changing curvature of property curves, 186–187
copying and pasting property curves, 189–191
deleting anchor points, 187–188
deleting property curves, 188
duplicating motion tweens, 191–192
editing property curves, 182–184
moving anchor points, 186–187
overview of, 179–180
removing eases, 199
review, 208–209
values in, 184
view options for, 188–189
viewing effects of properties on objects, 138
motion, natural. See animating natural motion and characters
Motion Presets panel, 142, 321
motion tweens
adding, 181–182, 194–196
adding anchor points, 184–186
adding ease-in, 196–198
adding second ease to different property curve, 206–207
animating bounces, 199–202
changing curvature, 186–187
comparing with classic tweens, 373
copying and pasting property curves, 189–191
duplicating, 129–130, 319–320
deleting anchor points, 187–188
deleting property curves, 188
duplicating motion tweens, 191–192
easing, 156–159
editing property curves in Motion Editor, 182–184
Motion Editor, 179–180
moving anchor points, 187
overview of, 125, 127, 176–179
project file contents, 180
removing, 130
removing eases, 199
review, 208–209
saving as presets, 142, 321
splitting, 156–157
swapping tween targets, 146–147
understanding Motion Editor values, 184
using BounceIn ease, 203–205
view options for Motion Editor, 188–189

mouse events, 308
Move Guide dialog box, 109–110

ANIMATE CC CLASSROOM IN A BOOK (2017 RELEASE) 413
movie clip symbols
  adding background to character animation, 277–279
  adding instance to Stage, 378
  adding/removing bones from armature, 253
  converting text to symbol, 117
  creating, 95–96, 374–375
  creating animation in, 324–326
  inserting animation into, 222–223
types of symbols, 93
visible property applied to, 112
visual effects in, 90
movie clips, animating
  adding frames, 132
  changing duration, 131–132
  changing path of motion, 142–143
  changing scale or rotation of path, 144
  creating nested animations, 147–149
  editing path of motion, 144–145
  moving keyframes, 133
  moving path of motion, 143
  orienting objects to path, 146
  previewing, 130–131
  swapping tween targets, 146–147
testing movie, 173
  working with filters, 136–138
  working with position, 128–130
  working with transformations, 139–142
  working with transparency, 134–135
MSAA (Microsoft Active Accessibility), 114

N
naming rules, 300
natural motion, animating. See animating natural motion and characters
navigation, interactive
  ActionScript 3.0 for writing code, 304
  adding ActionScript code, 315–317
  adding button instances, 314–315
  adding event listeners, 307–309
  adding stop action, 305–306
  animating buttons, 324
  checking for errors, 309–310
  creating animation in movie clip symbols, 324–326
  creating button symbols, 290–294
  creating code snippets, 317–318
  creating destination keyframes, 310
  creating event handlers for buttons, 306–307
  creating home button, 314
  creating transition animations, 319–321
  duplicating buttons, 294–295
  gotoAndPlay command, 322
  inserting keyframes with different content, 310–312
  interactive movies and, 289–290
  labeling keyframes, 312–314
  naming button instances, 299–300

overview of, 286–289
placing button instances, 298–299
preparing interactive animation, 319
review, 324–326
sharing code snippets, 318–319
stopping animations, 322–323
swapping bitmaps and symbols, 295–297
nested animations, 147–149
New Document dialog box, 3
New Workspace dialog box, 6

O
Object Drawing mode, 46
objects
  aligning and distributing, 79–81
  grouping, 50–51
  scaling relative to control points, 42
  scripting terminology, 302
Onion Skin Outlines button, Timeline, 228–229
onion skinning
  adjusting markers for, 229–230
  customizing colors, 230
  previewing animations, 227–228
  turning on, 228–229
Orient To Path option, Rotation, 146
Oval tool
  adding shadows, 62–63
  creating shapes, 41–42
paths
  changing path of motion, 142–143
  changing scale or rotation, 144
  creating with Pen tool, 60
  editing path of motion, 144–145
  moving path of motion, 143
  orienting objects to, 146
Pattern brushes
  in Brush library, 66
  creating, 67–68
  designing patterns, 65–66
  designing symbols, 374–375
Pen tool
  adding/deleting anchor points, 59
  creating curves, 57–58
  creating paths, 60
Pencil tool, 51–52
Perspective Angle value, 121
perspective, to create 3D feel, 120–121
phonemes, selecting frames to align sounds, 150–156
Photoshop. See Adobe Photoshop
Pin option, Properties panel, 259–260
pixels, resizing and scaling content, 32–33
Play command
  playing animation, 130, 152
  playing shape tween, 215
  testing movie, 173
playback
  controlling video playback, 356–358
  previewing animations, 130–131
  of video, 352–356
playback (runtime) environment, in determining document type, 4–5
playhead, 350
PNG files
  bitmap formats supported in Animate, 100
  exporting art as, 82–83
  generating PNG sequences, 174
PolyStar tool, 27–30
poses, in character animation
  creating walk cycle, 257–258
  inserting for walk cycle, 268–270
  inserting generally, 282–283
Position and Size, Properties panel, 312
positioning
  animating position, 128–130
  changing symbol position, 106–108, 118
  symbols in 3D space, 116–118
preferences
  Adobe Media Encoder, 346
  Animate, 7
  Auto-Recovery, 34
  color, 230
  Preset Browser, 345
  pressure-sensitive tablets, 70
preview

animation of transparency, 135
animations or movies, 31–32
looping, 221
movie clip, 130–131
nested animation, 149
with onion skinning, 227–230
Primitive Drawing mode, 46
projectors, 395–397
properties
scripting terminology, 302
understanding property keyframes, 138
Properties panel
3D Position, 120–121
Accessibility, 114
alpha values, 51–52
Blend, 113, 216
Camera Color Effects, 172–173
Camera Properties, 171
color options, 28–29
eases/easing, 158, 241–242
fill color, 45
Filters, 115–116, 136–138
getting to know workspace, 5
Looping, 152
offsets, 264
Orient To Path, 146
overview of, 23
Pin, 259–260
Position and Size, 312
positioning objects on Stage, 23–25
Render menu, 113–114
resizing and scaling content, 32–33
scaling graphics, 139
Speed, 271
Spring, 281–282
Stage properties, 8–9
Text Type, 116
translations, 265
Visible, 112
x and y coordinates, 129
property curves
changing curvature, 186–187
copying and pasting, 189–191
defined, 182–184
deleting, 188
eases/easing, 206–207
editing, 182–184
moving anchor points, 187
vs. ease curves, 199
PSD files, 100
Publish Settings dialog box, 370–372, 379–381, 389
publishing
adding click response, 382–384
adding movie clip instance, 378
applying classic tween, 375–377
classic tweens, 373
clearing cache, 369
controlling Timeline, 384–385
converting AS3 to HTML5 Canvas, 386–388
creating AIR applications, 389–394
creating movie clips, 374–375
creating projectors, 395–397
desktop applications, 389
document types, 368
exporting to HTML5, 378–379
Flash Player settings, 369–372
for HTML5, 372–373
HTML5 Canvas code snippets and, 381
image assets and, 388–389
inserting JavaScript, 381
inserting keyframes and changing instance, 375
installing AIR applications, 394–395
mobile apps, 401–404
to mobile devices, 397
overview of, 366–367
Publish Settings dialog box, 379–381
review, 406–407
runtime environments, 368–369
Simulating mobile apps, 398–401
testing mobile apps, 397–398
WebGL animations, 397
Q
quality settings, filters, 115
quotation marks (“ “), scripting syntax, 303
R
Rectangle tool, 41, 272–273
Refine Tween command, 196
Remove Motion command, 196
Render menu, Export As Bitmap, 113–114
Reset Filter command, 116
Rotate control, cameras, 166
rotation
changing rotation of path, 144
constraining range of joint rotation, 263–264
disabling joint rotation, 261–263
isolating rotation of individual bones, 258–259
Orient To Path option, 146
rotating Stage for easier drawing, 70
Rotation tool, 70
rotsoping, 353
rulers
aligning and distributing objects, 79–81
placing symbols, 109–110
positioning objects on Stage, 7
runtime environments, 368–369
S
sans serif fonts, 77
saturation, Camera Color Effects, 172
Save As Preset command
filters, 116
motion tweens, 142
saving
animations or movies, 33
swatches, 53–54
workspace, 6–7
XFL documents, 34–35
Scalable Vector Graphics (SVG)
extporting, 83
importing, 92
scripting. See ActionScript 3.0
selection
of multiple frames, 16
overview of, 27–30
Selection tool
changing shape contours, 44
creating shapes, 41
defining bones inside a shape, 272–273
editing curves, 58–59
grouping objects, 50–51
manipulating path of motion, 145
posing armature to create walk cycle, 257–258
rearranging armature stacking order, 255–256
selecting fill color, 47
selecting strokes and fills, 42, 53
using Copy and Paste, 43–44
semicolon (;), scripting syntax, 303
serif fonts, 77
shadows, adding, 62–63
shape hints
adding, 224–227
removing, 227
shape tweens
adding additional keyframes, 217–218
adding shape hints, 224–227
adding to masked layer, 237–240
adjusting gradient fills, 231–234
animating color, 230
animating shapes, 212–213
applying, 215
broken, 220
creating, 213
easing, 241
extending, 219–220
function of, 211
moving keyframes to change pace, 216–217
variable widths for, 223
shapes
adding additional keyframes, 217–218
adding ease-in, 241–242
adding shape hints, 224–227
adding tween to masked layer, 237–240
adjusting gradient fills, 231–234
animating color, 230
animating shapes, 212–213
applying, 215
broken, 220
creating, 213
easing, 241
extending, 219–220
function of, 211
moving keyframes to change pace, 216–217
variable widths for, 223
(continued)
Blend options, 216
broken shape tweens, 220
changing shape contours, 44
creating, 41
creating and using masks, 234
creating keyframes for, 213–214
creating mask layer, 235–236
creating shape tween, 213
defining mask layer, 234–235
duplicating keyframes to create looping, 220–221
easing shape tweens, 241
eering, 43
extending shape tweens, 219–220
inserting animation into movie clip, 222–223
moving keyframes to change pace, 216–217
overview of, 210–213
previewing animations with onion skinning, 227–230
previewing loop, 221
project file, 213
removing shape hints, 227
review, 243
understanding strokes and fills, 40
variable widths for shape tweens, 223
viewing mask effects, 236
shapes, inverse kinematics with
adding background, 277–279
combining tail movement with walk cycle, 275–277
defining bones inside a shape, 272–273
editing shapes, 277
moving tail armature, 274–275
overview of, 271
sharing assets, 122
Shift key
constraining transformation, 108
isolating rotation of individual bones of character armature, 259
working with anchor points, 187
SimController (Adobe), 398–401
simulation, of physics. See springiness, simulating in character animation
size, changing symbol size, 106–108
skins, choosing video interface style, 354
smooth points, 60
smoothing option, working with images, 25
Snap To Objects
adding shape hints, 224
creating shapes, 41–42
sound. See audio (sound)
span-based selection, of keyframes, 133
special effects
applying filters to symbols, 114–116
uses of symbols, 93
Speed option, Properties panel, 271
Split Audio, 339
Split Motion
adding next motion tween, 195
animating bounces, 200
splitting motion tweens, 156–157
Spring option, Property panel, 281–282, 283–284
springiness, simulating in character animation
adding damping effects, 283–284
defining bones, 280–281
inserting poses, 282–283
overview of, 279
setting spring strength for each bone, 281–282
sprite sheets, generating, 174
stack as collection of panels, 26–27
stacking order, rearranging character armature, 255–256
Stage
adding items from Library panel, 10
adding movie clip instances, 378
area of workspace, 7–8
changing size to match Photoshop canvas, 99
changing Stage properties, 8–9
creating symbols, 94–96
dragging bitmap to, 128
dragging symbol to Stage, 106
editing symbols in place, 103–105
function of, 1
getting to know workspace, 5
importing files to, 89
keyframe indicating change in content, 16
modifying, 32–33
positioning objects on, 23–25
rotating for easier drawing, 70
Star tool, 29
start-up, Adobe Animate CC, 2
static text, 71, 116
stop action
stopping animation, 322–323
stopping interactive navigation, 305–306
strokes
changing, 45
changing color of style, 277
mask layer and, 235
Paint Brush tool, 63
selecting, 42
setting stroke size, 52
understanding strokes and fills, 40–41
Style menu
Alpha option, 134–135, 140, 320
changing symbol brightness, 110
changing symbol transparency, 111
Subselection tool
editing curves, 58–59
manipulating path of motion, 145
selecting strokes and fills, 42
SVG (Scalable Vector Graphics)
exporting, 83
importing, 92
Swap Symbol dialog box, 296
swatches
accessing preset colors from Swatches panel, 53–54
creating and using tagged, 54–56
saving, 53–54
updating tagged swatches, 56
Swatches panel, 53–57
SWF files
ActionScript 3.0 document published to, 368
exporting, 173
Flash Player settings, 369–372
symbols
animating. See animating symbols
applying filters to, 114–116
blending effects, 113
breaking apart, 106
button symbols. See button symbols
changing 3D position, 118
changing brightness, 110–111
changing size and position, 106–108
changing transparency, 111
creating, 94–96
defined, 87
display options, 112
drawing from library, 101–103
drawing in place, 103–105
exporting as bitmap, 113–114
graphic symbols. See graphic symbols
importing, 94
importing Illustrator files for use with, 88–92
importing Photoshop file for background, 96–99
importing SVG files for use with, 92
inserting, 222
movie clip symbols. See movie clip symbols
organizing in library, 101
overview of, 86, 93
perspective to create 3D feel, 120–121
positioning in 3D space, 116–118
resetting transformation, 119–120
review, 123
rulers and guides in placing, 109–110
storing in Library panel, 9
swapping bitmaps and symbols, 295–297
visible property applied to movie clips, 112
working with in Illustrator, 94
Symbols panel, in Illustrator, 94
Sync menu, audio (sound), 335
T
tables, pressure-sensitive, 70
tagged swatches
creating and using, 54–56
overview of, 53
updating, 56
Test command
error checking, 309–310
previewing button behavior, 299
previewing imported video, 360
previewing mask effects, 236
previewing movie, 173
previewing movie clip background, 279
previewing movie in Browser, 31
previewing nested animation, 149
previewing shape tween, 240
text
adding dynamic, 71–72
adding titles, 116–117
adding web fonts, 72–75
changing object position, 118–119
converting text layer to mask layer, 235
converting to symbol, 117
creating and editing, 71
import options, 92, 99
removing web fonts, 76–78
static, 116
Text tool, 71–72, 116, 235
Timeline
ActionScript commands for navigating, 309
adding frames, 132
adding layers, 13–14
adding layers to layer folders, 21–22
adding stop action, 305–306
adjusting video length, 350
applying classic tween, 375–377
button states and, 290
changing appearance of, 12
controlling, 384–385
creating keyframes, 16–18
creating layer folders, 20–21
cut, copy, paste, duplicate layers, 22
deleting or changing sound files, 341–342
editing poses, 270
function of, 1
going to know workspace, 5
inserting frames, 15–16, 214
inserting keyframes, 214, 310–312
keyframes for animating tail shape, 274–275
Layer Properties dialog box, 234
locking layers, 139
Loop button, 221
Loop Option, 158–159
moving keyframes, 19
Onion Skin Outlines button, 228–229
placing sounds on, 334–335
preparing for interactive navigation, 305
previewing animations, 130–131
removing keyframes, 19
renaming layers, 12–13
selecting multiple frames, 16
span-based selection of keyframes, 133
understanding, 11
working with layers, 15
Tools panel. See also by individual tools
getting to know workspace, 5
overview of, 27
selecting and using tools, 27–30
Trace Bitmap command, 100
Transform panel
resetting transformation, 119–120
rotating photos, 23–25
scaling transformations, 139
transformations
animating, 139–142
changing scale or rotation of path, 144
changing symbol position, 118–119
Free Transform tool. See Free Transform tool
global vs. local transformations, 119
Gradient Transform tool. See Gradient Transform tool
positioning symbols in 3D space, 116–118
resetting, 119–120
transitions
creating gradient transitions, 47–49
creating transition animations, 319–321
translation options, constraining translation of joints, 264–265
transparency
adding shadows, 62–63
alpha values, 51
animating, 134–135
Bitmap Background menu, 114
changing symbol transparency, 111
creating animation in movie clip, 325–326
Layer Properties dialog box, 14
transition animation and, 320
using to create depth, 61
video and, 358
trimming video, 350
tweens/tweening
motion tweens. See motion tweens
overview of, 127
shape tweens. See shape tweens
typefaces, serif and sans serif, 77
Typekit
adding web fonts, 72–75
identifying your domain where project hosted, 75–76
removing web fonts, 76–78
using dynamic text, 71
U
Undo command, 30–31, 106
V
vanishing point, in creating perspective, 120–121
variable widths
adding variable-width lines, 51–52
for shape tweens, 223
Variable Width Stroke tool, 223
variables, scripting terminology, 301
vector graphics
converting bitmaps to/from, 100
converting vector art to bitmap, 81–82
video
with ActionScript 3.0 or AIR documents, 344
adding video file to Adobe Media Encoder, 345–346
adjusting length, 350
controlling playback, 356–358
converting video files, 346–349
encoding, 344
with HTML5 Canvas documents, 344
importing, 358–360
overview of, 328–331
playback, 352–356
project file contents, 331–332
review, 365
setting and saving advanced options, 351–352
transparency and, 358
understanding encoding options, 349
using embedded video, 362–364
View Magnification options, 8
View menu, 179
Visible option, Properties panel, 112
volume, of audio, 338–341
W
Wacom tablets, 70
walk cycle, in character animation combining tail movement with, 275–277
constraining range of joint rotation, 263–264
constraining translation of joints, 264–265
creating, 257
disabling joint rotation, 261–263
inserting poses, 268–270
isolating rotation of individual bones, 258–259
pinning individual bones, 259–260
posing armature to create walk cycle, 257–258
waveform. See also audio (sound)
adding sound to button symbol, 293
(continued)
adding sounds to Timeline, 334–335
clipping end of audio file, 337–338
web fonts
adding, 72–75
identifying your domain where project hosted, 75–76
removing, 76–78
searching for right font, 77
using dynamic text, 71
WebGL
choosing playback environment, 4
publishing, 397
runtime environments, 368
Width tool, 52–53
workspace
changing Stage properties, 8–9
choosing new, 6
getting to know, 5
saving, 6–7
Stage area of, 7–8

X
x and y coordinates
positioning buttons, 299
positioning objects on Stage, 23
rulers and guides in placing symbols, 109
setting in Properties panel, 129
X and Y property curves
adding anchor points, 184–186
adding ease-in, 196–198
adding second ease to different property curve, 206–207
BounceIn ease, 203–205
changing curvature, 186–187
copying and pasting, 189–191
deleting, 188
editing in Motion Editor, 182–184
understanding Motion Editor values, 184

XFL files
documents saved as, 4
modifying, 35–36
saving, 34–35
saving projects as, 368

Y
Y coordinates. See x and y coordinates
Y property curves. See X and Y property curves

Z
Zoom control, cameras, 166
zooming
in with camera, 166–167
out with camera, 171–172
view options for Motion Editor, 188–189