Learn how to create webpages for the modern web; use and customize web frameworks to build responsive designs for a wide variety of desktop computers and mobile devices with a minimum of hand coding; incorporate graphics, text, animation, and video; build rich interactive applications; add links to text and images; add interactive elements to your sites, such as HTML5-compatible video and animation; work with HTML5 and CSS3 code and structures; and publish a finished site to the web.

“The Classroom in a Book series is by far the best training material on the market. Everything you need to master the software is included: clear explanations of each lesson, step-by-step instructions, and the project files for the students.”

Barbara Binder,
Adobe Certified Instructor
Rocky Mountain Training

What you need to use this book: Adobe Dreamweaver CC (2015 release) software, for either Windows or Mac OS. (Software not included.)

Note: Classroom in a Book does not replace the documentation, support, updates, or any other benefits of being a registered owner of Adobe Dreamweaver software.

Adobe Dreamweaver CC 2015 release
CLASSROOM IN A BOOK®

The fastest, easiest, most comprehensive way to learn Adobe Dreamweaver CC (2015 release)

Classroom in a Book, the best-selling series of hands-on software training workbooks, offers what no other book or training program does—an official training series from Adobe Systems Incorporated, developed with the support of Adobe product experts.

Adobe Dreamweaver CC Classroom in a Book (2015 release) contains 14 lessons that cover the basics and beyond, providing countless tips and techniques to help you become more productive with the program. You can follow the book from start to finish or choose only those lessons that interest you.

Purchasing this book includes valuable online extras. Follow the instructions in the book’s “Getting Started” section to unlock access to:

• downloadable lesson files you need to work through the projects in the book
• Web Edition containing the complete text of the book, interactive quizzes, videos that walk you through the lessons step by step, and updated material covering new feature releases from Adobe

Adobe Dreamweaver CC 2015 release
CLASSROOM IN A BOOK®

The official training workbook from Adobe
Jim Maivald
# CONTENTS

## GETTING STARTED

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Classroom in a Book</td>
<td>1</td>
</tr>
<tr>
<td>TinyURLs</td>
<td>1</td>
</tr>
<tr>
<td>Prerequisites</td>
<td>2</td>
</tr>
<tr>
<td>Conventions used in this book</td>
<td>2</td>
</tr>
<tr>
<td>Windows vs. OS X instructions</td>
<td>3</td>
</tr>
<tr>
<td>Installing the program</td>
<td>4</td>
</tr>
<tr>
<td>Updating Dreamweaver to the latest version</td>
<td>5</td>
</tr>
<tr>
<td>Accessing the Classroom in a Book files</td>
<td>6</td>
</tr>
<tr>
<td>Recommended lesson order</td>
<td>8</td>
</tr>
<tr>
<td>Web Edition</td>
<td>8</td>
</tr>
<tr>
<td>Bonus material</td>
<td>9</td>
</tr>
<tr>
<td>Defining a Dreamweaver site</td>
<td>9</td>
</tr>
<tr>
<td>Setting up the workspace</td>
<td>12</td>
</tr>
<tr>
<td>Checking for updates</td>
<td>14</td>
</tr>
<tr>
<td>Additional resources</td>
<td>14</td>
</tr>
</tbody>
</table>

## 1 CUSTOMIZING YOUR WORKSPACE

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Touring the workspace</td>
<td>18</td>
</tr>
<tr>
<td>Using the Welcome Screen</td>
<td>19</td>
</tr>
<tr>
<td>Exploring New Feature Guides</td>
<td>22</td>
</tr>
<tr>
<td>Switching and splitting views</td>
<td>23</td>
</tr>
<tr>
<td>Working with panels</td>
<td>29</td>
</tr>
<tr>
<td>Selecting a workspace layout</td>
<td>33</td>
</tr>
<tr>
<td>Working with Extract</td>
<td>35</td>
</tr>
<tr>
<td>Adjusting toolbars</td>
<td>37</td>
</tr>
<tr>
<td>Personalizing Dreamweaver</td>
<td>37</td>
</tr>
<tr>
<td>Creating custom keyboard shortcuts</td>
<td>40</td>
</tr>
<tr>
<td>Using the Property inspector</td>
<td>41</td>
</tr>
</tbody>
</table>
Using the Related Files interface ........................................... 42
Using tag selectors ............................................................... 43
Using the CSS Designer ......................................................... 44
Using the Visual Media Query interface (VMQ) ....................... 49
Using the DOM Viewer .......................................................... 50
Using the heads-up displays .................................................. 50
Introducing Emmet ............................................................... 52
Exploring, experimenting, and learning .................................... 54

2   HTML BASICS                                             56

2B   HTML BASICS BONUS ONLINE LESSON                     B2-1

What is HTML? ....................................................................... 58
Where did HTML begin? ....................................................... 58
Frequently used HTML elements ........................................... 60
What’s new in HTML5 .......................................................... 62

B2-2

3   CSS BASICS                                             66

3B   CSS BASICS BONUS ONLINE LESSON                     B3-2

What is CSS? ....................................................................... 68
HTML vs. CSS formatting .................................................... 69
HTML defaults ..................................................................... 70
CSS box model .................................................................... 74
Previewing the completed file .............................................. 75
Formatting text ..................................................................... 77
Multiples, classes, and ids, oh my! ...................................... 96
CSS3 overview and support .................................................. 98

B3-3

4   WEB DESIGN BASICS                                     102

4B   WEB DESIGN BASICS BONUS ONLINE LESSON                B4-1

Developing a new website .................................................... 104
Scenario .............................................................................. 108
Working with thumbnails and wireframes .............................. 108
Creating web assets using Adobe Generator (optional) ......... 112
## CONTENTS

### 5 CREATING A PAGE LAYOUT 120
- Evaluating page design options 122
- Working with predefined layouts 124

### 6 WORKING WITH A WEB FRAMEWORK 144
- Creating header content 146
- Creating a navigation menu 167
- Building semantic content 182
- Managing Bootstrap component width 189
- Inserting HTML entities 191
- Creating global type styles 192

### 7 DESIGNING FOR MOBILE DEVICES 204
- Responsive design 206
- Adapting Bootstrap layouts to different screen sizes 208
- Working with media queries 221
- More information on media queries 231

### 8 WORKING WITH TEMPLATES 234
- Creating a template from an existing layout 236
- Inserting editable regions 237
- Inserting metadata 239
- Producing child pages 241

### 9 WORKING WITH TEXT, LISTS, AND TABLES 256
- Previewing the completed file 258
- Creating and styling text 261
- Creating lists 269
- Creating and styling tables 279
- Spellchecking web pages 302
- Finding and replacing text 304
- Optional self-paced exercise 307

### 10 WORKING WITH IMAGES 310
- Web image basics 312
- Previewing the completed file 317
- Inserting an image 318
- Adjusting image positions with CSS classes 320
Working with the Insert panel .............................................. 322
Using the Insert menu .................................................... 323
Inserting non-web file types .............................................. 325
Working with Photoshop Smart Objects (optional) ............... 328
Copying and pasting images from Photoshop (optional) ....... 331
Inserting images by drag and drop ...................................... 335
Optimizing images with the Property inspector .................... 337

11 WORKING WITH NAVIGATION ........................................ 342
Hyperlink basics .............................................................. 344
Previewing the completed file ............................................. 345
Creating internal hyperlinks .............................................. 348
Creating an external link .................................................. 355
Setting up email links ..................................................... 358
Creating an image-based link ............................................. 360
Targeting page elements .................................................. 363
Checking your page .......................................................... 369
Adding destination links to the same page (optional) ........... 370

12 ADDING INTERACTIVITY ............................................... 372
Learning about Dreamweaver behaviors .............................. 374
Previewing the completed file ............................................. 376
Working with Dreamweaver behaviors .................................. 377
Working with Bootstrap Accordion widgets ....................... 387

13 WORKING WITH WEB ANIMATION AND VIDEO ................. 400
Understanding web animation and video ............................... 402
Previewing the completed file ............................................. 403
Adding web animation to a page ........................................... 405
Adding web video to a page ............................................... 410
Choosing HTML5 video options ......................................... 415
14 PUBLISHING TO THE WEB 418

Defining a remote site .............................................. 420
Cloaking folders and files ........................................... 428
Wrapping things up .................................................... 430
Putting your site online (optional) ............................... 432
Synchronizing local and remote sites ......................... 436

APPENDIX: Tiny URLs 440

INDEX 441
Adobe® Dreamweaver® CC is the industry-leading web-authoring program. Whether you create websites for others for a living or plan to create one for your own business, Dreamweaver offers all the tools you need to get professional-quality results.

About Classroom in a Book

*Adobe Dreamweaver CC Classroom in a Book® (2015 release)* is part of the official training series for graphics and publishing software developed with the support of Adobe product experts.

The lessons are designed so you can learn at your own pace. If you’re new to Dreamweaver, you’ll learn the fundamentals of putting the program to work. If you are an experienced user, you’ll find that Classroom in a Book teaches many advanced features, including tips and techniques for using the latest version of Dreamweaver.

Although each lesson includes step-by-step instructions for creating a specific project, you’ll have room for exploration and experimentation. You can follow the book from start to finish, or complete only those lessons that correspond to your interests and needs. Each lesson concludes with a review section containing questions and answers on the subjects you’ve covered.

TinyURLs

At several points in the book, we reference external information available on the Internet. The uniform resource locators (URLs) for this information are often long and unwieldy, so we have provided custom TinyURLs in many places for your convenience. Unfortunately, the TinyURLs sometimes expire over time and no longer function. If you find that a TinyURL doesn’t work, look up the actual URL provided in the appendix.
Prerequisites

Before using Adobe Dreamweaver CC Classroom in a Book (2015 release), you should have a working knowledge of your computer and its operating system. Be sure you know how to use the mouse, standard menus, and commands, and also how to open, save, and close files. If you need to review these techniques, see the printed or online documentation included with your Windows or Mac operating system.

Conventions used in this book

Working in Dreamweaver means you’ll be working with code. We have used several conventions in the following lessons and exercises to make working with the code in this book easier to follow and understand.

Code font

In many instructions, you will be required to enter HTML code, CSS rules, and properties and other code-based markup. To distinguish the markup from the instructional text, the entries will be styled with a code font, like this:

Examine the following code `<h1>Heading goes here</h1>`

In instances where you must enter the markup yourself, the entry will be formatted in color, like this:

Insert the following code `<h1>Heading goes here</h1>`

Strikethrough

In several exercises, you will be instructed to delete markup that already exists within the webpage or style sheet. In those instances, the targeted references will be identified with strikethrough formatting, like this:

Delete the following values:

```
margin: 10px 20px 10px 20px;
background-image: url(images/fern.png), url(images/strip.png);
```

Be careful to delete only the identified markup so that you achieve the following result:

```
margin: 10px 10px;
background-image: url(images/fern.png);
```

Missing punctuation

HTML code, CSS markup, and JavaScript often require the use of various punctuation, such as periods (.), commas (,) and semicolons (;), among others, and can be damaged by their incorrect usage or placement. Consequently, periods and
other punctuation expected in a sentence or paragraph may be omitted from an instruction or hyperlink whenever it may cause confusion or a possible error, as in the following two instructions:

Enter the following code: `<h1>Heading goes here</h1>`

Type the following link: `http://adobe.com`

**Element references**

Within the body of descriptions and exercise instructions, elements may be referenced by name or by class or id attributes. When an element is identified by its tag name, it will appear as `<h1>` or `h1`. When referenced by its class attribute, the name will appear with a leading period (.) in a code-like font, like this: `.content` or `.sidebar1`. References to elements by their id attribute will appear with a leading hash (#) and in a code font, like this: `#top`. This practice matches the way these elements appear in Dreamweaver’s tag selector interface.

**Windows vs. OS X instructions**

In most cases, Dreamweaver performs identically in both Windows and OS X. Minor differences exist between the two versions, mostly due to platform-specific issues out of the control of the program. Most of these are simply differences in keyboard shortcuts, how dialogs are displayed, and how buttons are named. In most cases, screen shots were made in the OS X version of Dreamweaver and may appear differently from your own screen.

Where specific commands differ, they are noted within the text. Windows commands are listed first, followed by the OS X equivalent, such as Ctrl+C/Cmd+C. Common abbreviations are used for all commands whenever possible, as follows:

<table>
<thead>
<tr>
<th>WINDOWS</th>
<th>OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control = Ctrl</td>
<td>Command = Cmd</td>
</tr>
<tr>
<td>Alternate = Alt</td>
<td>Option = Opt</td>
</tr>
</tbody>
</table>

As lessons proceed, instructions may be truncated or shortened to save space, with the assumption that you picked up the essential concepts earlier in the lesson. For example, at the beginning of a lesson you may be instructed to “press Ctrl+C/Cmd+C.” Later, you may be told to “copy” text or a code element. These should be considered identical instructions.

If you find you have difficulties in any particular task, review earlier steps or exercises in that lesson. In some cases if an exercise is based on concepts covered earlier, you will be referred back to the specific lesson.
Installing the program

Before you perform any exercises in this book, verify that your computer system meets the hardware requirements for Dreamweaver, that it’s correctly configured, and that all required software is installed.

If you do not have Dreamweaver, you will first have to install it from Creative Cloud. Adobe Dreamweaver must be purchased separately; it is not included with the lesson files that accompany this book. Go to www.adobe.com/products/dreamweaver/tech-specs.html to obtain the system requirements.

Go to https://creative.adobe.com/plans to sign up for Adobe Creative Cloud. Dreamweaver may be purchased with the entire Creative Cloud family or as a standalone app. Adobe also allows you to try Creative Cloud and the individual applications for 30 days for free.

Check out www.adobe.com/products/dreamweaver.html to learn more about the different options for obtaining Dreamweaver.
Updating Dreamweaver to the latest version

Although Dreamweaver is downloaded and installed on your computer hard drive, periodic updates are provided via Creative Cloud. Some updates provide bug fixes and security patches, while others supply amazing new features and capabilities.

The lessons in this book are based on Dreamweaver CC (2015.1 release) and may not work properly in any earlier version of the program. To check which version is installed on your computer, choose Help > About Dreamweaver in Windows or Dreamweaver > About Dreamweaver on the Macintosh. A window will display the version number of the application and other pertinent information.

If you have an earlier version of the program installed, you will have to update Dreamweaver to the latest version. You can check the status of your installation by opening the Creative Cloud manager and logging in to your account.

Check out https://helpx.adobe.com/creative-cloud/help/download-install-trials.html to learn how to download and install a limited-period trial of Creative Cloud to your computer or laptop.
Accessing the Classroom in a Book files

In order to work through the projects in this book, you will need to download the lesson files from your Account page at peachpit.com.

If you purchased an eBook from peachpit.com or adobepress.com, the files will automatically appear on your Account page, under the Lesson & Update Files tab.

If you purchased an eBook from a different vendor or a print book, use the unique code in this book to gain access to the lesson files.

To download the Lesson files

1. On a Mac or PC, go to www.peachpit.com/redeem and enter the code that you’ll find on the card bound into the back of your book.

   This code is not the same as the book’s ISBN.

2. Click Redeem Code and sign in or create an account. You will be taken to your Account page.

   You need to enter the code only once. After you redeem the code, you’ll be able to access your lesson files on peachpit.com anytime you want without entering the code again.

3. Click the Lesson & Update Files tab of your Account page to see a list of downloadable files.
Click the lesson file links to download them to your computer. You can download the files for individual lessons, or download them all at once in one large file.

The files are compressed into ZIP archives to speed up download time and to protect the contents from damage during transfer. You must uncompress (or “unzip”) the files to restore them to their original size and format before you use them with the book. Modern Mac and Windows systems are set up to open ZIP archives by simply double-clicking.

Do one of the following:

- If you downloaded `DWCC2015_lesson_files.zip`, unzipping the archive will produce a folder named `DWCC2015_Lesson_Files` containing all the lesson files used by the book.

- If you downloaded the lessons individually, create a new folder on your hard drive and name it `DWCC2015`. Unzip the individual lesson files to this folder. That way, all the lesson files will be stored in one location. Do not share or copy files between lessons.
Recommended lesson order

The training in this book is designed to take you from A to Z in basic to intermediate website design, development, and production. Each new lesson builds on previous exercises, using supplied files and assets to create an entire website. We recommend that you download all lesson files at once and then perform each lesson in sequential order to achieve a successful result and the most complete understanding of all aspects of web design.

The ideal training scenario will start in Lesson 1 and proceed through the entire book to Lesson 14. Each lesson builds the skills and understanding necessary to complete subsequent tasks. We recommend that you do not skip any lessons, or even individual exercises. Although ideal, this method may not be a practicable scenario for every user. So, each lesson folder contains all the files needed to complete every exercise within it using partially completed or staged assets, allowing you to complete individual lessons out of order, if desired.

However, don’t assume that the staged files and customized templates in each lesson represent a complete set of assets. It may seem that these folders contain duplicative materials. But these “duplicate” files and assets, in most cases, cannot be used interchangeably in other lessons and exercises. Doing so will probably cause you to fail to achieve the goal of the exercise.

For that reason, you should treat each folder as a standalone website. Copy the lesson folder to your hard drive, and create a new site for that lesson using the Site Setup dialog. Do not define sites using subfolders of existing sites. Keep your sites and assets in their original folders to avoid conflicts.

One suggestion is to organize the lesson folders in a single web or sites master folder near the root of your hard drive. But avoid using the Dreamweaver application folder or any folders that contain a web server, such as Apache, ColdFusion, or Internet Information Services (IIS). In most cases, you’d want to use such a local web server as your testing server, which is described in Lesson 14, “Publishing to the Web.”

Web Edition

This book comes with a free Web Edition that provides many benefits and can be accessed from any device with a connection to the Internet.

Your Web Edition contains the complete text of the book, plus hours of instructional video keyed to the text and interactive quizzes. In addition, the Web Edition will be updated when Adobe adds significant feature updates between major Creative Cloud releases.
Accessing the free Web Edition

You must register your book purchase on peachpit.com in order to access the free Web Edition:

1 Go to www.peachpit.com/register, and then sign in or create a new account.
3 Answer the questions as proof of purchase.
   The Web Edition will appear under the Digital Purchases tab on your Account page.
4 Click the Launch link to access the product.

Bonus material

We’ve provided additional material for both Lessons 2 and 3 on the Peachpit website. You’ll find “HTML Basics Bonus” for Lesson 2 and “CSS Basics Bonus” for Lesson 3 on your account page (Lessons & Update Files tab) once you register your book as described earlier in “Accessing the Classroom in a Book files.”

Defining a Dreamweaver site

In the course of completing the following lessons, you will create webpages from scratch and use existing files and resources that are stored on your hard drive. The resulting webpages and assets make up what’s called your local site. When you are ready to upload your site to the Internet (see Lesson 14, “Publishing to the Web”), you publish your completed files to a web-host server, which then becomes your remote site. The folder structures and files of the local and remote sites are usually mirror images of one another.

The first step is to define your local site:

1 Launch Adobe Dreamweaver CC (2015.1 release) or later.
2 Open the Site menu.
   The Site menu provides options for creating and managing standard Dreamweaver sites.
3 Choose New Site.

To create a standard website in Dreamweaver, you need only name it and select the local site folder. Site names typically relate to a specific project or client and appear in the Files panel. This name is intended for your own purposes, so there

⚠️ Warning: You must unzip the lesson files before you create your site definition.
are no limitations to the name you can create. Use a name that clearly describes
the purpose of the website. For the purposes of this book, use the name of the
lesson you intend to complete, such as lesson01, lesson02, lesson03, and so on.

4 Type lesson01 or another name, as appropriate, in the Site Name field.

5 Next to the Local Site Folder field, click the Browse for Folder icon.

   The Choose Root Folder dialog appears.

6 Navigate to the appropriate folder containing the lesson files you downloaded
   from Peachpit.com (as described earlier), and click Select/Choose.

   Note: The main folder that contains the site will be referred to
   throughout the book as the site root folder.

   Note: The folder that contains the image assets will be referred to
   throughout the book as the site default images folder or the default images folder.

You could click Save at this time and begin working on your new website, but
we’ll add one more piece of handy information.

7 Click the arrow next to the Advanced Settings category to reveal the
categories listed there. Select Local Info.
Although it’s not required, a good policy for site management is to store different file types in separate folders. For example, many websites provide individual folders for images, PDFs, videos, and so on. Dreamweaver assists in this endeavor by including an option for a Default Images folder. Later, as you insert images from other places on your computer, Dreamweaver will use this setting to automatically move the images into the site structure.

8 Next to the Default Images Folder field, click the Browse for Folder icon 🗃. When the dialog opens, navigate to the appropriate images folder for that lesson or site and click Select/Choose.

The path to the images folder appears in the Default Images Folder field. The next step would be to enter your site domain name in the Web URL field.

9 Enter http://green-start.org for the lessons in this book, or enter your own website URL, in the Web URL field.

You’ve entered all the information required to begin your new site. In subsequent lessons, you’ll add more information to enable you to upload files to your remote and testing servers.

10 In the Site Setup dialog, click Save.

The Site Setup dialog closes.
In the Files panel, the new site name appears in the site list drop-down menu. As you add more site definitions, you can switch between the sites by selecting the appropriate name from this menu.

Whenever a site is selected or modified, Dreamweaver will build, or rebuild, a cache of every file in the folder. The cache identifies relationships between the web pages and the assets within sites, and will assist you whenever a file is moved, renamed, or deleted to update links or other referenced information.

11 Click OK.

Setting up a site is a crucial first step in beginning any project in Dreamweaver. Knowing where the site root folder is located helps Dreamweaver determine link pathways and enables many sitewide options, such as orphaned-file checking and Find and Replace.

**Setting up the workspace**

Dreamweaver CC (2015.1 release) includes five main workspaces to accommodate various computer configurations and individual workflows. For this book, the Design workspace is recommended.

1 If the Design workspace is not displayed by default, you can select it from the Workspace drop-down menu on the upper-right side of the screen.
If the default Design workspace has been modified—where certain toolbars and panels are not visible (as they appear in the figures in the book)—you can restore the factory setting by choosing Reset ‘Design’ from the Workspace drop-down menu.

Workspace Layout options can also be accessed from the Window menu.

Most of the figures in this book show the Design workspace. When you finish the lessons in this book, experiment with each workspace to find the one that you prefer, or build your own configuration and save the layout under a custom name.

For a more complete description of the Dreamweaver workspaces, see Lesson 1, “Customizing Your Workspace.”
Checking for updates

Adobe periodically provides software updates. To check for updates in the program, choose Help > Updates in Dreamweaver. An update notice may also appear in the Creative Cloud update desktop manager.

![Creative Cloud update desktop manager](image)

For book updates and bonus material, visit your Account page on Peachpit.com and select the Lesson & Update Files tab.

Additional resources

*Adobe Dreamweaver CC Classroom in a Book (2015 release)* is not meant to replace documentation that comes with the program or to be a comprehensive reference for every feature. Only the commands and options used in the lessons are explained in this book. For comprehensive information about program features and tutorials, refer to these resources:

**Adobe Dreamweaver Learn & Support**: helpx.adobe.com/dreamweaver (accessible in Dreamweaver by choosing Help > Help And Support > Dreamweaver Support Center) is where you can find and browse tutorials, help, and support on Adobe.com.

**Dreamweaver Help**: helpx.adobe.com/dreamweaver/topics.html is a reference for application features, commands, and tools (press F1 or choose Help > Help And Support > Dreamweaver Online Help). You can also download Help as a PDF document optimized for printing at helpx.adobe.com/pdf/dreamweaver_reference.pdf.
Adobe Forums: forums.adobe.com lets you tap into peer-to-peer discussions and questions and answers on Adobe products.

Resources for educators: www.adobe.com/education and edex.adobe.com offer a treasure trove of information for instructors who teach classes on Adobe software. You’ll find solutions for education at all levels, including free curricula that use an integrated approach to teaching Adobe software and that can be used to prepare for the Adobe Certified Associate exams.

Also check out these useful links:

Adobe Add-ons: creative.adobe.com/addons is a central resource for finding tools, services, extensions, code samples, and more to supplement and extend your Adobe products.

Adobe Dreamweaver CC product home page: www.adobe.com/products/dreamweaver has more information about the product.

Adobe Authorized Training Centers
Adobe Authorized Training Centers offer instructor-led courses and training on Adobe products. A directory of AATCs is available at training.adobe.com/trainingpartners.
Lesson overview

In this lesson, you’ll learn the following:

• The basics of webpage design
• How to create page thumbnails and wireframes
• How to use Photoshop to generate site image assets automatically

This lesson will take about 45 minutes to complete. If you have not already done so, download the project files for this lesson from the Lesson & Update Files tab on your Account page at www.peachpit.com, store them on your computer in a convenient location, and define a new site in Dreamweaver based on this folder, as described in the “Getting Started” section of this book. Your Account page is also where you’ll find any updates to the chapters or to the lesson files. Look on the Lesson & Update Files tab to access the most current content.
Whether you use thumbnails and wireframes, Photoshop, or just a vivid imagination, Dreamweaver can quickly turn your design concepts into complete, standards-based CSS layouts.
Developing a new website

Before you begin any web design project for yourself or for a client, you need to answer three important questions:

- What is the purpose of the website?
- Who is the audience?
- How do they get here?

What is the purpose of the website?

Will the website sell or support a product or service? Is your site for entertainment or games? Will you provide information or news? Will you need a shopping cart or database? Do you need to accept credit card payments or electronic transfers? Knowing the purpose of the website tells you what type of content you’ll be developing and working with and what types of technologies you’ll need to incorporate.

Who is the audience?

Is the audience adults, children, seniors, professionals, hobbyists, men, women, everyone? Knowing who your audience will be is vital to the overall design and functionality of your site. A site intended for children probably needs more animation, interactivity, and bright, engaging colors. Adults will want serious content and in-depth analysis. Seniors may need larger type and other accessibility enhancements.

A good first step is to check out the competition. Is there an existing website performing the same service or selling the same product? Are they successful? You don’t have to mimic others just because they’re doing the same thing. Look at Google and Yahoo—they perform the same basic service, but their site designs couldn’t be more different from one another.
How do they get here?

This sounds like an odd question when speaking of the Internet. But just as with a brick-and-mortar business, your online customers can come to you in a variety of ways. For example, are they accessing your site on a desktop computer, laptop, tablet, or cellphone? Are they using high-speed Internet, wireless, or dial-up service? What browser are they most likely to use, and what is the size and resolution of the display? These answers will tell you a lot about what kind of experience your customers will expect. Dial-up and cellphone users may not want to see a lot of graphics or video, whereas users with large flat-panel displays and high-speed connections may demand as much bang and sizzle as you can send at them.

So where do you get this information? Some you’ll have to get through painstaking research and demographic analysis. Some you’ll get from educated guesses based on your own tastes and understanding of your market. But a lot of it is actually available on the Internet itself. W3Schools, for one, keeps track of tons of statistics regarding access and usage, all updated regularly:

- w3schools.com/browsers/browsers_stats.asp provides information about browser statistics.
- w3schools.com/browsers/browsers_os.asp gives the breakdown on operating systems. In 2011, they started to track the usage of mobile devices on the Internet.
- w3schools.com/browsers/browsers_display.asp lets you find out the latest information on the resolution, or size, of screens using the Internet.

If you are redesigning an existing site, your web-hosting service itself may provide valuable statistics on historical traffic patterns and even the visitors themselves. If you host your own site, you can incorporate third-party tools, such as Google Analytics and Adobe Omniture, into your code to do the tracking for you for free or for a small fee.
As of the fall of 2015, Windows still dominates the Internet (80 to 85 percent), with most users favoring Google Chrome (60 percent), followed by Firefox (21 percent), with various versions of Internet Explorer (7 percent) a distant third. The vast majority of browsers (99 percent) are set to a resolution higher than 1024 pixels by 768 pixels. If it weren’t for the rapid growth in usage of tablets and smartphones for accessing the Internet, these statistics would be great news for most web designers and developers. But designing a website that can look good and work effectively for both flat-panel displays and cellphones is a tall order.
Responsive web design

Each day, more people are using cellphones and other mobile devices to access the Internet. Some people may use them to access the Internet more frequently than they use desktop computers. This presents a few nagging challenges to web designers. For one thing, cellphone screens are a fraction of the size of even the smallest flat-panel display. How do you cram a two- or three-column page design into a meager 300 to 400 pixels? Another problem is that mobile device manufacturers have dropped support for Flash-based content on their devices.

Until recently, web design usually required that you target an optimum size (height and width in pixels) for a webpage and then build the entire site on these specifications. Today, that scenario is becoming a rare occurrence. Now, you are presented with the decision to either build a site that can adapt to displays of multiple different dimensions (responsive) or build two or more separate websites to support desktop and mobile users at the same time (adaptive).

Your own decision will be based in part on the content you want to provide and on the capabilities of the devices accessing your pages. Building an attractive website that supports video, audio, and other dynamic content is hard enough without throwing in a panoply of different display sizes and device capabilities. The term responsive web design was coined, in a book of the same name (2011), by a Boston-based web developer named Ethan Marcotte; he describes the notion of designing pages that can adapt to multiple screen dimensions automatically. As you work through the following lessons, you will learn many techniques for responsive web design and implement them in your site and asset design.

Many of the concepts of print design are not applicable to the web, because you are not in control of the user’s experience. A page carefully designed for a typical flat panel is basically useless on a cellphone.
Scenario

For the purposes of this book, you’ll be working to develop a website for Meridien GreenStart, a fictitious community-based organization dedicated to green investment and action. This website will offer a variety of products and services and require a broad range of webpage types, including dynamic pages using technologies such as jQuery, which is a form of JavaScript.

Your customers come from a wide demographic that includes all ages and education levels. They are people who are concerned about environmental conditions and who are dedicated to conservation, recycling, and the reuse of natural and human resources.

Your marketing research indicates that most of your customers use desktop computers or laptops, connecting via high-speed Internet services. You can expect to get 20 to 30 percent of your visitors exclusively via cellphone and other mobile devices, and much of the rest will be using mobile from time to time.

To simplify the process of learning Dreamweaver, we’ll focus on creating a fixed-width site design first. In Lesson 7, “Designing for Mobile Devices,” you’ll learn how to adapt your fixed-width design to work with smartphones and tablets.

Working with thumbnails and wireframes

After you have nailed down the answers to the three questions about your website purpose, customer demographic, and access model, the next step is to determine how many pages you’ll need, what those pages will do, and finally, what they will look like.

Creating thumbnails

Many web designers start by drawing thumbnails with pencil and paper. Think of thumbnails as a graphical shopping list of the pages you’ll need to create for the website. Thumbnails can also help you work out the basic navigation structure for the site. Draw lines between the thumbnails showing how your navigation will connect them.
Most sites are divided into levels. Typically, the first level includes all the pages in your main navigation menu—the ones a visitor can reach directly from the home page. The second level includes pages you can reach only through specific actions or from specific locations, say from a shopping cart or product detail page.

Creating a page design

Once you’ve figured out what your site needs in terms of pages, products, and services, you can then turn to what those pages will look like. Make a list of components you want or need on each page, such as headers and footers, navigation, and areas for the main content and the sidebars (if any). Put aside any items that won’t be needed on every page. What other factors do you need to consider? If mobile devices are going to be an important consideration of your design identity, will any of the components be required or optional for these devices? Although many components can be simply resized for mobile screens, some will have to be completely redesigned or reimagined.

1. Header (includes banner and logo)
2. Footer (copyright info)
3. Horizontal navigation (for internal reference; i.e., Home, About Us, Contact Us)
4. Main content (one-column with chance of two or more)
Do you have a company logo, business identity, graphic imagery, or color scheme you want to match or complement? Do you have publications, brochures, or current advertising campaigns you want to emulate? It helps to gather them all in one place so you can see everything all at once on a desk or conference table. If you’re lucky, a theme will rise organically from this collection.

**Desktop or mobile**

Once you’ve created your checklist of the components that you’ll need on each page, sketch out several rough layouts that work for these components. Depending on your target visitor demographics, you may decide to focus on a design that’s optimized for desktop computers or one that works best on tablets and smartphones.

Most designers settle on one basic page design that is a compromise between flexibility and sizzle. Some site designs may naturally lean toward using more than one basic layout. But resist the urge to design each page separately. Minimizing the number of page designs may sound like a major limitation, but it’s key to producing a professional-looking site that’s easy to manage. It’s the reason why some professionals, like doctors and airline pilots, wear uniforms. Using a consistent page design, or template, conveys a sense of professionalism and confidence to your visitor.

While you’re figuring out what your pages will look like, you’ll have to address the size and placement of the basic components. Where you put a component can drastically affect its impact and usefulness.

In print, designers know that the upper-left corner of a layout is considered one of the “power positions,” a place where you want to locate important aspects of a design, such as a logo or title. This is because in western culture we read from left to right, top to bottom. The second power position is the lower-right corner, because this is the last thing your eyes will see when you’re finished reading.

Unfortunately, in web design this theory doesn’t hold up for one simple reason: You can never be certain how the user is seeing your design. Are they on a 20-inch flat panel or a 2-inch cellphone?

In most instances, the only thing you can be certain of is that the user can see the upper-left corner of any page. Do you want to waste this position by slapping the company logo here? Or make the site more useful by slipping in a navigation menu? This is one of the key predicaments of the web designer. Do you go for design sizzle, workable utility, or something in between?
Creating wireframes

After you pick the winning design, wireframing is a fast way to work out the structure of each page in the site. A wireframe is like a thumbnail, but bigger, that sketches out each page and fills in more details about the components, such as actual link names and main headings, but with minimal design or styling. This step helps to catch or anticipate problems before you smack into them when working in the code.

Wireframes allow you to experiment with page designs quickly and easily without wasting time with code.

The wireframe for the final design should identify all components and include specific information about content, color, and dimensions.
Once the basic concepts are worked out, many designers take an extra step and create a full-size mockup or “proof of concept” using a program like Adobe Photoshop or even Illustrator. It’s a handy thing to do because you’ll find that some clients just aren’t comfortable giving an approval based only on pencil sketches. The advantage here is that all these programs allow you to export the results to full-size images (JPEG, GIF, or PNG) that can be viewed in a browser as if they were finished webpages. Such mockups are as good as seeing the real thing but may take only a fraction of the time to produce.

In addition to creating graphical mockups, Photoshop has tricks geared specifically for web designers, like the Adobe Generator feature.

**Creating web assets using Adobe Generator (optional)**

Adobe Generator is one of the web-oriented tools that allow you to export web assets from a Photoshop file in a variety of sizes, resolutions, and even file types. Best of all, this feature works in real time, exporting image assets from your file based on user-specified attributes added to the layer name. Let’s take a closer look at this great tool.
Working with Adobe Generator

In this exercise, you’ll work with an Adobe Photoshop document to prepare assets for your web project.

1. Launch Photoshop CC 2015 or higher.

2. Open `GreenStart_mockup.psd` from the lesson04/resources folder.

   The Photoshop file contains a complete mockup of the GreenStart site design, which is composed of various vector-based design components as well as image assets stored in separate layers. Note the use of colors and gradients in the design.

3. Choose File > Save As.
   Name the file `resources/myGreenStart_mockup.psd`.

4. If necessary, choose Window > Layers to display the Layers panel. Observe the names and contents of the layers and layer groups.

   The layers and layer groups are named for the webpage components.

5. Open the header layer group, and observe the contents.

   The header group contains two text elements and four graphical elements. Often, it’s difficult to understand how a graphic component is built or for what purpose it is intended by looking at the layer names alone.

---

**Note:** This exercise requires the installation of Photoshop CC 2015 or higher and the lesson04 lesson files.

**Note:** The sample file used in this exercise requires the font Bree Serif, which you can download and install for free from Adobe Typekit. To access this font, and the entire Typekit library, choose Type > Add Fonts from Typekit in Photoshop CC 2015 or higher.

**Tip:** It’s a good idea to save the file under a different name so you can refer back to the original assets should you make an error.
6 In the GreenStart layer, click the eye icon to toggle the layer visibility off.

The text “greenstart” disappears from the layer.

7 In the fern layer, click the eye icon to toggle the layer visibility off.

The image of the fern disappears. Using this method, you can identify each element of the header and see what role it plays in the creation of the overall design. The number and type of layers and the level of detail used here aren't necessary for a mockup that you merely want to use for a client approval. This file was set up specifically to create many of the final assets for the page design.

8 Click the eye icon to toggle the GreenStart and fern layers back on.

**Exporting assets from Photoshop**

The fern layer will be used to create one component of the header background. Photoshop generates a web asset automatically if you add a file extension to the layer name.

1 Double-click the name of the fern layer, type *fern.png* and press Enter/Return to complete the name.

When activated, Generator works in the background exporting assets in real time.

2 Choose File > Generate > Image Assets.
The next time you look at the Generate menu option, a checkmark will appear beside Image Assets, indicating that Generator is active.

3 Choose File > Open.

Navigate to the lesson04 > resources folder.

A new folder has been created and named myGreenStart_mockup-assets by Generator. Whenever you add file extensions to the layer names and enable Generator, it creates a folder and fills it with assets automatically, based on the layer names and settings.

4 Navigate to the myGreenStart_mockup-assets folder created by Photoshop.

The folder contains a single image: fern.png.
5 Open fern.png.

The file contains the fern with a transparent background. Note that the image displays a drop shadow. The shadow is a permanent part of the image, no longer created by a Photoshop effect.

6 Choose Image > Image Size. 
Note the dimensions and resolution of the image.

The image is 468 pixels by 157 pixels, at 72 pixels per inch (ppi).

7 Click OK to close the Image Size dialog. 
Close fern.png.

**Creating multiple assets using Generator**

Generator can also modify the default export specifications and even create multiple assets at multiple resolutions.

1 Change the layer name fern.png to 200% fern.png+fern.jpg and press Enter/Return to complete the name.

2 Choose File > Open. If necessary, navigate to the **myGreenStart_mockup-assets** folder.
The folder contains two images: **fern.png** and **fern.jpg**, both created by Generator. Older files with the same names are replaced automatically.

3 Select **fern.png** and open the file.

The file contains the fern, but it appears twice as large as the previous image.

4 Open **fern.jpg**.

The file contains the same fern image, but at the original size. JPEGs do not support transparency, so the background is white. There’s no need for the JPEG version of the image. Generator can remove assets automatically too.

5 Change the layer name **200% fern.png+fern.jpg** to **150% fern.png** and press Enter/Return to complete the name.

The specification creates a larger, higher-quality image that will display well in regular browsers and on new higher-resolution devices. By removing “fern.jpg” from the layer name, Generator automatically deletes the JPEG version of the file.

6 Choose File > Open. Navigate to the myGreenStart_mockup-assets folder.

The JPEG version of the file is no longer visible in the folder. As you can see, Photoshop generates assets based on the name of the layer. You can create an entire set of images for your site design from the layers in this file.

7 In the Layers panel, open the header layer group. Change the name of the **stripe** layer group to **stripe.png**.

8 Open the sidebar2 layer group. Change the layer shopping to **shopping.jpg**. Change the layer biking to **biking.jpg**.

**Note:** In Photoshop, the background is mocked up using two layers: stripe and stripes-group. You are exporting the web background from the smaller stripe layer group, which looks like a folder icon in the Layers panel.
9 Choose File > Open. Navigate to the myGreenStart_mockup-assets folder.

The myGreenStart_mockup-assets folder now contains four image files. These files are identical to the ones you will use to build the site template and populate articles in upcoming lessons. As you can see, Generator offers some handy tools for turning this mockup into real web design assets, but the tricks don’t stop there. Photoshop and Dreamweaver have even more collaboration tools to offer, as you will see later.

Check out http://helpx.adobe.com/photoshop/using/generate-assets-layers.html to see a complete explanation of Adobe Generator and how to use it.
Review questions

1 What three questions should you ask before starting any web design project?
2 What is the purpose of using thumbnails and wireframes?
3 Why is it important to create a design that takes into account smartphones and tablets?
4 Why would you use Adobe Photoshop, Illustrator, or Fireworks to design a website?
5 How does Adobe Generator assist in the creation of a website design?

Review answers

1 What is the purpose of the website? Who is the audience? How did they get here? These questions, and their answers, are essential in helping you develop the design, content, and strategy of your site.
2 Thumbnails and wireframes are quick techniques for roughing out the design and structure of your site without having to waste lots of time coding sample pages.
3 Mobile device users are one of the fastest-growing demographics on the web. Many visitors will use a mobile device to access your website on a regular basis or exclusively. Webpages designed for desktop computers often display poorly on mobile devices, making the websites difficult or impossible to use for these mobile visitors.
4 Using Photoshop, Illustrator, or Fireworks, you can produce page designs and mockups much faster than when designing in code with Dreamweaver. Designs can even be exported as web-compatible graphics that can be viewed in a browser to get client approval.
5 Adobe Generator allows you to export site image assets quickly from Photoshop mockups, allowing you to produce multiple sizes and versions of each asset.
INDEX

A
<a> element, 60, 175, 344
absolute hyperlinks, 345, 355–358
Accordion widgets. See Bootstrap
Accordion widgets
Add Behavior icon, 374, 379, 382, 383
Add Class/ID icon, 158, 187, 320, 364
Add New Server icon, 422, 427
Add Selector icon, 159, 225, 248, 276
Adobe Add-ons, 15, 374, 375
Adobe Authorized Training Centers, 15
Adobe Creative Cloud, 4
Adobe Dreamweaver. See Dreamweaver
Adobe Edge Animate, 404, 405
Adobe Flash, 402
Adobe forums, 15
Adobe Generator. See Generator
Adobe Muse, 59
Adobe Photoshop. See Photoshop
All mode, CSS Designer, 48, 94, 149
alpha transparency, 315, 317
animation. See web animation
<article> element, 62, 78, 215, 263, 389
<aside> element, 62, 182, 184, 211, 212
Assets panel, 250, 261, 318–319, 335
<audio> tag, 62

B
background color, 163, 176, 396
background images
adding to headers, 160–163
gradients as, 164, 177, 179, 397
banner animation, 405–409
Beginner workspace, 33
behaviors, 377–387
adding to hyperlinks, 383–385
applying, 379–382
overview of, 374–375
removing applied, 382–383
responsive design and, 385–387
review questions/answers on, 399
Swap Image behavior, 379–381
Swap Image Restore behavior, 381–382
Berners-Lee, Tim, 58
bit depth, 314
<blockquote> element, 60, 183, 185, 273
<body> element, 60, 84–85
Bootstrap, 131–141
adding HTML5 elements to, 139–141
code inconsistency cleanup, 174
column width manipulation, 217–221
component width management, 189–191
creating layouts using, 133–139
hiding unwanted content using, 210–214
mobile device design and, 208–221
read-only style sheet, 189
Bootstrap Accordion widgets, 387–398
inserting into layouts, 388–392
styling, 392–398
borders
indented text, 276–277
navigation menu, 177–178
table row, 287
box model, 74–75
<br> tag, 60, 262
Brightness and Contrast tool, 340
Browse icon, 11, 349, 411, 412
browsers. See web browsers

canvas> tag, 62
caption elements, 294–296
cascade theory, 79–82
cells, styling table, 287–289
character entities, 61
Check Spelling dialog, 302–303
child pages, 241–253
adding content to, 243–247
creating new, 242–243
formatting content in, 247–250
hyperlink updates on, 353–355
updating, 250–253, 353–355
class attributes, 87–88, 97–98
classes
  creating custom, 158–160, 187–188
  pseudo-classes and, 175
Classroom in a Book series, 1
clipboard, 262
cloaking process, 428–429
code font used in book, 2
Code Hinting window, 275
Code Navigator, 90–93
Code view, 24
  creating long selectors in, 299
  Find and Replace feature in, 306
  Refresh button for, 389
Code workspace, 34
Coding toolbar, 37
color
  background, 163, 177
text, 155
color picker, 155
color space, 314–315
column widths, 217–221
comma-separated values (CSV) file, 291
Commit icon, 327, 333, 338
Compare option, 438
compression, image file, 316
Connect to Remote Server icon, 433
content placeholders, 186–187
Copy Dependent Files dialog, 127
copying/pasting
  CSS properties, 226–230
  images from Photoshop, 331–334
tables, 284–285
Create tab, 19–20
Crop tool, 338–339, 340
cropping images, 338–339
CSS (cascading style sheets), 66–101
  box model, 74–75
  cascade theory, 79–82
class and id attributes, 87–88, 97–98
  Code Navigator tool, 90–93
copying/pasting properties, 226–230
creating in CSS Designer, 151–153
CSS Designer, 44–49, 93–96
  All and Current modes, 48, 94, 149
copying/pasting properties, 226
header creation, 148–157
@Media window, 45
Properties window, 46–48, 95, 285
Selectors window, 46, 95
Sources window, 45
style sheet creation, 151–153
Current mode, CSS Designer, 48, 94, 149, 399
custom classes, 158–160
D
declarations, 77
default workspace, 34
delete icon, 228, 438
dependent files, 433
descendant theory, 85–89
design view, 24–25
clipboard use and, 262
table cell navigation in, 282
design workspace, 12–13, 35
designing web pages. See web design
destination links
  adding to the same page, 370
  Element HUD for creating, 367–368
table cell navigation in, 282
disable icon, 228
dithering process, 314
<div> element, 60, 85, 123, 139, 143, 408
docking panels, 32–33
document toolbar, 37
dOM Viewer, 50, 214–215
dpi (dots per inch), 313
dragging-and-dropping images, 335–336
Dreamweaver
  Help reference, 14
  installing, 4
  product home page, 15
  site creation, 9–12
  support center, 14
  updating, 5, 14
drop zone, 32
dwt file extension, 237
dynamic templates, 237
E
Edge Animate program, 404, 405
Edge Web Fonts, 193–198
Edit HTML Attributes icon, 319, 336, 360
Edit Image Settings tool, 340
editable regions
formatting content in, 247–250
inserting into templates, 237–239
Element HUD, 50, 357, 360–361, 367
element references, 3
<em> tag, 60, 357
email links, 347, 358–362
creating, 358–360
image-based, 360–361
text-based, 361–362
warning about, 362
embedded formatting, 77
Emmet feature, 52–54
exporting Photoshop assets, 114–116
external hyperlinks, 344, 355–358
Extract workspace, 35–36
eye icon, 114, 330

F
<figcaption> tag, 62
<figure> tag, 62
file formats
for raster images, 316–317
for vector graphics, 312
for video files, 412
Find and Replace feature, 304–307
Flash, Adobe, 402
floating panels, 31–32
FLV file format, 412, 414, 417
fonts
Edge Web, 193–198
size specifications for, 200–202
stacks of, 194, 198–200
typefaces vs., 193
web-hosted, 198
<header> tag, 62
<form> tag, 60
forums, Adobe, 15
FTP (File Transfer Protocol), 420
FTP over SSL/TLS connection method, 420
FTP sites
connection options, 423
steps for setting up, 421–425
troubleshooting connections to, 424

G
Generator, 112–118
creating multiple assets using, 116–118
exporting assets from Photoshop using, 114–116
steps for working with, 113–114
Get icon, 435, 438
Getting Started tab, 21
GIF file format, 316
Google Maps, 355–357
gradient backgrounds, 163–165, 177, 179, 397
graphic tools, 340
graphics
raster, 312–317
vector, 312
See also images
grouping panels, 32
<h1> to <h6> tags, 60
<head> tag, 60, 231, 237
<header> element, 62, 146
headers, 146–167
background images for, 160–163
color background for, 163
creating for text, 264–266
CSS Designer options for, 148–157
custom classes for, 158–160
entering text for, 146–148
formatting text for, 153–157
gradient effects for, 163–165
responsive design for, 298
heads-up displays (HUDs), 50–51
<hgroup> tag, 62
hiding elements, 210–214
high color, 315
hinting menu, 156, 182, 211
home page
hyperlinks to, 352–353
setting up, 430–431
<hr> tag, 60
HTML (HyperText Markup Language), 56–65
character entities, 61
code structure, 59
CSS comparison, 69–70
current version, 62–64
defaults, 70–72
historical origins, 58–59
review questions/answers on, 65
table formatting and, 280
tags, 58–59, 60–61
HTML5, 62–64
  animation support, 402, 410
  Bootstrap and, 139–141
  quote attribution in, 268
  semantic web design, 63–64
tags, 62–63
  video support, 402, 415–416
HTML entities, 191–192
HTML Property inspector, 41–42
HTML structures, 266–269
  <html> tag, 60
HUDs (heads-up displays), 50–51
Hyperlink icon, 357
hyperlinks, 342–371
  absolute, 345, 355–358
  adding behaviors to, 383–385
  checking on pages, 369–370
  destination, 365–369, 370
  editing/removing, 349
  email, 347, 358–362
  external, 344, 355–358
  home page, 352–353
  image-based, 360–361
  internal, 344, 348–355
  navigation menu, 178–179
  placeholder for, 349, 383, 384
  pseudo-classes for, 175
  relative, 344, 345, 348–351
  review questions/answers on, 371
  targeted, 363–369, 370
text-based, 361–362
  updating in child pages, 353–355
id attributes, 87–88
  creation process for, 98
  targeted links and, 363, 365–369
<iframe> tag, 60
Ignore option, 438
Image HUD, 50, 326
Image Optimization dialog, 325, 340
Image Property inspector, 42
image-based links, 360–361
images, 310–341
  color spaces used for, 314–315
  copying/pasting from Photoshop, 331–334
dragging-and-dropping, 335–336
  file formats for, 312, 316–317
  inserting on a webpage, 318–320, 322–328
  non-web file type, 325–328
  optimizing with Property inspector, 337–339
  Photoshop Smart Objects, 328–331
  positioning, 320–321
  Quality setting for, 325
  raster graphics, 312–317, 333
  resolution of, 313–314, 328
  review questions/answers on, 341
  screen size and, 334–335
  size of, 314–315, 328, 338
tools for editing, 340
  vector graphics, 312
Images category icon, 318
<img> element, 60, 320
Import Tabular Data dialog, 291–292
importing text, 261–263
incompatible code, 165
indented text, 273–277
inheritance theory, 82–85
inline formatting, 77
<input> tag, 60
Insert Article dialog, 264, 281
Insert menu, 323–324
Insert panel, 322–323
Insert Rows or Columns dialog, 283
inserting
  editable regions into templates, 237–239
  images on a webpage, 318–320, 322–328
  metadata into templates, 239–241
  tables from other sources, 291–294
Inspect mode, 28
installing Dreamweaver, 4
interactivity, 372–399
  Bootstrap Accordion widgets for, 387–398
  Dreamweaver behaviors for, 374–375, 377–387
  review questions/answers on, 399
See also behaviors
interface customization, 16–55
internal hyperlinks, 344, 348–355
  home link creation, 352–353
  relative link creation, 348–351
  targeted link creation, 363–365
  updating in child pages, 353–355
Internet Explorer, 403, 416
J
JPEG file format, 316
jQuery framework, 373, 388, 398
K
keyboard shortcuts, 40–41

L
layouts
  page, 120–143
  predefined, 124–141
  template creation from, 236–237
  workspace, 33–35
lesson files
  downloading and unzipping, 6–7
  recommended order for using, 8
  <li> element, 60, 272
  <link> element, 61, 81
  Link Checker panel, 370
  linked CSS formatting, 77
  links. See hyperlinks
  Lintering support, 52
  lists, 269–279
    creating, 270–273
    indented text in, 273–277
    ordered and unordered, 272–273
    responsive, 277–279
  Live Source Code mode, 27–28
  Live view, 25, 127, 135
    previewing pages in, 259, 286, 355, 416
    table styling in, 286
local site, 9, 420
Locked icon, 243
Log button, 434
lossy compression, 316

M
Manage Sites dialog, 421
map links, 356–357
Marcotte, Ethan, 107
max-width specification, 49, 335
measurement systems, 156
media content. See web animation; web video
media queries, 207, 221–231
  adding rules to, 224–226
  explanation of, 130
  identifying, 221–224
  resources on, 231
  syntax used in, 208
  VMQ interface and, 129–131
Media Query Definition dialog, 224
media type property, 207
menus. See navigation menus
<meta> tag, 61, 240, 241
metadata
  image-related, 320
  inserting into templates, 239–241
min-width specification, 49, 224, 335
mobile device design, 204–233
  Bootstrap framework and, 208–221
  column width manipulation and, 217–221
  copying/pasting CSS properties, 226–230
  lists and, 277–279
  media queries and, 207–208, 221–231
  media type property and, 207
  mobile-first design and, 206, 214–217
  responsive design and, 206–208
  review questions/answers on, 232–233
  Scrubber tool and, 208–210
  steps for completing, 230–231
  tables and, 296–302
  mobile-first design, 206, 214–217
  mobile-optimized sites, 213
  mockups, 112
  monochrome, 314
  MP4 file format, 412
  Muse, Adobe, 59

N
named anchors, 363
<nav> element, 62, 175
navigation, 342–371
  basics of, 344–345
  checking on pages, 369–370
  email links for, 358–362
  external hyperlinks for, 355–358
  image-based links for, 360–361
  internal hyperlinks for, 348–355
  review questions/answers on, 371
  targeting page elements, 363–369
  text-based links for, 361–362
  See also hyperlinks
navigation menus, 167–182
  adding new items to, 170–174
  centering, 180–182
  cleaning up, 174
  hyperlinks in, 178–179
  steps for creating, 167–170
  styling, 175–180
New Document dialog, 125
New Feature guides, 22–23
New Features tab, 20
O
Ogg file format, 412
<ol> element, 61, 272, 273
online resources. See resources
ordered lists, 271–272
OS X vs. Windows instructions, 3

P
page design
evaluating options for, 122–124
list of components for, 109–110
page layouts, 120–143
  Bootstrap framework and, 131–141
evaluating design options for, 122–124
review questions/answers on, 142–143
Visual Media Queries interface and,
  129–131
  working with predefined, 124–141
palettes, color, 314–315
panels, 29–33
  closing, 30–31
docking, 32–33
dragging, 31
floating, 31–32
grouping, 32
minimizing, 29–30
stacking, 32
tabbed, 388
passwords, 422
Paste Styles option, 293, 395
Photoshop
  copying/pasting images from, 331–334
  exporting assets from, 114–116
  Smart Objects from, 328–331
pixels, 312–313
placeholders
  content, 186–187
  hyperlink, 349, 383, 384
  video, 411
  web page, 434
PNG file format, 317
Point to File icon, 351
Position Assist HUD, 50, 389, 410
positioning images, 320–321
poster images, 410
predefined layouts, 124–141
  Bootstrap framework and, 131–141
  steps for working with, 125–129
  VMQ interface and, 129–131
Preferences dialog, 38–39
prelaunch checklist, 432
Preview in Browser option, 296
Property inspector, 41–42
displaying, 187, 239
docking, 410
graphic tools in, 340
optimizing images with, 337–339
Refresh button, 389
table properties, 42, 282
pseudo-classes, 175
publishing to the web, 418–439
cloaking process for, 428–429
home page setup for, 430–431
prelaunch checklist for, 432
putting your site online, 432–435
remote site setup for, 420–428
review questions/answers on, 439
synchronization process for, 436–438
testing server used for, 426–428
punctuation, 2–3
Put icon, 433, 438

Q
queries. See media queries
Quick Tag Editor, 184, 268, 276

R
raster graphics, 312–317
color spaces for, 314–315
file formats for, 316–317
resolution of, 313–314
scaling issues, 333
size of, 314–315
RDS (Remote Development Services), 421
Refresh icon, 197, 250, 335
regular expressions, 304
Related Files interface, 42–43
relative hyperlinks, 344, 345, 348–351
remote sites, 9, 420–428
  connection methods, 420–421
  setting up for FTP, 421–425
  synchronizing local and, 436–438
testing server used for, 426–428
troubleshooting connections to, 424
Remove Event icon, 383
Resample tool, 340
Reset icon, 327, 338
resolution, 313–314
resources, 14–15
  on CSS, 100
  on HTML, 59
  on HTML5 video, 416
  on media queries, 231
responsive web design, 107
  behaviors and, 385–387
  lists utilizing, 277–279
mobile devices and, 206–208
  tables utilizing, 296–302
See also mobile device design
rollover effects, 374, 385, 386, 396–398
rows, table, 283–284
rules, CSS, 77–78, 224–226

S
Save All command, 253
Save Web Image dialog, 326
saving
  custom workspaces, 37
  pages as templates, 236
<script> tag, 61
Scrubber tool
  mobile device design and, 208–210
  resizing document windows with, 128, 131
<section> element, 63, 248
Select File dialog, 350
Select Image Source dialog, 322, 324
selectors, 46, 77, 90
semantic content, 182–188
  creating for text, 263–264
  custom element classes and, 187–188
  main content placeholders and, 186–187
  steps for building, 182–186
semantic web design, 63–64
SFTP (Secure FTP), 420
Sharpen tool, 340
shorthand, CSS, 96–97
Show Set option, 47, 95, 150–151, 286
Site menu, 9
site root folder, 10
Site Setup dialog, 11, 422, 428–429
Smart Objects, 328–331
smartphones. See mobile device design
<source> tag, 63
<span> tag, 61, 158
special characters, 191–192
specificity theory, 89–90
spellchecking web pages, 302–304
Split view, 26–27, 267
stacking panels, 32
stacks, font, 194, 198–200
staging servers, 420
Standard toolbar, 37
starter layouts, 125–129
strikethrough formatting, 2
<style> tag, 61, 357
<style> tag, 61, 79, 81
style sheets, 151–153
styling
  Accordion widgets, 392–398
  navigational menus, 175–180
  tables and cells, 285–289
SVG graphics, 312
Swap Image behavior, 379–381
Swap Image Restore behavior, 381–382
SWF file format, 412, 414
synchronization process, 436–438
Synchronize Files dialog, 437
syntax
  CSS rule, 78
  media query, 208

T
Table dialog, 280–281
Table Property inspector, 42
tables, 279–302
  caption elements in, 294–296
  cell styling for, 287–289
  controlling the display of, 289–291
  copying and pasting, 284–285
  creating from scratch, 279–284
  inserting from other sources, 291–294
  making responsive, 296–302
  review questions/answers on, 308, 309
  styling with CSS, 285–286
<table> tag, 61, 282, 294
tag selector interface, 43–44, 280
tags
  HTML, 58–59, 60–61
  HTML5, 62–63
targeted links, 363–369
  creating internal, 363–365
  Element HUD for creating, 367–368
  id attribute for, 363, 365–367, 368–369
<td> tag, 61, 287, 288
templates, 234–255
  adding content to, 243–247
  Bootstrap framework, 131–141
  child pages produced from, 241–253
  creating from existing layouts, 236–237
  editable regions in, 237–239
  formatting content in, 247–250
  how they work, 236
  metadata added to, 239–241
  review questions/answers on, 254–255
  updating, 250–253
Templates category icon, 250, 261
testing server, 426–428
text, 261–269
  finding and replacing, 304–307
  font size specification for, 200–202
  formatting for headers, 153–157
text (continued),
  global type styles for, 192–202
  headings created for, 264–266
  HTML structures added to, 266–269
  importing from documents, 261–263
  indented, 273–277
  lists created from, 269–279
  semantic structures for, 263–264
  spellchecking, 302–304
Text HUD, 50, 357, 361–362
<textarea> element, 61
text-based links, 361–362
<th> tag, 61, 287, 288
thumbnails, 108–109
TinyURLs, 1
Tips & Techniques tab, 21–22
<title> tag, 61, 237, 240
Toggle Size Constrain icon, 327, 338
toolbars, 37
<ul> tag, 61, 306
typefaces
  fonts distinguished from, 193
  using in web design, 192–193
See also fonts
</ul>
unordered lists, 273
Update from Original tool, 340
Update Pages dialog, 251, 354
Update Template Files dialog, 251, 353
updating Dreamweaver, 5, 14
uploading files, 432–435
usernames, 422
values, 156
vector graphics, 312
video. See web video
</video> element, 63, 412, 415
views, 23–28
  Code view, 24
  Design view, 24–25
  Inspect mode, 28
  Live Source Code mode, 27–28
  Live view, 25
  Split view, 26–27
Visual Media Query (VMQ) interface, 49,
  129–131
W
Web 2.0, 374
web animation
  adding to pages, 405–409
  Edge Animate program for, 404
  explanation of, 402
  review questions/answers on, 417
  viewing on older systems, 410
See also web video
web browsers
  hyperlink info in, 346
  popularity of specific, 73, 106
  previewing pages in, 296
  video support in, 404, 416
web design, 102–119
  Adobe Generator and, 112–118
  important questions for, 104–106
  page design and, 109–110
  responsive, 107, 206–208
  review questions/answers on, 119
  thumbnails for, 108–109
  wireframes for, 111–112
Web Edition of book, 8–9
web fonts
  building font stacks with, 198–200
  Edge Web Fonts as, 195–198
web video
  adding to pages, 410–413
  explanation of, 402
  fixing buggy, 414
  HTML5 options for, 415–416
  resources about, 416
  review questions/answers on, 417
See also web animation
WebDav system, 421
WebM video format, 412
web-safe color palette, 315
Welcome screen, 19–22
  Create tab, 19–20
  Getting Started tab, 21
  New Features tab, 20
  Tips & Techniques tab, 21–22
Windows vs. OS X instructions, 3
wireframes, 111–112
workspace
  customizing, 16–55
  setting up, 12–13
WYSIWYG HTML editor, 17, 18
X
XML (Extensible Markup Language), 312