CLASSROOM IN A BOOK®
The official training workbook from Adobe
Brie Gyncild & Lisa Fridsma
CONTENTS

GETTING STARTED ............................................ 1
  About Classroom in a Book .................................. 1
  Prerequisites .................................................. 2
  Installing After Effects and Bridge ....................... 2
  Optimizing performance ..................................... 2
  Restoring default preferences ................................ 2
  Accessing the Classroom in a Book files ............... 3
  How to use these lessons .................................... 5
  Additional resources ......................................... 6
  Adobe Authorized Training Centers ...................... 6

1  GETTING TO KNOW THE WORKFLOW ................. 8

  About the After Effects work area ...................... 10
  Getting started ............................................. 11
  Creating a project and importing footage ............ 11
  Creating a composition and arranging layers ........ 15
  About layers ............................................... 18
  Adding effects and modifying layer properties ...... 19
  About the Tools panel ..................................... 19
  Animating the composition ................................ 26
  About the Timeline panel .................................. 27
  About timecode and duration ............................... 30
  Previewing your work ....................................... 33
  Optimizing performance in After Effects ............. 35
  Rendering and exporting your composition ............ 35
  Customizing workspaces .................................... 36
  Controlling the brightness of the user interface .... 37
# Finding resources for using After Effects .......................... 38
# Review questions and answers ........................................ 39

2  **CREATING A BASIC ANIMATION USING EFFECTS AND PRESETS**  
## Getting started ............................................................ 42
## Importing footage using Adobe Bridge .............................. 43
## Creating a new composition ............................................. 45
## Working with imported Illustrator layers ........................... 48
## Applying effects to a layer ............................................. 49
## Applying and controlling effects ..................................... 50
## Applying an animation preset ......................................... 52
## Previewing the effects .................................................. 54
## Adding transparency ..................................................... 55
## Rendering the composition ............................................. 56
## Review questions and answers ....................................... 59
## Review answers ............................................................ 59

3  **ANIMATING TEXT** ...................................................... 60
## Getting started ............................................................ 62
## About text layers .......................................................... 64
## Installing a font using Typekit ........................................ 64
## Creating and formatting point text .................................. 67
## Using a text animation preset ........................................ 69
## Animating with scale keyframes ..................................... 72
## Animating using parenting ............................................. 74
## About parent and child layers ........................................ 75
## Animating imported Photoshop text ................................ 76
## Animating type tracking ................................................ 79
## Animating text opacity ................................................... 81
## Using a text animator group .......................................... 82
## About text animator groups .......................................... 82
## Animating a layer’s position .......................................... 85
## Timing layer animations ............................................... 87
## Adding motion blur ....................................................... 88
## Review questions and answers ....................................... 89
# About expressions ............................................. 150
# Animating movement in the scenery .......................... 152
# Adjusting the layers and creating a track matte .......... 156
# About track mattes and traveling mattes .................. 157
# Animating the shadows ...................................... 160
# Adding a lens flare effect .................................... 162
# Adding a video animation .................................... 164
# Rendering the animation ..................................... 165
# Retiming the composition .................................... 166
# Review questions and answers ................................ 173

## 7 WORKING WITH MASKS ........................................ 174
# About masks ..................................................... 176
# Getting started .................................................. 176
# Creating a mask with the Pen tool ........................... 177
# Editing a mask .................................................... 178
# About mask modes .............................................. 179
# Feathering the edges of a mask ............................... 182
# Creating a Bezier mask ........................................ 182
# Replacing the content of the mask ............................ 183
# Zooming and panning by touch ................................ 184
# Adding a reflection .............................................. 186
# Creating a vignette .............................................. 190
# Adjusting the timing ............................................ 192
# Using the Rectangle and Ellipse tools ......................... 192
# Tips for creating masks ........................................ 193
# Trimming the work area ....................................... 194
# Review questions and answers ................................ 195

## 8 DISTORTING OBJECTS WITH THE PUPPET TOOLS .......... 196
# Getting started .................................................. 198
# About the Puppet tools ......................................... 202
# Adding Deform pins ............................................. 202
# Defining areas of overlap ...................................... 204
Stiffening an area ................................................. 205
Animating pin positions ....................................... 206
Squash and stretch .............................................. 206
Recording animation ........................................ 210
Review questions and answers ........................... 211

9 USING THE ROTO BRUSH TOOL 212
About rotoscoping ............................................... 214
Getting started .................................................. 214
Creating a segmentation boundary ...................... 216
Using Adobe Premiere Pro with After Effects ....... 216
Fine-tuning the matte .......................................... 223
Freezing your Roto Brush tool results ................. 225
Refine Soft Matte and
Refine Hard Matte effects .................................. 225
Changing the background .................................. 226
Adding animated text ....................................... 228
Outputting your project ...................................... 230
Extra credit ....................................................... 231
Review questions and answers ........................... 233

10 PERFORMING COLOR CORRECTION 234
Getting started .................................................. 236
Previewing your project on a video monitor ........... 238
Adjusting color balance with levels ..................... 239
Adjusting color balance with Color Finesse 3 ....... 241
Replacing the background .................................. 244
Color-correcting using Auto Levels ..................... 249
Motion tracking the clouds ................................ 250
Replacing the sky in the second clip ..................... 251
Color grading ...................................................... 255
Extra Credit ......................................................... 259
Review questions and answers ........................... 261
11 USING 3D FEATURES 262
Getting started ........................................... 264
Creating 3D text ........................................... 265
Using 3D views ........................................... 267
Importing a background ................................. 269
Adding 3D lights ......................................... 270
Adding a camera ......................................... 273
Repositioning layers .................................... 275
Adding a text layer ....................................... 276
Working with Cinema 4D Lite ......................... 277
Review questions and answers ....................... 287

12 WORKING WITH THE 3D CAMERA TRACKER 288
About the 3D Camera Tracker effect .................. 290
Getting started ........................................... 290
Repairing rolling shutter distortions .................. 292
Tracking the footage .................................... 293
Creating a ground plane, a camera, and the initial text .... 294
Creating realistic shadows .............................. 299
Adding ambient light .................................... 301
Creating additional text elements ..................... 302
Locking a layer to a plane with a null object .......... 304
Animating the text ....................................... 306
Adjusting the camera’s depth of field ................. 308
Rendering the composition ............................ 309
Review questions and answers ....................... 311

13 ADVANCED EDITING TECHNIQUES 312
Getting started ........................................... 314
Using Warp Stabilizer VFX .............................. 314
Bicubic scaling ........................................... 315
Warp Stabilizer VFX settings .......................... 317
Using single-point motion tracking .................... 319
Checking for drift ....................................... 323
Moving and resizing the track points ..........................324
Using multipoint tracking ........................................325
mocha for After Effects .........................................329
Creating a particle simulation .................................330
Understanding Particle Systems II properties ...............332
About high dynamic range (HDR) footage ................339
Review questions and answers ..............................345

14 RENDERING AND OUTPUTTING ..........................346

Getting started ....................................................348
Creating templates for the Render Queue ................349
About compression ..............................................353
Exporting using the Render Queue .........................354
Preparing movies for mobile devices ......................356
Rendering movies with Adobe Media Encoder ............357
Preparing a movie for broadcast output .................360
Review questions and answers ..............................363

APPENDIX: GENERAL KEYBOARD SHORTCUTS ..........365

INDEX .........................................................366
Adobe After Effects CC provides a comprehensive set of 2D and 3D tools for compositing, animation, and effects that motion-graphics professionals, visual effects artists, web designers, and film and video professionals need. After Effects is widely used for digital post-production of film, video, DVD, and the web. You can composite layers in various ways, apply and combine sophisticated visual and audio effects, and animate both objects and effects.

About Classroom in a Book

Adobe After Effects CC Classroom in a Book (2015 release) is part of the official training series for Adobe graphics and publishing software, developed with the support of Adobe product experts. The lessons are designed to let you learn at your own pace. If you’re new to Adobe After Effects, you’ll learn the fundamental concepts and features you’ll need to master the program. And if you’ve been using Adobe After Effects for a while, you’ll find that Classroom in a Book teaches many advanced features, including tips and techniques for using the latest version.

Although each lesson provides step-by-step instructions for creating a specific project, there’s room for exploration and experimentation. You can follow the book from start to finish, or do only the lessons that match your interests and needs. Each lesson concludes with a review section summarizing what you’ve covered.

Prerequisites

Before beginning to use Adobe After Effects CC Classroom in a Book (2015 release), make sure that your system is set up correctly and that you’ve installed the required software and hardware. You should have a working knowledge of your computer and operating system. You should know how to use the mouse and standard menus and commands, and also how to open, save, and close files. If you need to review these techniques, see the printed or online documentation included with your Microsoft® Windows® or Apple® Mac® OS software.
To complete the lessons in this book, you’ll need to have both Adobe After Effects CC (2015 release) and Adobe Bridge CC installed. The exercises in this book are based on After Effects CC (2015.1 release).

Installing After Effects and Bridge

You must purchase the Adobe After Effects CC software separately. For system requirements and complete instructions on installing the software, visit www.adobe.com/support. Note that After Effects CC requires a 64-bit operating system and OpenGL 3.3 support. You must also have Apple QuickTime 7.6.6 or later installed on your system.

Some of the lessons in this book use Adobe Bridge. After Effects and Bridge use separate installers. You must install these applications from Adobe Creative Cloud (creative.adobe.com) onto your hard disk. Follow the onscreen instructions.

Optimizing performance

Creating movies is memory-intensive work for a desktop computer. After Effects CC (2015 release) requires a minimum of 4GB of RAM. The more RAM that is available to After Effects, the faster the application will work for you. For information about optimizing memory, cache, and other settings for After Effects, see “Improve performance” in After Effects Help.

Restoring default preferences

The preferences files control the way the After Effects user interface appears on your screen. The instructions in this book assume that you see the default interface when they describe the appearance of tools, options, windows, panels, and so forth. Therefore, it’s a good idea to restore the default preferences, especially if you are new to After Effects.

Each time you quit After Effects, the panel positions and certain command settings are recorded in the preferences files. To restore the original default settings, press Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while starting After Effects. (After Effects creates new preferences files if they don’t already exist the next time you start the program.)

Restoring the default preferences can be especially helpful if someone has already customized After Effects on your computer. If your copy of After Effects hasn’t been used yet, these files won’t exist, so this procedure is unnecessary.
Important: If you want to save the current settings, you can rename a preferences file instead of deleting it. When you are ready to restore those settings, change the name back, and make sure that the file is located in the correct preferences folder.

1 Locate the After Effects preferences folder on your computer:

- For Windows: .../Users/<user name>/AppData/Roaming/Adobe/AfterEffects/13.6
- For Mac OS: .../Users/<user name>/Library/Preferences/Adobe/After Effects/13.6

2 Rename any preferences files you want to preserve, and then restart After Effects.

## Accessing the Classroom in a Book files

The lessons in *Adobe After Effects CC Classroom in a Book (2015 release)* use specific source files, such as image files created in Adobe Photoshop® and Adobe Illustrator®, audio files, and prepared QuickTime movies. In order to work through the projects in this book, you will need to download the lesson files from your Account page at peachpit.com. You can download the files for individual lessons or download them all in a single file.

If you purchased an eBook from peachpit.com or adobepress.com, the files will automatically appear on your Account page, under the Lesson & Update Files tab.

If you purchased an eBook from a different vendor or a print book, use the unique code in the back of this book to gain access to the lesson files.

To access the *Classroom in a Book* files, follow these steps:

1 On a Mac or PC, go to www.peachpit.com/redeem, and enter the code found at the back of your book. **This code is not the same as the book’s ISBN.**

2 Click Redeem Code, and sign in or create an account. You will be taken to your Account page.

   You only need to enter the code once. After you redeem the code, you'll be able to access your lesson files at peachpit.com any time you want without entering the code again.

3 Click the Lesson & Update Files tab of your Account page to see a list of downloadable files.

4 Click the lesson file links to download them to your computer.

   The files are compressed into ZIP archives to speed download time and protect the contents from damage during transfer. You must uncompress (or “unzip”) the files to restore them to their original size and format before you use them with the book. Modern Mac and Windows systems are set up to open ZIP archives by simply double-clicking.
5 On your hard drive, create a new folder in a convenient location and give it the name “Lessons,” following the standard procedure for your operating system:

- In Windows, right-click, and choose New > Folder. Then enter the new name for your folder.
- In Mac OS, in the Finder, choose File > New Folder. Type the new name, and drag the folder to the location you want to use.

6 Drag the unzipped Lessons folder (which contains folders named Lesson01, Lesson02, and so on) that you downloaded onto your hard drive to your new Lessons folder. When you begin each lesson, navigate to the folder with that lesson number to access all the assets you need to complete the lesson.

**About copying the sample movies and projects**

You will create and render one or more QuickTime movies in some lessons in this book. The files in the Sample_Movie folders are examples that you can use to see the end results of each lesson and to compare them with your own results.

The files in the End_Project_File folders are samples of the completed project for each lesson. Use these files for reference if you want to compare your work in progress with the project files used to generate the sample movies. These end-project files vary in size from relatively small to a couple of megabytes, so you can either download them all now if you have ample storage space, or download just the end-project file for each lesson as needed, and then delete it when you finish that lesson.

**Web Edition**

This book comes with a free Web Edition that provides many benefits and can be accessed from any device with a connection to the Internet.

Your Web Edition contains the complete text of the book, plus hours of instructional video keyed to the text as well as interactive quizzes. In addition, the Web Edition will be updated when Adobe adds significant feature updates between major Creative Cloud releases.

**Accessing the free Web Edition**

You must register your book purchase on peachpit.com in order to access the free Web Edition:

1 Go to www.peachpit.com/register, and then sign in or create a new account.
3 Answer the questions as proof of purchase. The Web Edition will appear under the Digital Purchases tab on your Account page.
4 Click the Launch link to access the product.
How to use these lessons

Each lesson in this book provides step-by-step instructions for creating one or more specific elements of a real-world project. The lessons build on each other in terms of concepts and skills, so the best way to learn from this book is to proceed through the lessons in sequential order. In this book, some techniques and processes are explained and described in detail only the first few times you perform them.

Many aspects of the After Effects application can be controlled by multiple techniques, such as a menu command, a button, dragging, and a keyboard shortcut. Only one or two of the methods are described in any given procedure, so that you can learn different ways of working even when the task is one you’ve done before.

The organization of the lessons is also design-oriented rather than feature-oriented. That means, for example, that you’ll work with layers and effects on real-world design projects over several lessons, rather than in just one lesson.

Additional resources

*Adobe After Effects CC Classroom in a Book (2015 release)* is not meant to replace documentation that comes with the program or to be a comprehensive reference for every feature. Only the commands and options used in the lessons are explained in this book. For comprehensive information about program features and tutorials, refer to these resources:

- **Adobe After Effects Learn & Support**: helpx.adobe.com/after-effects.html is where you can find and browse tutorials, help, and support on Adobe.com.

- **After Effects Forums**: forums.adobe.com/community/aftereffects_general_discussion lets you tap into peer-to-peer discussions, and questions and answers about After Effects.

- **Adobe Create Magazine**: create.adobe.com offers thoughtful articles on design and design issues, a gallery showcasing the work of top-notch designers, tutorials, and more.

- **Resources for educators**: www.adobe.com/education and edex.adobe.com offer a treasure trove of information for instructors who teach classes on Adobe software. Find solutions for education at all levels, including free curricula that use an integrated approach to teaching Adobe software and can be used to prepare for the Adobe Certified Associate exams.
Also check out these useful links:

- **Adobe Add-ons**: creative.adobe.com/addons is a central resource for finding tools, services, extensions, code samples, and more to supplement and extend your Adobe products.

- **Adobe After Effects CC product home page**: www.adobe.com/products/aftereffects

## Adobe Authorized Training Centers

Adobe Authorized Training Centers offer instructor-led courses and training on Adobe products. A directory of AATCs is available at training.adobe.com/trainingpartners.
This page intentionally left blank
Lesson overview

In this lesson, you’ll learn how to do the following:

• Create custom shapes.
• Customize a shape’s fill and stroke.
• Use path operations to transform shapes.
• Animate shapes.
• Repeat shapes.
• Snap layers into alignment.
• Use an expression to animate properties in time with audio.

This lesson will take approximately an hour to complete. Download the Lesson04 project files from the Lesson & Update Files tab on your Account page at www.peachpit.com, if you haven’t already done so. As you work on this lesson, you’ll preserve the start files. If you need to restore the start files, download them from your Account page.
Shape layers make it easy to create expressive backgrounds and intriguing results. You can animate shapes, apply animation presets, and add Repeaters to intensify their impact.
Getting started

Shape layers are created automatically when you draw a shape with any of the drawing tools. You can customize and transform an individual shape or its entire layer to create interesting results. In this lesson, you will use shape layers to build dynamic and whimsical designs on the street and driveways of a neighborhood.

First, you'll preview the final movie and set up the project.

1 Make sure the following files are in the Lessons/Lesson04 folder on your hard disk, or download them from your Account page at www.peachpit.com now:
   - In the Assets folder: Beat.aif, drop.aep, Melody.aif, tracking.aep, Tracking.mp4
   - In the Sample_Movie folder: Lesson04.mov

2 Open and play the Lesson04.mov sample movie to see what you will create in this lesson. When you are done, quit QuickTime Player. You may delete this sample movie from your hard disk if you have limited storage space.

As you start After Effects, restore the default application settings. See “Restoring default preferences” on page 2.

3 Start After Effects, and then immediately hold down Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) to restore default preferences settings. When prompted, click OK to delete your preferences.

4 Close the Start window.

After Effects opens to display a blank, untitled project.

5 Choose File > Save As > Save As, and then navigate to the Lessons/Lesson04/Finished_Project folder.

6 Name the project Lesson04_Finished.aep, and then click Save.

Creating the composition

Next, you'll import the files you need and create the composition. You'll import two footage items and two saved project files.

1 Double-click an empty area of the Project panel to open the Import File dialog box.

2 Navigate to the Lessons/Lesson04/Assets folder on your hard disk, Ctrl-click (Windows) or Command-click (Mac OS) to select the Beat.aif and Melody.aif files, and then click Import or Open.
3 Choose File > New > New Folder to create a new folder in the Project panel.

4 Name the folder Audio, press Enter or Return to accept the name, and then drag the two audio files you imported into the Audio folder. Then expand the folder so you can see its contents.

5 Double-click an empty area of the Project panel to open the Import File dialog box again.

6 Navigate to the Lessons/Lesson04/Assets folder. Ctrl-click (Windows) or Command-click (Mac OS) to select the drop.aep and tracking.aep project files, and then click Import or Open. The video files and other elements you will need later are imported with the projects.

Now you’re ready to create the composition.

7 Press Ctrl+N (Windows) or Command+N (Mac OS) to create a new composition.

8 In the Composition Settings dialog box, name the composition Spiral, select the HDTV 1080 24 preset, and set the Duration to 10:00. Then click OK.

After Effects opens the new composition in both the Timeline and Composition panels.

Tip: To specify 10 seconds, type 10. in the Duration box. The period indicates that there are no units in that position. To specify 10 minutes, type 10.. in the box.
Adding a shape layer

After Effects includes five shape tools: Rectangle, Rounded Rectangle, Ellipse, Polygon, and Star. When you draw a shape directly in the Composition panel, After Effects adds a new shape layer to the composition. You can apply stroke and fill settings to a shape, modify its path, and apply animation presets. Shape attributes are all represented in the Timeline panel, and you can animate each setting over time.

The same drawing tools can create both shapes and masks. Masks are applied to layers to hide or reveal areas or as input into effects; shapes have their own layers. When you select a drawing tool, you can specify whether the tool draws a shape or a mask.

Drawing a shape

You'll begin by drawing a rectangle with a fill and stroke.

1. Select the Rectangle tool ( ).
2. Choose Fit from the Magnification Ratio pop-up menu at the bottom of the Composition panel so that you can see the entire composition.
3. Using the Info panel to guide you, position the cursor at approximately 950, 540, which is near the center of the Composition panel. (You may need to widen the Info panel to see the X and Y coordinates.)
4. Drag down and to the right to create a rectangle. Again, watch the Info panel. The bottom (B) value should be approximately 40 pixels and the right side (R) value should be about 400 pixels. The shape appears in the Composition panel, and After Effects adds a shape layer named Shape Layer 1 to the Timeline panel.
5. Select the Shape Layer 1 layer name, press Enter or Return, change the layer name to Spiral, and press Enter or Return to accept the change.
Applying a fill and stroke

You can change the color of a shape by modifying its Fill settings in the Tools panel. Clicking the word Fill opens the Fill Options dialog box, where you can select the kind of fill, its blending mode, and its opacity. Clicking the Fill Color box opens the Adobe Color Picker if the fill is solid, or the Gradient Editor if the fill is a gradient.

Similarly, you can change the stroke color and width of a shape by modifying its Stroke settings in the Tools panel. Click the word Stroke to open the Stroke Options dialog box; click the Stroke Color box to select a color.

1 Select Rectangle 1 in the Timeline panel.

2 Click the Fill Color box (next to Fill) to open the Shape Fill Color dialog box.

3 Change the color to a light blue (we used R=0, G=170, B=255), and click OK.

4 Click the Stroke Color box in the Tools panel, change the stroke color to the same light blue color, and then click OK.

5 Choose File > Save to save your work so far.

Twisting a shape

The rectangle is fine, but it isn't very exciting. In After Effects, you can easily modify a basic shape into something more complex and interesting. You'll use the Twist path operation to transform this rectangle into a spiral shape.

As you work with the Twist path operation, keep in mind that it rotates a path more sharply in the center than at the edges. Positive values twist clockwise; negative values twist counterclockwise.

1 In the Timeline panel, open the Add pop-up menu next to Contents in the Spiral layer, and choose Twist.
2  Expand Twist 1.

3  Change the Angle to **220**.

The rectangle changes dramatically. Next, you'll change the center point of the twist to create a larger spiral.

4  In the Timeline panel, change the x-axis value for Center to **–220**.

The spiral is a bit thin. You’ll change the stroke width to thicken it.

5  Select the Spiral layer in the Timeline panel, and then change the Stroke Width value in the Tools panel to **20 px**.

The center of the spiral has a rounded cap, but the end is square. You'll change the end so that they match.

---

**Note**: If the center of your spiral looks different from ours, you probably drew a slightly larger or smaller rectangle. You can delete what you have and start over with a fresh composition or try adjusting the x-axis value for Center.
6  Expand Stroke 1 to see its properties.

7  Choose Round Join from the Line Join menu.

The spiral looks great. Now you just need to center it, so that it looks natural when it rotates, and then you’ll set up its rotation and add motion blur.

8  Press A to reveal the Anchor Point property for the layer. Then adjust the x-axis and y-axis values until the anchor point is centered in the black center (negative space) of the spiral, just above the center end cap. (The exact values will vary depending on how you created the initial shape.)

9  Make sure the current-time indicator is at the beginning of the timeline. Then press R to reveal the Rotation property for the layer. Click the stopwatch icon (●) to create an initial keyframe.

10 Press the End key, or move the current-time indicator to the end of the timeline. Change the Rotation value to $1x+0.0^\circ$. With this setting, the shape will rotate once during its ten-second cycle.
11 Click the Motion Blur switch for the layer, and then click the Enable Motion Blur button (⢀) at the top of the Timeline panel.

12 Press the spacebar to preview your animation, and press the spacebar again to stop the preview. Choose File > Save to save your work so far.

Creating custom shapes

You can use the five shape tools to create a wide variety of shapes. However, the real power in using shape layers is that you can draw any shape and manipulate it in a myriad of ways.

Drawing a shape with the Pen tool

You'll use the Pen tool to draw a shape that resembles a lightning bolt. In order to position it properly in the final project, you'll create a separate composition for this shape.

1 Press Ctrl+N (Windows) or Command+N (Mac OS) to create a new composition.

2 In the Composition Settings dialog box, name the composition Bolt, select the HDTV 1080 24 preset, set the duration to 10:00, and then click OK.

3 Select the Pen tool (_pen) in the Tools panel.

4 In the Composition panel, draw a shape that resembles a lightning bolt, as in the illustration. When you create the first vertex, After Effects automatically adds a shape layer to the Timeline panel.
5 Select Shape Layer 1, press Enter or Return, and change the layer’s name to **Bolt**. Press Enter or Return to accept the new name.

6 With the Bolt layer selected, click the Fill Color box in the Tools panel, and select a yellow color (we used R=255, G=237, B=0). Then click the Stroke Color box in the Tools panel, and select black (R=0, G=0, B=0).

7 Change the Stroke Width to **10 px**.

Creating a self-animating shape

Wiggle Paths turns a smooth shape into a series of jagged peaks and valleys. You’ll use it to make the lightning bolt more electrifying. Because the operation is self-animating, you need to change only a few properties for the entire shape to move on its own.

1 Expand the Bolt layer in the Timeline panel, and choose Wiggle Paths from the Add pop-up menu.

2 Expand Wiggle Paths 1. Then change the Size to **15** and the Detail to **30**.

3 Change Wiggles/Second to **24** to speed up the movement.

4 Click the Motion Blur switch for the layer, and then click the Enable Motion Blur button at the top of the Timeline panel. Then hide the layer properties.

5 Move the current-time indicator across the time ruler to see the shape move.
Duplicating shapes

You could draw a shape multiple times, but it’s easier to duplicate the shape automatically. The Repeater path operation lets you multiply a shape and transform its properties to achieve different results.

You’ll use the Repeater path operation to duplicate a shape that was created in Adobe Illustrator and then pasted into the Path property of a shape layer in the Drop.aep project file.

1 In the Project panel, expand the drop.aep folder, and then double-click the Drop composition to open it.

The Drop composition opens in the Timeline panel and the Composition panel.

2 Expand the Drop layer and its Contents folder if its properties aren’t visible. Then select Shape 1, and choose Repeater from the Add pop-up menu.

You’re selecting Shape 1 because you want to add the Repeater to the individual shape, not the entire layer.

3 Expand Repeater 1.

4 Change the number of copies to 4.
The Repeater creates three copies of the shape, for a total of four. You’ll rotate the shapes and then reposition them to create a pinwheel.

5 Expand Transform: Repeater 1.

6 Change the Rotation to 90°.

Because you applied the rotation to the Repeater rather than to the shape, each drop rotates around the layer’s anchor point to a different degree. When you change the Transform properties for the Repeater, the change is multiplied by the number of copies created. In this case, the first shape retains the original value of 0, the second shape rotates 90 degrees, the third shape rotates 180 degrees, and the fourth shape rotates 270 degrees. The same concept applies to each of the Transform properties.

7 In the Transform: Repeater 1 properties, change the Position to 0, 0.

The shapes overlap because the anchor point is located in the center of each shape.

8 Change the Anchor Point value to 15, 45.

The shapes align to form a pinwheel. Now you’ll make the pinwheel rotate.

9 Make sure the current-time indicator is at the beginning of the time ruler. Then, expand the Transform: Shape 1 category, and click the stopwatch icon next to the Rotation value to create an initial keyframe.
10 Press the End key or move the current-time indicator to the end of the time ruler, and change the Rotation value to $2\pi + 0.0^\circ$.

11 Drag the current-time indicator across the time ruler to see the pinwheel rotate.

You used the Repeater path operation to duplicate an individual shape. Now you’ll use it to copy all the contents of the layer, turning one pinwheel into eight.

12 In the Timeline panel, hide all the properties under Shape 1. Then select the Drop layer, and choose Repeater from the Add pop-up menu.

13 Expand the new Repeater 1 category, and change the number of copies to 4. Because you applied the Repeater to the entire layer, the full pinwheel was copied.

14 Expand the Transform: Repeater 1 category, and change the Position values to 450, 0.

There are now four pinwheels across the top of the Composition window.

15 Select the Drop layer, and choose Repeater from the Add pop-up menu again to create the Repeater 2 category.
Expand the Repeater 2 category, and change the number of copies to 2. Then expand the Transform: Repeater 2 category, and change the Position values to 0, 575.

By applying another Repeater to the entire layer, you copied the full row of pinwheels.

17 Hide all the properties for the layer.

18 Click the Motion Blur switch for the layer, and then click the Enable Motion Blur button (○) at the top of the Timeline panel.

19 Press the spacebar to preview eight pinwheels rotating in unison; press the spacebar again to stop the preview. Then choose File > Save to save your work so far.

**Duplicating and modifying a composition**

You'll use the Drop composition as a starting point for a similar composition that uses different fill and stroke options.

1 In the Project panel, select the Drop composition, and choose Edit > Duplicate to create a copy of the composition.

2 Double-click the Drop 2 composition in the Project panel to open it. Then, in the Timeline panel, expand the Drop layer, and the Contents category.

3 Select Shape 1, and then choose Fill from the Add pop-up menu.

4 Expand Fill 1, click the Color box, and choose any fill color you like.

5 Expand Stroke 1, click the Color box, and choose the stroke color you like.

6 Move the current-time indicator across the time ruler to preview the rotating pinwheels.

7 Hide all the properties for the layer.

8 Choose File > Save to save your work so far.
Positioning layers with snapping

You’ve created and manipulated shapes in a variety of ways. Now you’ll create a checkerboard pattern. Positioning the layers will be easy with the snapping feature in After Effects.

Creating a new composition

This checkerboard background includes multiple layers, so you’ll create a new composition for it.

1  Press Ctrl+N (Windows) or Command+N (Mac OS) to create a new composition.

2  In the Composition Settings dialog box, name the composition Checkerboard, choose HDTV 1080 24 from the Preset menu, and type 10:00 for Duration. Then click OK.

After Effects opens the new Checkerboard composition in the Timeline and Composition panels. You'll start by adding two solid layers—the building blocks of the checkerboard background.

3  Choose Layer > New > Solid to create a solid layer.

4  In the Solid Settings dialog box, do the following, and then click OK:

   • Name the layer Dark Red.
   • Change both the Width and Height to 200 px.
   • Choose Square Pixels from the Pixel Aspect Ratio menu.
   • Select a dark red color. (We used R=145, G=0, B=0.)

5  With the Dark Red layer selected in the Timeline panel, press R to display the Rotation property for the layer. Then change the Rotation to 45 degrees.
6  Select the Selection tool (A). Then, in the Composition panel, drag the layer up so that only the bottom half of the diamond appears in the composition.

7  Press Ctrl+Y (Windows) or Command+Y (Mac OS) to create another solid layer.

8  In the Solid Settings dialog box, name the layer **Light Red**, and change the color to a light red (we used R=180, G=75, B=75). Then click OK.

The default width and height for the new solid layer match the settings you used previously, so the Light Red layer has the same dimensions as the Dark Red layer.

9  With the Light Red layer selected in the Timeline panel, press R to display the Rotation property. Then change the Rotation to **45** degrees.

---

**Snapping layers into position**

You've created two layers, but they have no relationship to each other in the composition. You'll use the Snapping option in After Effects to quickly align the layers. When the Snapping option is enabled, the layer feature that is closest to your pointer when you click becomes the snapping feature. As you drag the layer near other layers, features on other layers are highlighted, showing you where the snapping feature would snap if you released the mouse button.

1  Select Snapping in the options section of the Tools panel, if it's not already selected.

2  Using the Selection tool, select the Light Red layer in the Composition panel.

When you select a layer in the Composition panel, After Effects displays the layer handles and anchor point. You can use any of these points as the snapping feature for a layer.

---

**Note:** You can snap two shape layers together, but not two shapes within a single layer. Also, a layer must be visible to snap to it. 2D layers can snap to 2D layers, and 3D layers can snap to 3D layers.

**Tip:** If the Snapping option isn't selected, you can temporarily enable it: Click a layer and start dragging, and then press Ctrl (Windows) or Command (Mac OS) as you drag the layer.
3. Click near the corner handle on the left side of the Light Red layer, and drag it near the lower right edge of the Dark Red layer until it snaps into place, with the sides abutted. Be careful not to drag the corner itself, or you’ll resize the layer.

As you drag the layer, a box appears around the left corner handle you selected, indicating that it is the snapping feature.

4. In the Timeline panel, select both of the layers, and press R to hide the Rotation property for both layers.

5. With both layers still selected, choose Edit > Duplicate to copy them.

6. In the Composition panel, drag the two new layers down to the left, and then down to the right, so that the new Dark Red layer abuts the original Light Red layer. Remember that the snapping feature is determined by where you initially click when you begin to drag.

7. Repeat steps 5–6 until you have a column of diamonds filling the screen.

8. Choose Edit > Select All to select the layers in the Timeline panel.

9. Press Ctrl+D (Windows) or Command+D (Mac OS) to duplicate the layers. Then move them to the left in the Composition panel until they snap into place.

10. Repeat step 9 until the Composition panel is full. Pull the duplicate layers to the left or right as necessary. Remember to click near an appropriate snapping feature as you begin dragging each time.

11. Choose File > Save to save your work.
Adding compositions to a 3D project

You've created several compositions, all of which need to stay in position as the camera moves through the scene. You'll integrate the compositions using the 3D Camera Tracker effect, which lets you add 3D layers to a clip with the same movement and perspective changes as the original.

You'll work extensively with the 3D Camera Tracker effect in Lesson 12. For this project, we've set the effect up so that all you need to do is to position layers and parent them to a null object to attach them to the 3D scene. A null object is an invisible layer that has all the properties of a visible layer, so that it can be a parent to any layer in the composition. In this case, the null object tracks the camera movement.

1. In the Project panel, double-click the Tracking composition (in the tracking.aep folder) to open it. Choose Fit from the Magnification Ratio pop-up menu at the bottom of the Composition panel so that you can see the entire composition.

The Tracking composition includes the background video you'll use to place the shapes you've created.

2. Select the Spiral composition in the Timeline panel, and then select the 3D switch ( ) for the Spiral layer.

3. Select the Tracking composition in the Timeline panel again. Then drag the Spiral composition from the Project panel to the Timeline panel, placing it at the top of the layer stack.

4. Select the 3D switch for the Spiral layer, and then select the Collapse Transformations switch ( ) for the layer, too.

The Collapse Transformations switch ensures that transformations in a nested composition aren’t flattened; instead, when the project is rendered, transformations in the nested composition will be performed at the same time transformations are performed for the containing composition.
In the Timeline panel, click the Parent pop-up menu for the Spiral layer, and choose 2. Track Null 1. This sets the Track Null 1 layer as the parent of the Spiral layer, which in turn becomes the child layer.

With the Spiral layer selected, press P to reveal its Position property. Change the value to 0, 0, 0. This moves the spiral to the same location as the Null object.

Move the current-time indicator to 5:00 so you can clearly see the Spiral layer’s position in the image. Then press Shift+R to reveal the Rotation properties, and change the Orientation values to 0, 0, 0.

The spiral is almost in the right place, but you want to position it perfectly in the cul-de-sac. You’ll tweak its position.

Change the Position for the layer to –35, –225, 0.

Press the spacebar to preview the spiral rotating in the cul-de-sac. Press the spacebar again to stop the preview. Hide the Spiral layer’s properties to keep the Timeline panel tidy.

You’ve placed the first composition. You’ll repeat the process to place the others.

Drag the Bolt composition from the Project panel to the top of the Timeline panel, and select the 3D switch for the Bolt layer.

Select 3. Track Null 1 from the Parent menu for the Bolt layer. Then press the P key, press Shift+R, and press Shift+S to reveal the Position, Rotation, and Scale properties for the layer.
Pressing the Shift key as you press keyboard shortcuts lets you view multiple layer properties at the same time.

12 Change the Position values to $-650$, $-1200$, $0$. Change the Orientation to $0$, $0$, $345$. Change the Scale to $85\%$. Finally, select the Motion Blur switch for the Bolt layer, and then hide the layer’s properties.

Next, you’ll use the same process to integrate the Drop composition.

13 Go to 2:00 so you can see the driveway where this composition will be placed. Drag the Drop composition from the Project panel to the top of the stack in the Timeline panel, and select the 3D switch for the layer.


15 Change the Position values to $730$, $2275$, $0$; the Orientation values to $5$, $8$, $2$; and the Scale to $45\%$. Then select the Motion Blur switch for the layer, and hide the layer’s properties.

You’ll place the Drop2 composition in the lower left driveway, visible as the camera begins to pan.

16 Go to the beginning of the time ruler. Drag the Drop2 composition from the Project panel to the top of the Timeline panel, select the 3D switch, and select 5. Track Null 1 from the Parent menu.
17 Press P, Shift+R, and Shift+S. Change the Position values to \(-1025, 3575, 0\); the Orientation to \(0, 352, 0\); and the Scale to 35%. Select the Motion Blur switch for the layer, and hide the layer’s properties.

Finally, you’ll add the Checkerboard composition. You’ll need to scale it a little differently so that it fits into the driveway.

18 Go to 4:00 in the time ruler. Drag the Checkerboard composition from the Project panel to the top of the Timeline panel, select its 3D switch, and choose 6. Track Null 1 from the Parent menu.

19 Press P, Shift+R, and Shift+S. Change the Position values to \(-922, 814, 10\) and the Orientation to \(1, 355, 2\). Then click the link icon for the Scale property to unlink the values, and change the values to 42%, 35%, 42%. Select the Motion Blur switch for the layer, and hide the layer’s properties.
Adding the finishing touches

The layers work pretty well with the underlying video, but they’ll blend more convincingly if you change the blending modes. You’ll also add the audio file.

1. Click the Toggle Switches/Modes button at the bottom of the Timeline panel.

2. Choose Multiply from the Mode menu for all the layers except the Checkerboard layer; choose Overlay for the Checkerboard layer. (You won’t be able to change the mode for the Spiral layer, because Collapse Transformations is selected.)

3. Drag the Melody.aif clip from the Project panel to the bottom of the layer stack in the Timeline panel.

4. Press the spacebar to enjoy your creation! When you’re done previewing the project, save your work.
Extra credit

Animating layers to match audio

Currently, the spiral shape turns in a slow circle. The movie will be more compelling if the size of the spiral is animated to match the beat of the music. You can scale the spiral in time with the amplitude of an audio file. First, you need to create keyframes from the audio information.

1 Select the Spiral composition in the Timeline panel. Drag the Beat.aif file from the Project panel into the Timeline panel, and place it beneath the Spiral layer.

2 Right-click or Control-click the Beat.aif layer, and choose Keyframe Assistant > Convert Audio To Keyframes.

After Effects adds the Audio Amplitude layer. The new layer is a null object layer, meaning it has no size or shape and won’t appear in a final render. Null objects let you parent layers or drive effects.

3 Select the Audio Amplitude layer, and press E to display the effects properties for the layer.

Three categories of effects properties are available for the layer: Left Channel, Right Channel, and Both Channels. You’ll work with the Both Channels category.

4 Expand the Both Channels category.

When you converted the audio to keyframes, After Effects created keyframes that specify the amplitude of the audio file in each frame of the layer. You’ll sync the scale of the spiral to those values.

5 Select the Spiral layer, and press S to reveal the Scale property for the layer.

6 Alt-click (Windows) or Option-click (Mac OS) the Scale stopwatch to add an expression. The words transform.scale appear in the time ruler for the layer.

7 With the transform.scale expression selected in the time ruler, click the pick whip icon (♀) on the Expression:Scale line, and drag it to the Slider property name in the Audio Amplitude layer.

When you release the mouse, the pick whip snaps, and the expression in the shape layer time ruler now reads temp = thisComp.layer("Audio Amplitude").effect("Both Channels")("Slider"); [temp, temp, temp]. (You may need to click the expression to see the full thing.) This expression means that the Scale values for the shape layer will depend on the Slider values of the Audio Amplitude layer.

Note: You’ll learn more about expressions in Lesson 6.

8 Choose Edit > Deselect All to deselect the layers. Then move the current-time indicator through the time ruler to see the spiral resize with the audio’s amplitude.

The scale definitely changes, but sometimes the spiral disappears. You’ll modify the expression so that the spiral remains visible.

9 In the time ruler, click the expression to make it active. Click an insertion point at the end of the first line, between the closing parentheses and the semicolon. Type +90, and then click an empty area of the Timeline panel to accept the change.

10 Preview the composition, and watch the spiral pulse to the beat of the audio file.

11 Return to the Tracking composition in the Timeline panel. Then press the spacebar, and watch the spiral pulse as the camera moves through the scene. Save your work.
Review questions

1. What is a shape layer, and how do you create one?
2. How can you quickly create multiple copies of a shape?
3. How can you snap one layer to another?
4. What does the Twist path operation do?

Review answers

1. A shape layer is simply a layer that contains a vector graphic called a shape. To create a shape layer, draw a shape directly in the Composition panel using any of the drawing tools or the Pen tool.

2. To quickly duplicate a shape multiple times, apply a Repeater operation to the shape layer. The Repeater path operation creates copies of all paths, strokes, and fills included in the layer.

3. To snap one layer to another in the Composition panel, select Snapping in the options section of the Tools panel. Then click next to the handle or point you want to use as a snapping feature, and drag the layer close to the point to which you want to align it. After Effects highlights the points to which it will align when you release the mouse button. Note that you cannot snap shape layers.

4. The Twist path operation rotates a path more sharply in the center than it does at the edges. Entering a positive value twists clockwise; entering a negative value twists counterclockwise.
INDEX

SYMBOLS

3D axis 267
3D cameras 273–274
  adjusting depth of field 308
  point of interest 274
3D Camera Tracker effect 290–310
3D features 262–287
3D layers
  camera layers 273
  creating in Cinema 4D Lite 277–285
  Position properties 185
  rotating 185
  Rotation properties 267
3D Layer switch 267
3D lights 270–272
  casting shadows with 272
  point of interest 271
3D text 265–267
3D views 267–268

A

action-safe zones 29
Active Camera view 273

adding
  blur 256–257
  transitions 237
  vignettes 190, 258
Add mask mode 246
Add Or Remove Keyframe At Current Time button 207
adjustment layers 137, 256
Adobe After Effects CC application
  After Effects Help 38
  compositions 12
  installing 2
  optimizing performance in 2
  projects 12
  workflow 11
  workspace 10
Adobe After Effects CC Classroom in a Book (2015 release)
  lesson files 3
  prerequisites 1
Adobe After Effects Help 38
Adobe Audition, editing audio files in 140
Adobe Bridge
  about 43
  browsing animation presets in 70
importing files with 43
installing 2, 43
navigating folders in 43
opening 43
previewing images in 44
Preview panel 44
workspaces 44
Adobe Illustrator files, importing 47
Adobe Media Encoder 357–362
creating presets for 360
encoding presets in 358
Adobe Photoshop files
importing 146
importing layer styles from 147
importing text from 76
layered 145
Adobe Premiere Pro, using with After Effects 216
Adobe Stock 117
Adobe Typekit
installing a font using 64–66
sorting fonts in 65
using sample text in 66
alpha track mattes. See also track mattes
adjusting 156
ambient lights, adding 301
Analyze Forward button 322
anchor points, adjusting 119
animating
in time with audio 112
layers 142, 145
lighting 148, 159
motion 152
on a path 126
opacity 81, 276
precomposed layers 135
Puppet tool pins 210
scale 72
shadows 159
text 62–89, 76, 82, 228, 306
using parenting 74
using the Puppet tools 201
walking cycles 206
animation presets 29–30
applying 52, 80
applying from Adobe Bridge 70
browsing in Adobe Bridge 43, 70
Bullet Train 52
customizing 71
Dissolve - Vapor 54
Evaporate 70
Fade Up Characters 78
Increase Tracking 80
text 69
animations
about 26
copying to other elements 308
duplicating using pick whips 150
easing 73
linking through expressions 150
repeating 130
smoothing with Easy Ease 31
Warp Stabilizer VFX 316
animator properties in text animator
groups 82
application window 10
audio
  adding tracks 139
  editing files in Adobe Audition 140
  file formats supported 139
  using amplitude to animate layers 112
Audio/Video Switches in the Timeline
  panel 27
Audition. See Adobe Audition
Auto Levels effect 249

B
background, replacing 244–249
background strokes, creating with the Roto
  Brush tool 218–219
base frames
  adding for the Roto Brush tool 221
  creating with the Roto Brush
  tool 216–217
beveling text in Cinema 4D Lite 283
Bezier curves
  breaking direction handles for 181
  in a motion path 127
  using to create masks 180
Bezier masks, creating 182
bicubic scaling 315
bilinear sampling 315
blending modes
  about 189
  applying 189
  for masks 179, 245
blur, adding 256–257
Bridge. See Adobe Bridge
brightness, changing in the user interface 37
broadcast, preparing a movie for 360
Browse Presets command 70
Bullet Train animation preset 52

C
C4D files 279
cached frames 220
cameras, adding to a 3D scene 273–274
Camera Settings 309
Casts Shadows property 272
CC Particle Systems II effect 330
  properties 332
CC Toner 256
Channel Blur effect 32–33
Character panel 49, 67, 266
checkerboard, generating 106
child layers 74, 75
Cinema 4D Lite 277–284
  adding surface textures to objects in 284
  coordinate measurements 277
  creating 3D text in 280–282
  exporting an After Effects composition for 279
  positioning objects in 282
  updating objects in After Effects 284
  workspace 280
Cineware effect 279
Classroom in a Book 1
Clone tool 259
cloning an object 259
codecs 353
Collapse Transformations switch 107
color
  adjusting color balance 239
  keying 214
  mapping 256
color correction 234, 249
  about 236
  previewing accurately 238
Color Emboss effect 51
Color Finesse 3. See SA Color Finesse 3 effect
color grading 236, 255–256
Color Range effect 253–254
Comp Camera option in the Cineware effect 280
Composition Navigator bar 28
Composition panel
  about 15
  splitting into multiple views 268
  typing in 67
compositions
  about 15
  adding footage items to 17
  creating 15, 45, 63
  defined 12
  fitting layers to 46
  importing 13
  nesting 17
  rendering 56, 309
  retiming 166
Composition Settings dialog box 45, 63
compression 353
Convert Audio To Keyframes 112
Convert To Editable Text command 28, 77
Convert Vertex tool 180, 181
coordinates
  entering for effects 22
  measured in After Effects and Cinema 4D Lite 277
copying
  animation to other elements 308
  layers 124
Corner Pin effect 160
Create Text And Camera command 294, 295
creating
  compositions 15, 63
  shape layers 90, 320
  text 48
Creative Cloud Libraries 117
current-time indicator 27
current time in the Timeline panel 27
customizing
  brightness of the user interface 37
  workspaces 37
custom shapes, drawing 98–99
Custom View 1, in 3D views 268

D
default preferences 2
  restoring in Windows 11
Deform pins
  about 202
  adding 202
  customizing 203
dependencies, finding missing 15
depth of field, adjusting 308
deselecting layers 18
Directional Blur effect 134
direction handles, breaking 181
Dissolve - Vapor animation preset 54
distortions, rolling shutter 292
docking panels 10
drawing
circles 336
custom shapes 98
ellipses 191
rectangles 94
shapes 94
drift, in motion tracking 323
Drop Shadow effect 50
drop zone 10
duplicating
animations 130
animations using pick whips 150
layers 20
objects in a scene 259
videos 132
duration 93
about 30
changing 194

e
Easy Ease
about 31
adding 31, 73
adjusting 171
in the Graph Editor 343

inging
masks 178
Premiere Pro clips in After Effects 216
segmentation boundaries 220
text 77
Effect Controls panel 22
about 50
hiding properties in 24
setting properties in 22, 32–33
effects
about 19
applying 50
applying to solid-color layers 132
Auto Levels 249
CC Particle Systems II 330
Channel Blur 32–33
Color Emboss 51
Color Range 253–254
controlling 50
Corner Pin 160
Directional Blur 134
Dissolve - Vapor animation preset 54–55
Drop Shadow 50
Exposure 23
finding 21
Fractal Noise 134
Glow 229
Hue/Saturation 227
Lens Flare 162, 338
missing 15
motion blur 88
Radial Blur 20
Ramp 337
Refine Hard Matte 225
Refine Soft Matte 225
SA Color Finesse 3 241
Timewarp 340
Wave Warp 137
Zoom-Bubble 30
Effects & Presets panel 21, 29
Ellipse tool 191, 336
    using to create a mask 192
encoding presets in Adobe Media Encoder 358
end bracket, setting for the work area 71
Evaporate animation preset 70
exporting
    for Cinema 4D 279
    movies with Adobe Media Encoder 357
Exposure effect 23
expressions 112, 260
    about 150
    applying 150
    linking animations through 150
Extrude in Cinema 4D Lite 282
extruding text in Cinema 4D Lite 282–283

F
face tracking 231
Fade Up Characters animation preset 78
Fast Blur effect 257
feathering masks 187
fills, gradient 95
filtering fonts in Typekit 65
finding missing footage, fonts, or effects 15
Fit To Comp command 46
Fit To Comp Width command 68
fonts
    finding missing 15
    selecting 67
footage
    about 13
    finding missing 15
    importing 12, 15, 144, 62
    importing using Adobe Bridge 43
    tracking 293
foreground strokes, creating with the Roto Brush tool 217–218
Fractal Noise effect 134
freezing Roto Brush tool results 225

G
Glow effect 229
gradient fills 95
Graph Editor
    about 168
    in the Timeline panel 27
    using to remap time 169, 343
grids
    displaying 49, 68
    hiding 49, 69
    snapping to 68
ground planes, creating with 3D Camera Tracker effect 294
H
HDR (high dynamic range) footage 339
hiding properties 24
Home key 29
Horizontal Type tool 29, 48, 79
Hue/Saturation effect 227

I
importing
files from Adobe Bridge 44
footage 12, 15, 144, 43, 62
multiple files 13
Photoshop files 13, 76
text 76–77
Increase Tracking animation preset 80
Increment And Save command 228–229
Info panel 94
In point 27
installing After Effects 2
interpolation between keyframes 31

J
JavaScript in expressions 150

K
keyboard shortcuts 25
keyframes
about 31
adding 125
adding to current time 207
creating from audio amplitude 112
keying 214
with Color Range effect 253–254
with Keylight 1.2 effect 244
Keylight 1.2 effect 246–248
layer features, used when snapping 105
Layer Name column 18
layers
about 15, 18
adjustment 137
animating 142, 145
animating to match audio 112
child 74, 75, 120
converting to 3D layers 269
copying 124
deselecting 18
duplicating 20
expanding in the Timeline panel 24
fitting to compositions 46
importing in Photoshop files 145
light, 3D 270–272
locking 200
making visible in the Timeline panel 33
naming in Photoshop 146
naming text layers 49
nesting 53
null 304
parent 74, 75
parenting 120
precomposing 53, 122, 156, 257
rearranging in the Timeline panel 18
renaming 20, 77
scaling 200
shape 90, 94
snapping 104
solid 104, 134
soloing 149
text 64
transforming properties 24
trimming 137
viewing multiple properties 209
layer styles 147
Layer switches in the Timeline panel 27
learning resources for Adobe After Effects CC 5
Lens Flare effect 162, 338
lesson files, downloading 3
Levels (Individual Controls) effect 239
Libraries panel 117
lighting, simulating changes in 148
lightning bolt, drawing 98–99
lights
  adding to a 3D scene 270–272
  ambient 301
  point 300
Light Settings dialog box 270
linking animations through expressions 150
locking layers 200
mask modes 245
  Add 246
  Subtract 246
masks
  about 176
  creating Bezier 180, 182
  creating with the Pen tool 177
curved 180
drawing with the Ellipse tool 192
drawing with the Rectangle tool 192
editing 178
feathering 187
inverting 178
modes for 179
modifying with the Convert Vertex tool 180
properties, displaying 178
replacing content of 183
segments 176
tips for creating 193
tracking 244
vertices 176
working with 174
mask tracker 244–246, 251–253
Master Exposure (Exposure effect) 24
Material Options properties 267, 272
mattes
  about 214
  adjusting with the Refine Edge tool 224
screen 248
track 157
traveling 157
viewing against black 219
viewing with red overlay 219

M

Magnification Ratio pop-up menu 94, 107
Mask Expansion setting 246
Mask Feather tool 187
Maxon Cinema 4D Exporter 279
Maxon Cinema 4D Lite 277–284
meshes
  adjusting the Triangle value 204
  used with Puppet tools 202
missing fonts, effects, or footage 15
mobile devices, preparing compositions for 356
mocha for After Effects 329
modes, mask 179
motion
  animating 152
  stabilization 314
motion blur, adding 88, 158
motion paths
  customizing 126
  hiding 33
  using Bezier handles to alter 127
Motion Source 322
Motion Target 322
motion tracking 250–251, 254–255
  analyzing and applying 322, 328
  drift 323
  multipoint 325
  single-point 319

N
navigating folders in Adobe Bridge 43
nesting
  compositions 17
  layers 53
NTSC D1 preset 45
null objects 278, 304

O
opacity
  animating 81, 276
  modifying 26, 55
optimizing performance in After Effects 2, 35
Out point 27
output modules in the Render Queue panel 57
outputting projects 346
overlap, defining areas of 204
Overlap pins
  about 202
  customizing 205
overscan, accounting for 29

P
Pan Behind tool 120
panels
  docking and arranging 10
  groups 10
  maximizing 12
  menus 27
  stacking 10
panning with touch gestures 184
Paragraph panel 68
paragraph text 64
parallel corner-pinning 325
parenting 74, 120
  about 74, 75
  object to null layer 305
text in Cinema 4D Lite 282
particle systems
  creating 330–331
  customizing 333
Pen tool 177
performance, optimizing 2, 35
perspective corner-pinning 325
Photoshop. See Adobe Photoshop files
pick whip 305
  using to duplicate animation 150
pixel aspect ratio 360
point light, creating 300
point of interest
  for a 3D light 271
  for a camera layer 274
point text 67
Position property
  displaying in the Timeline panel 25
  for a 3D layer 185
Pre-compose dialog box 53, 122
precomposed layers, animating 135
precomposing layers 53, 54, 122, 156, 257
preferences
  location of files 3
  restoring defaults 2
  restoring defaults in Windows 11
Premiere Pro. See Adobe Premiere Pro
presets
  browsing in Adobe Bridge 70
  creating for Adobe Media Encoder 360
  finding 21
previewing
  compositions 33
  images in Adobe Bridge 44
  limiting to a range of frames 70
  manual 53
Preview panel 33
Preview panel in Adobe Bridge 44
Project panel 14
projects
  about 12
  saving 15
properties
  changing values for multiple layers 26
  displaying in the Timeline panel 25
  displaying multiple 125
  hiding 24
Puppet Overlap tool
  about 202
  using 204
Puppet Pin tool 202
Puppet Sketch tool 210
Puppet Starch tool
  about 202
  using 205
Puppet tools 196
  about 202
  customizing Overlap pins 205
  preparing artwork for use with 201
  recording animation with 210
  settings for Starch pins 205
  using the mesh 202
Q
  QuickTime required version 2
INDEX

R
Radial Blur effect 20
Ramp effect 337
Rectangle tool 94, 192
red overlay in matte preview 219
Reduce Chatter value 223
Refine Edge tool 224–225
Refine Hard Matte effect 225
Refine Soft Matte effect 225
reflections, adding to video 186
remap-time marker in the Source Time ruler 167
renaming layers 20
Renderer options in the Cineware effect 279
rendering 309
compositions 56
for mobile devices 356
movies 346
templates 349
test movies 354
using compression in 353
using the Render Queue panel 230, 355
with Adobe Media Encoder 357–362
Render Queue panel 166, 165, 230, 56
adding compositions to 56
opening 56
output modules 57
Render Settings options 57
render-settings templates 349
Repeater path operation 100–103
replacing content using a mask 183
resizing layers 200
resources for using After Effects 38
restoring default preferences 11, 42, 62
retiming
compositions 166
playback 340
rolling shutter distortions, repairing 292
rotating 3D layers 185
Roto Brush & Refine Edge effect 223
Roto Brush tool 212–233
creating background strokes with 218–219
creating foreground strokes with 217–218
freezing results 225
refining a segmentation boundary 220
rotscoping 214

S
SA Color Finesse 3 effect 241–244
safe zones 29
sample text, using in Typekit 66
sampling algorithms 315
saving projects 15
scaling layers 200
screen matte 248
segmentation boundary
about 216
creating 216–219
refining 220
segments in a mask 176
selectors in text animator groups 82
Select View Layout pop-up menu  268
self-animating shapes  99
separating background from foreground  214–233
Sequence Layers option  237
shadow catcher  300
shadows
  adding to a 3D scene  272
  creating with the 3D Camera Tracker effect  299
shape layers
  about  90, 92
  adding  94
  applying gradient fills to  95
  creating  90–113, 320
shapes
  creating a spiral  94–98
  custom  98–99
  drawing  94, 98
  duplicating  100–103
  self-animating  99
  twisting  95
shortcuts for Transform properties  25
shortening layers  194
Shutter Angle
  about  159
  adjusting  159
Shutter Phase  159
skewing text  83
smoothing animations with Easy Ease  31
snapping
  about  105
  features  105
layers  104–108
  temporarily enabling  105
Snap to Grid command  68
solid layers
  creating  104, 134
  using to create particle systems  331
soloing layers  149
sorting fonts in Typekit  65
Source Name column  18
Source Time ruler in time remapping  167
span, extending for Roto Brush tool  220
Specular Intensity  272
Specular Shininess  272
spiral, creating in After Effects  94–98
splitting the Composition panel into multiple views  268
squash and stretch animation  206
stabilizing motion  314
stacked panels  10
Starch pins
  about  202
  adding  205
  settings  205
Stock images in Libraries panel  117
Subdivision Surface icon in Cinema 4D Lite  282
Subtract mask mode  246
surface, adding to objects in Cinema 4D Lite  284
synchronizing audio with animation  112
Sync Selected Fonts  66
templates for rendering 349
text
  animating 62–89, 76, 78, 82, 228, 306
  animating tracking in 79
  animation presets for 29–30, 69
  beveling in Cinema 4D Lite 283
  centering 266
  converting to editable 77
  creating 48
  creating 3D 265–267
  creating 3D in Cinema 4D Lite 280–282
  editing 77
  entering in the Composition panel 67
  extruding in Cinema 4D Lite 282
  formatting 67, 228
  formatting in Cinema 4D Lite 281
  imported from Photoshop 76
  layers 64
  naming layers 49
  point 67
  positioning 68
  skewing 83
  text animator groups 82
Text tool in Cinema 4D Lite 281
time
current-time field 27
current-time indicator 27
duration 30
measuring 207
specifying in the Duration box 93
time code 30
time graph 27
time-lapse simulation, creating 166
Timeline panel
  about 27
  displaying properties in 25, 26
  expanding layers in 24
  renaming layers in 77
  viewing multiple layer properties in 209
Time Remap keyframes 169
Time Remapping 166
Time-Reverse Keyframes command 72
time ruler
  about 27
  in the Timeline panel 27
Timewarp effect 340
title-safe zones 29
Toggle Alpha Boundary button 219
Toggle Alpha button 219
Toggle Alpha Overlay button 219
Toggle Transparency Grid button 226
tools
  Clone Stamp 259
  Mask Feather 187
  Pan Behind 120
  Puppet 202
Tools panel
  about 19
  selecting hidden tools in 19
touch gestures 184
Track Camera command 293
Tracker panel 245, 250
tracking
  animating for text 79
  faces 231
  masks 251–253
  motion 254–255
  using mocha for After Effects 329
tracking motion
  multipoint 325
  single-point 319
  using the 3D Camera Tracker 293
tracking presets
  customizing 80
  using to animate text 80
track mattes
  about 157
  creating 156, 157
Track Motion 250
track points 250
  3D Camera Tracker 293
  moving and resizing 324
  positioning 321, 327
Track Selected Masks Backward button 245
Transform properties 24
transitions, adding 237
transparency 55
traveling mattes 157
Triangle value for Puppet tools 204
trimming
  layers 137
  the work area 194
twisting shapes 95

 Twist path operation 95–98
Typekit. See also Adobe Typekit
  filtering fonts in 65

U
  undocking panels 10
User Interface Colors 37
user interface, introduction to 10

V
  vertices
    converting 180
    in a mask 176
video file, duplicating in a timeline 132
Video switch 33, 54
views, 3D 267
vignettes, adding 190, 258

W
  walking cycle, animating 206
Warp Stabilizer VFX 314–319
  settings 317
Wave Warp effect 137
Wiggle Paths operation 99
work area
  brackets 27, 71
  introduction to 10
  trimming in the Timeline panel 194
workflow 11
workspaces
  customizing 10
  in Adobe Bridge 44
  predefined 36
  saving custom 37

X
  x axis 22
    in the 3D axis 267

Y
  y axis 22
    in the 3D axis 267

Z
  z axis 265
    in the 3D axis 267
Zoom-Bubble effect 30
zooming with touch gestures 184
Production Notes


References to company names in the lessons are for demonstration purposes only and are not intended to refer to any actual organization or person.

Typefaces used

Adobe Myriad Pro and Adobe Warnock Pro as well as other Adobe typefaces are used throughout the lessons. For more information about OpenType and Adobe fonts, visit www.adobe.com/type/opentype.

Team credits

The following individuals contributed to the development of *Adobe After Effects CC Classroom in a Book (2015 release)*:

- **Writer:** Brie Gyncild
- **Illustrator and Compositor:** Lisa Fridsma
- **Copyeditor and Proofreader:** Wendy Katz
- **Indexer:** Brie Gyncild
- **Keystroker:** Megan Ahearn
- **Cover design:** Eddie Yuen
- **Interior design:** Mimi Heft
- **Lesson Designer:** Lisa Fridsma
- **Adobe Press Executive Editor:** Victor Gavenda
- **Adobe Press Project Editor:** Karyn Johnson
- **Adobe Press Production Editor:** David Van Ness
This page intentionally left blank
Contributors

Mark Christiansen—Author of *After Effects CC Visual Effects and Compositing Studio Techniques* (Adobe Press), Mark has created visual effects and animations for feature films, network television, computer games, and an array of high-technology companies. Recent clients include *The Orphanage* (Dimension Films), *Telling Pictures* (The History Channel), and the Couturié Company (HBO), as well as Seagate, Sun, Intel, and Medtronic. Feature credits include *The Day After Tomorrow* and films by Robert Rodriguez.

Lee Daniels—Lee is a freelance animator, illustrator, and motion graphic artist working from his home studio in South London. Following a career in magazine design and image retouch, Lee has spent the last 10 years producing bespoke animation and visual effects for a wide range of international corporate, TV, and new media clients including Channel 4, Discovery US, National Geographic, Mirror Group, Exxon Mobile, and Cancer Research. Recently, he has worked on several newly commissioned UK TV shows for the 4oD short-form comedy platform. He generously shares tips & tricks in After Effects animation with the growing subscriber community on his LeeDanielsART YouTube channel. See more of his work at leedanielsart.com.

Takeshi Hiraoka—Plucked out of paradise, Hiraoka moved to chilly San Francisco from Honolulu, Hawaii, one cold winter day in 2002. In San Francisco, he attended the Academy of Art University, graduating in May 2004. This is where Hiraoka met Sheldon Callahan, with whom he directed and produced the feature-length DV film *Origin*. In addition to being a DV producer, Hiraoka is also a 2D and 3D animator.

Stephen Schleicher—Traveling from Kansas to Georgia to California, Stephen has worked as an editor, graphic designer, videographer, director, and producer on a variety of small and large video productions. Currently, Stephen teaches media and web development at Fort Hays State University. He also works on video and independent projects for state and local agencies and organizations, as well as his own works. Stephen is a regular contributor to Digital Media Net (www.digitalmedianet.com).

Anna Ullrich—Anna is a pale but fine digital artist based in Seattle, Washington, although her heart resides in Minnesota, where her spry and brilliant Democratic grandmother lives. Anna earned a BFA from the University of Washington in Seattle and an MFA from the University of Notre Dame in Indiana (both in photography).

Special Thanks

We offer our sincere thanks to Todd Kopriva for his support and help with this project. We couldn’t have done it without you!