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WITH UBUNTU INSTALLED and ready to rock, it’s time to get started using
your new desktop. The stock install of Ubuntu provides a very complete
and flexible system. Unlike other operating systems, Microsoft Windows
for example, Ubuntu includes everything you need to get started, such as
an office suite, media tools, a Web browser, a graphics package, an e-mail
client, and more. With the installation complete, you are up and running
right away.

Using a computer is a rather individual process, and different people use
their computers in different ways. To help promote this choice, Linux has
the capability to use any one of a number of different graphical interfaces.
This flexibility, combined with the ballooning popularity of Linux and
open source, has resulted in literally hundreds of different graphical envi-
ronments springing up, each covering these different types of users and
ways of working.

Despite this huge range of different environments available, there are two
clear leaders in KDE and GNOME. Both environments provide a com-
prehensive and easy-to-use desktop, but they differ in how that desktop is
used. The KDE system is more akin to Windows and aims for complete
configurability of your desktop. The competing GNOME desktop shows
inspiration from both Windows and Mac OS X and sets as a priority sim-
plicity and ease of use. Luckily, Ubuntu users are blessed with the choice
of either desktop—the default desktop in stock Ubuntu is GNOME, and
the Kubuntu distribution uses the KDE desktop. Kubuntu is covered in
Chapter 7.

In this chapter, you get started with GNOME and use it to do the normal
and not-so-normal things you face every day with your computer. This
includes opening and running applications, managing your files, adjusting
the look and feel, using applications, managing your media, and more.
Buckle up and get ready to take your shiny new desktop for a drive!

TIP The Ubuntu Desktop Is GNOME
When reading about Ubuntu you often see the terms Ubuntu desktop and GNOME used
interchangeably. Both of these terms refer to the same thing—the default Ubuntu desktop is
a version of GNOME itself. Of course, Ubuntu provides several other desktops, including
KDE (in Kubuntu), Xfce (in Xubuntu), and a variety of others.
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Taking Your Desktop for a Ride
When you start your Ubuntu system, you are asked for a username and
password to log in with. In the last chapter you specified a user account
when installing the system, so use that to log in. First type in your user-
name and press Enter, then your password and press Enter.

TIP Language? Sprache? Langue? Lingua?
Click the Options > Select Language button to change the language of the desktop. If you
click the button and the selection does not include your language, jump to the Ubuntu in
Your Language section on page 104 to learn how to add new language packs.

After a few seconds you will see the Ubuntu desktop appear (Figure 3-1).
The desktop comprises three main areas.

1. At the top of the screen is the panel. This bar contains the desktop
menu options and application shortcut icons on the left side as well as
the notification area on the right side. You use this bar to load
applications and to see the status of certain activities on your system.
The panel is always visible when you use your desktop.
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Figure 3-1 The Ubuntu desktop is simple, uncluttered, and . . . brown.
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2. The large middle part of the screen is the desktop. This part of the
screen is normally covered by the applications that you use, but you
can also put icons and shortcuts on the desktop, too.

3. The bottom part of the screen is called the taskbar. This area displays
a rectangle for each application open just like in Windows.

You may have noticed that, unlike other operating systems, there are no
icons on the desktop. The reason for this is that desktop icons typically get
covered by applications, and, as such, you can’t get at them. If you need to
start applications, you typically use the Applications menu or the shortcuts.

TIP Device Icons
Although there are no application icons on the desktop, when you plug in USB devices such
as portable music players, keyring drives, or digital cameras, a device icon will appear on the
desktop.

Starting Applications and Finding Things
Starting applications is simple. Just click on the Applications menu on the
left side of the panel. Inside this menu are a number of submenus for dif-
ferent types of applications. Hover your mouse over each category, and
then click the application you want to load. As an example, click on Appli-
cations > Internet > Firefox Web Browser. After a few seconds the browser
will pop up.

When applications are loaded, the brown window border has three but-
tons on the right-hand side:

� Left button (thin white line): This is used to minimize the applica-
tion and put it in the taskbar.

� Middle button (white square): This maximizes the window to take
up the full desktop area.

� Right button (white cross): This button closes the application.

Every application has an entry in the taskbar at the bottom of the screen.
You can click these entries to minimize or maximize the application and
right-click to see some other options.
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Changing Your Menu Layout Although the main Applications, Places, and
System menus are logical by default, you may want to further customize
them by moving entries into different submenus, not displaying certain
items, and making other tweaks. All of this is easily done with the built-in
menu editor.

To edit the menus, right-click on a menu, and select Edit Menus. The
menu editor now appears, as shown in Figure 3-2.

The menu editor is fairly intuitive. To adjust which items are shown, click
on a submenu in the left-hand pane and change the Show checkbox for the
items you want to show or hide. To add a new item, select the submenu the
item should appear in, and then click the New Item button on the right-
hand side. The box shown in Figure 3-3 will appear.

Menu items can be applications (the default), applications running in
terminals, or files. Select the appropriate setting for the Type box for your
menu item, or leave it as Application. Provide a name for your menu item in
the Name box, the command to run in the Command box (or the location
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Figure 3-2 The menu editor lets you easily change the Ubuntu menus.
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of your file in the Location box if you changed the type to File), and a brief
description in the Comment box. You can also use the Browse button to
select the application to run (or the file to open). Finally, click No Icon, and
select an icon for the item. Click OK to finish adding the new menu item.

Finding Your Files and Folders
When using your computer you often need to save and open files and fold-
ers, move them around, and perform other tasks. The Places menu con-
tains a bunch of entries, including those listed here, to access different
parts of your computer and the network.

� Home Folder: Your home folder is used to store the files and work for
each user who is logged in. This is the most important folder on the
system, and you can think of it as the equivalent of My Documents in
Windows—virtually everything you save lives here. Each user has a
separate home folder.

� Desktop: The Desktop folder is inside your home folder and contains
files that visually appear on your desktop as icons. If you drag a file
onto your desktop, it will appear in the Desktop folder. Similarly,
moving a file out of this folder or deleting it will remove it from your
desktop.

� Computer: Clicking this item displays the different drives attached to
your computer as floppy drives, CD/DVD drives, and USB keys or
sticks. This is the equivalent of the My Computer icon in Windows.
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� Network Servers: This option accesses servers that are available on
your local network. This is the equivalent of the Network Neighbor-
hood in Windows.

� Connect to Server: Click this to run a wizard to create a connection
to a network server. You can use this to add an icon to the desktop
that, when clicked, provides a list of remote files in the desktop file
manager. You can then treat this window like any other file manager
window and drag files back and forth. This is really useful for copying
files to other computers.

� Search for Files: Use this to search for files on your computer.

� Recent Documents: Click this submenu to display the most recently
used documents.

Configuring Your System
The third and final menu, System, is used to configure and customize your
system, access help, and report problems. Inside the menu are a few options.

� Preferences: This submenu contains items for customizing the look
and feel of your desktop. Each of these settings applies only to the
desktop of a user who is logged in. If you log in as another user, the
settings change to that user’s preferences.

� Administration: This submenu is used to configure systemwide
settings such as networking, users, printing, and more. To use 
these menu items, you need to know the system administrator
password.

� Help and Support: With this you can access the Ubuntu Help Center,
which provides documentation and guides for your Ubuntu desktop.

� Report a Problem: If you do encounter a problem with your system,
you can use this item to report it as a bug to Launchpad, the
application used by Ubuntu (and other projects) to manage
development and support. To learn more about Launchpad visit
http://launchpad.net.
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TIP Feel the Power
When you installed Ubuntu, you were asked for a username and password for the system.
This password not only provides access to your normal user account but also accesses the
all-powerful Administration features. As such, when you access the menu options and are
asked for the password, just enter your normal password, and you can use those features.

This feature applies only to the first user account that you created on the system. If you add
other accounts, those users cannot access the Administration options unless you explicitly
give them access.

Shortcut Icons
On the panel are a number of shortcut icons next to the menus. These
small icons are always visible and can be single-clicked to gain immediate
access to your favorite applications. Ubuntu comes with some stock short-
cuts on the panel, but you are welcome to add your own.

Adding your own icon is as simple as finding the application you want to
add in the menu and then dragging it to the panel. You can then right-click
the new shortcut icon and select Move to move it to the right place.

Applets
One of the most useful features in Ubuntu is the ability to run small pro-
grams called applets on the panel. These small programs are useful for a
variety of tasks and provide quick and easy access via the panel.

To add an applet, right-click the panel and select Add to Panel. The win-
dow shown in Figure 3-4 pops up. Select one of the many applets, and click
Add. When the applet appears on the panel, you can press the middle
mouse button (or the left and right buttons together) to move it around.

The Notification Area
In the top right-hand part of the panel is the notification area and the
clock. The notification area is similar to the Windows system tray in that it
provides a series of small icons that indicate something specific. A good
example of this is Network Manager, which looks after your network con-
nections—both wired and wireless—for you.
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You can fiddle with the notification area items by right-clicking them to
view a context menu. Some icons (such as the volume control) allow you
to left-click on them to view them. Try clicking the little speaker icon and
adjusting the slider.

QUICK TIP Right-click the volume icon, and select Open Volume Control to access the mixer settings
for your sound card. These settings configure the speakers, microphone, line-in, and any
other sound card inputs or outputs.

The Clock
Next to the notification area is the clock. Click on the clock to view a calen-
dar. Later, when you use Evolution, items that are added to your calendar
appear in the clock applet too. Instead of opening up Evolution to find out
when your dreaded dentist appointment is, just click on the clock to see it
immediately.

QUICK TIP Customize your clock by right-clicking it and selecting Preferences.
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The Taskbar
The taskbar sits at the bottom of the screen. This small bar is always visible
and indicates which applications are currently open. In addition to this,
the taskbar also sneaks in a few other handy little features.

To the far left of the taskbar is the Hide/Show Desktop button. Clicking
this button hides all of your open applications and shows the desktop.
Clicking it again redisplays them. This button is useful when you need to
quickly access something on your desktop.

Next to this button is the applications area, which shows each of the cur-
rently open applications. For each application, an entry is added, and you
can right-click it to view a context menu. This menu is used to minimize,
maximize, resize, close, and do other things to the application.

QUICK TIP You can switch between multiple applications in Ubuntu just like in Windows by pressing
Alt-Tab. When you press this key combination, a small window appears that can be used to
switch between active applications.

To the right of the applications area are two small rectangles called the
workspaces. Each of these rectangles represents another screen in which
you can view an application. As an example, you may be using your Web
browser and e-mail client while chatting to your friends on IRC and
instant messenger on the first desktop and working on a document on the
second desktop. You can then just click each virtual desktop to switch to it
to access your different applications. Another useful tip applies when
you’re moving applications between virtual desktops—if you have an
application on the first desktop, just right-click the brown window or the
taskbar entry, select Move to Another Workspace, and pick the relevant
workspace number. The menu also has Move to Workspace Left and Move
to Workspace Right options. This makes moving applications between
your workspaces quite simple.

QUICK TIP Although Ubuntu has only two workspaces configured by default, you can have as many—
or few—as you like, and even name them. To configure them, right-click on one of the work-
spaces in the bottom right-hand corner of your screen, and select Preferences from the
menu.
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To the right of the workspaces is the wastebasket. Files that are dragged
onto this icon are destined to be deleted. To fully delete these files, right-
click the wastebasket and select Empty the Wastebasket.

TIP Usability and the Ubuntu Desktop
Throughout the development of the Ubuntu desktop, great care and attention have gone into
usability. As an example, the four corners of the screen are established as areas that are
simple to access—you don’t need to carefully mouse over the area and can instead just
throw your mouse to the corner. This is why each corner has an important feature. It makes
accessing each feature that little bit easier.

Ubuntu is filled with tiny usability improvements such as this that help make it as intuitive as
possible.

Shutting Down Your Computer and Logging Out

Now that you’re becoming acquainted with Ubuntu, you’ll want to keep
using it as long as possible, but there will always come a time when you
have no choice but to leave your computer and go do something else. As
you have already seen, Ubuntu is extremely flexible, and this area is no
exception. Click System > Log Out or the icon in the top right of the screen
to see the various options (shown in Figure 3-5) for ending your current
computing session.
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There are a number of options available upon logout, however, the choices
presented to you will depend on your installation (e.g., Suspend and/or
Hibernate may not be available).

� Log Out: This option lets you log out of the current session and go
back to the main login screen.

� Lock Screen: This option locks the screen. This is useful when you
need to use the bathroom or grab some lunch. It will lock the
computer and ask for your password to reenable the desktop.

� Switch User: When you click this option, your user account remains
logged in, but another user account can be used. When the second
account logs out, Ubuntu reverts to the original one.

� Suspend: If your computer supports Suspend, click this icon to
suspend the power. The next time your computer is turned on, the
desktop will be resumed.

� Hibernate: When you click this option, the current state of the system
is saved to the hard disk and can be switched off. This is like the
Suspend option but slower, and it works on all computers.

� Restart: Click this to restart the computer.

� Shut Down: Click this to shut down your computer.

Using Your Applications
Now that you have gotten used to the desktop, let’s explore some of the
many applications included on your new system. By default, Ubuntu
comes with a wide range of popular and established applications to listen
to music, watch videos, create documents, browse the Web, manage your
appointments, read your e-mail, create images, and much more. These
applications have been vetted by the developers to ensure they are the best-
of-breed Linux applications available.

Although Ubuntu includes a range of different software applications, it is
likely you will want to install extra applications and explore other available
software. Fortunately, the Ubuntu system is built on a powerful founda-
tion that makes software installation as simple as pointing and clicking.
Click Applications > Add Applications, and a dialog box appears that you
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can use to install new applications. Just browse through the different cate-
gories and check the applications to install. Click the Apply button, and
the application is downloaded and installed for you.

This tool provides a simple way to access a limited core set of popular appli-
cations, but there are actually more than 16,000 packages available to your
Ubuntu system. Software installation is discussed in detail in Chapter 4.

TIP Another Way to Run Applications
Although you will most typically start your applications by selecting them from the Applica-
tions menu, you can also press Alt-F2 to bring up a box where you can type in the name of
an application and run it.

Browsing the Web with Firefox
Firefox is the default Ubuntu Web browser and provides you with a
simple, safe, and powerful browsing experience. Firefox has become one of
the most successful open source projects in the world and continues to
garner huge popularity. With more than 300 million downloads and rap-
idly increasing browser share, Firefox has been an unparalleled success. It
really is that cool.

Fire up Firefox by clicking its icon (the first one next to the System menu)
on the panel or by selecting Applications > Internet > Firefox Web
Browser. After a few seconds you are presented with the main Firefox win-
dow (Figure 3-6).

The Firefox window looks similar to most Web browsers and includes the
staple back, forward, reload, and stop buttons, an address bar, and some
menus. These familiar-looking elements help you become acquainted
with Firefox, and if you have used Internet Explorer, Opera, Netscape, or
Safari before, you are sure to pick it up in no time.

Navigating your way around the Internet is no different in Firefox than in
any other browser—just type the Web address into the address bar, and
press Enter. Firefox also has a few nice features that make it easy to access
your favorite sites. As an example, if you want to visit the Ubuntu Web site,
you can just enter www.ubuntu.com (leaving off all that http:// nonsense).
Alternatively, you can just type in “Ubuntu,” and Firefox will go off to
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Google, enter “Ubuntu” as the search term, and take you to the first result
in the search. This feature is incredibly handy for popular sites that are
likely to be at the top of the search results page.

TIP The search box next to the address bar can be used to do a search on Google. Just type in
your search term and press Enter. You can also choose other places to search (such as Ama-
zon, eBay, and so on) by clicking the small icon and selecting a different option.

This search box can be used to search just about anything. To add more search engines,
click the small icon and then select Add Engines.

Tabbed Browsing If you are anything like any of the authors behind this
book, you look at a number of different Web sites each time you use the
Internet. It is not uncommon to have your Webmail open as well as eBay,
some discussion forums, news sites, blogs, and more. Before long, your desk-
top is littered with browser windows, and your taskbar is full to the brim.

Firefox has a nimble solution to this problem in the form of tabbed brows-
ing. If you are looking at your friend’s Web site about raccoons and decide
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you want to check out your favorite sports player’s Web site, just click
File > New Tab or press Ctrl-T and—ta-da!—a new tab is unveiled in your
browser window. You can now load another page inside this tab.

The tabbed browsing fun doesn’t stop, though—oh no! When you are read-
ing the Web and you see a link you are interested in viewing, right-click the
link, and select Open Link in New Tab. The page will load in the new tab,
and you can continue reading the article and view the link afterward.

Bookmarking Your Favorite Sites To bookmark the page you are viewing,
click Bookmarks > Bookmark This Page. In the dialog box that pops up,
use the combo box to select the folder to store the bookmark in. If you
want to create a new folder, click the small arrow button on the right side
of the box, and the box will expand. To create a main folder, select the
Bookmarks folder, and click New Folder. You can also create subfolders by
clicking an existing folder and again clicking New Folder. When you have
finished selecting or creating a new folder, click Add to add the bookmark.

Save Time with Live Bookmarks Firefox also includes a special feature
called live bookmarks that automatically grabs content from a Web site
without your needing to visit it. As an example, go to http://fridge.
ubuntu.com/ (a popular Ubuntu news site), and you will see a small orange
icon—which indicates that this site has feed available—on the right side of
the address bar. Click this orange square, and you will be taken to a new
page that previews the feed and gives you the option of what you would
like to use to subscribe to it. Use the default option (Live Bookmarks), and
click Subscribe Now. A dialog box will pop up. Use the default values pro-
vided and click OK. A new toolbar button is added, and when you click on
it, a list of the items from the Web site are displayed. Each time you start
Firefox, it will quietly go away and update this list so that you don’t need to
visit the site yourself.

TIP If You Liked the Fridge
You may also like Planet Ubuntu at http://planet.ubuntu.com/. This site collects the personal
blogs of a number of different Ubuntu developers. Planet Ubuntu gives a unique insight into
what the developers are working on.

Bolt It On, Make It Cool Although Firefox is already a powerful and flex-
ible Web browser, it can be extended even further using special plug-in
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extensions. These extensions cover not only typical browsing needs such as
the Macromedia Flash plug-in but also other more specialized extras that
extend the browser itself.

To install normal Web plug-ins, just visit a site that requires the plug-in. A
yellow bar will appear indicating that you are missing a plug-in. Click the
Install Missing Plug-ins button to grab the required plug-in. By default,
Ubuntu does not come with the Macromedia Flash plug-in because it does
not live up to Ubuntu software freedom requirements, so you will need to
install this separately.

To extend the browser itself with additional features, go to https://addons.
mozilla.org/, and browse for an extension that you are interested in. When
you find something you would like to install, click the Install link. A dialog
box will pop up asking you to confirm the installation. Click Install Now.
Your new extension will now download and install automatically. Typi-
cally this requires a restart of Firefox, and then your extension is available.

TIP Be Careful Where You Download
It is recommended that you download extensions only from http://addons.mozilla.org. If you
do need to install an extension from another site, make sure it is a site you trust. Otherwise,
the extension may contain unsafe software, viruses, or spyware.

Creating Documents with OpenOffice.org
Included with Ubuntu is a full office suite called OpenOffice.org. This
comprehensive collection contains applications for creating word process-
ing documents, spreadsheets, presentations, databases, drawings, and
mathematical equations. The suite provides an extensive range of func-
tionality, including reading and writing Microsoft Office file formats, and
can also export documents as Web pages, PDF files, and Macromedia Flash
animations.

Let’s give OpenOffice.org a whirl by creating a letter with it. Start OpenOf-
fice.org Writer by selecting it from the Applications > Office menu. When
it has loaded, you will be presented with the interface shown in Figure 3-7.

If you have used a word processing program before, many of the com-
mon interface elements, such as the buttons for setting font type and
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size, bold, italic, underline, and alignment, look and behave the same. The
OpenOffice.org developers have designed the suite to be easy to migrate
to if you have used something such as Microsoft Office before. After a
few hours playing with OpenOffice.org, you are sure to know how to do
what you need.

Start your letter by first choosing a nice font. In the font combo box you
should see DejaVu Sans Condensed selected as the default. Click the box
and instead choose the lovely Bitstream Vera Sans font. Change the font
size by clicking the combo box to the right of the font box and selecting 10
as the size. With the cursor on the left side of the page, add your home
address to the letter.

Now press Enter to leave a blank line under the address, and click the Align
Right toolbar button (the icon looks like some lines aligned to the right). If
you are unsure of what a button does, hover your mouse over it to pop up
a tool tip. Now add to your letter the address of the recipient.
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Press Enter again to leave a blank line, and type the main body of the letter.
Feel free to use the bold, italic, and underline buttons to add emphasis to
your words. You can also use other toolbar buttons to add items such as
bullet points and numbered lists and to change the color of the font. If you
want to add features such as graphics, tables, special characters, and
frames, click the Insert menu and select the relevant item. You can cus-
tomize each item added to the page by right-clicking the item and using
the options shown in the context menu.

When your letter is complete, you can save it by selecting File > Save, by
clicking the floppy disk toolbar icon, or by pressing Ctrl-S. The default file
format used by OpenOffice.org is the OpenDocument Format. This file
format is an official open standard and is used across the world. The file
format is slightly different for different types of applications (.odt for
word processor files, .ods for spreadsheets, and so on), but each format
provides an open standard free from vendor lock-in. You can also save in a
variety of other formats, including Microsoft Office.

TIP Vendor Lock-In?
In the proprietary software world, it is common for each application to have its own closed
file format that only the vendor knows how to implement. When a person uses the software
to create documents, the closed format means that only that specific tool can read and write
the format. As long as you want to access your documents, you need that tool. This is
known as vendor lock-in.

To combat this problem, the OpenOffice.org suite (and the vast majority of other open
source applications) uses an open file format that is publicly documented. In fact, the format
is a published standard under ISO/IEC 26300:3006. This means that other applications can
implement the OpenDocument file format, and you can be safe in the knowledge that your
documents will always be available and you are not locked in to any specific tool.

Another useful feature wedged into OpenOffice.org is the capability to
save your documents in the Adobe PDF format. PDF files have been
increasingly used in the last few years and are useful for sending people
documents that they should not change (such as invoices). PDF files pro-
vide a high-quality copy of the document and are well supported across all
operating systems. This makes PDFs ideal for creating catalogs, leaflets,
and flyers. To save a document as a PDF file, click the PDF button on the
main toolbar (next to the printer icon). Click the button, enter a filename,
and you are done. Simple.
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Managing Your E-Mail and Calendars with Evolution
Evolution has been modeled around the all-in-one personal information
management tool. Within Evolution you can read your e-mail, manage
your schedule, store contact details, organize to-do lists, and more in a
single place. This makes Evolution particularly useful for businesspeople
who want easy access to this information.

Setting Up Your E-Mail Account To use Evolution to read your e-mail, you
need to find out the following settings for connecting to your e-mail server
(you can get these details from your ISP or system administrator):

� Your type of e-mail server (such as POP or IMAP)

� Your mail server name (such as mail.chin.com)

� Your mail account’s username and password

� Authentication type (typically by password)

� Your outgoing mail server type (typically SMTP)

� Your outgoing mail server name

TIP Evolution and Webmail
You can’t use Evolution to read Webmail such as Gmail, Yahoo! Mail, or Hotmail unless you
configure your Webmail to output as POP and use SMTP to send e-mail. Consult your Web-
mail provider for more details.

Load Evolution by clicking the envelope and clock shortcut icon from the
panel (hover your mouse over the shortcuts to see what they are) or by
clicking Applications > Internet > Evolution Mail. When the application
loads, you are taken through a wizard to set up your e-mail server (as
shown in Figure 3-8).

Click Forward to continue the setup, and you will then be asked for your
identity. Fill in your e-mail address in the E-Mail Address box, and add the
optional information if you want to. The additional details are not essen-
tial for using Evolution. Click Forward to continue.

You are next asked to choose what kind of e-mail server you have from the
drop-down box. When you make your selection, some additional settings
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are displayed. Fill in the server name and the username. You may need to
adjust the Security and Authentication Type settings, but for most
accounts the default settings should be fine. Click Forward to continue.

The next page configures some options for receiving your e-mail. None of
these options are essential, although you may want to check the first box to
automatically check for new mail. Click Forward to continue. The next
screen configures the settings for sending e-mail. In the combo box select
the Server Type (typically SMTP) and add the server name to the Server
box. Click Forward to continue.

In the next screen enter a name to describe the account. The default entry
(your e-mail address) is fine, but you may want to add something more
meaningful such as “Work E-Mail” or “Home E-Mail.” When you have
added this, click Forward to continue. Finally, select your location from
the map. If you click on your area of the world, the map will zoom in.
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Figure 3-8 Setting up Evolution is simple as long as you know the details for your
mail server.

Hill_ch03.qxd  6/7/07  10:24 AM  Page 76



Once you have done this, click Apply to complete the process and close
the wizard.

With the wizard completed, the main Evolution interface will appear, as
shown in Figure 3-9.

On the left sidebar you can see a number of buttons to access the mail,
contacts, calendars, memos, and tasks components in Evolution. When
you click each button, the interface adjusts to show you the relevant infor-
mation about that component.

Working with Your E-Mail Inside the e-mail component you can see the
e-mail folders in the left panel and the list of messages in the top pane.
When you click on a message, it is displayed in the bottom pane, where
you can read it. With your new account set up, you will first want to go and
grab the e-mail from your mail server. Click Send/Receive, and the mail is
retrieved from your server and any unsent mail is sent.
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Figure 3-9 Those of you who have used Microsoft Outlook should find the
interface very similar.
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TIP Problems?
If you cannot connect to your mail server, there may be an error in your account configura-
tion. To edit your account settings again, click Edit > Preferences, select the account from
the list, and click Edit.

With your messages loaded, new e-mails are shown in bold in the top
pane. Move through the different e-mails using the up and down arrow
keys, and each message will be displayed. You can reply to a message by
clicking the Reply or Reply To All toolbar buttons. New e-mails can be cre-
ated by clicking the New toolbar button. By default, new e-mails and
replies are sent automatically when you click the Send button in the com-
pose window. This way you don’t need to click the Send/Receive button to
deliver them.

Managing Your Calendar Inside calendar mode, Evolution provides a
convenient way to manage your schedule, add new events, and view your
calendar in different ways. When you click the Calendars button to switch
to this mode, you can see the timetable for today as well as the month view.
The month view shows a couple of months in which the bold dates have
events.

You can add two types of events to your calendar.

� Meetings: These are events with a specific group of people.

� Appointments: These are general events.

To add a new appointment, navigate to the date you require using the cal-
endar, then right-click a time slot in the day view, and select New Appoint-
ment. Alternatively simply click the New toolbar item. In the box that pops
up, fill in the Summary, Location, Time (adjusting the date if necessary),
and Description boxes. You can also select which calendar the event
appears on if you have multiple calendars configured.

TIP Multiple Calendars
Evolution supports multiple calendars. This is useful if you want different calendars for dif-
ferent types of events such as personal and work-related activities. To create a new calendar,
right-click the calendar list in the left sidebar and select New Calendar.
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To add a new meeting, again find the date, right-click the day view, and
select New Meeting. Inside the dialog box that pops up, you need to add
the participants who are attending the meeting. You can add participants
in two ways: Use the Add button if they are not in your address book, or
use the Attendees button if they are in your address book.

When you click Attendees, a new dialog pops up with a list of attendees
down the left. You can use the Add and Remove buttons to add contacts to
(or remove them from) the different categories of Chairpersons, Required
Participants, Optional Participants, and Resources. Now, you probably
don’t have any contacts in there as you are just starting to use Evolution, so
use the main Contacts button on the left side of the main Evolution win-
dow to add some.

You can view your calendar in lots of different ways by clicking the differ-
ent toolbar buttons such as Week, Month, and List. Play with them and see
which ones are most useful to you.

QUICK TIP Remember, you can access your appointments without opening Evolution by clicking on the
clock in the panel.

Creating Graphics with GIMP
The GNU Image Manipulation Program, affectionately known as GIMP
to its friends, is a powerful graphics package. GIMP provides a compre-
hensive range of functionality for creating different types of graphics. It
includes tools for selections, drawing, paths, masks, filters, effects, and
more. It also includes a range of templates for different types of media
such as Web banners, different paper sizes, video frames, CD covers, floppy
disk labels, and even toilet paper. Yes, toilet paper. You can load GIMP by
clicking Applications > Graphics > GIMP Image Editor.

Unlike Adobe Photoshop, GIMP does not place all of its windows inside a
single large window; instead, GIMP has a number of separate child win-
dows. This can be a little confusing at first for new users. To get you
started, let’s run through a simple session in GIMP.
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An Example Start GIMP by clicking Applications > Graphics > GIMP
Image Editor.

When GIMP loads, you will see a collection of different windows, as
shown in Figure 3-10.

Close the Tip of the Day window, and you are left with two other windows.
The one on the left in the screenshot is the main tool palette. This window
provides you with a range of different tools that can be used to create your
images. The window on the right provides details of layers, brushes, and
other information. GIMP provides a huge range of different windows that
are used for different things, and this is just one of them.

To create a new image, click File > New. The window shown in Figure 3-11
will appear.

The easiest way to get started is to select one of the many templates. Click
the Template combo box and select 640 × 480. If you click the Advanced
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Figure 3-10 GIMP does not put everything in one window like Adobe Photoshop.
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Options expander, you can also select the type of color used in the image
with the Colorspace box and the background fill. The Fill combo box is
useful for either selecting a fill color or having a transparent background.

Click OK, and you will see your new image window (Figure 3-12).

To work on your image, use the tool palette to select which tool you want
to use on the new image window. Each time you click on a tool in the

Using Your Applications 81

Figure 3-11 Lots of templates are available, including one for toilet paper!

Figure 3-12 Use the right mouse button on the image to access lots of GIMP
options and features.
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palette, you see options for the tool appear at the bottom of the palette
window.

When you click the T button in the palette, it selects the text tool. At the
bottom of the palette you see the different options. Click the Font button,
and select the Sans Bold font. Now click the up arrow on the Size box, and
select the size as 45. Move your mouse over to the empty image, and you
will see the mouse pointer change to a text carat. Click in the image, and a
box pops up in which you can enter the text to add to the image. Type in
“Ubuntu.” With the text entry still open, click the up arrow on the Size box
so the text fills most of the window. As you can see, you can adjust the text
while it is in the image. When you are happy with the formatting, click
Close on the text entry box. Your image should look a little like Figure 3-13.

Now click the button in the palette with four arrows on it. You can use this
to move the text around. Click the black text, and move the mouse.

Let’s now add an effect filter. GIMP comes with a range of different filters
built in. You can access these by right-clicking the image and selecting the
Filters submenu. GIMP also allows you to create scripts that combine fil-
ters to create interesting combinations. Again, a number of these scripts
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Figure 3-13 Ubuntu comes with a range of attractive fonts for use in your images.
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are included, and you can access them by right-clicking the image and
selecting the Python-Fu and Script-Fu submenus.

For our image, right-click the image and select Filters > Blur > Gaussian
Blur. In the Horizontal and Vertical boxes select 20 as the value. Click OK
to apply the effect. After a few seconds the blur is applied to your text. Any-
thing in GIMP can be undone by clicking Edit > Undo or typing Ctrl-Z.
Your image should now look like Figure 3-14.

Now we are going to create another layer and put some text over our
blurred text to create an interesting effect. In your image window, click
Dialogues > Layers. The Layers window now appears (Figure 3-15).

Layers are like clear plastic sheets that can be stacked on top of each other.
They allow you to create some imagery on one layer and then create
another layer on top with some other imagery. When combined, layers can
create complex-looking images that are easily editable as you can edit lay-
ers individually. Currently, our blurred text is one layer. We can add a new
layer by clicking the paper icon in the Layers dialog box. Another window
appears to configure the layer. The defaults are fine (a transparent layer the
size of your image), so click OK.
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Figure 3-14 Several filters and effects are bundled with GIMP in Ubuntu.
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Now double-click the black color chip in the palette window and select a
light color. You can do this by moving the mouse in the color range and
then clicking OK when you find a color you like. Now click the text button
from the palette and again add the “Ubuntu” text. When the text is added,
it will be the same size as before. Now use the move tool and position it
over the blurred text. Now you have the word “Ubuntu” with a healthy
glow, as shown in Figure 3-16!
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Figure 3-15 Layers are essential when creating complex images with lots of parts.

Figure 3-16 Combining steps as we have done can result in interesting effects
such as this.
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The final step is to crop the image to remove the unused space. Click Tools >
Transform Tools > Crop > Resize, and use the mouse to draw around the
Ubuntu word. You can use the black pins on the outside of the selection to
move it more precisely. Click Crop, and the image is now cropped. To save
your work, click File > Save, and enter a filename. You can use the Select
File Type expander to select from one of the many different file formats.

Communicating with Gaim
With the Internet steamrolling its way across the world, the ubiquitous
global network has become a part of everyday life and something you can
reasonably assume people have access to. This has in turn spawned a range
of Web-based services and, interestingly, a variety of methods for commu-
nicating with each other.

Included with Ubuntu is Gaim, a cornucopia of different methods for
instantly messaging your friends from within a single program. Instead of
having to install a separate client application to talk to your friends on
MSN, AIM, ICQ, and Jabber, Gaim can do it all in one place. (The Gaim
project has recently been renamed Pidgin. While this is not reflected in
Feisty since the rename came too close to release time, it will be in a future
version of Ubuntu.)

Gaim is available by clicking Applications > Internet > Gaim Instant
Messenger.

Setting Up Your Accounts When you start Gaim for the first time, you will
be asked if you want to add an account as none have been configured yet.
Click the Add button to add a new account, and the Add Account box
appears (Figure 3-17).

QUICK TIP To add or edit accounts at a later date, click Accounts > Add/Edit within Gaim to access your
account list.

This window adjusts which text boxes are available depending on the proto-
col chosen. The different networks available are listed as options in the Pro-
tocol box. To create an account, you will need to have an existing account on
one of the networks. Gaim allows you to have different accounts on different
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networks running together—you just create a new account for each proto-
col—or even multiple accounts on the same network.

When you have selected a protocol, fill in the remaining boxes. The Screen
Name box needs to contain your registered username (or e-mail address
for MSN), and the Password box needs the respective password to be
added. You can also use the Local Alias box to add an interesting name that
is displayed when other people see you online. If you want to configure
any other options, click the Advanced tab.

Using Instant Messaging With your account(s) set up, Gaim will auto-
matically sign you in. When you are logged in, your list of contacts (known
as buddies in Gaim) is displayed (Figure 3-18).

You can use the Buddies menu option to add more buddies to the list with
the Add Buddy option. To speak with a buddy, double-click the name, and
a window will pop up. To change your status or sign out, click the status
box at the bottom of your Buddy List and select the appropriate option.
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Figure 3-17 Gaim supports many different types of accounts (MSN, AIM, Jabber,
ICQ, IRC, and so on).
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Using IRC Included in Gaim is support for IRC channels, and it has a
very nice interface for IRC discussion. To use the IRC feature, first create
an account. Next, sign on, and then click Buddies > Add Chat and enter
the IRC channel name in the Channel box. Finally, double-click on the
channel name to go to it.

Cutting-Edge Voice Over IP with Ekiga
Included with Ubuntu is a simple-to-use yet powerful Internet phone
called Ekiga. Formally known as GNOME Meeting, Ekiga lets you make
voice and video calls with other people across the Internet. In addition to
the traditional Microsoft Netmeeting support, Ekiga now supports SIP, a
protocol commonly used to allow people with software phones such as
Ekiga to communicate with people using hardware Voice Over IP phones.
SIP is an industry standard that many hardware phones, software phones,
services, and providers support.

If you choose to use SIP, calls from one phone to another across the Inter-
net are free. In addition to this, many providers allow you to make calls to
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Figure 3-18 Gaim provides quick and easy access to your buddies—just click
them to talk!
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normal landline phones for very little cost. Ekiga offers you the possibility
to call anyone in the world directly from your computer with little fuss.

You can access Ekiga by clicking Applications > Internet > Ekiga Softphone.

Setting Up When you first start Ekiga, you are guided through a setup
wizard (Figure 3-19).

Click Forward to get started, and you see the next page (Figure 3-20).

In this box, enter your first and last name (such as Frankie Banger). Click
Forward to continue.

You can now configure an Ekiga.net account (Figure 3-21).

At Ekiga.net, a free SIP service is offered. If you don’t have an account
(which is likely if this is the first time you have used Ekiga), click the Get an
Ekiga.net SIP Account button. Firefox is then loaded, and you can use the
online form to sign up. If you don’t want an account, just select the check-
box in the wizard saying you don’t want to sign up. If you do sign up, add
your username and password, and then click Forward.
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Figure 3-19 Setting up Ekiga is simple with the setup wizard.
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Now you can configure your connection speed (Figure 3-22).

Select the type of connection you have, and then click Forward.

Traditionally, one of the problems in the past with Internet phones has
been that you need to modify your firewall (if you are running one) to get
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Figure 3-20 Adding your name makes it easier for people to find you online.

Figure 3-21 Ekiga.net offers a free SIP service.
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the phone working. This typically involved configuring your Network
Address Translation (NAT) settings. Luckily, Ekiga can detect the type of
NAT settings that you need (Figure 3-23).

After a few seconds of detecting your type of NAT, Ekiga will propose an
option. Click Yes to continue, and then click Forward.
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Figure 3-22 Be honest here—selecting a faster speed won’t make it any quicker!

Figure 3-23 Traditionally, setting up NAT with Internet phones was a pain—until now.
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Next, configure your audio (Figure 3-24).

Select ALSA from the box, and click Forward to continue.

You can now select the audio input and output devices (Figure 3-25).
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Figure 3-24 Ubuntu supports different types of audio frameworks, but the
Advanced Linux Sound Architecture (ALSA) is the most common.

Figure 3-25 Make sure you get these settings right, or you won’t hear anything.

Hill_ch03.qxd  6/7/07  10:24 AM  Page 91



These settings are used to ensure that you can hear and record the audio. To
test your settings, click Test Settings. If all is fine, click Forward to continue.

Next select the type of video manager (Figure 3-26).

The video manager ensures that video is displayed correctly on your
screen. Select V4L from the list, and click Forward to continue.

The final setting to configure is your Web camera (Figure 3-27).

Ensure that your camera is plugged in, and select a device from the combo
box. If you can’t see any options, you will need to configure your camera
driver first. When you have selected a device, click Test Settings to verify
that it works.

Finally, a summary of your options is displayed (Figure 3-28).

Ekiga is now configured.

Making a Call With the configuration wizard complete, the main Ekiga
window is displayed (Figure 3-29).
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Figure 3-26 Ubuntu supports different types of video, but V4L is the most
common.
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You are now ready to make a call. To do this, simply enter the phone num-
ber or SIP address of the person you want to call, and click the Connect
button next to the address bar. The call is then connected, and you can
begin talking.
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Figure 3-27 Remember to look your best online!

Figure 3-28 Now you are all set to make calls.
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On the left side of the window are a number of icons that do different
things.

� Text Chat: When in a chat, click this icon to open the text chat
window. You can use this to send text messages to the user.

� View Mode: Click this icon to select which view mode Ekiga is in. You
typically need this when in a video chat with someone.

� Address Book: Click this icon to access the address book. Here you
can save your contacts, and you can also access the Ekiga.net online
white pages to see who else is online.

� View Webcam: This icon switches on the Webcam so that you can see
the person you are speaking to.

In addition to these icons, there are some tabs located below the numeric
keypad. Click these tabs to configure the audio and video settings for Ekiga.

Exploring the Ubuntu Landscape
Unlike many other operating systems, Ubuntu includes a comprehensive
suite of applications right inside the system. This range of tools has been
selected to allow you to install Ubuntu and get your work done, communi-
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Figure 3-29 The Ekiga window is simple and sleek.
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cate with other people, read and create documents, watch and/or listen to
media, and more. Unfortunately, due to space restrictions this book can
only skim over the surface of available applications.

To help remedy this a bit, here is a quick summary of many of the applica-
tions included on the Applications menu in Ubuntu, including how to
find the applications and a brief description.

� Text Editor

Applications > Accessories > Text Editor

This simple, yet powerful, text editor is ideal for editing documents,
making quick notes, and programming. Included is a range of plug-
ins for spell checking, statistics, file listings, and more.

� Calculator

Applications > Accessories > Calculator

For those times when you need to figure out a percentage or calculate
whether you are getting a raw deal from your employer, the calculator
is there. It provides a range of functionality for simple and scientific
calculations.

� Terminal

Applications > Accessories > Terminal

Underpinning the desktop is an incredibly powerful command-line
core. This application puts a window around a command-line
interface and allows you to configure transparency, fonts, behavior,
and more. Essential for the command-line junkies among you.

� Dictionary

Applications > Accessories > Dictionary

The dictionary provides a great way to find out how to spell a word or
discover its meaning. The dictionary uses the latest definitions from
an online dictionary. For those of you who spent hours as a child
looking up rude words in the dictionary, hours of fun are guaranteed.
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� Gnometris

Applications > Games > Gnometris

If you have too much time on your hands, a sure-fire way to waste it is
to play this version of Tetris. If you decide that single-player Tetris is
not enough, go and download gtetrinet.

� Nibbles

Applications > Games > Nibbles

The classic worm game comes to Ubuntu. Another surefire way to
while away an afternoon.

� Mahjongg

Applications > Games > Mahjongg

For those of you who actually understand the rules of Mahjongg, this
application provides a great implementation of the game.

� FreeCell Patience

Applications > Games > FreeCell Patience

There is a body of thinking that suggests that FreeCell may be
responsible for untold hours of lost productivity. If you are impatient
about playing Patience, select FreeCell Patience.

� Internet Relay Chat

Applications > Internet > XChat-GNOME IRC Chat

Internet Relay Chat (IRC) provides a way to talk to other people on
the Internet by typing text into discussion channels. There are literally
thousands of users online and thousands of channels available. IRC
has proven to be a truly useful tool for getting help about Ubuntu and
Linux, too. Be sure to log onto the Freenode network, and visit
#ubuntu.

� Terminal Server Client

Applications > Internet > Terminal Server Client

If you need to connect to a remote terminal server, this is how you do it.
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� Movie Player

Applications > Sound & Video > Movie Player

Although listed as a movie player, this application actually plays a
range of different types of media, including both video and audio.

� Sound Recorder

Applications > Sound & Video > Sound Recorder

If you need to record something, such as your voice for a podcast or
audio message, you can use this simple tool.

� Audio CD Creator

Applications > Sound & Video > Serpentine Audio-CD Creator

If you have a collection of sound files that you would like to convert
to an audio CD, this is the tool for you. It is particularly handy if you
have a long drive and want to burn a CD with some music or
podcasts to listen to.

� CD Ripper

Applications > Sound & Video > Sound Juicer CD Extractor

This application is the reverse of the previous one, allowing you to
convert songs on a CD into songs that live on your hard disk or
portable music player.

� System Monitor

System > Administration > System Monitor

To get an idea of the current performance of your computer, click on
this tool. The System Monitor lets you know which applications are
running and how much memory/processing power they are using,
and it also allows you to kill or restart processes that are hogging the
resources.

� Sudoku

Applications > Games > Sudoku

The increasingly popular logic game arrives on Ubuntu.
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� Disk Usage Analyzer

Applications > Accessories > Disk Usage Analyzer

Bits and bytes never looked so good! In case you were wondering
exactly where all your disk space had gone, this will help solve the
mystery.

Other Applications to Try There are literally thousands of available pack-
ages that can be installed on your Ubuntu computer. These packages span
a range of different areas, and this section covers some of the popular
ones. Coverage of software installation appears in Chapter 4. Try the fol-
lowing useful applications.

� Blender

Package to install: blender

Blender (Figure 3-30) is an incredibly powerful 3D modeling,
animation, rendering, and production studio. Blender amasses an
impressive range of functionality for creating photorealistic scenes,
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Figure 3-30 Blender
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animations, and real-time virtual walkthroughs. Blender is also fully
scriptable in Python.

� Inkscape

Package to install: inkscape

Inkscape (Figure 3-31) is a drawing package for creating Scalable
Vector Graphics (SVG). Ever since the SVG format was introduced, it
has taken the design world by storm. SVG allows the creation of
graphics that can scale to any size. Inkscape is a hugely flexible tool
for creating such graphics, and a huge range of icons and artwork in
open source projects are made in Inkscape.

� Beagle

Package to install: beagle

Beagle (Figure 3-32) is a search system that indexes virtually
everything. After you install Beagle, you can search for “campfire,”
and it will return documents, images, Web pages, blog entries, instant

Using Your Applications 99

Figure 3-31 Inkscape
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messaging conversations, and more that contain that term. Beagle is
still very much in development but is an incredibly useful tool.

� F-Spot

Package to install: f-spot

F-Spot (Figure 3-33) is a complete photo management application.
With it you can import photos from your digital camera or USB stick,
tag them with familiar terms, do touchups, and edit them in different
ways. In addition to this, F-Spot can upload photos easily to Flickr
and other online photo galleries. F-Spot is particularly useful for
those of you who are trigger happy with a digital camera.

� Bluefish

Package to install: bluefish

For those of you who want to create Web pages but prefer to write
code, Bluefish (Figure 3-34) is an excellent Web editor. Bluefish is a
lightweight but feature-rich editor with support for a range of
languages as well as HTML and CSS.
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Figure 3-33 F-Spot

Figure 3-34 Bluefish
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� Eclipse

Package to install: eclipse

If you are a developer and want an entire development environment,
Eclipse (Figure 3-35) is a good choice. Eclipse includes support for a
huge range of languages by using plug-ins. This includes support for
C, C++, Java, Python, Perl, Ruby, PHP, and more. Eclipse also has
built-in support for source control (CVS or Subversion) and
debugging, and it automatically handles its own (and the plug-in’s)
software updates.

The Ubuntu File Chooser and Bookmarks
One area in which the GNOME developers have worked hard is in creating
an intuitive and useful file chooser that is accessed in applications with File >
Open. You may be wondering why they have spent so much time on such a
small and seemingly insignificant part of the desktop. In reality, however,
finding files is one of the most frustrating aspects of using computers and
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Figure 3-35 Eclipse
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often involves digging through folder after folder to find what you need.
Luckily, the GNOME file chooser (Figure 3-36) helps cut down much of
this file hunting significantly.

The listing of files on the right-hand side is used to find the file you need,
and you can click on folders in this listing to traverse deeper into your sub-
folders. Note how each folder is displayed above the listing in a series of
buttons. You can click these buttons to easily jump back to parent folders
when needed.

Aside from enabling you to manually pick files, the chooser also supports
bookmarks. On the left side of the chooser is a list of devices and book-
marks. These include your home directory (shown as your username),
Desktop (the files on your desktop), and File System (the entire hard
drive), as well as devices such as CD drives, floppy drives, and USB sticks.

To create your own bookmark, use the listing on the right to find the folder
that you want to bookmark, single-click it, and then click Add below the
Places box. The folder now appears in your bookmarks. Now whenever
you need to access that folder, just click the bookmark! In addition to put-
ting the bookmark in the file chooser, it is also available in other parts of
the desktop, such as the Places menu and in the file manager.
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Figure 3-36 The file chooser has a number of subtle features such as bookmarks.
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Ubuntu in Your Language
When you installed Ubuntu, you were asked which language the system
should use. Although this sets the initial language for the system, you may
want to change the language at a later date. To do this, click System > Con-
trol Center, and choose the Language Support task in the System group.

Ubuntu supports a huge range of different languages, and many applica-
tions include a Translate This Application menu option in the Help menu
so that all Ubuntu users can contribute translations in their language(s). If
you would like to help with this effort, it is a fantastic contribution to the
Ubuntu project.

When the language selector first loads, it may ask you to update your lan-
guage packs. Just click Yes to continue. Inside the dialog box a number of
languages are listed, each of which has Translations and Writing Aids
checkboxes. For each language that you want available on the system,
check the relevant boxes. The Translations box should be checked for
menus, labels, and buttons to be translated, and the Writing Aids box
should be checked to install dictionaries and grammar checkers.

When you have selected the boxes, click the Apply button, and the appro-
priate language packs are downloaded and installed. Now use the Default
Language combo box to choose the new language. You need to log out and
log back in for the changes to take effect.

TIP Choosing a New Language
When you see the login screen, you can use the Language button to choose a language for
that specific login session. When you select the language, you are asked if you want to make
it the default language or use it just for that specific session.

Customizing Ubuntu’s Look and Feel
Whenever we put someone in front of Ubuntu for the first time, there
seems to be a uniform natural desire to tweak the look and feel of the desk-
top. In our increasingly diverse society, everyone is different, and every-
one’s tastes are equally individual and unique. It can be fun tweaking our
desktops so they look just right, and Ubuntu has great support for all
kinds of adjustments. Do you want different-looking applications with a
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lime green background and crazy fonts? No problem; just don’t show it to
anyone else. . . .

Changing the Background
To change the background of your desktop, right-click it and select
Change Desktop Background. Inside the dialog box that appears, choose
your wallpaper by clicking on an image, and the desktop background will
automatically change. Ubuntu comes with a limited range of preinstalled
wallpapers, so it is likely that you will want to add your own wallpaper. To
do this, save your wallpaper somewhere on your computer, and then use
the Add Wallpaper button to select it. The new wallpaper can be selected
from the list.

If you are not really a wallpaper kind of person and would prefer just a
color for the background, you can use the Desktop Colors controls at the
bottom of the dialog box. The combo box provides three different types of
background: Solid Color, Horizontal Gradient, and Vertical Gradient. Next
to the combo box, click on the color chip to select the relevant color(s).

Changing the Theme
When you are using your applications, the visual appearance of the but-
tons, scroll bars, widgets, and other bits and pieces are controlled by the
theme. The built-in theming system can make your applications look
radically different, and Ubuntu ships with a number of themes that you
can try.

Choosing a New Theme To choose a new theme, click System > Prefer-
ences > Theme. Inside the dialog box that pops up are a number of themes
that you can choose. Just click on a theme, and the desktop will be adjusted
automatically. You can further customize your theme by clicking the
Theme Details button. A new dialog box appears that has tabs for the dif-
ferent parts of the theme you can configure. Click each tab, and select an
entry from the list to create your own perfect theme.

Installing New Themes To install a new theme, first head over to http://
art.gnome.org/, and find a theme that you like. You need to look for Appli-
cation Themes when browsing the site. When you find a theme that you
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like, download it to your computer. Now Click System > Preferences >
Themes, and click the Install Theme button. Using the file chooser, find
the theme that you just downloaded, and it will install automatically. Now
select your new theme from the list.

Configuring a Screensaver
To choose a different screensaver, click System > Preferences > Screen-
saver. The screensaver configuration tool then loads (Figure 3-37).

On the left side of the window is a list of available screensavers. Click on a
screensaver and you will see a preview appear in the space to the right of
the list. You can then use the slider to select how long the computer needs
to be idle before the screensaver kicks in.

The Lock Screen When Screensaver Is Active checkbox can be selected to
lock the screen when the screensaver starts and, as such, require a user to
enter the password to reactivate the desktop. This is useful if you work in
an office and want to ensure that no one tampers with your computer
when you are away.
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Figure 3-37 A number of screensavers are bundled with Ubuntu.
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Managing Your Files
Files are the meat and potatoes of any computer, and they need to be man-
aged, copied, moved, renamed, grouped, and loaded. Included with Ubuntu
is a powerful yet simple file manager called Nautilus that integrates tightly
into your desktop.

Nautilus makes extensive use of drag and drop. Unlike the kind of file
manager used in Windows with its tree view and listing of files, Nautilus
displays files in a series of windows in which you can drag files around eas-
ily. For those who just can’t say goodbye to the tree view, Nautilus also sup-
ports that. Aside from providing a simpler user interface, Nautilus also
includes a number of useful features such as video and image previews,
emblems, bookmarks, permissions management, and more.

How Linux Stores and Organizes Files
Before we use Nautilus it would be worthwhile to have a crash course in
how files and folders are organized on a Linux system. If you have not used
Linux before, this is likely to be new to you as the layout is quite different
from Windows and Mac OS X.

TIP Folders and Directories
When reading about file management, don’t get confused by the terms folders and directo-
ries—both words describe the same thing.

In the Windows world each disk drive is labeled with an identifying letter
such as C: for your hard disk and A: for the floppy drive. In the Linux
world, however, everything is part of the same filesystem organization. As
such, if you have two or three hard disks, a CD drive, and a USB stick all
plugged in, they will all be part of the same folder structure.

The diagram shown in Figure 3-38 should give you an idea of how every-
thing hangs together.

Right at the top of the tree is the root folder, referred to as /. Inside this
folder are a number of special system folders, each with a specific use. As
an example, the /home folder contains a number of home directories for
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each user on the system. As such, the jono user account has the home
folder set to /home/jono.

Which Folder Does What?
The folder structure in a modern Linux distribution such as Ubuntu was
largely inspired by the original UNIX foundations that were created by
men with large beards and sensible sweaters. Although you don’t really
need to know what these folders do since Ubuntu looks after the house-
keeping for you, some of you may be interested in the more important
folders. For your pleasure, we present the Linux folder hit list in Table 3-1.

Configuration Files In the table, /etc is described as storing systemwide
configuration files for your computer. Aside from these files that affect
everyone, there are also configuration files for each specific user. Earlier,
when you customized Ubuntu’s look and feel, the settings were applied
only to your current user account. So where are those settings stored?

Inside your home directory are a number of folders that begin with a dot
(.), such as .gnome2 and .openoffice2. These folders contain the configu-
ration settings for specific applications for that specific user. By default
these dot folders are hidden in Nautilus, as you rarely need to access them.
For future reference you can view these hidden files and folders by clicking
View > Show Hidden Files.

You can start Nautilus from a number of different places, such as Applica-
tions > Accessories > File Browser, or more commonly by clicking Places >
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Home Folder to load your home folder. When the folder loads, you should
see something similar to what Figure 3-39 shows.

The Nautilus window is split into two parts. The sidebar shows categories
of information such as bookmarks, folders, emblems (more on these
later), and more. In the main part of the window you can see the subfold-
ers and files in the current folder. By default, Nautilus displays your book-
marks in the left sidebar and displays the contents of your home folder.

So, let’s play with Nautilus and see what you can do with it. The first
important skills to learn involve general file management. Many of the
tasks you need to do can be achieved by right-clicking your file/folder and
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Table 3-1 Linux Folders

Folder Use

/boot This folder contains important files to boot the computer, including the
bootloader configuration and the kernel.

/dev Each device on your system (such as sound cards, Webcams, etc.) has an
entry in this folder. Each application accesses the device by using the
relevant items inside /dev.

/etc Systemwide configuration files for the software installed on your system
are stored here.

/home Each user account on the system has a home directory that is stored here.

/lib Important system software libraries are stored here. You should never need
to delve into this world of the unknown.

/media Media devices such as CD drives and USB sticks are referenced here when
they are plugged in. More on this later.

/mnt Other devices can be mounted, too. Again, more on this later.

/opt Optional software can be installed here. This folder is usually used when
you want to build your own software. If you don’t build your own
software, you ignore this folder.

/proc/sys Information about the current running status of the system is stored here.

/root This is the home directory for the main superuser.

/sbin Software that should be run only by the superuser is stored here.

/usr General software is installed here.

/var This folder contains log files about the software on your computer.
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selecting the relevant option. There are also a number of options in the
Edit menu.

First, create a folder. Do this by right-clicking the main part of the window
and selecting Create Folder. A folder is added, and you can type in the
name of it. If you change your mind about the name, rename it by right-
clicking and selecting Rename. If you double-click on a folder, you can
access it and perform the same operations within that folder.

QUICK TIP Just as folders and directories are the same thing, so are folders and subfolders . . . well,
almost. When we refer to subfolders, we are referring to folders contained within another
folder. For example, /home is a folder, while we can refer to /home/jono as a subfolder of
/home.

Nautilus is also flexible in how your files are displayed. You can view the
files and folders as either the default collection of icons or as a list. To
switch to the list view, select View > View As List. You can also configure
the organization of how your files and folders are displayed by right-
clicking the main part of the window and selecting one of the options in
the Arrange Items menu. Play with each of these options to see which ones
work best for you.
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Figure 3-39 Accessing your home folder files is as simple as clicking Places >
Home Folder.
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QUICK TIP Just like in the file dialog, Nautilus displays each of the different parts of the path as different
buttons. As an example, /home/jono/work would have three buttons: home, jono, and work.

Selecting, Copying, and Moving Files and Folders
Copying and moving files and folders are simple tasks with Nautilus and
can be done in a number of different ways. To test this, create two folders
called Work and Invoices in your home directory. Save some files inside
each folder. You can quickly create empty files by double-clicking the
folder to go into it, right-clicking, selecting Create Document > Empty
File, and renaming the file to something useful. With a couple of folders
now complete with files in them, let’s move them around.

One method is to use two windows. Right-click the Work folder, and select
Open in New Window. You now have two windows open, one with the
contents of Work and one with the contents of your home directory. Now
copy the Invoices folder to the Work folder by clicking it and dragging it
over to the second window (which shows the contents of Work). By
default, dragging from one window to another copies the item.

Another option is to select what you want to copy and paste it. Selecting
items can again be done in a number of ways. One method is to click
each file/folder while holding down the Shift or Ctrl keys to make mul-
tiple selections. The difference between the two keys is that Shift allows
you to select a number of files and folders next to each other, and Ctrl
selects independent files and folders from anywhere in the folder-listing
view. When you have selected what should be copied, right-click and
select Cut or Copy. Cut will copy the original files but remove them, and
Copy will just copy them while leaving the original files intact. Now go to
the destination folder, right-click it, and select Paste. The files/folders are
now added.

Using the Sidebar
The sidebar in Nautilus can be changed to a variety of views that should
cater to virtually all tastes. Each of these different sidebar views has a range
of functions. Table 3-2 explains each one.

Managing Your Files 111

Hill_ch03.qxd  6/7/07  10:25 AM  Page 111



Although you will probably stick with one in particular, it is not uncom-
mon to switch between options to achieve a particular task. For this rea-
son, the flexibility provided by the range of sidebar options is useful.

TIP Drag and Drop
If you want to put something in the Places view, drag and drop the item. The Ubuntu desktop
is filled with drag-and-drop shortcuts like this. If you think something could be dragged and
dropped, try it!

Using Emblems
Emblems give you the ability to tag files and folders to indicate something.
These small graphical icons are used to say that the file/folder falls into a
particular category, visually signified by the emblem. As an example, you
may want to tag a file to indicate it is a draft.

When you select the Emblems sidebar, a range of different emblems
appears. To apply an emblem to a file/folder, just drag the emblem onto it.
You can drag multiple emblems onto the files to indicate multiple things.

Ubuntu and Multimedia
In recent years, multimedia has become an essential part of computing.
Watching DVDs and videos and listening to CDs and music have become
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Table 3-2 The Different Nautilus Sidebar Options

Option Feature

Places (Default view) Includes the devices and bookmarks in the sidebar that
you typically see in the file chooser.

Information Displays some limited information about the current folder.

Tree Displays a tree view similar to Windows/Mac OS X. Those of you who
love the way Windows/Mac OS X works may want to use this.

History Displays a history of the folders you have clicked on.

Notes Allows you to write notes in the sidebar that are stored in the folder.
This is handy when you need to explain or make comments about the
current folder.

Emblems Lists the files and folders that have specific emblems attached.
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part and parcel of the modern desktop computer experience. These multi-
media capabilities have been further bolstered by the huge popularity of
legal music downloading. With a range of online stores for a variety of dif-
ferent types of music, it is not uncommon to listen to the majority of your
music without ever seeing a little shiny silver disk.

Installing Codecs
Multimedia files and disks come in a variety of different types, and each
type uses a special codec to compress the content to a smaller size while
retaining a particular level of quality. To play this media, you need to
ensure that you have the relevant codecs installed. Ubuntu now makes
this easier by suggesting packages that provide a suitable codec when you
open a file that isn’t supported by the ones that are currently installed.
Simply double-click the file you want to open, and you should be pro-
vided with a list of packages that you can install to enable support for the
file you have tried to open. Select the packages that seem appropriate, and
click Install.

QUICK TIP If you do this but no packages are suggested, you may need to change the package filter in
the top right-hand corner to All Available Applications.

Codecs still remain a problem for open source software due to the legal
restrictions placed upon them. Certain codecs (including MP3, Windows
Media Format, QuickTime, and RealMedia) are proprietary and as such
have restrictions placed on their use, distribution, and licensing.

Although developers in the open source community have gone away and
created free implementations of these codecs, the licensing that surrounds
some of them conflicts with the legal and philosophical position that
Ubuntu has set. These codecs are not included not only because they are
legally dubious but also because they disagree with Ubuntu’s ethic of cre-
ating a distribution that is entirely comprised of free software in the freest
sense of the word.

QUICK TIP If you want to find out more about installing these codecs, see https://wiki.ubuntu.com/
RestrictedFormats.
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To work toward resolving these problems, a number of developers are
working on free codecs such as Ogg Vorbis and Ogg Theora that provide
high-quality results and open licensing. The Ogg Vorbis codec is used on
audio and can provide better results than MP3 at a smaller file size. The
Ogg Theora codec is used for video and competes with the MPEG-4
codec. Ubuntu includes the Ogg Vorbis and Ogg Theora codecs, and you
can encode and play back any media that uses those codecs.

Although the world would be a better place if all codecs were free, the real-
ity is different, and many Ubuntu users still want to play their media on
their new desktops. Table 3-3 shows the most typical codecs used to
encode and play back media and lists their support in Ubuntu.

Listening to Audio Files
Ubuntu includes a powerful music player called Rhythmbox to organize
and play your music file collection. Before you fire up Rhythmbox, though,
you need to create a folder to store your music files in. This folder can be
anywhere, but putting it on the desktop makes sense since it will then be
easily accessible when you want to add new songs to it.
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Table 3-3 Codec Support

Codec File Type Included Supported

MP3 .MP3 No Yes

Ogg .ogg Yes N/A

Windows Media Audio .wma No Yes*

Wave .wav Yes N/A

MPEG-1 .mpg No Yes

MPEG-2 .mpg No Yes

Raw DV .dv Yes N/A

Quicktime .mov No Yes*

Windows Media Video .wmv No Yes*

Realmedia .rm No Yes*

* These codecs involve the installation of nonfree software that may or may not be legal in
your country.
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Right-click your desktop, and select Create Folder. A new folder is created,
and you should enter a name for it. Call it Music for now. Within this
directory, organize your music in a way that makes sense to you. A good
system that many people use is to first give each artist or band a folder and
then inside each folder have a subfolder for each album that contains the
songs. So, as an example, inside the Music folder you would have an
Overkill folder inside of which would be a Horrorscope folder that con-
tains the individual songs. You don’t need to use this system if you don’t
want to, but as your music collection builds, it makes sense to organize it
this way. Many CD rippers also store songs in this way, so you should not
need to reconfigure your CD ripper later.

QUICK TIP Why not add your new music folder as a bookmark so it appears in the file chooser, Places
menu, and elsewhere?

Using Rhythmbox Load Rhythmbox (Figure 3-40) by clicking on Appli-
cations > Sound & Video > Rhythmbox Music Player. When Rhythmbox
first starts, it asks you to select the directory where your music is stored, so
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Figure 3-40 Rhythmbox is a great place to look after your music collection.
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select your Music folder. To import your music, right-click the Library
entry in the left panel and select Import Folder. Your songs are added to
your music collection.

The Rhythmbox window is split into a number of different panes, each
displaying different details about your music collection. The left pane
(Source) lets you select the source of the music, such as your media library,
podcasts, and Internet radio. Each of these options has a browser pane
available to display the source of the content. As an example, when you use
the Library, one pane displays the artists and one displays the albums. You
can use this to navigate your music.

Listening to Podcasts Podcasts are audio shows that you can subscribe
to, and they are increasingly becoming the new way to listen to audio and
music. When you subscribe to a podcast, each new release is automatically
downloaded for you. This makes it extremely convenient to regularly lis-
ten to audio shows.

If you are new to podcasting, you should grab yourself a podcast feed of
something you like. A site such as www.podcast.net is a good place to start.
Go to the site in Firefox, and when you see a link that indicates a podcast
feed or RSS feed, right-click it, and select Copy Link Location.

Rhythmbox has good support for Podcast feeds, and subscribing to a feed
is simple. In the sidebar, right-click the Podcast entry and click New Pod-
cast Feed. Paste in the feed by right-clicking the box and selecting Paste.
The files are automatically downloaded, and you can listen to them by
double-clicking on them. Each time you start Rhythmbox, a check is made
to see if any new episodes exist, and if so, they are downloaded.

NOTE Rhythmbox and iPods
Rhythmbox can also read songs from your iPod—just plug it in and it will display in Rhythmbox.
Unfortunately, at the moment Rhythmbox can only read from the iPod and not write to it.

Playing and Ripping CDs
When you pop a CD into your CD drive, an application called Sound
Juicer automatically loads to play your CD. If you are connected to the
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Internet, the CD is looked up on the Internet, and the album details and
song titles are displayed.

Ripping Songs as Oggs Sound Juicer is not just a CD player but a ripper
too. Using a ripper you can convert the songs on the CD into files that you
can play on your computer. By default, Sound Juicer rips the files in the
Ogg format, which provides better sound quality than MP3 at a smaller
size. Before you rip the CD, click Edit > Preferences, and use the Music
Folder combo box to select the Music folder that you created earlier to
store your music files. If you have not set this folder to be a bookmark, you
will need to click the combo box and then click Other to bring up the file
chooser. By default, the ripped files are stored in the format discussed ear-
lier, with each artist as a folder and then albums as subfolders.

To rip the songs, just select the checkboxes of the songs you want ripped
(by default, all songs are selected), and then click Extract. Each song is
then stored in your Music folder, and the song titles are used as the names
of the files.

Ripping Songs as MP3s Although the default Ogg support is recom-
mended in most situations, you may prefer to rip MP3 files if you have a
digital audio player that does not support Ogg files. To do this, you need to
configure Sound Juicer to enable MP3 support.

You should first install the gstreamer0.10-plugins-ugly-multiverse pack-
age (see Chapter 4 for more details on installing packages). Next, in Sound
Juicer click Edit > Preferences and choose the CD Quality, MP3 (MP3
audio) profile from the Output Format options.

TIP A Word of Caution
Always, always remember that ripping CDs that are not yours is piracy. It’s not fair, so don’t
do it!

Watching Videos
To watch videos in Ubuntu, you need to ensure that you have the correct
codecs installed. As discussed earlier, some of these codecs are available
separately due to the legal implications of including them with the
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Ubuntu system. Although the new process for suggesting and installing
codecs should cover most popular types of files, you should still refer to
the Ubuntu wiki at http://wiki.ubuntu.com/ for details of how to install
ones that are not recognized.

Using Totem To watch videos in Ubuntu, you use the Totem media player
(Figure 3-41). Load it by clicking Applications > Sound & Video > Totem
Media Player.

To watch a video on your hard disk, click Movie > Open, and select the file
from the disk.

TIP Another Way to Load Files into Totem
You can also load multimedia files into Totem by double-clicking them on your desktop or in
the file manager.

Totem also supports video streams. To watch a stream, click Movie > Open
Location, and enter the Internet address for the stream. The video feed is
then loaded and displayed.
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Figure 3-41 Totem is a simple and flexible media player.
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Getting DVDs to Work Ubuntu comes with DVD support for unencrypted
DVDs. With the DVD industry being what it is, the majority of DVDs
come encrypted, and if you want to watch them, you need to ensure that a
library that can decrypt these DVDs is installed. Unfortunately, this
library needs to be installed separately and is not included with Ubuntu.
Refer to the Ubuntu wiki restricted formats page at https://wiki.ubuntu.
com/RestrictedFormats for details.

With the library installed, insert a disk into your computer, and Ubuntu
will automatically start Totem to view the disk. Alternatively, fire up Totem,
and click Movie > Play Disk to play the DVD. Totem fully supports DVD
menus, and you can use the mouse to select the different menu options.

If you are settling down to watch a movie, you may want to configure a few
other settings. First click View > Aspect Ratio to select the correct aspect
ratio for your screen, and then select View > Fullscreen to switch to full
screen mode. To exit full screen, just move your mouse, and some on-
screen controls will appear.

TIP Control Totem with a Remote Control
Totem supports the Linux Infrared Control (LIRC) library so you can use a remote control
while watching your media.

Summary
In this chapter you’ve learned how to start using the core features of your
new desktop. These concepts should allow you to perform most of the
day-to-day tasks when using your computer and provide a base from
which to explore the other applications installed on your system. This
solid grounding in the desktop paves the way for you to meander through
the rest of the book, learning about the more advanced uses of your new
system and exploring the enormous flexibility that Ubuntu provides.

Always remember that there is a wealth of help and documentation avail-
able online. If you ever find yourself stuck, take a look at the Ubuntu Web
site at www.ubuntu.com/ or the Ubuntu documentation at http://help.
ubuntu.com/ and make use of the forums, wiki, mailing lists, and IRC
channels.
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