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9Designing a Worksheet 
with Excel

Introduction

Microsoft Office Excel 2003 offers several tools that make your
worksheets look attractive and professional. Without formatting,
a worksheet can look confusing with meaningless data. To high-
light important information, you can change the appearance of
selected numbers and text by adding dollar signs, commas, and
other numerical formats, or by applying attributes such as bold-
face and italics.  You can change font and font size, adjust the
alignment of data in cells, and add colors, patterns, borders, and
pictures. By using AutoFormats and styles to apply multiple
changes, you can speed up the formatting process and ensure a
greater degree of consistency among your worksheets. 

You can also modify the look of your printouts by adjusting a
variety of print settings, including page orientation, margins,
headers and footers, and other elements that enhance the read-
ability of your worksheets and workbooks. When you’re ready to
print your workbook, you can choose to print all or part of the
worksheets.

What You’ll Do

Format Text and Numbers

Change Data Alignment

Change Data Font and Color

Design Conditional Formatting

Add Color and Patterns to Cells

Add Borders to Cells

Format Data with AutoFormat

Create and Apply Styles to Cells

Format Tabs and the Background

Insert Page Breaks

Set Up the Page

Add Headers and Footers

Customize Worksheet Printing

Set the Print Area

Preview a Worksheet

Print a Worksheet
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Formatting Text 
and Numbers

Format Text Quickly

Select a cell or range with the text
you want to format.

Click one of the buttons on the
Formatting toolbar to apply that
attribute to the selected range:

◆ Bold

◆ Italic

◆ Underline

Click the Font or Font Size list
arrow, and then select a font or
size.

You can apply multiple attributes to
the range.

Format Numbers Quickly

Select a cell or range with the
numbers to format.

Click one of the buttons on the
Formatting toolbar to apply that
attribute to the selected range.

◆ Currency Style

◆ Percent Style

◆ Comma Style

◆ Increase Decimal

◆ Decrease Decimal

You can apply multiple attributes to
the range.

2

1

3

2

1

Sometimes you want to format cells with labels differently from cells with
totals. You can change the appearance of data in selected cells without
changing its actual label or value. Format text and numbers by using font
attributes, such as boldface, italics, or underlines, to enhance data to
catch the readers’ eye and focus their attention. You can also apply
numeric formats to values to better reflect the type of information they
present—dollar amounts, dates, decimals, or percentages.
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Apply Numeric, Date, and 
Time Formats

Select a cell or range with the
numbers to format.

Click the Format menu, and then
click Cells.

Click the Number tab.

Click a numeric, date, or time
category.

Select the formatting type options
you want to apply.

Preview the sample.

Click OK.7
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Did You Know?
Excel has formatting intelligence. As
you type at the end of a column or row,
Excel extends the formatting and for-
mulas you are using in that column or
row.

You can use AutoFormat to save time.
An AutoFormat is a combination of
ready-to-use, designed formats. Select
the cell or range you want to format,
click the Format menu, click
AutoFormat, click a format style, and
then click OK.
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When you enter data in a cell, Excel aligns labels on the left edge of the
cell and aligns values and formulas on the right edge of the cell.
Horizontal alignment is the way in which Excel aligns the contents of a
cell relative to the left or right edge of the cell; vertical alignment is the
way in which Excel aligns cell contents relative to the top and bottom of
the cell. Excel also provides an option for changing the character flow
and rotation of text in a cell. You can select the rotate text in horizontal
orientation up or down. The default orientation is 0 degrees—the text is
level in a cell. 

Changing Data
Alignment

Change Alignment Using the
Formatting Toolbar

Select a cell or range containing
the data to be realigned.

Click the Align Left, Center, or
Align Right  button on the
Formatting toolbar.

To center cell contents across
selected columns, click the Merge
And Center button on the
Formatting toolbar.

Change Alignment Using the
Format Dialog Box

Select a cell or range containing
the data to be realigned.

Click the Format menu, and then
click Cells.

Click the Alignment tab.

Click the Horizontal list arrow or
the Vertical list arrow, and then
select an alignment.

Select an orientation. Click a point
on the map, or click the Degrees
up or down arrow.

If you want, select one or more
Text Control check boxes.

Click OK.7
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You can change the color of numbers and text on a worksheet. The 
strategic use of font color can be an effective way of visually uniting 
similar values. For example, on a sales worksheet you might want to 
display sales in blue and returns in red. The Font Color button on the
Formatting toolbar displays the last font color you used. To apply this
color to another selection, simply click the button. To apply a different
color, click the Font Color button list arrow, and then select a color.

Designing a Worksheet with Excel 205

Changing Data Font
and Color

Change Font Color Using the
Formatting Toolbar

Select a cell or range that
contains the text you want to
change.

Click the Font Color list arrow on
the Formatting toolbar.

Click a color.

Change Font, Font Style, and
Font Size

Select a cell or range that
contains the font you want to
change. 

Click the Format menu, and then
click Cells.

Click the Font tab.

Select a font.

Select a font style.

Select a font size.

Select any additional formatting
effects.

Click OK.8
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You can make your worksheets more powerful by setting up conditional
formatting. Conditional formatting lets the value of a cell determine its
formatting. For example, you might want this year’s sales total to be dis-
played in red and italics if it’s less than last year’s total, but in green and
bold if it’s more. 

Designing Conditional
Formatting

Establish a Conditional Format

Select a cell or range you want to
conditionally format.

Click the Format menu, and then
click Conditional Formatting. 

Select the operator and values you
want for condition 1.

Click the Format button, select the
attributes you want applied, and
then click OK.

Click Add to include additional
conditions, and then repeat steps
3 and 4.

Click OK.

Delete a Conditional Format

Click the Format menu, and then
click Conditional Formatting.

Click Delete. 

Select the check box for the
condition(s) you want to delete.

Click OK.4
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Colors and patterns added to the worksheet’s light gray grid help identify
data and streamline entering and reading data. If your data spans many
columns and rows, color every other row light yellow to help readers fol-
low the data. Or add a red dot pattern to cells with totals. Color adds
background shading to a cell. Patterns add dots or lines to a cell in any
color you choose. You can use the Format Cells dialog box to add color
and patterns to a worksheet. However, if you want to add color to cells
quickly, you can use the Fill Color button on the Formatting toolbar.

Adding Color and
Patterns to Cells

Apply Color and Patterns

Select a cell or range to which you
want to apply colors and patterns.

Click the Format menu, and then
click Cells. 

Click the Patterns tab.

To add shading to the cell, click a
color in the palette.

To add a pattern to the cell, click
the Pattern list arrow, and then
click a pattern and color in the
palette.

Click OK.

Apply Color Using the
Formatting Toolbar 

Select a cell or range.

Click the Fill Color list arrow on the
Formatting toolbar. 

If necessary, click the Toolbar
Options list arrow to display the
button.

Click a color.3
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The light gray grid that appears on the worksheet helps your eyes move
from cell to cell. Although you can print these gridlines, sometimes a 
different grid pattern better emphasizes your data. For example, you
might put a decorative line border around the title, a double-line bottom
border below cells with totals, or a thick border between sections of a
complicated worksheet. You can add borders of varying colors and
widths to any or all sides of a single cell or range.

208

Adding Borders 
to Cells 

Apply a Border

Select a cell or range to which you
want to apply borders.

Click the Format menu, and then
click Cells. 

Click the Border tab.

Select a line style.

Click the Color list arrow, and then
click a color for the border. 

If you want a border on the outside
of a cell or range, click Outline. If
you want a border between cells,
click Inside. If you want to remove
a border, click None.

To set a custom border, click a
Border button, or click the Preview
Border box where you want to add
a border.

Click OK.8
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Did You Know?
You can apply a border using the
Formatting toolbar. Select a cell or
range to which you want to apply a
border, Click the Borders button list
arrow on the Formatting toolbar to
select a border. The most recently
selected style displays on the Borders
button.
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Formatting worksheet data can be a lot of fun but also very intensive. To
make formatting data more efficient, Excel includes 18 AutoFormats. An
AutoFormat includes a combination of fill colors and patterns, numeric
formats, font attributes, borders, and font colors that are professionally
designed to enhance your worksheets. If you don’t select any cells
before choosing the AutoFormat command, Excel will “guess” which
data should it should format.

Formatting Data 
with AutoFormat

Apply an AutoFormat

Select a cell or range to which you
want to apply an AutoFormat, or
skip this step if you want Excel to
“guess” which cells to format.

Click the Format menu, and then
click AutoFormat. 

Click an AutoFormat in the list. 

Click Options.

Select one or more Formats To
Apply check boxes to turn a
feature on or off.

Click OK.6
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Did You Know?
You can copy cell formats with Format
Painter. Select the cell or range whose
formatting you want to copy, double-
click the Format Painter button on the
Standard toolbar, select the cells you
want to format, and then click the
Format Painter button.
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A style is a defined collection of formats—font, font size, attributes,
numeric formats, and so on—that you can store as a set and later apply
to other cells. For example if you always want subtotals to display in blue
14-point Times New Roman, bold, italic, with two decimal places and
commas, you can create a style that includes all these formats. If you
plan to enter repetitive information, such as a list of dollar amounts in a
row or column, it’s often easier to apply the desired style to the range
before you enter the data. That way you can simple enter each number,
and Excel formats it as soon as you press Enter. You can also copy styles
from one workbook to another. Once you create a style, it is available to
you in every workbook.

Creating and Applying
Styles to Cells

Create a New Style

Select a cell or range that you
want to create a style.

Click the Format menu, and then
click Style. 

Type the name of the new style. 

Clear the check boxes with the
options you do not want.

Click Modify. 

Click any of the formatting tabs,
and make additional formatting
changes to the style.

Click OK. 

Click OK.8

7

6

5

4

3

2

1

Did You Know?
You can merge a style from another
workbook. Click the Format menu,
click Style, click Merge, click the
workbook that contains the style you
want, click OK, and then click OK.
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Apply a Style

Select a cell or range to which you
want to apply a style.

Click the Format menu, and then
click Style. 

Click the Style Name list arrow,
and then select the style you want
to apply.

Click OK.

Delete a Style

Click the Format menu, and then
click Style.

Click the Style Name list arrow,
and then click the style you want
to delete. 

Click Delete.

Click OK.4
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Depending on your screen size, the sheet tabs at the bottom of your
workbook can be hard to view. You can add color to the sheet tabs to
make them more distinguishable. If you want to add artistic style to your
workbook or you are creating a Web page from your workbook, you can
add a background picture. When you add a background to a worksheet,
the background does not print, and it’s not included when you save an
individual worksheet as a Web page. You need to publish the entire
workbook as a Web page to include the background.

Formatting Tabs and
the Background

Add Color to Worksheet Tabs

Click the sheet tab you want to
color.

Click the Format menu, point to
Sheet, and then click Tab Color.

Click a tab color.

Click OK.

Add or Remove a Background

Click the sheet tab you want to add
a background to.

Click the Format menu, point to
Sheet, and then click Background.

Select the folder with the graphic
file you want to use.

Select the graphic you want.

Click Insert.

To remove the background, click
the Format menu, point to Sheet,
and then click Remove
Background.
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If you want to print a worksheet that is larger than one page, Excel
divides it into pages by inserting automatic page breaks. These page
breaks are based on paper size, margin settings, and scaling options you
set. You can change which rows or columns are printed on the page by
inserting horizontal or vertical page breaks. In page break preview, you
can view the page breaks and move them by dragging them to a different
location on the worksheet.

Inserting Page Breaks

Insert a Page Break

To insert a horizontal page break,
click the row where you want to
insert a page break.

To insert a vertical page break,
click the column where you want
to insert a page break.

Click the Insert menu, and then
click Page Break.

Preview and Move a 
Page Break

Click the View menu, and then
click Page Break Preview.

Drag a page break (a thick blue
line) to a new location.

When you’re done, click the View
menu, and then click Normal.
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You can set up the worksheet page to print just the way you want. With
the Page Setup dialog box, you can choose the page orientation, which
determines whether Excel prints the worksheet data portrait (vertically)
or landscape (horizontally). You can also adjust the print scaling (to
reduce or enlarge the size of printed characters), change the paper size
(to match the size of paper in your printer), and resize or realign the left,
right, top, and bottom margins (the blank areas along each edge of the
paper). Changes made in the Page Setup dialog box are not reflected in
the worksheet window. You can see them only when you preview or print
the worksheet.

214

Setting Up the Page

Change Page Orientation

Click the File menu, and then click
Page Setup.

Click the Page tab.

Click the Portrait (8.5 x 11 inches)
option (the default) or click the
Landscape (11 x 8.5 inches) option
to select page orientation.

Click OK.

Change the Margin Settings

Click the File menu, and then click
Page Setup.

Click the Margins tab.

Click the Top, Bottom, Left, and
Right up or down arrows to adjust
the margins.

Select the Center On Page check
boxes to automatically center your
data.

Click OK.5
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Adding a header or footer to a workbook is a convenient way to make
your printout easier for readers to follow. Using the Page Setup com-
mand, you can add information such as page numbers, the worksheet
title, or the current date at the top and bottom of each page or section of
a worksheet or workbook. Using the Custom Header and Custom Footer
buttons, you can include information such as your computer system’s
date and time, the name of the workbook and sheet, a graphic, or other
custom information.
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Adding Headers and
Footers

Change a Header or Footer

Click the File menu, and then click
Page Setup.

Click the Header/Footer tab.

If the Header box doesn’t contain
the information you want, click
Custom Header. 

Type the information in the Left,
Center, or Right Section text boxes,
or click a button to insert built-in
header information. If you don’t
want a header to appear at all,
delete the text and codes in the
text boxes.

Select the text you want to format,
click the Font button, make font
changes, and then click OK. Excel
will use the default font, Arial,
unless you change it.

Click OK.

If the Footer box doesn’t contain
the information that you want,
click Custom Footer.

Type information in the Left,
Center, or Right Section text boxes,
or click a button to insert the built-
in footer information.

Click OK.

Click OK.10
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At some point you’ll want to print your worksheet so you can distribute it
to others or use it for other purposes. You can print all or part of any
worksheet, and you can control the appearance of many features, such
as whether gridlines are displayed, whether column letters and row
numbers are displayed, or whether to include print titles, columns and
rows that are repeated on each page. If you have already set a print
area, it will appear in the Print Area box on the Sheet tab of the Page
Setup dialog box. You don’t need to re-select it.

Customizing
Worksheet Printing

Print Part of a Worksheet

Click the File menu, and then click
Page Setup.

Click the Sheet tab. 

Click in the Print Area box, and
then type the range you want to
print. Or click the Collapse Dialog
button, select the cells you want to
print, and then click the Expand
Dialog button to restore the dialog
box.

Click OK. 

Print Row and Column Titles on
Each Page

Click the File menu, and then click
Page Setup.

Click the Sheet tab. 

Enter the number of the row or the
letter of the column that contains
the titles. Or click the Collapse
Dialog button, select the row or
column with the mouse, and then
click the Expand Dialog button to
restore the dialog box.

Click OK.4
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Print Gridlines, Column Letters,
and Row Numbers

Click the File menu, and then click
Page Setup.

Click the Sheet tab.

Select the Gridlines check box.

Select the Row And Column
Headings check box.

Click OK.

Fit Your Worksheet on a Specific
Number of Pages

Click the File menu, and then click
Page Setup.

Click the Page tab.

Select a scaling option.

◆ Click the Adjust To option to
scale the worksheet using a
percentage.

◆ Click the Fit To option to force a
worksheet to be printed on a
specific number of pages.

Click OK.4
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When you’re ready to print your worksheet, you can choose several
printing options. The print area is the section of your worksheet that
Excel prints. You can set the print area when you customize worksheet
printing or any time when you are working on a worksheet. For example,
you might want to print a different range in a worksheet for different
people. In order to use headers and footers, you must first establish, or
set, the print area. You can design a specific single cells or a contiguous
or non-contiguous range.

Setting the Print Area 

Set the Print Area

Select the range of cells you want
to print.  

Click the File menu, and then point
to Print Area.

Click Set Print Area.

Clear the Print Area

Click the File menu, and then point
to Print Area.

Click Clear Print Area.2
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Before printing, you should verify that the page looks the way you want.
You save time, money, and paper by avoiding duplicate printing. Print
Preview shows you the exact placement of your data on each printed
page. You can view all or part of your worksheet as it will appear when
you print it. The Print Preview toolbar makes it easy to zoom in and out to
view data more comfortably, set margins and other page options, pre-
view page breaks, and print.

Previewing a
Worksheet

Preview a Worksheet

Click the Print Preview button on
the Standard toolbar, or click the
File menu, and then click Print
Preview. 

Click the Zoom button on the Print
Preview toolbar, or position the
Zoom pointer anywhere on the
worksheet and click it to enlarge a
specific area of the page.

If you do not want to print from
Print Preview, click the Close
button to return to the worksheet.

If you want to print from Print
Preview, click the Print button on
the Print Preview toolbar.

Click OK.5

4
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1

Did You Know?
You can preview your work from the
Print dialog box. In the Print dialog
box, click Preview. After previewing
you can click the Print button on the
Print Preview toolbar to print the work-
sheet or click the Close button to
return to your worksheet.
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Printing a paper copy is a common way to review and share a document.
You can print a copy of your worksheet by clicking the Print button on the
Standard toolbar or on the Print Preview toolbar. When you use the Print
button, Excel prints the selected worksheet with the current Print dialog
box settings. You can open the Print dialog box to specify several print
options, such as choosing a new printer, selecting the number of pages
in the worksheet you want printed, and specifying the number of copies.

Printing a Worksheet

Print a Worksheet Quickly

Click the Print button on the
Standard toolbar. 

Excel prints the selected
worksheet with the current Print
dialog box settings. 

Specify Print Options

Click the File menu, and then click
Print. 

If necessary, click the Name list
arrow, and then click the printer
you want to use.

Select whether you want to print
the entire worksheet or only the
pages you specify.

Select whether you want to print
the selected range, the active
worksheet(s), or all the worksheets
in the workbook with data.

Select the number of copies you
want.

Click OK.6
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