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7Creating a Worksheet 
with Excel

What You’ll Do

View the Excel Window

Select Cells

Move Around Cells

Enter Text and Numbers

Make Label Entries

Edit and Clear Cell Contents

Insert and Delete Cells

Select a Column or Row

Insert and Delete Columns or Rows

Hide and Unhide a Column or Row

Adjust Column Width and Row Height

Select and Name a Worksheet

Insert and Delete a Worksheet

Move and Copy a Worksheet

Hide and Unhide Worksheets and
Workbooks

Split a Worksheet in Panes

Freeze Panes

Introduction

Are you spending too much time number-crunching, rewriting
financial reports, drawing charts, or searching for your 
calculator? Throw away your pencil, graph paper, and calculator,
and start using Microsoft Office Excel 2003. 

Excel is a sspprreeaaddsshheeeett  pprrooggrraamm, designed to help you
record, analyze, and present quantitative information. With Excel
you can track and analyze sales, organize finances, create 
budgets, and accomplish a variety of business tasks in a fraction
of the time it would take using pen and paper. With Excel, you
can create a variety of documents for analysis and record 
keeping, such as monthly sales and expense reports, charts 
displaying annual sales data, an inventory of products, or a
payment schedule for an equipment purchase.

Excel offers several tools that make your worksheets look
more attractive and professional. Without formatting, a work-
sheet can look like nothing more than meaningless data. To
highlight important information, you can change the appearance
of selected numbers and text by adding dollar signs, commas, 
and other numerical formats, or by applying attributes such as
boldface and italics.

The file you create and save in Excel is called a wwoorrkkbbooookk. 
It contains a collection of wwoorrkksshheeeettss, which look similar to an
accountant’s ledger sheets with lines and grids, but can perform
calculations and other tasks automatically.
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Viewing the Excel Window

Title bar
The title bar contains

the name of the active
workbook.

Formula bar
Any data contained in the
active cell appears in the
formula bar. 

Toolbars
Frequently-used
Excel
commands are
available
through toolbar
buttons, which
are organized on
toolbars. 

Menu bar
The nine menus give
you access to all
Excel commands. 

Status bar
The status bar
shows information
about commands. 

Worksheet tab
Each sheet has a tab
you can click to move
from sheet to sheet
that you can rename. 

Mouse pointer
The mouse pointer
takes this shape when
Excel is ready to
perform a new task. 

Cell address
Each cell has a unique
address determined by the
column letter and row
number. For example, the
cell B4 is the intersection of
column B and row 4. 

Select All
button
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A cell is the intersection of a column and a row. You must select a cell
and make it active to work with it. A range is one or more selected cells
that you can edit, delete, format, print, or use in a formula just like a sin-
gle cell. The active cell has a dark border; selected cells have a light
shading called a see-through selection. A range can be contiguous (all
selected cells are adjacent) or noncontiguous (selected cells are not all
adjacent). As you select a range, you can see the range reference in the
Name box. A range reference lists the upper-left cell address, a colon (:),
and the lower-right cell address. Commas separate noncontiguous cells.
For example, B4:D10,E7,L24. You can click any cell to deselect a range.

Selecting Cells

Select a Cell

Click a cell to select it.

Select a Range

Click the first cell you want to
include in the range.

Drag to the last cell you want to
include in the range. The upper-
left cell of a selected range is
active and the others are
highlighted.

Select a Noncontiguous Range

Click the first cell, or select the
first contiguous range you want to
include.

Press and hold Ctrl while you click
additional cells and select other
ranges.

2

1

2

1

1

1

1

1

2

2
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You can move around a worksheet or workbook using your mouse or the
keyboard. You might find that using your mouse to move from cell to cell
is most convenient, while using various keyboard combinations is easier
for covering large areas of a worksheet quickly. However, there is no
right way; whichever method feels the most comfortable is the one you
should use.

Moving Around Cells

Use the Mouse to Navigate

Using the mouse, you can navigate to:

◆ Another cell

◆ Another part of the worksheet

◆ Another worksheet

Did You Know?

Microsoft IntelliMouse users can roll
from cell to cell with IntelliMouse. 
If you have the new Microsoft
IntelliMouse—with the wheel button
between the left and right buttons—
you can click the wheel button and
move the mouse in any direction to
move quickly around the worksheet.

You can quickly zoom in or out using
IntelliMouse. Instead of scrolling
when you roll with the IntelliMouse,
you can zoom in or out. To turn on this
feature, click the Tools menu, click
Options, click the General tab, click to
select the Zoom On Roll With
IntelliMouse check box, and then click
OK.

To move from one cell
to another, point to the
cell you want to move

to, and then click. 

When you click the wheel button on the
IntelliMouse, the pointer changes
shape. Drag the pointer in any direction
to move to a new location quickly. 

To see more sheet
tabs without
changing the
location of the
active cell, click a
sheet scroll button. 

To move from
one worksheet
to another, 
click the tab of
the sheet you
want to move to. 

XL03S-1-2, XL03S-5-2
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Use the Keyboard to Navigate

Using the keyboard, you can 
navigate to:

◆ Another cell

◆ Another part of the worksheet

Refer to the table for keyboard
shortcuts for navigating around 
a worksheet.

Go To a Specific Location

Click the Edit menu, and then click
Go To. 

Type the cell address to the cell
location where you want to go. 

To go to other locations (such as
comments, blanks, last cell,
objects, formulas, etc.), click
Special, select an option, and then
click OK.

Click OK.4

3

2

1

Did You Know?
You can change or move cell selec-
tions after pressing Enter. When you
press Enter, the active cell moves
down one cell. To change the direc-
tion, click the Tools menu, click
Options, click the Edit tab, click the
Direction list arrow, select a direction,
and then click OK.

Keys For Navigating in a Worksheet

Press This Key To Move

Left arrow One cell to the left

Right arrow One cell to the right

Up arrow One cell up

Down arrow One cell down

Enter One cell down

Tab One cell to the right

Shift+Tab One cell to the left

Page Up One screen up

Page Down One screen down

End+arrow key In the direction of the arrow key to the 
next cell containing data or to the last 
empty cell in the current row or column

Home To column A in the current row

Ctrl+Home To cell A1

Ctrl+End To the last cell in the worksheet
containing data

43

2
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You can enter values as whole numbers, decimals, percentages, or
dates. You can enter values using the either numbers on the top row of
your keyboard, or the numeric keypad on the right side of your keyboard.
When you enter a date or the time of day, Excel recognizes these entries
(if entered in an acceptable format) as numeric values and changes the
cell’s format to a default date, currency, or time format. The AutoFill 
feature fills in data based on the data in adjacent cells. Using the fill han-
dle, you can enter data in a series, or you can copy values or formulas to
adjacent cells. The entry in a cell can create an AutoFill that repeats a
value or label, or the results can be a more complex extended series,
such as days of the week, months of the year, or consecutive numbering.

Entering Text and
Numbers

Enter a Value

Click the cell where you want to
enter a value. 

Type a value. 

To simplify your data entry, type
the values without commas and
dollar signs, and then apply a
numeric format to them later.

Press Enter, or click the Enter
button on the formula bar.

3

2

1

Did You Know?
You can use the numeric keypad like a
calculator to enter numbers on your
worksheet. Before using the numeric
keypad, make sure NUM appears in
the lower-right corner of the status
bar. If NUM is not displayed, you can
turn on this feature by pressing the
Num Lock key on the numeric keypad.

You can quickly select all data within
a worksheet. To select all the cells in
the worksheet, including those cells
that do not contain data, click the
Select All button. 

3

2 1

XL03S-1-1
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Enter Repeating Data 
Using AutoFill

Select the first cell in the range
you want to fill.

Enter the starting value or label
that you want to repeat.

Position the mouse pointer on the
lower-right corner of the selected
cell. The fill handle (a small black
box) changes to the fill handle
pointer (a black plus sign). 

Drag the fill handle pointer over
the range where you want to
repeat the value. The fill handle
ScreenTip indicates what is being
repeated.

Create a Complex Series 
Using AutoFill

Select the first cell in the range
you want to fill.

Enter the starting value for the
series, and then click the Enter
button on the formula bar.

Position the mouse pointer on the
lower-right corner of the selected
cell, and then hold down Ctrl. The
pointer changes to the fill handle
pointer (a black plus sign with a
smaller plus sign).

Drag the fill handle pointer over
the range where you want the
value extended. The destination
value appears in a small box.

Click the AutoFill Options button,
and then click an option that
specifies how you want to fill in
the data.

5

4

3

2

1

4

3

2

1

1

2

3

4

2

1 4

5

C07OF.qxd  8/17/2003  10:17 PM  Page 155



156

Excel has three types of cell entries: labels, values, and formulas. Excel
uses values and formulas to perform its calculations. A label is text in a
cell that identifies the data on the worksheet so readers can interpret
the information, such as titles or column headings. A label is not
included in calculations. A value is a number you enter in a cell. To enter
values easily and quickly, you can format a cell, a range of cells, or an
entire column with a specific number-related format. Labels turn a work-
sheet full of numbers into a meaningful report by identifying the different
types of information it contains. You use labels to describe or identify the
data in worksheet cells, columns, and rows. You can enter a number as
a label (for example the year 2003), so that Excel does not use the num-
ber in its calculations. To help keep your labels consistent, you can use
Excel’s AutoComplete feature, which completes your entries based on
the format of previously entered labels.

Making Label Entries

Enter a Text Label

Click the cell where you want to
enter a text label.

Type a label. 

A label can include uppercase and
lowercase letters, spaces,
punctuation, and numbers.

Click the Enter button on the
formula bar, or press Enter.

3

2

1

Did You Know?
You can enter labels quickly using
AutoComplete. Type the first few char-
acters of a label. If a previous entry in
that column begins with the same
characters, AutoComplete displays the
entry. Press Enter or click the Enter
button on the formula bar to accept the
entry. Resume typing to ignore the
AutoComplete suggestion.

You can enable AutoComplete for cell
values. Click the Tools menu, click
Options, click the Edit tab, click to
select the Enable AutoComplete For
Cell Values check box, and then 
click OK. 

1 2

3 What you type in the cell also
appears in the formula bar. 

XL03S-1-1
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Enter a Number as a Label

Click the cell where you want to
enter a number label.

Type ’ (apostrophe). 

The apostrophe is a label prefix
and does not appear on the
worksheet.

Type a number. 

Examples of number labels include
a year, social security number, 
or telephone number.

Click the Enter button on the
formula bar, or press Enter or Tab.

Enter a Label from the PickList

Right-click the cell at the bottom 
of a list where you want to enter 
a label, and then click Pick From
Drop-Down List.

Click an entry from the list.2

1

4

3

2

1

Did You Know?
Using long labels might appear 
truncated. When you enter a label
wider than the cell it occupies, the
excess text appears to spill into the
next cell to the right—unless there is
data in the adjacent cell. If the adja-
cent cell contains data, the label
appears truncated—you see only the
portion of the label that fits in the 
cell’s current width.

4 1

32

1

2
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No matter how much you plan, you can count on having to make
changes on a worksheet. Sometimes you’ll need to correct an error;
other times, you’ll want to add new information or see the results for 
different conditions, such as higher sales, fewer produced units, or other
variables. You edit data just as easily as you enter it, using the formula
bar or directly in the active cell.

Editing Cell Contents

Edit Cell Contents

Double-click the cell you want 
to edit.

The status bar displays Edit
instead of Ready.

Use the mouse pointer or the
Home, End, and arrow keys to
position the insertion point in 
the cell.

To erase characters, press
Backspace or Delete.

To enter characters, type new
characters.

Press Enter or click the Enter
button on the formula bar to
accept the edit, or click the 
Cancel button on the formula 
bar to cancel it.

5

4

3

2

1

Did You Know?
You can change editing options. Click
the Tools menu, click Options, click the
Edit tab, change the editing options
you want, and then click OK.

By deleting a cell, you remove the cell
completely from the worksheet. When
you choose Delete from the Edit menu
or from the shortcut menu, you must
choose to move the remaining cells
left or up, or to remove the entire row
or column.

1

4

5
Click to edit the cell
content in the formula bar. 

XL03S-1-1
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You can clear a cell to remove its contents. Clearing a cell does not
remove the cell from the worksheet; it just removes from the cell 
whatever elements you specify: data, comments (also called cell 
notes), or formatting instructions. When clearing a cell, you must 
specify whether to remove one, two, or three of these elements from 
the selected cell or range.

Clearing Cell Contents

Clear the Contents of a Cell

Select the cell or range you want
to clear.

Click the right mouse button, and
then click Clear Contents on the
shortcut menu, or press Delete.

Clear Cell Contents, Formatting,
and Comments

Select the cell or range you want
to clear.

Click the Edit menu, and then point
to Clear.

Click All.3

2

1

2

1

See Also
See “Inserting Comments” on page 41
for information on inserting comments. 

1

2

1

32

XL03S-1-1
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You can insert new, blank cells anywhere on the worksheet so you can
enter new data exactly where you want it. Inserting cells moves the
remaining cells in the column or row to the right or down as you choose
and adjusts any formulas so they refer to the correct cells. You can also
delete cells if you find you don’t need them; deleting cells shifts the
remaining cells to the left or up a row—just the opposite of inserting
cells. Deleting a cell is different from clearing a cell. Deleting a cell
removes the actual cell from the worksheet whereas clearing a cell
erases the cell contents, the cell format, or both.

Inserting and 
Deleting Cells

Insert One or More Cells

Select one or more cells where
you want to insert new cell(s). 

Click the Insert menu, and then
click Cells.

To move the contents of the cells
right, click the Shift Cells Right
option; to move the contents of 
the cells down, click the Shift 
Cells Down option.

Click OK.

Delete One or More Cells

Select one or more cells you 
want to delete.

Click the Edit menu, and then 
click Delete.

To move the remaining cells left,
click the Shift Cells Left option; to
move the remaining cells up, 
click the Shift Cells Up option. 

Click OK.4

3

2

1

4

3

2

1 2

3

41

1 4

2

3

XL03S-5-2
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Selecting a Column 
or Row

Select a Column or Row

Click the column or row header
button of the column or row you
want to select.

Select Multiple Columns 
or Rows

Drag the mouse over the header
buttons of any contiguous columns
or rows you want to select. 

To select noncontiguous columns
or rows, press and hold Ctrl while
clicking each additional column or
row header button. 

2

1

1

You can select one or more columns or rows in a worksheet in order to
apply formatting attributes, insert or delete columns or rows, or perform
other group actions. The header buttons above each column and to the
left of each row indicate the letter or number of the column or row. You
can select multiple columns or rows even if they are non-contiguous—
that is, not next to one another in the worksheet.

Did You Know?
You can select the entire worksheet
quickly. Click the Select All button
located above the row number 1 and
the left of column A.

1

2 1
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You can insert one or more blank columns and rows on a worksheet
between columns or rows that are already filled. The header buttons
above each column and to the left of each row indicate the letter or
number of the column or row. Inserted columns are added to the left of
the selected columns. Inserted rows are added above the selected rows.
Excel repositions existing cells to accommodate the new columns and
rows and adjusts any existing formulas so that they refer to the correct
cells. The Insert menu can change depending on the selection. When
you select a column, only the Columns command appears on the Insert
menu. When you select a row, only the Rows command appears.

Inserting and 
Deleting Columns 
or Rows

Insert One or More 
Columns or Rows

To insert a column, click the
column header button directly 
to the right of where you want 
to insert the new column.

To insert a row, click the row
header button directly below
where you want to insert the 
new row.

To insert multiple columns or rows,
drag to select the header buttons
for the number of columns or rows
you want to insert. 

Click the Insert menu, and then
click Columns or Rows.

Delete One or More 
Columns or Rows 

Select the columns or rows you
want to delete.

Click the Edit menu, and then 
click Delete.

2

1

3

2

1

Column header buttonRow header button

3

1

2

2

1

XL03S-3-3
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Hiding and Unhiding 
a Column or Row

Hide a Column or Row

Click the column or row header
button of the column or row you
want to hide. (Drag to select
multiple header buttons to hide
more than one column or row.)

Click the Format menu, point 
to Column or Row, and then 
click Hide.

Unhide a Column or Row

Drag to select the column or row
header buttons on either side of
the hidden column or row.

Click the Format menu, point to
Column or Row, and then click
Unhide.

2

1

2

1

Not all the data on a worksheet should be available to everyone. You can
hide sensitive information without deleting it by hiding selected columns
or rows. For example, if you want to share a worksheet with others, but it
includes confidential employee salaries, you can simply hide the salary
column. Hiding columns and rows does not affect calculations in a work-
sheet; all data in hidden columns and rows is still referenced by formulas
as necessary. Hidden columns and rows do not appear in a printout
either. When you need the data, you can unhide the sensitive
information.

Header button

2

2 1

XL03S-3-3
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You’ve entered labels and values, constructed formulas, and even 
formatted the cells, but now some of your data isn’t visible; the value dis-
plays as ##### in the cell. Also, some larger-sized labels are cut off. You
can narrow or widen each column width to fit its contents and adjust
your row heights as needed. As you build your worksheet, you can
change the default width of some columns or the default height of some
rows to accommodate long strings of data or larger font sizes. You can
manually adjust column or row size to fit data you have entered, or you
can use AutoFit to resize a column or row to the width or height of its
largest entry.

Adjusting Column
Width and 
Row Height

Adjust Column Width 
or Row Height

Click the column or row header
button for the first column or row
you want to adjust.

If you want, drag to select more
columns or rows.

Right-click the selected column(s)
or row(s), and then click Column
Width or Row Height.

Type a new column width or row
height in points. 

Click OK.5

4

3

2

1

1

5

4

XL03S-3-3
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Adjust Column Width or Row
Height Using the Mouse

Position the mouse pointer on the
right edge of the column header
button or the bottom edge of the
row header button for the column
or row you want to change. 

When the mouse pointer changes
to a double-headed arrow, click
and drag the pointer to a new
width or height.

Change Column Width or Row
Height Using AutoFit

Position the mouse pointer on the
right edge of the column header
button or the bottom edge of the
row header button for the column
or row you want to change.

When the mouse pointer changes
to a double-headed arrow, double-
click the mouse. 

2

1

2

1
2

1
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Each new workbook opens with three worksheets (or sheets), in which
you store and analyze values. You work in the active, or selected, 
worksheet. The default worksheet names are Sheet1, Sheet2, and
Sheet3, which appear on the sheet tab, like file folder labels. As you 
create a worksheet, give it a meaningful name to help you remember its
contents. The sheet tab size adjusts to fit the name’s length. If you work
on a project that requires more than three worksheets, add additional
sheets to the workbook so all related information is stored in one work-
book.

Selecting and 
Naming a Worksheet

Select a Worksheet

If necessary, click a sheet tab
scroll button to display other tabs.

Click a sheet tab to make it the
active worksheet.

To select multiple worksheets,
press and hold Ctrl as you click
other sheet tabs.

Name a Worksheet

Double-click the sheet tab you
want to name.

Type a new name. 

The current name, which is
selected, is replaced when 
you begin typing.

Press Enter.3

2

1

3

2

1

1

1

2

XL03S-5-4
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Inserting and Deleting
a Worksheet

Insert a Worksheet

Click the sheet tab to the right of
where you want to insert the new
sheet.

Click the Insert menu, and then
click Worksheet. 

A new worksheet is inserted to the
left of the selected worksheet.

Delete a Worksheet 

Click the sheet tab of the
worksheet you want to delete.

Click the Edit menu, and then 
click Delete Sheet. 

2

1

2

1

You can add or delete sheets in a workbook. If, for example, you are
working on a project that requires more than three worksheets, you can
insert additional sheets in one workbook rather than open multiple work-
books. You can insert as many sheets in a workbook as you want. If, on
the other hand, you are using only one or two sheets in a workbook, you
can delete the unused sheets to save disk space. Before you delete a
sheet from a workbook, make sure you don’t need the data. You cannot
undo the deletion.

1

2

2

1

XL03S-5-4
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After adding several sheets to a workbook, you might want to reorganize
them. You can arrange sheets in chronological order or in order of their
importance. You can easily move or copy a sheet within a workbook or
to a different open workbook. Copying a worksheet is easier and often
more convenient then reentering similar information on a new sheet. If
you are moving or copying a worksheet a short distance, you should use
the mouse. For longer distances, you should use the Move Or Copy
Sheet command on the Edit menu.

Moving and Copying 
a Worksheet

Move a Worksheet Within 
a Workbook

Click the sheet tab of the
worksheet you want to move, and
then hold down the mouse button.

When the mouse pointer changes
to a sheet of paper, drag it to the
right of the sheet tab where you
want to move the worksheet.

Release the mouse button.3

2

1

Did You Know?
You can use the Create A Copy check
box to move a worksheet. Clear the
Create A Copy check box in the Move
Or Copy dialog box to move a work-
sheet rather than copy it.

You can give your worksheet a differ-
ent background. Click the tab of the
sheet on which you want to insert a
background, click the Format menu,
point to Sheet, and then click
Background. Select the picture you
want to use as a background, and 
then click Insert.

2 1

XL03S-5-4
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Copy a Worksheet

Click the sheet tab of the
worksheet you want to copy.

TIMESAVER Press and hold
the Ctrl key while you drag a sheet
name to copy a worksheet.

Click the Edit menu, and then click
Move Or Copy Sheet. 

If you want to copy the sheet to
another open workbook, click the
To Book list arrow, and then select
the name of that workbook. The
sheets of the selected workbook
appear in the Before Sheet list.

TROUBLE? If the workbook you
want to copy to does not show up
in the To Book drop-down list, you
must first open the other
workbook.

Click a sheet name in the Before
Sheet list. Excel inserts the copy 
to the left of this sheet. 

Select the Create A Copy check
box.

Click OK.6

5

4

3

2

1

Did You Know?
You can use groups to affect multiple
worksheets. Click a sheet tab, press
and hold the Shift key, and click
another sheet tab to group work-
sheets. Right-click a grouped sheet
tab, and then click Ungroup Sheet on
the shortcut menu.

51

6

4

3

2
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Not all worksheets and workbooks should be available to everyone. 
You can hide sensitive information without deleting it by hiding selected
worksheets or workbooks. For example, if you want to share a workbook
with others, but it includes confidential employee salaries, you can sim-
ply hide a worksheet. Hiding worksheets does not affect calculations in
the other worksheets; all data in hidden worksheets is still referenced by
formulas as necessary. Hidden worksheets do not appear in a printout
either. When you need the data, you can unhide the sensitive
information.

Hiding and Unhiding
Worksheets and
Workbooks

Hide or Unhide a Worksheet

◆ Hide. Click the sheet tab you want
to hide, click the Format menu,
point to Sheet, and then click Hide.

◆ Unhide. Click the Format menu,
point to Sheet, click Unhide, select
the worksheet you want to unhide,
and then click OK.

Hide or Unhide a Workbook

◆ Hide. Open the workbook you
want to hide, click the Window
menu, and then click Hide.

◆ Unhide. Click the Window menu,
click Unhide, select the workbook
you want to unhide, and then click
OK.

Click to hide or unhide a worksheet.

Select a workbook to unhide it.

XL03S-3-4, XL03S-5-6
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Splitting a Worksheet
in Panes

Split a Worksheet in Panes

◆ Split. Click the Window menu, and
then click Split.

◆ Remove Split. Click the Window
menu, and then click Remove Split.

If you are working on a large worksheet, it can be time consuming and
tiring to scroll back and forth between two parts of the worksheet. You
can split the worksheet into four panes and two scrollable windows that
you can view simultaneously but edit and scroll independently. As you
work in two parts of the same worksheet, you can resize the window
panes to fit your task. Drag the split bar between the panes to resize the
windows. No matter how you display worksheets, Excel’s commands and
buttons work the same as usual.

Did You Know?
You can search for a value or data in a
cell and then replace it with different
content. Click the cell or cells contain-
ing content you want to replace. Click
the Edit menu, click Find, and then
click the Replace tab for additional
options.

Click to split
the worksheet.

Worksheet split
into four panes

Scroll panes
separately.
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Once you’ve finished creating the worksheet structure—labels and 
formulas—you’re ready to enter data. The first six columns and twelve
rows or so are just fine, but as you scroll to enter data in later columns
or rows, the labels for the column headings shift out of view. Instead of
memorizing the headings, freeze the label columns and rows so they
remain visible as you scroll through the rest of the worksheet. You can
freeze a row, a column, or a pane from a split worksheet.

Freezing Panes

Freeze Columns and Rows

Click the cell that intersects the
rows and columns you want to
remain visible on the screen.

To freeze panes from a split
window, skip step 1.

Click the Window menu, and then
click Freeze Panes.

Edit and scroll the worksheet as
usual.

Unfreeze Columns and Rows

Click the worksheet that you want
to unfreeze. 

Click the Window menu, and then
click Unfreeze Panes.

2
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