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Formatting a Worksheet

Introduction

Microsoft Office Excel 2003 offers several tools for making your
worksheets look more attractive and professional. Without for-
matting, a worksheet can look like a sea of meaningless data. To
highlight important information, you can change the appearance
of selected numbers and text by adding dollar signs, commas,
and other numerical formats or by applying attributes, such as
boldface, italics, and underline.

Once you’ve set up your worksheet, additional changes are
available to customize your worksheets look. You can change the
default font and font size, or maybe you’d like to adjust the
alignment of data in cells. In addition to column, row, or font
changes, you can add colors to cells or fonts, and include pat-
terns to cells.  You can also add borders around columns of data
to help group them visually, or even add some clip art, a 
company logo, or some pictures. 

By using AutoFormats and styles to apply multiple changes,
you can speed up the formatting process and ensure a greater
degree of consistency among your worksheets.  You can use the
Find and Replace Formatting feature to find the various format-
ting attributes and change them.  5

5
What You’ll Do

Format Text and Numbers

Design Conditional Formatting

Copy Cell Formats

Change Fonts 

Change Data Alignment

Control Text Flow

Change Data Color 

Add Color and Patterns to Cells

Add Borders to Cells

Format Data with AutoFormat

Modify an AutoFormat

Format Tabs and Background

Create and Apply Style

Modify a Style

Find and Replace Formatting
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You can change the appearance of the data in the cells of a worksheet
without changing the actual value in the cell. You can format text and
numbers with font attributes, such as bolding, italics, or underlining, to
enhance data to catch the reader’s attention. You can also apply numeric
formats to numbers to better reflect the type of information they repre-
sent—dollar amounts, dates, decimals, and so on. For example, you can
format a number to display up to 15 decimal places or none at all. If you
don’t see the number format you need, you can create a custom one.
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Formatting Text
and Numbers

Format Text Quickly

Select a cell or range with the text
you want to format.

Click one of the buttons on the
Formatting toolbar to apply that
attribute to the selected range:

◆ Bold

◆ Italic

◆ Underline

Click the Font or Font Size list
arrow, and then select a font or
size.

You can apply multiple attributes to
the range.

3

2

1

Formatting Toolbar Buttons

Button Name Example

Bold Excel

Italic Excel

Underline Excel

Currency Style $5,432.10 

Percent Style 54.32%

Comma Style 5,432.10

Increase Decimal 5,432.10 becomes 5,432.100

Decrease Decimal 5,432.10 becomes 5,432.1

Did You Know?
You can remove a numeric format or
font attribute quickly. The buttons on
the Formatting toolbar are toggle but-
tons, which means you simply click to
turn them on and off. To add or remove
a numeric format or a font attribute,
select the cell, range, or text, and then
click the appropriate button on the
Formatting toolbar to turn the format or
attribute off.

You can format numbers in interna-
tional currencies. In the Format Cells
dialog box, click the Number tab, click
Currency in the Category list, click the
Symbol list arrow, and then click an
international currency symbol. 

XL03S-3-1, XL03E-2-1
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Format Numbers Quickly

Select a cell or range that
contains the number(s) you want
to format.

Click one of the buttons on the
Formatting toolbar to apply that
attribute to the selected range.

◆ Currency Style

◆ Percent Style

◆ Comma Style

◆ Increase Decimal

◆ Decrease Decimal

You can apply multiple attributes to
the range.

Format a Number Using the
Format Cells Dialog Box

Select a cell or range that
contains the number(s) you want
to format.

Click the Format menu, and then
click Cells.

Click the Number tab.

Click to select a category.

Select the options you want to
apply. 

To create a custom format, click
Custom, type the number format
code, and then use one of the
existing codes as a starting point.

Preview your selections in the
Sample box.

Click OK.7

6

5

4

3

2

1

2

1
2

1

3

4 7

5

6

C05XL.qxd  9/2/2003  8:12 PM  Page 93



94

You can make your worksheets more powerful by setting up conditional
formatting. Conditional formatting lets the value of a cell determine its
formatting. For example, you might want this year’s sales total to be dis-
played in red and italics if it’s less than last year’s total, but in green and
bold if it’s more. The formatting is applied to the cell values only if the
values meet the a condition that you specify. Otherwise, no conditional
formatting is applied to the cell values. 

Designing Conditional
Formatting

Establish a Conditional Format

Select a cell or range you want to
conditionally format.

Click the Format menu, and then
click Conditional Formatting. 

Select the operator and values you
want for condition 1.

Click the Format button, select the
attributes you want applied, and
then click OK.

Click Add to include additional
conditions, and then repeat steps
3 and 4.

Click OK.

Delete a Conditional Format

Click the Format menu, and then
click Conditional Formatting.

Click Delete. 

Select the check box for the
condition(s) you want to delete.

Click OK.4
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See Also
See “Formatting Data with Auto
Format” on page 106 for information on
formatting data more efficiently.
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After formatting a cell on a worksheet, you might want to apply those
same formatting changes to other cells on the worksheet. For example,
you might want each subtotal on your worksheet to be formatted in italic,
bold, 12-point Times New Roman, with a dollar sign, commas, and two
decimal places. Rather than selecting each subtotal and applying the
individual formatting to each cell, you can paint (that is, copy) the for-
matting from one cell to others.
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Copying Cell Formats

Copy a Cell Format

Select a cell or range containing
the formatting you want to copy.

Click the Format Painter button on
the Standard toolbar. If necessary,
click the Toolbar Options list arrow
to display the button.

Drag to select the cell(s) you want
to paint. When you release the
mouse button, the cells appear
with the new formatting.

3

2

1

Did You Know?
You can use the Esc key to cancel for-
mat painting. If you change your mind
about painting a format, cancel the
marquee by pressing Esc.
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A font is a collection of alphanumeric characters that share the same
typeface, or design, and have similar characteristics. Most fonts are
available in a number of styles (such as bold and italic) and sizes. The
size of each font character is measured in points (a point is approxi-
mately 1/72 of an inch). You can use any font that is installed on your
computer on a worksheet, but the default is 10-point Arial. 

96

Changing Fonts

Change Font, Font Style, and
Font Size

Select a cell or range that
contains the font you want to
change. 

Click the Format menu, and then
click Cells.

Click the Font tab.

Select a font.

Select a font style.

Select a font size.

Select any additional formatting
effects.

Click OK.8
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Did You Know?
Each computer has different fonts
installed. Users with whom you share
files may not have all the fonts you’ve
used in a workbook installed on their
computers.

XL03S-3-1
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Change Font and Font Size Using
the Formatting Toolbar

Select a cell or range whose font
and font size you want to change.

Click the Font list arrow on the
Formatting toolbar.

If necessary, scroll to find the font
you want to use, and then click it.

Click the Font Size list arrow on
the Formatting toolbar. If
necessary, click the Toolbar
Options list arrow to display the
button.

If necessary, scroll to find the font
size you want to use, and then
click it.

5
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Did You Know?
You can tell the difference between a
TrueType and printer font. A TrueType
(outline) font is a font that uses special
software capabilities to print exactly
what is seen on the screen. A printer
(screen) font is a font that comes only
in specified sizes. If you are creating a
worksheet for publication, you need to
use printer fonts.

You can display font names in their
font. Click the Tools menu, click
Customize, click the Options tab, and
then click to select the List Font
Names In Their Font check box.
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When you enter data in a cell, Excel aligns labels on the left edge of the
cell and aligns values and formulas on the right edge of the cell.
Horizontal alignment is the way in which Excel aligns the contents of a
cell relative to the left or right edge of the cell; vertical alignment is the
way in which Excel aligns cell contents relative to the top and bottom of
the cell. Excel also provides an option for changing the flow and angle of
characters within a cell. The orientation of the contents of a cell is
expressed in degrees. The default orientation is 0 degrees, in which
characters are aligned horizontally within a cell.
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Changing Data
Alignment

Change Alignment Using the
Format Dialog Box

Select a cell or range containing
the data to be realigned.

Click the Format menu, and then
click Cells.

Click the Alignment tab.

Click the Horizontal list arrow or
the Vertical list arrow, and then
select an alignment.

Select an orientation. Click a point
on the map, or click the Degrees
up or down arrow.

If you want, select one or more of
the Text Control check boxes.

Click OK.7
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Did You Know?
You can use the Format Cells dialog
box to select other alignment options.
Many more alignment options are
available from the Format Cells dialog
box, but for centering across columns
and simple left, right, and center align-
ment, it’s easier to use the Formatting
toolbar buttons.

XL03S-3-3
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Change Alignment Using the
Formatting Toolbar

Select a cell or range containing
the data to be realigned.

Click the Align Left, Center, or
Align Right button on the
Formatting toolbar.

To center cell contents across
selected columns, click the Merge
And Center button on the
Formatting toolbar.

3

2

1

Alignment Toolbar Buttons

Button Name Description

Align Left Aligns cell contents on the left edge of 
the cell.

Center Centers cell contents in the middle of 
the cell.

Align Right Aligns cell contents on the right edge 
of the cell.

Merge and Center Centers cell contents across the 
columns of a selected range.               

1

32

See Also
See “Add Color to Worksheet Tabs” on
page 108 for information on adding
background color or pictures.
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The length of a label might not always fit within the width you’ve chosen
for a column. If the cell to the right is empty, text spills over into it, but if
that cell contains data, the text will be truncated (that is, cut off). A cell
can be formatted so its text automatically wraps to multiple lines; that
way, you don’t have to widen the column to achieve an attractive effect.
For example, you might want the label Interior Vanity Strips to fit in a col-
umn that is only as wide as Interior. Cell contents can also be modified to
fit within the available space or can be combined with the contents of
other cells.

100

Controlling Text Flow

Control the Flow of Text in a Cell 

Select a cell or range whose text
flow you want to change.

Click the Format menu, and then
click Cells.

Click the Alignment tab.

Click to select one or more Text
Control check boxes.

◆ Wrap Text moves the text to
multiple lines within a cell.

◆ Shrink To Fit reduces character
size to fit within a cell.

◆ Merge Cells combines selected
cells into a single cell.

Click OK.5

4
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You can change the color of the numbers and text on a worksheet.
Strategic use of font color can be an effective way of tying similar values
together. For instance, on a sales worksheet you might want to display
sales in green and returns in red. Or, you may want to highlight column
or row headers with colored labels. Either way, using color to highlight
numbers and texts makes deciphering your worksheet data easier.

Formatting a Worksheet 101

Changing Data Color

Change Font Color Using the
Formatting Toolbar

Select a cell or range that
contains the text you want to
change.

Click the Font Color button list
arrow on the Formatting toolbar.

Click a color.3

2

1

Did You Know?
The Font Color button on the
Formatting toolbar displays the last
font color you used. To apply this color
to another selection, simply click the
button, not the list arrow.

XL03S-3-1
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You can fill the background of a cell with a color and a pattern to make
its data stand out. Fill colors and patterns can also lend consistency to
related information on a worksheet. On a sales worksheet, for example,
formatting all fourth-quarter sales figures with a blue background and all
second-quarter sales with a yellow background would make each group
of figures easy to identify. You can use fill colors and patterns in conjunc-
tion with text attributes, fonts, and font colors to further enhance the
appearance of your worksheet.

102

Adding Color and
Patterns to Cells

Apply Color and Patterns

Select a cell or range to which you
want to apply colors and patterns.

Click the Format menu, and then
click Cells. 

Click the Patterns tab.

To add shading to the cell, click a
color in the palette.

To add a pattern to the cell, click
the Pattern list arrow, and then
click a pattern and color in the
palette.

Click OK.6
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Did You Know?
You can paint a format. When you
paint a format using the Format Painter
button on the Standard toolbar, the fill
colors and patterns get copied too.

XL03S-3-1
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Apply Color Using the
Formatting Toolbar 

Select a cell or range.

Click the Fill Color button list arrow
on the Formatting toolbar. 

If necessary, click the Toolbar
Options list arrow to display the
button.

Click a color.3

2

1

5

Did You Know?
You can use the Print Preview button
on the Standard toolbar to save time.
Preview your worksheet before you
print it, especially if you don’t have a
color printer. Some colors and patterns
look great on screen but can make a
worksheet difficult to read when
printed in black and white.
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The light gray grid that appears on the worksheet helps your eyes move
from cell to cell. Although you can print these gridlines, sometimes a 
different grid pattern better emphasizes your data. For example, you
might put a decorative line border around the title, a double-line bottom
border below cells with totals, or a thick border between sections of a
complicated worksheet. You can add borders of varying colors and
widths to any or all sides of a single cell or range.

Adding Borders 
to Cells 

Apply a Border

Select a cell or range to which you
want to apply borders.

Click the Format menu, and then
click Cells. 

Click the Border tab.

Select a line style.

Click the Color list arrow, and then
click a color for the border. 

If you want a border on the outside
of a cell or range, click Outline. If
you want a border between cells,
click Inside. If you want to remove
a border, click None.

To set a custom border, click a
Border button, or click the Preview
Border box where you want to add
a border.

Click OK.8
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Apply a Border Using the
Formatting Toolbar 

Select a cell or range to which you
want to apply a border.

Click the Borders list arrow on the
Formatting toolbar or the Borders
button to select the default border
style. If necessary, click the
Toolbar Options list arrow to
display the button.

Select a border from the submenu
of available borders. The previous
border style you have chosen
appears as the default Borders
button on the Formatting toolbar.

3

2

1

5

Did You Know?
You can use the Select All button. To
place a border around the entire work-
sheet, click the Select All button, and
then apply the border.

2

3

1

C05XL.qxd  9/2/2003  8:13 PM  Page 105



106

XL03S-3-1

Formatting worksheet data can be a lot of fun but also very intensive. To
make formatting data more efficient, Excel includes 18 AutoFormats. An
AutoFormat includes a combination of fill colors and patterns, numeric
formats, font attributes, borders, and font colors that are professionally
designed to enhance your worksheets. If you don’t select any cells
before choosing the AutoFormat command, Excel will “guess” which
data it should format.

Formatting Data 
with AutoFormat

Apply an AutoFormat

Select a cell or range to which you
want to apply an AutoFormat, or
skip this step if you want Excel to
“guess” which cells to format.

Click the Format menu, and then
click AutoFormat. 

Click an AutoFormat in the list. 

Click Options.

Select one or more Formats To
Apply check boxes to turn a
feature on or off.

Click OK.6

5
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Did You Know?
You can copy cell formats with Format
Painter. Select the cell or range whose
formatting you want to copy, double-
click the Format Painter button on the
Standard toolbar, select the cells you
want to format, and then click the
Format Painter button.
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Excel AutoFormats give any worksheet a professional look, but you may
need to modify an AutoFormat to better suit the needs of a particular
project. For example, the AutoFormat you applied might be perfect
except that the font used should be different—to match the font in the
rest of your report. You can control individual elements in an AutoFormat
so that not all are applied to the current worksheet. These changes are
temporary; you can’t permanently alter an AutoFormat.

Formatting a Worksheet 107

Modifying an
AutoFormat

Modify an AutoFormat

Select a cell or range whose
AutoFormat you want to change,
or skip this step if you want Excel
to “guess” which cells to format. 

Click the Format menu, and then
click AutoFormat.

Click the AutoFormat you want to
modify. 

Click Options.

Click to select or clear one or
more Formats To Apply check
boxes to turn a feature on or off. 

Click OK.6

5

4
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2

1

5

Did You Know?
You can let Excel choose the range to
format. If you don’t select the cells you
want to apply the AutoFormat to, Excel
will guess which cells you want 
formatted.

XL03S-3-1
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Depending on your screen size, the sheet tabs at the bottom of your
workbook can be hard to view. You can add color to the sheet tabs to
make them more distinguishable. If you want to add artistic style to your
workbook or you are creating a Web page from your workbook, you can
add a background picture. When you add a background to a worksheet,
the background does not print, and it’s not included when you save an
individual worksheet as a Web page. You need to publish the entire
workbook as a Web page to include the background.

Formatting Tabs and
Background

Add Color to Worksheet Tabs

Click the sheet tab you want to
color.

Click the Format menu, point to
Sheet, and then click Tab Color.

Click a tab color.

Click OK.4

3

2

1

3
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5

5

4

3
Add or Remove a Background

Click the sheet tab you want to add
a background to.

Click the Format menu, point to
Sheet, and then click Background.

Select the folder with the graphic
file you want to use.

Select the graphic you want.

Click Insert.

To remove the background, click
the Format menu, point to Sheet,
and then click Remove
Background.
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A style is a defined collection of formats—font, font size, attributes,
numeric formats, and so on—that you can store as a set and later apply
to other cells. For example if you always want subtotals to display in
blue 14-point Times New Roman, bold, italic, with two decimal places
and commas, you can create a style that includes all these formats. If
you plan to enter repetitive information, such as a list of dollar amounts
in a row or column, it’s often easier to apply the desired style to the
range before you enter the data. That way you can simple enter each
number, and Excel formats it as soon as you press Enter. You can also
copy styles from one workbook to another. Once you create a style, it is
available to you in every workbook.

Creating and Applying
Styles

Create a New Style

Select a cell or range that you
want to create a style.

Click the Format menu, and then
click Style. 

Type the name of the new style. 

Clear the check boxes with the
options you do not want.

Click Modify. 

Click any of the formatting tabs,
and then make additional
formatting changes to the style.

Click OK. 

Click OK.8

7

6

5

4

3

2

1

Did You Know?
You can merge a style from another
workbook. Click the Format menu,
click Style, click Merge, click the
workbook that contains the style you
want, click OK, and then click OK
again.

4 3
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7
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5

Apply a Style

Select a cell or range to which you
want to apply a style.

Click the Format menu, and then
click Style. 

Click the Style Name list arrow,
and then select the style you want
to apply.

Click OK.4

3

2

1

4

31

2

C05XL.qxd  9/2/2003  8:13 PM  Page 111



Any style—whether it was supplied by Excel or created by you or some-
one else—can be modified. Suppose you created a style containing
fonts and colors your company uses. If those specifications changed,
you could modify the style to include the new attributes. If you want to
use styles created or modified in another workbook, you can merge the
styles into the open workbook. If you no longer use a style, you can
delete it from the workbook.

112

Modifying a Style

Modify a Style

Click the Format menu, and then
click Style.

Click the Style Name list arrow.

Click the style you want to modify.

Click Modify.

Make any changes you want in the
Format Cells dialog box.

Click OK.

Click OK.7
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Merge Styles 

Open the worksheet that contains
the styles you want to merge.

Click the Format menu, and then
click Style.

Click Merge.

Click the workbook that contains
the styles you want to merge with
the current workbook.

Click OK.

Click OK.

Delete a Style

Click the Format menu, and then
click Style.

Click the Style Name list arrow,
and then click the style you want
to delete. 

Click Delete.

Click OK.4
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5Did You Know?
You can use the Add button to create a
new style based on a current style.
You never know when you might want
to use an original style supplied by
Excel. To keep the original style intact,
modify the formatting in the Style dia-
log box as desired, click Add, and then
give the modified style a new name.
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The Find and Replace commands make it easy to locate or replace spe-
cific text, numbers, and formatting in a workbook. For example, you might
want to replace all the references to cell A6 in your formulas with data
contained in cell H2, or you might want to replace bold text with italic
text.  Or, you may want to change a client name or contact on all of your
financial reports.  You can be specific in your replacing, by replacing one
at a time, or all matches found.
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Finding and Replacing
Formatting

Find or Replace Formatting

Click the Edit menu, and then click
Find or Replace.

Enter the word or words you want
to find.

Click Options to display formatting
options. If necessary, click Format,
and then click Clear Formatting
From Cell to clear previous criteria.

Click Format, specify the
formatting you want to locate, and
then click OK.

Click Find Next to find the
formatting options you specified.

To replace text and formatting,
click the Replace tab, and then
enter the word or words you want
to replace in the Replace With text
box. 

Click the Replace With Format
button, specify the formatting you
want to replace, and then click OK.

Click Find Next to select the next
instance of the formatted text or
click Replace or Replace All to
substitute formatting.
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