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Remember the days when you could have only

editable and non-editable regions in your tem-

plates or when you tried adding a behavior or

CSS to a template-based page and it failed?

Headaches like these are all but gone with the

release of Dreamweaver MX! Many new fea-

tures have been implemented for templates. |

recommend you go get your favorite non-

alcoholic beverage, kiss your spouse and chil-

dren goodnight, call into your boss’s voicemail

with your excuse for being late for work tomor-

row, and strap into your computer chair

because this project will get your creative

juices flowing for sure.
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Project 3

Dream Templates

A Dreamweaver MX template
in action.

Welcome to Template Mojo

Company Information
ompany Info 1

ampany Info 2

by Brad Halstead T

46

Section 1

[Section 2 this ta show clients how copy would look if it was inserted here without the client getting
kection 3 caught up with what it really says.
ISection 4 This copy is used for placement only, in an effort to better show you how your page will look,

we have added this text, This text is known as filler text and is to be considered a visual
indicator of how your page(s) will look with text instead of just the page layout. Designers use
this to show clients how copy would look if it was inserted here without the client getting
caught up with what it really says.

This copy is used for placement only, in an effort to better show you how your page will look,
we have added this text, This text is known as filler text and is to be considered a visual
indicator of how your pageds) will look with text instead of just the page layout. Designers use
this to show clients how copy would look if it was inserted here without the client getting
caught up with what it really says.

Abstract 101

This copy is used for placement only, in an effort to
better show you how your page will look, we have added
this text. This text is known as filer text and is to be
considered a visual indicator of how your page(s) will look
with text instead of just the page layout. Designers use

IT WoRKS LIKE THIS

Dreamweaver MX templates are worth much more exploration and this project
builds on Project 2, “Overcoming Template Anxiety,” where you learned how
to make a basic template. At the end of this project, you will have a highly cus-
tomized and functional template set that can be used for site consistency, but

also allows you the flexibility to have regions on some pages and not on others.

In this project, you learn many things, including how to add repeating regions
(such as repeating tables and repeating rows and optional regions), inserting a

Multiplelf expression, making a tag attribute editable, adding CSS to a template-

based page, adding a behavior to a template-based page, checking template syntax,

and working with methods of detaching template-based pages from a template.

PREPARING TO WORK

Preparing for this project requires the same routine you have repeated with
other projects. Copy the Projects\03_dream_templates folder on the accompany-
ing CD to your hard drive, start Dreamweaver MX, and define a site using the

folder you copied from the CD as the site root.
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Start Dreamweaver MX and create a site using
03 _dream_templates as the root folder. See the figure

for a representation of the site settings.

Configure Dreamweaver MX to use Dreamweaver
MX Workspace (choose Edit>Preferences>
General>Change Workspace, select the Dreamweaver
MX Workspace radio button, and click OK twice).

Note: | recommend that you use Document Split
view to see the code that is being generated as you
follow along in this project. (You will need to access
Code and Design view in the project as you follow
along.) This can be changed by selecting View>Code
and Design.

You may notice a lock icon beside the files in the Site
panel; this means that the files are read-only. Before
you can use these files, you need to remove the lock
and make them editable. In the Site window, select
the files and folders, right-click, and select Turn Off
Read Only. Your local files are now editable!

For this project, I also have included an extension for
you; it inserts the required Template comment to
turn on/off code above or below HTML functionali-
ty as a Snippet. Updates can be found at
http://www.prettylady2.net and support email is
x10@prettylady2.net. I do plan on adding more tem-

plate functionality to the Snippets as time permits.

Start Extension Manager (EM). Choose File>Install

Extension.

Browse to the CDProjects/03_dream_templates/

Extensions folder. Select dwm_03_Templates.mxp.

—p—

Site Definition for 03_dream_templates:

Basic  Advanced |
Categary

Flemoie Info
Testing Server
Closking

Design Notes
Site Map Layout
File Wiew Columns

LocalInfo
Site Name:
Local oot Folder: [C:\D3_dieam_templates' (]
[¥ Refresh Local File List Automatically
Disfault Innagss Folder: [T:503_dresm_templateshimanss' )

HTTP Address: [http://

This address enables the Link Checker to
detect HTTP finks that refer to pour own
site.

Cache: [¥ Enable Cache

The cache maintains fils and asset
information in the site, This speeds up the
Asset panel, ik management, and Site bap
features.

0k | Cancel Help

Project 3 Site Definition.

E}ED Temolates

& & Behavior_Templake, dw
& & Eait_arcrio_1 emplate, dwk
@ @ Multiple_IF_Template, dwt
@ & Cpt_Region_Template.dwt
& B Rep Row_Temnplate, dwt
@ B Rep_Table_Template, dwt

Enabling your local files
to be edited.

Filew |Editel Views Sites
Mew File CerH-Shifk-+M
e Folder CerlH+-Alk+Shift+1
Open
Save Site Mam,..
Renarne F2
Delete Del
Turn
Preview in Browser 4
Check Links Shift+Fa

Desigm Nates, .,

Exit CtrHQ

47
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5 Agree to the license agreement and the extension

will install.

Note: This extension creates a new folder called
Templates in your Snippets panel and adds four
Snippets. The Snippets include these:

m Ability to add a Template comment that
enables/disables code above/below HTML
(as specified in the help docs).

m Required base code for a Multiplelf conditional
region, also as specified in the help docs.

We will be referencing some of these Snippets later
in the project, so be sure to install this extension.

REPEATING REGIONS—RoOWS

“4Macromedia Extension Manager : ;Iglil
File Help
E& | '@ | IDreamweavel b =7 | E\] | @

On/0ff | Instaled E ztensions Yersion Type Author
-

E stension ta insert a Mew Snippet Folder called Templates and add a Snippet for Templates that ;I
allows wour termplate page to have editable content outzside the HTRL tags as per the documentation.
Mew [4/16/2002) added Multiplelf Head and Body statements.

Snippetz Panel » Templates Folder.

A repeating region can be used to allow the builder of the template-based page to add

table rows or other types of repeating regions without having to edit the template. This

allows for the template builder to have more control of the template while allowing the

user of the template-based file the freedom to add content without messing up the

structure of the template. In this project segment, you learn how to add, remove, and

use a table row repeating region in your template and template-based page(s).

Tip: When naming regions, each region name must
be unique.

1 Open the file named Rep Row_ Template.dwt in the

Templates folder.

48

Extension Manager with the
extension installed.
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2 Position your cursor in the table cell that says Company Tag Selector.

"navlinka"> <p>Company Info Z

Info 2. Using the Tag Selector, choose the right-most

<tr> tag.

S
This copy is used far placement only,
. . Company Info 1 ros in an effort to better show you how
Repeating Region. Company 1o 2 il T imsicecs oy cormeiing . |your page wil ook, we have added
Dreamueaver 4.x template into|this text. This text is known as filler
text and is to be considered a visual
indicator of how your page(s) will look|
with text instead of just the page
layout. Designers use this to show
dlients how copy would look if it was

3 From the menu, choose Insert>Template Objects>

Section 1
Section 2

4 Type MenuRow1 in the New Repeating Region Section 3
. . Section 4 ectian: rted hi ithout the dient
dialog box and click OK. st napasing o (GoUIng CauGh P Wi W roaly
Repeuing Tanies e :
D e This copy is used for placement anly,
o e
5 Select the content of the cell and from the menu, e ot T tot s ko = filer
text and is to be considered a visual

choose Insert>Template Objects>Editable Region.

bley <t <1ds ctables <t <tdh <tables <In ctds ctablg

6 In the Editable Region dialog box, type the name
MR1Content and click OK.

7 Repeat Steps 1 through 6, selecting the Section 4

1‘ Template with editable
repeating rows.

‘Welcome to Template Mojo
Section 3

Sectond

Introduction to Nested
[templates, what you can do
uith ther and their imitations.
Section 4
Seotont

cell, using MenuRow?2 as the Repeating Region
name and MR2Content for the Editable Region

This copy is used for placement only,
Intraduction te Dreamuesver |IN @N SHOMt to hetter shaw you how
v Tampisias by sanvaning 3 |our pag wil lock, we have sdded
Dreamweaver 4.x template into|this text. This text is known as filler
the new M formatting. No text and is to be considered a visual
indicator of how your page(s) will look
with text instead of just the page
layout. Designers use this to show
clients how copy would look if it was
Section?. inserted here without the client

Introduction to Repeating & | getting caught up with what it really
ptional Regions. This indudes| says

name. Save the template.

In the final lassan, you il
learn how to make 4 tag
stiribute editable, apply new
55 0 a tanplate based page
and 2dd 2 behaviar to 3
template based page!

Frepeat eruRiou2,

8 You should be prompted to Update Template Files

Fapasting Table Rous. This copy is used for placement only,
o

that are based on this template. Choose Update. Close

the update report dialog and continue on to Step 9. w s ]

9 Close the template file.

10 Open the root file named Repeat Row.htm. This

i | e:[Repeating row sanple poge 1, @), Repeating row is shown.

C <wp )i

. L P— ~ p— B
file is based on the template you worked with in iy )Cumpan;‘;;;)‘;;p: freraneER e e et
ol
- . 102 —- Inst EndEditable ——></td>
Steps 1 through 9, Rep_ Row_Template.dwt. S I

- T A

7 Template: Rep_Row_Template:

11 Notice that there is a new GUI where you added

- .. . m
editable rows. Position the cursor in the S Vicleame to Tomniate Mojo
. . i Displagt -t
MR 1 Content cell that is named, select the cell con- - ‘Seotiont This copy is used for placement only,
Fapeastenfiont CHLTEN") 4o uction to breamweaver [iN @N effort to better show yau how
L MRIContent M Tamplates by cmearing 3 |your page will look, we have added
tents, and type Additionall (or use your own text). Company Info 2 Orsamuasvar . kemplata ko this teit. This (24 15 known 35 fller
the i M: fﬂhvmafttl:q N!ﬂ text and is to be cansidered a visual
e s Sle S L indicator of how your page(s) will look
SR 1 f:g‘fz:‘j ninonasdiisbis with text instead of just the page -
Section 2 layout. Designers use this to shaw R o wll
) I S 0 clients how copy would look if it was ttribute =ditable, appl
;?;;[n:f:::mwz LM i inserted here without the client i o el s (ot e
ey Intraduction to Repeating &

Optional Regions. This indudes]
Repaating Tables and +|=|*]| 2]

Repeating Table Rows.

Mowve selecr.eg Row Up
L Mowve selected Row Down
Fepeat_Fow htm

Remove a repeating row
Add a repeating row

NV 3 Ha
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Warning: If you are too vigorous with your mouse

selection, you may inadvertently overwrite the <p>
tags for the content in the repeating region cells. If
you do that, the menu will not display properly. To
correct the problem, you may have to select the
content and set it as a paragraph for proper cross-
browser rendering. To do this, open the Property
inspector, click the Format drop-down menu and
choose Paragraph. This caution applies to Steps 11,
12, and 13.

Click the GUI + button to add another row; then
select the content of this row and replace it with

Additional2 or use your own content.

Repeat Steps 11 and 12 for the MR2Content repeat-
ing row using Additional3 and Additional4 as your

entered text.

You may have to select the content and set it as a
paragraph for proper cross-browser rendering. To do
this, open the Property inspector, click the Format

drop-down menu and choose Paragraph.

Save the document, preview in a browser to see that
your edits are viewable, and then close the document
when you are satisfied with your additions. You have
successfully added a repeating region, made it editable,

and controlled it from the template-based page.

So now you decide that you don’t want the repeating
editable regions anymore, and now they have to be

deleted. Open the template Rep Row_Template.dwt.

3 Repeating Row Sample PagH

osoft Internet Explorer

Fle Edt view Favorites Tools  Help

=tk - o - G [2] 3| Qoeach GaFavorites freda B D- S EH D R 2

Address [{) C:\03_cheam_templatesiRepeat_Row htm

| @e [unks

W

Welcome to Template Mojo

Section 1

Company Information

Company Info 1

Introduction ta Dreamussuar

Section 1
Section 2
Section 3
{Edditionalay,
additionale,/

Wy Temnplates by canvarting =
Dreammeaver 4.x template inta

the new MX formatting, Mo

more headaches with just
editable and nen-editable
regians |

Introduction to Repeating &
Optional Regions, This incudes
Repeating Tables and
Repesting Table Rows,

This copy is used for placement only,
in an effort to better show you how
your page will look, we have added
this text. This text is known as filler
text and is to be considered a visual
indicator of how yaur page(s) will [ook
with text instead of just the page
layout. Designers use this ta show
clients how copy would [ook if it was
inserted here without the client
getting caught up with what it really
says.

This copy is used for placement only,
in an effort to better show you how
your page will look, we have added
this text. This text is known as filler
text and is to be considered a visual
indicator of how your page(s) will [ook
with text instead of just the page
layout. Designers use this ta show
clients how copy would [ook if it was
inserted here without the client
getting caught up with what it really

says.

Section 3
Introduction to Nestad

tamplates, what you can do
with thern and their limitations.

Section 4

In the final lesson, you will
learn hou to make = tag
sttribute aditable, apply new
e35 to a terplate based page
and add a behavior to a
template based page.

This copy is used for placement only, in an effort to better show you how your page will look,
e hava addad thic Favk This tavk iz brawe ac fillar favk and iz 0 ke cancidarad 2 visoal

&) Dane

i My Computer

Browser view of the project
with Steps 1 through 14
completed.
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16 To remove an inserted editable region, sclect the
editable region you want to remove by clicking
inside the editable region. Then select the
<mmtemplate:editable> tag using the Tag Selector.
Use the Modify>Templates>Remove Template
Markup menu item to remove the selected editable
region. At this point, remove the MR 1 Content

editable region.

£ » Insert

| =7 ‘T\tle‘ Repeating Row Sampl= Page 0. @), | € €29 {}. &,
<cr> =

<td class="sectiontextl"»<!-- InstanceBeginEditable name="Sectionl” —-

<prénbsp;énbsp; Introduction to Dreswwesver MX Tewplates by convertin—d
<!-- InstanceEndEditable ——»</td> =
»

Template: Rep_Row_Template:

Welcome to Template Mojo
Section 1 il Section 3

IR This copy is used for placement only, [Seoion: it
Introd ta Dreamuveaver |IN 3N effort to better show you how Introduction to Nested K
M Templates by converting a |your page will look, we have added templates, what you can do
Dreamuweaver 4.x template into[this text, This text is known as filler with therm and their limitations.

the nev MK formatting, Ho text and is to be considered a visual i 4
mare headaches with just SOCHIT 2 evesvessesseesirsns

pany Informal
Company Info 1
Company Info 2

Section 1 indicatar of how your page(s) will look

17

To remove an inserted repeating region, select the

aditable and non-editable
regions!

Section 3
Section 4

Sactionz
Introduction to Repesting &

with text instead of just the page
layout. Designers use this to shaw
clients how copy would look if it was
inserted here without the client
getting caught up with what it really

Seotiant

In the final lzsson, vou will
learn haw to make a tag
attribute editable, apply new
25 to a template bazed page
and 2dd 2 behavior o 3

repeating region you want to remove by clicking
inside the repeating region, and then select the
<mmtemplate:repeat> tag using the Tag Selector. Use
the same menu item (Remove Template Markup) to
delete the repeating region. At this point, remove the

MenuRow 1 repeat region.

18 Repeat Steps 16 and 17 to remove the other editable
and repeating regions you added to the page.

19 Save the document, update the pages associated to
this template, and close the template. You will be
prompted to relocate found content in the
Inconsistent Region Names dialog. Select the
MenuRow! and choose nowhere from the drop-
down list. Repeat this for MenuRow?2. This action
makes sure that they are completely deleted from the

template-based page. Close the template file.

20 Open Repeat_Row.htm again to verify that the
repeating row and editable region are removed from

the page. Close the file when verified.

With this segment, you have learned how to add a repeat-
ing row, make it editable, and modify a template-based
page to use the repeating editable region. You then decid-
ed that you wanted a change and deleted the editable

region and the repeating region.

Optional Regions. This indudes|says,

Repeating Tables and

Repasting Table Rovs. This copy is used for placement only,
in an effort to better show you how

your page will look, we have added

this text. This text is known as fillar

text and is to be considered a wisual

template based page.

d|

Fepeat_Fiow htm

786328 o [ 1K [ 3580

[emmtinstancsfileinstance <body> clablex chrs cids clablex chro cids clablex chrs cids clablex chr» cid.szctionteatly smmtinstanceseditable <p>

The repeating row is
removed.

51
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REPEATING TABLES

Although this segment is similar to the previous one, there are important differences. A
repeating table has a complete row that is marked as repeating and each cell in that row
is an editable region. Another difference is that instead of using the <tr> tag as your
selector, you use a friendly user interface (UI) to perform the insertion of the

Repeating Table object.

1 Open the file named Rep_Table_Template.dwt in

Tip: Region names cannot contain spaces or any special characters;
the Templates folder. p: negio ot co p or any sp

you can use only alpha-numeric characters.

2 Position the cursor in the large center cell with a

white background (to the right of the menu system).

3 From the menu, choose Insert>Template Insert Repeating Table x| The Insert Repeating Table
Objects>Repeating Table. Fill in the following prop- dialog box.
erties in the Repeating Table dialog box and then I— ; Ok |
Rows: |2 Zell Padding: IE
click OK: ] c |
Columns: |3 Cell Spacing: IIII Ance

Rows: 2 width: [75 |Percent ¥ | Help |

Cell Padding: 5 Bk Il—

Columns: 3 Repeat rows of the table:

Cell Spacing: 0 Starting Row: |2 Ending Row: |2

Reqgion Mame: | DataTablel]|

Width: 75 Percent

Border: 1

Starting Row: 2
Ending Row: 2
Region Name: DataTablel

52
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Before and after converting
<td> to <th>.

4 In Code view, change the top row <td> tag pairs to O, )] G | e resams e evine 58, @, | C <> (), G, |

<th> to make them table headers instead of standard

table cells.

Welcome to Template Mojo

[ o [ o \ E

This includes code lines 122 through 124, where you

change the cells from <td>&nbsp:</td> to <th>&

nbsp;</th>. You do this to make the row your table

heading row. You also may decide you want column
| ][ )| 5 | i Repeatog Tole Termire gt @. | © <2» (). '@ |

1 to be the headings. Changing from <td> to <th>

centers the content and makes it bold by default.

5 Now back to Design view. In row 1 (which is now

Weicome to Template Mojo

Fepeat DaaTabel
Eaegont

table headers), type the following in the cells, begin- - -

ning on the left and moving to the right: Item No.,

Item Name, and Item Description.

To do this, position the cursor in the appropriate cell

Fep_Titi_Templte ot

and type the text; then move the cursor to the next e
desired cell and repeat.
6 Click the region header labeled EditRegion3 in the €)Macromedia Dreameaver MX - [<<Template’> (Rep Table Template.dwb] Working with Editable Region
3 Fle Edt View Insert Modify Text Commands Ste Window Help p i
Design window (this is your editable region label), v Properties = roperties.
m ;ﬂilahle Mame: | EditRegions %
. s
open the Property inspector panel (the name should
say Editable Region), and change the contents of the -
. » Insert
Name field to ItemNo. ) 2| 5 | me: Repeano e rengite [, @, | C € (), 1T, |
pR-3: </rr> ;I
126 <l-— TemplareBeginRepeat name="DataTablei” ——>
1z7 <tr>
iza B Tcuslaicnecintiitahlc niae- ZitRegion:’ —-gebspi ! — Ty Lo
|
b
o welcome to Template Mojo
L [ Ttem No Item Name Item Description
Repeat: DataTablet p
porenes T e
Sectional Links
Section 1
Section 2
Section 3
Section 4
Fiep_Table_Template dwr

<body> <tables cir> <td> stables oir> <td> stables oira stdb stables <o <td> i 7861237 . 1012 sec

NV 3 Ha
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Note: You can display the template region Property
inspector three different ways when you are editing a
template (not a template-based file):
m Using the Tag Selector, select
<mmtemplate:regiontype>.

m Select the <I-- TemplateEndRepeat --> comment
in Code view. (This is the closing comment for
the region. Note that this method does not work
for most region opening comments!)

m Carefully select the region header in Design view.
(Note that you have to be very careful in select-
ing when you use this method because you could
easily select the parent region by mistake.)

| recommend using the first method because it is the
most reliable.

Repeat to the right, naming the remaining two fields

ItemName and ItemDesc.

Save the template. (If you are prompted to update the
template files that are based on this template, choose

Update. Close the Update Report dialog box.) Close
the template.

Open the root file named Repeat Table.htm. Notice
that the row contains an editable region in each cell
and that it looks identical to the repeating region row

discussed in the previous segment.

Position the cursor in row 2, column 1 (this should
be the first editable region named ItemNo) and type
03, then press the Tab key and type Ring in the
editable region named ItemName. Press Tab again

and type 1 karat Diamond Cluster in the editable

region named ItemDesc. Save the page and preview it

in a browser.

—p—

<bodys <tables <tre <kd: ctable: <tr: <bd> ctabler <tr> <tds <table: <mmtemplaterepeat: <tr: <td: mtemplate:editable;

» Insert

B ‘ i ‘T\t\e: Repeating Tatle Template A7 @, | O

<y 1}, 5,

<ftrr
“lem emplateEndquEst ——x

</tablex

<tdr<!-— TemplateBeginEditable nawe="EditRegionS" —->d&nbspr<!-- Templd

Welcome to Ten

Co y Ir n
ompany Info 1
Company Info 2

Sortimmal Linke

epeat; CiataT able

Mo, Item Name

| ™
EditFegion3

EditFegiond

Item Description

EditRegions

Ttem iht
Lt - Ttem Name Ttem Description
Iremido Itemfame IremDese
Template: Rep_Table_Template:
. Welcome to Template Mojo
any 0 3Ll Tram hn T i i
e ] tem Name Item Description

Company Info 2

Section 1
Section 2

Section 3
Section 4

emlo emblame ItemDes

03 Ring

1 karat Diamond Cluster

The completed repeating table
template.

The repeating table document.




04_DWMX_CH-03

10

11

12

08.05.02 09:14 AM Page 55

Click the + button in the repeating table GUI three
times to add three more rows to the table. Starting in
the third row, insert the data displayed in the list to
the right:

Note: You can use the Tab key to move from field
to field and then to the next row just like a normal
table. You cannot, however, add another repeating
table row by using the Tab key because an error
message will be displayed.

When you’ve finished entering the data, save the
page and preview it in a browser. Your item list
should be 03, 01, 04, and 02 as you look from top to
bottom in the Item No. column. Notice that the
items are out of order! We'll fix that in the next few
steps. Close your browser session and go back to

Dreamweaver.

Position your cursor in the Item No. 03 row and
click the down-arrow of the Repeating Object GUI
once. This repositions the currently selected row
down one position each time it is clicked. The order
should now be 01, 03, 04, and 02.

Now position your cursor in the Item No. 02 row
and click the up-arrow of the Repeating Object GUI
twice. This moves this row up two positions. The
order should now be 01, 02, 03, and 04. Save the

page and close it.

You’re probably wondering what the difference is
between these last two objectives. With a repeating
table, you can define more than one row and use an
interface to control which row is the repeating row
with an interface; it also makes every cell in the

defined row editable. A repeating region, on the

—p—

Item No Item Name Item Description

01 Watch Analog

04 Bracelet Gold

02 Necklace Silver

Repeating table content.
Item Mo, Item Mame Item Description

o1 W atch Analog
oz MNecklace Silver
03 Ring 1 Karat Diamond Cluster
04 Bracelet Gold

Tip: If you know your Optional Region is going to be editable as well,

use Insert>Template Objects>Editable Optional Region.

The completed repeating
table.

55
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other hand, is selectable, which means that if you
were to select the entire row, you could make only
the last two cells editable and leave the leftmost cell
non-editable so that cell remains the same down the
table. (This is perfect for working with bullets, for
example.) Repeating regions don’t have to be a row;
they can be an image or just about any tag. (Lists pro-

vide a good example for a repeating region.)

In this section, you learn how to insert an optional region in your template, set it as

viewable or hidden, and control it in your template-based page.

1

56

Open the file named Opt_Region_Template.dwt in
the Templates folder.

Select the abstract art image in the large center cell
with a white background. Select Insert>Template

Objects>Optional Region.

In the Optional Region GUI, give the region a
name of ArtPicturel and place a checkmark in the
Show by Default field if it is not already checked.
(The Advanced tab is not used at this time.) Click
the OK button.

In Code view, scroll to just above the closing head tag
</head> and you should see the following code added

to your document (line 38 in the top figure).

If you select the image and view the code, you will
see the code shown in lines 124-126 of the figure on
the bottom. (I have modified the document for the
purpose of the screenshot, so your view may be dif-

ferent than the code around line 122 in Code view.)

The New Optional Region
Basic Advanced .
K dialog box.
Mame: | ArtPicture] Cancel
I¥ Show by Defaul —I
Help
gl </ scripts
<link rel="stylesheet™ type="text/csa" href="../core.css">
<!—— TemplateParam hname="ArtPicturel” type="boolean" wvalue="true" —->
121 [
<tdr <!-- TewplateBeginIf cond="ArtPicturel” --»<img src="../iwmages/Abstract 1.jpg" width=",

<p class="headerz"ribstract 101</p>
<!—— TemplateEndEditshle ——>

The Optional Region
head code.

The Optional Region
body code.
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Note: The body code and the head statement are
related and one cannot exist without the other. Well,
that is not entirely true—as of this writing, you can
move the body code around the image and the head
statement remains. This occurs because the parame-
ter may be used by another expression and currently
Dreamweaver has no way of detecting that.

Save the template. (If you are prompted to update the
template files that are based on this template, choose
Update. Then close the Update Report dialog box.)
Close the template.

Open the root document Opt_Region.htm. Notice
that the editable regions are there. Select
Modify>Template Properties.

In the UI, select ArtPicturel. By unchecking the
Show ArtPicturel checkbox, the image will not be
shown. Notice that the source template provides only
the initial state of the image, and the htm page itself
controls the other state of the image—in this case,
off. Remove the checkmark from the Show
ArtPicturel checkbox, save your document, and pre-

view it in a browser.

Repeat Step 7, this time placing a checkmark in the
Show ArtPicturel checkbox; then save the document
and preview in a browser. When you are satisfied
with the results, close the document in

Dreamweaver.

Template Properties

Marne

| Malue

ArkPicturel

¥ show ArtRicturel
I allow Mested Templates ko Control This

true

o4
Cancel

Help

(i

The Template Properties
dialog box for the optional
region.
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You have just successfully created and used an optional

region. Congratulations!
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INSERTING A Multiplelf CONDITIONAL

STATEMENT

Tip: Multiplelf conditional regions must be entered by hand, but you
can use the Advanced tab of the Optional Region dialog box to gener-
ate your conditions. If you installed the extension for this project, your

So, you want to have a specific image shown on certain pages—or not at alll To do Snippets>Templates folder will display the head and body regions as
this, you use an optional region and convert it to a MultipleIf conditional statement. usable Snippets.
1 Open the file named Multiple If Template.dwt in
the Templates folder.
2 In Code view, insert the highlighted line of code
shown just above the closing head tag. You can use <link rel="stylesheet" type="text/css" href="../core.css">
the Snippet in the Snippet Template folder called z } };;agfmm ateParam name="ArtPicturel" type="number" value="1" -->
MultipleIf Expression and then modify it to match
the highlighted code on the right, or you can open
MI_Head.txt and copy and paste it into the head
region of the template file.
3 Select the abstract art image in Design view and go to
Code view. Notice that the code for the image is
highlighted. Press the Delete key to delete the image
reference in the template file.
4 Press the Ctrl+" keyboard shortcut (Cmd+" for Mac)
to go to the Code window of the Split view. (Your <td>
cursor should be positioned beside the <td> tag, <!-- Define the fapprop.riate image to display -->
<!-- TemplateBeginMultiplelf -->
where the image was located.) Type the highlighted <l-- TemplateBeginIfClause cond="ArtPicturel == 1" --><imgsrc="../images/Abstract_1.jpg"
code listed at the right. Alternatively, if you don’t wyidth="210" height="80"hspace="10" vspace="5" border="0" align="left"><!--TemplateEndIfClause -->
want to type all the code, you can open T hei210" b= B hspaCet 10" VSpACeE'S border-rD a11gn-rleTersct-Temg FeEndLfClause —->
MI_Bodyl.txt and use the copy and paste operations <!-- TemplateEndMultipleIf -->
to insert the code into the template file. <!-- TemplateBeginEditable name="Header" -->
The code you just entered says this: “Provide the end
user of the template-based file with the choice of two
images. If image 1 is set, display image 1 and hide
image 2. If image 2 is set, display image 2 and hide
image 1.7
58
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What you’ve done here is manually enter a condi-
tional region. In this instance, all the images are
defined in the template; the end page allows you to
choose which image to show. This is an excellent way
to define a specific image for, say, a support depart-
ment and a sales department not yet using the exact

same layout.

» Insert The Multiplelf optional region
- i i i itle: | Multiple: I Conditional Templat H
Note: Notice that both images are shown in the B [ e o T . @ [ © <t (0. B | for the template.
. . . <!-— Pefine the appropriate image to display -—->
template. This is the best presentation because you = o
. . Bl < - TewplateBeginIfClawse cond="irtPicturel==1" —-»<img sre="../iwages/ibstract_L.ipg" widd
are editing the template file and you need to see the <o TemplateBeginIfClause cond="irtPicturel==2% --><img sre=’../imeges/Abstract 2.jpg” wid
. . . . . ) <!— TemplateEndlultiplelf ——»
options available while editing. This won't be the B
case in the template-based page, though, as you will
see belOW Welcome to Template Maojo|
L i _JJ/| Abstract 101
,, pa g L
Seciona Lok “ \._-ﬁf&“ , = agéém“iﬁg ‘inuuf,g‘sg”ﬂ'
ection *<q, & > effort to better show
: & L/ h
5  Save the template. (Choose Update if you are action. 2 will lnok, e have added this text, This text is known as filler text and is f0 b oontidered o
Section 3 visual indicator of how your page(s) will Iaok with text instead of just the page layout
Sertinm 4 Designers yse thic to chy lients b Tt wild look if it inserts b ithout thy

prompted to update the template files that are based
on this template; then close the dialog box.) Close

the template.

Template Properties x|  The Template Properties
| dialog box for Multiplelf.

6 Open the root document Multiple If-htm. Notice Name [valoe oK
. . . ArtPicturel 3 e
that the editable regions are there, but wait and select e

Help |

Modify>Template Properties.

7 In the UI, select ArtPicturel, change the value from
1to 2.
ArtPicturel: | 2]

Because you have a choice of two images, placing a I~ Allow Nested Templates b Cantrol This

value of 3 or higher there will work, but no image

will be displayed when you view the page online or
in a local browser! Try it, insert any number other

than 1 or 2 and see what happens!

NV 3 Ha
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You can correct this by opening the template file
(Multiple_if” template.dwt) and manually adding
another conditional test using the following line (out-
lined to the right) just before the closing <!--
TemplateEndMultiplelf --> statement. Add the high-
lighted code at right. If you don’t want to type all the
code, open the file named MI_Body2.txt and use copy

and paste to place the code into your template file.

‘What this does is tell Dreamweaver to display a text
message in the template-based file if neither option 1
nor option 2 is selected. If you used more images or
objects, reflect this in the conditional test. What you
have done here is add a conditional statement that
checks the template-based page template property of
Artlmagel. If this property is not set to a 1 or a 2, the
inserted message is displayed. If the value isa 1 ora 2,

the appropriate image appears.

—p—

<!-- TemplateBeginIfClause cond="ArtPicturel != 1 &
wArtPicturel != 2" --><p>Your parameter selection for
= ArtPicturel is out of range!<br>Please use a 1 or a
=2.</p><!-- TemplateEndIfClause -->

<!-- TemplateEndMultiplelf -->

Tip: Here's what | did to generate the conditional statement: | selected a
clean area on the document, selected Insert>Template Objects>Optional
Region, clicked the Advanced tab, selected Enter Expression, and typed
ArtPicturel =1 & ArtPicturel = 2. | then modified the following generated
line:

<l-- TemplateBeginIf cond="ArtPicturel !='1"' & ArtPicturel !=
o s

<!-- TemplateEndIf -->

to look like:

<!-- TemplateBeginIfClause cond="ArtPicturel != 1 & ArtPicturel
I= 2" --><p>Your parameter selection for ArtPicturel is out of
range!<br>Please use a 1 or a 2.</p><!--

=TemplateEndIfClause -->

Finally, | pasted the code into the appropriate place in the Multiplelf code

segment.
124 < /-- Define the appropriate image to display -->
125 <!-- TemplateBeginMultipleIf -->
126 <!-- TemplateBeginIfClause cond="ArtPicturel==17 -—-»<imy sro="../images/kbstract_1.jpg"
127 <!-— TemplateBeginTfClause cond="irtPicturei==2" ——><img sro="../images/ibstract_2.ipg"”
128 «!-— TewplateBeginIfClause cond="ArtPicturel !'= 1 & ArtPicturel != 27 ——><p>Your parame

129

120

<1--

TemwplateEncdMultipleIf -->

The template with the
Multiplelf condition.
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9 Save the template (choose Update if prompted). Close
the Update Report dialog box. Close the template.

10 Open the root document Multiple_[f.htm and modi-
fy the Template Properties, trying various values
from 1 through 5, saving the page and previewing in

a browser each time.

11 Click OK, save the document, and preview the page

in a browser.

12 Close any open documents and continue to the

next segment.

Here, you can sce that the template allows you to

define template parameters to, in this instance, con-

trol which image shows on which page. The template

allows you only to define the choice of images and

the page itself. End users can use Template Properties

to define the desired image without messing up the

layout by editing the template itself.

EDITABLE TAG ATTRIBUTES

Abstract 101
This copy is used for placement only, in an effort to better
'~# shaw you haw your page will ook, we have added this text
This text is known as filler text and is to be considered a

i ¥ o, visuslincicator of how your pagels) wil ook with tert
~ instead of just the page layout. Designers use this to show
clients how copy would loak if it was inserted here withaut the dlient getting caught up with
what it really says

This copy is used far placement only, in an effort to better show you how your page willloak,
we have added this text, This text is known as filer text and is to be considered a visual
indicator of how your page(s) will look with text instead of just the page layout, Desigrers use
this to show dients how copy would loak if it was inserted here witholt the cient getting
caught up with what it really says.

This copy is used far placement only, in an effort to better show yau how yaur page will loak,
we have added this text, This text is known as filer text and is to be considered a visual
indicator of how your page(s) will look with text instead of just the page layout, Designers use
this to show dients how copy would loak if it was inserted here witholt the cient getting
caught up with what it really says

lease use a 1oraz
Abstract 101

This capy is used for placement only, in an effort to better show you haw your page will look,
we have added this text. This text is known as filler text and is to be considered a visual
indicator of how your page(s) will Inok with text instead of just the page layout. Designers use
this to show clients how copy would look if it was inserted here without the dient gefting
caught up with what it really says.

‘oUr parameter selection for ArtPicture is oUE of ram]e)

This capy is used for placemert orly, in an effort to better show you haw your page will look,
we have added this text. This text is known as filler text and is to be considered a visual
indicator of how your page(s) will Inok with text instead of just the page layout. Designers use
this to show clients how copy would look if it was inserted here without the dient gefting
caught up with what it really says

This copy is used for placement only, in an effort to better show you how your pags wil look,
we have added this text. This text is known s filler text and is to be considered a visual
indicator of how your page(s) will Inok with text instead of just the page layout. Designers use
this to show dients how copy would look if it was inserted here without the dient getting
caught up with what it really says.

Multiplelf conditional using
ArtPicture1=2.

Multiplelf conditional using
ArtPicture1=3.

Note: Always use Modify>Template Properties to modify the desired

Multiplelf element; otherwise, elements could be selected or displayed

incorrectly.

You want to allow the page-building personnel to have some creative input into the

design without risking corruption of the template? Great, let’s add some editable tag

attributes to the mix to get control over the <img> tag’s alt attribute content.

61
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Open the file named Edit_Attrib_Template.dwt in
the Templates folder.

Select the abstract art image and choose
Modify>Templates>Make Attribute Editable. The
Editable Tag Attributes dialog box opens.

The Attribute field populates with a drop-down of
found attributes for the selected tag. If an attribute is
not available in the list, and you know it is specific

for the tag, click Add and type the attribute name.

Click the Add button and in the dialog, type ALT
and click OK. Notice that the Make Attribute
Editable checkbox was automatically checked by

this action!

In the Label field, type Altl. In the Type drop-
down, choose text, and in the Default field, type
Alternate Text and then click OK.

In Code view, you see that the image tag now has an
alt attribute and it is defined with @@ (Altl)@@. If
you also look in the head section just before the
</head> tag, you will see that the following code has

been added:

<!-- TemplateParam name="Altl" type="text"
wyvalue="alternate text" -->

Oh look, another parameter type!

Save the template (choose Update if you're prompted
to do so; then close the dialog box). Close the template.

Editable Tag Attributes

hoase which attributes of this IME tag should
be editable.

Attribute: I.ﬁ.LT - I Add...

W Make Attribute Editable
Label: |Alt1

Twpe; IText hd I

Default: | Alternate Text

To change the walue of this attribute in a page
based on this template, choose Modify =
Template Properties.

To change whether it is editable, use the "Make
Atkribute Editable" command again.

Zancel

Pl

Help

The Editable Tag Attribute
dialog box.
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The Template Properties

7 Open the root document Edit_Attrib.htm. Notice Templatc Propertics
hat the editabl . h d sel = o= | ok | dialog box with the editable
that the editable regions are there and select i —— = tag attribute.
Modity>Template Properties. Help

8 In the UI, select Alt1, and change the value to

Abstract Art. Click OK, save the document, and

Al [Abstract A

preview 1n a browser. T~ Alow Hested Templates ta Contral This

9 Repeat Steps 2 through 8, this time selecting other
attributes of the image tag to make them editable.
Define their defaults and experiment! Save the docu-
ment and preview it in a browser. Close the docu-

ment when you are satisfied with the results.

This is a great way to add a customizable link in your doc-
ument to allow a template page author to insert links.
Experiment with this; try making it a repeating region and

see what you can do with it.

ADDING CSS 10 A
TEMPLATE-BASED PAGE

In the days of Dreamweaver 4, you could not add or edit a style block of a page that

was based on a template (without hand-coding a workaround, that is). Well, that fea-

ture is built into Dreamweaver MX now, and you will learn and use that method here.

T Open the file named Edit_Attrib.htm in the

root folder.

Note: You cannot add CSS to a non-editable region of a page. To add CSS
to a non-editable region, it must be done in the template itself.

Tip: You can add an editable tag attribute in the template to make the
desired tag accept user-added CSS!

63
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2 Open the CSS Styles panel, and click the Edit Styles
radio button. Choose the New CSS Style button
from the bottom of the panel and choose the Make
Custom Style (Class) radio button. Type .testpara in
the Name field, and lastly, in the Define In Option,
click the This Document Only radio button and
click OK.

3 Under Category, choose Type, and choose the

following settings:

Font: Times New Roman, Times, serif (Your
font choices may vary depending on the platform,

OS, and fonts installed on your machine.)
Size: 14 Pixels

Style: Italic

Color: #008080

Click Apply and OK to close the CSS Editor.

4 Now view your document in Code view and look at
the page, specifically, at an editable region named
head in the head block of the document, where you
will see the class added inside a new style block.
Dreamweaver MX automatically adds this editable
region to templates and template-based documents

for just this reason as well as adding behaviors.

64

= Design
£S5 Stules

| 0K I (o Apply Stylez {* Edit Stylez

Edit_Attribhtrm -
Cancel = —
[ corenss

fekd 12pu Werdana T
1] 12pu Werdana pac
#FFEECD bold |
10p: background

10p: background =
3

Mame: I.testpara j

Type: (+ Make Custom Style [class)
" Redefine HTML Tag
= Use CSS Selector

.sectionhead

Defing In: = | core.css - _sectiontetta

& This Document Only

Help |

sectiontesth

[Eat bt

9|+ 2| i
» Advanced Layout
55 Style definition for .testpara Style Editor.
Categom Type
Tupe
Background F T New R T r j
EBlock Dn[l Imes New faman, [Imes, senl
E:
Borcer Size: [14 = [t =] weight | =l
List
Positioning Style: [italic = Wariant: -
Extensions
Line Height: | feiets ] Cme| =l
Decoration: [~ underline Color: [ | [#008080
™ overline
™ line-through
I” blink
™ hone

1[4 I Canecel Apply Help

<l-- InstanceBeginEditable name="head" -->
<style type="text/css">
<l oo
.testpara {
font-family: "Times New Roman", Times, serif;
font-size: 14px;
font-style: italic;
color: #008080;

1

-_—

</style>

<!-- InstanceEndEditable -->

The New Style button in the
CSS Styles panel and New
CSS Style dialog box.
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5 Using Design view, position your cursor in the first

paragraph of the Body_Content editable region and

. . 147 Sy brap dae
select the <p.Contenttext> tag using the Tag Selector. 148 <\ Thotancezndditanle </t
1as -
150 e> =
amal op . o hd |\ |
KIpS] o]
o look if it was inserted here without the dient getting caught up with what it really says. S
Section 4
This copy is used for placement only, in an effort to better shaw you how your page will loak,
we have added this text. This text is known as filler text and is to be considered a visual
indicator of how your page(s) will look with text instead of just the page layout. Designers use
this to show clients how copy would look if it was inserted here without the dient getting N
caught up with what it really says &

6 Seclect Text>CSS Styles>testpara. and your document
view will be refreshed with the selected style.

7 Save the document, and preview it in a browser.

Close the file when you are satisfied with your

Section 4
changes.
caught up with what it really says,

G ‘T\Ue Ecltable Attrbute Sample Page {7, (@), ‘ C e (1 f

145
145 [

InstancebeginEditahle nam

ody_Content”

<bodp ables an i ctables cy 14 ctabley <t ctable i @

rssat0 o [oKrases | |

1 | e [Etabie ttits samois oz U, @, | © v 1) |

<td><!-- InstanceBeginEditsble name="Body _Content” --> =
<p class="testpara’>&nbsp;&nbsp{This copy is used for placewent only
<p>&nbsp;&absp;This copy is used for placement only, in an effort to
<!-- InstanceEndEditable ——></td>r
</tr>
</rable>

N IL%I

look if it was inserted here without the dient getting caught up with what it really says.

This copy fs used for placement anly, in an effort to better show you how your page will lock, we have
adlded this text, This text & known as fller text and is fo be considered a visual indicator of how your
page(s) witl look with text instead of just the page layout Desigrers use this fo show cliants how copy
wouild look if it was inserted here without the client getting caught up with what it really saps.

This copy is used for placement only, in an effort to better show you how your page will look,
we have added this test. This text is known 3s filer test and is to be considered a visual
indicator of how your page(s) will 0ok with text instead of just the page layout. Designers use
this to show clients how copy would loak if it was inserted here without the dlient getting

cesbies an ctsbies an

reswren , [owcrssee | |

ADDING A BEHAVIOR TO A TEMPLATE-BASED

PAGE

With the advent of editable tag attributes, you can add behaviors to the body tag with

Paragraph that will be styled.

The paragraph tag after
the CSS addition.

case, as long as the JavaScript already exists on the page and you know what the func-
tion name and parameters are. (It pays here to apply your behavior to a non-template-
based page and use copy and paste to insert the required code in the Template

Properties dialog box.)

T Open the file named Behavior Template.dwt in the Templates folder.

Note: A few notes about behaviors:
mYou can add behaviors to any body-area editable region without issue.

mIf you want to add a behavior to a non-editable region, the appropriate tag
must have an editable tag attribute. (See the section, “Editable Tag
Attributes.”)

m If the behavior JavaScript block does not exist on the page when you add
the behavior, the JavaScript will go in the same editable region (called
head) as the page added CSS as in the previous segment.

65
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Select the body tag and make it editable as you have
done previously. For the editable attribute, choose
onLoad. (If you don’t see onLoad in the drop-down
list, click the Add button, type onLoad, and click
OK.) Label the tag LoadIt and leave the remainder
of the dialog fields at their defaults; then click OK.

This does not assign a value to the onLoad event, but
rather assigns a parameter that you can use from the

Template-based page to the onlLoad event.

Save the template, updating the files if prompted.

Close the template.
Open the file in the root folder named Behavior.htm.

Select Modify>Template Properties, choose Loadlt
from the dialog box, and in the text field, type
MM_showHideLayers(‘LyrCopyr’,”’,‘show’).
Click OK.

Save the document, preview it in a browser to see the
copyright message layer shown onLoad at the top of
the page. Close the document when you are satisfied

with the changes.

You can select just about any element and apply a behavior

to it, but it has to be in an editable region or an editable

attribute in the desired element.

66

—p—

F
<link rel="styleshest™ type="text/oss" href="../core.css™
<!—— TemplateParam hame="LoadIt" type="text" walue="r _—_>
</ heads>

<hody l%ft,margin="0" topmargin="0" marginwidth="0" marginheight="0" onLoad="EQR (LoadItc)[{A@ ">
2 <div id="LyrCopyr" style="position:absolute; width:500px; z-index:1; left: 155px: top: Tpx:

Code view showing the modified body tag.

Template Propetties The Template Properties
dialog box.

Marme |¥alue oK
Loadlt

Cancel

Help

dis

LoadIt: |MM_showHideLayers('Lerop
I~ Allow Mested Templates ko Contral This

CHECKING TEMPLATE SYNTAX

You now have the capability of manually checking your template syntax prior to 1 To check your template syntax manually, choose Modify>Templates>

saving the template or Dreamweaver will do it for you automatically when you Check Template Syntax.

save a template. If any errors are detected in your template syntax, they are report-

2 To automatically check your syntax, save the template file.

ed to you in a dialog box showing the error description, line number, and the

location of error.
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Macromedia Dreamweaver MX

3 Ifany crrors are detected, the syntax checker dialog

box appears. When you are manually using the There is an errar at line 126, column 33 (absoluke position 6853 of

Check Template Syntax functions, if everything is tags can only contain TemplateBeginIfClause tags

OK, the OK dialog appears. Note that when you

“automatically” save your template, you will not see
Dreamweaver

@ Template Syntax is correct

the OK dialog box if everything is fine.

& "C:A\03_dream_templatesiTemplatesiMultiple_If_Template dwt": TemplateBeginMultiplelf

DETACHING YOUR TEMPLATE-BASED PAGES

Remember in Dreamweaver 4 when you had to detach the page from the template to
add a custom behavior to the body tag? That functionality is still there, but you have a
new way to do it without completely messing up your template-based page. This seg-

ment of the project deals with methods of detaching your pages from a template.

You really have no reason to detach your pages from a template anymore due to func-
tionality reasons (such as adding a behavior to the body tag); however, you might have
other reason to detach your pages. These reasons include, but are not limited to

the following:
m To reduce the amount of code in your page, thereby reducing bandwidth usage.
m To make troubleshooting your page(s) easier for out-

siders who might not have your template.

m To camouflage the fact that you used a template to
build the site.

® To make a unique change to one instance of the tem-
plate, that you do not want applied in other instances

in the same template.

A Check Template Syntax
warning.

A dialog box telling you that
the Check Template Syntax
is OK.
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Method A: Clean Up HTML

1

When to use this method: Use this method when you are

Choosing the Clean Up HTML
command.

Open the file name methoda.htm in the root Start Recarding Chrlshift+x

%

Play Reconded) ommand Remove: [ St Convainer Tans (<bmsbes shim<ihio, d) = ;

Edit Command List. .. ¥ Redundant Nested Tags (==
I Hon-Dreamweaver HTML Comments Help

. e W o The Clean Up HTML/XHTML

From the menu, choose Commands>Clean Up Maniage Extensiors... " stersae [ dialog box

site folder.

HTML The Clcan UP HTML/XHTML dlalog Apply Source Formatting Rz gE:Z;T;N::t::’;;;:;nhgswhenPass\b\e

Apply Source Formatting to) Seleckion

box appears.
Clean Up Waord HTML. ..

AddiRemove Netscape Resize Fix,..

Place a checkmark in Remove>Dreamweaver Special

Markup. When you do this, a warning message

appears telling you that library items, templates, and Macromedia Dreamweaver M3 The warning message explain-
o : ; ing what th ration will
tracing images will no IOIlgCI' be updated. Click OK. Mote: IF you remove Dreamweaver markup, then changes ko library ikems, templates, 9 at the operatio
and tracing images will no longer update this page. do.
The Clean up summary report lets you know how

many tags were affected on the page. Click OK.

Dreamweaver refreshes the page in your original
The Clean up summary report.

Macromedia Dreamweay

view. The page is 100 percent editable—no more

locked regions. & Clean up surmmaty:

Save the resulting page as methoda_done.htm and 7 spedified tag(s) removed

close the document.

working on a single page that is based on a template, if you

want a level of control to delete all template markup and

do a code check at the same time.

Method B: Detach from Template

1
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OPCH the file name methodb.htm in the root Page Properties... Ctrl+] ChOOSinQ the Detach from

Template Properties. .. Temp|ate command.
Selection Properties  Cerl+-Shift+1

site folder.

<

: E;.:lt:;aﬁi “Edltur Chrl+T S AL
From the menu, choose Modify>Templates>Detach g Apply Template to Page...
IMake Link, ChrlHL rom Template
from Ternplate. Remoye Link CEr|-Shift+L Open Attached Template
Cpen Linked Page, .. Check Template Syntasx
) Link Targek » o 0
Save the resulting page as methodb_done.htm and e s
- Table » Update Pages...
—
close the document. Al Resmove Temke Marlup
Mavigation Eat:
Repeating Entries »
Arrange » Male Attribute Editable. ..
Align 3
Canvert 3 2]
¥ Header
Liby » HeaderBody
BodyContent

Timeline:
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When to use this method: Use this method most for single-
page detachment. The reason for this is that there are no
dialog boxes to complete and no warning prompts—it’s

instantaneous.

Method C: Export Without Markup

1 Using your file manager application, create a new
folder on your local hard drive and label it methodc.
(Do not create this folder in the site structure or errors will
occur!) Close your file management application and

start Dreamweaver if necessary.

2 You can open any document or not open any at all
for this procedure. It’s your choice—either way, the
result is the same. For the purpose of this demonstra-

tion, open methodc.htm from the site root.

3 From the menu, choose Modify>Templates>Export
without Markup.

4 The Export Site Without Template Markup dialog

box appears.

5 Using the Browse button, navigate to the methodc
folder, open it, and click the Select button in the
Extract Template XML dialog box.

6 Optional: Enable Keep Template Data Files by placing
a check in the checkbox, if it is empty. This exports
the template data to an .xml file, which makes it easi-
er in the future to apply the removed template to the
page again. It also helps Dreamweaver decide if the
page needs updating when the Extract Only Changed
Files is enabled. If you decide to disable this, no .xml
files will be generated and it will be difficult to recre-
ate or apply the template to the pages again, and
Dreamweaver won’t know the change status as

discussed in the following steps.

Selecting the Export without

Markup command.

Apply Template ko Page.. .
Detach from Template
Open Attached Template
Check Template Syntam

Page Properties... Chrl+
Template Properties. ..

v Selection Properties  Chrl+Shift+]
Edit Tag...
Guick Tag Editor Chrl4T)
IMake Link ol
Remove Link ChrlShifEAL
Cpen Linked Page. .
Link Target
Table
Frameset

Mavigation Bat

Update Current Page
Update Pages. ..

Arrange
Align
Convert

Remaoye Template Markug
Repeating Entries »
Make Attribute Editable. ..

Library

head
Header
HeaderBiody
BodwContent

Export Site Without Template Markup

Choose a folder to export the site inka,

X

o]

Falder: |Fi|e:,|’,|’,|'C|,|’l33_Exported,l’
¥ Keep Template Data Files

Browse... |

¥ Extrack Only Changed Files

Cancel |
Help |

The Export Site Without
Template Markup dialog box.
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7

11

Optional: Enable Extract Only Changed Files by plac-
ing a check in the checkbox, if it is empty. (This
exports the files that have changed since your last
export or the entire site if no export has been previ-

ously performed.)

Click OK. Dreamweaver’s processing dialog may
show up with the cursor in the busy state and after a
little bit the dialog goes away. At this point, your
entire site is exported with no visual clue even if you

had a document open at the time.
Close the document if you had one open.

Using your file management application, navigate to
the folder methodc and have a look. Now there is an
additional .xml file for each template-based page.
These .xml files are used by Dreamweaver and
Dreamweaver alone and do not require publishing to
the web site on the server. You could delete them if
you like, but the reasons for keeping them are detailed

above if you decided to create them in the first place.

Close your file management application.

When to use this method: Use this method when you want

to be able to delete all template markup on the entire site

or only on changed files since last export, and you don’t

want to affect your local site files.

Cautionary Note: Unless you are careful with the options,

you could export newer files that you don’t want updated,

so choose your options carefully. All template-based pages

will have their template code removed using this method,

excluding the templates themselves.
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Cancel |
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Here you have learned various ways to detach a file or a

Fle Edt View Favortes Took Help

=izl File management application

group of files from the template with which they were

EBack - = - & | @search [Ryrorers (F | B B X 0| B

view of the exported site.

Addes | it

B
1

Folders

x

created. Exercise caution using any of the methods; it is e

= my computer

24 3% Floppy (A:)

) SVSTEM (C)

1 03_dream_templates
i avnoos

{1 CRusionMx.

1 comeheck

{1 Documents and Settings
1 Tnetpub.

/3 methodc

1 My Intranet

easy to overwrite good pages with bad and lose the tem-

plate update capability in a site.

Play with the various methods you have learned and

£ my pusic
L1 Program Fies
LT

0 temp font

decide for yourself when you should use which method

0 viabm

£ wint

0 snews

2 waserver ()
2 Generd (F)
5 Compct Disc (5:)
13 Control Panel

P Macromedia FTP &RDS
Wy Nk lces

for your own needs and situation.

¢ T
meth:)dc

Select an iter ko view s description

See akor
Dy Documents

Dy Network Places
Dy Cormputer

Name
Cnotes
Cextensions
Clinages
Csoures

(J Templates

&) Behavior.hem
%Behavmv.htm il

Edit_atrib.htm

Edit_Atrib htm i
methoda.htm
methoda.htm.xmil
methodb.htm
methodb.htm.xm
methadh_done.htm
method him
methodz, htm.xml
Hultple_IF him
Hultple_IF htm. ol
Opk_Region.htm
Opk_Region.htm
Repeat_Row.Htm
Repeat_Rovhtm. il
Repsat_Table.htm
Repsat_Table.tm. il

T

IMODIFICATIONS

You can go in many different directions with this template set, which contains
two basic templates. One template could be used for the index page, a news area
start page, or just about any sectional starting page. The other is useful for the
remainder of the site. For instance, you could make a nice PC service web site
out of this template or perhaps a web design site. All you need to do is modify the
provided template to your requirements, but try adding CSS styles to the repeat-
ing and optional regions to further customize it. Any element of the template set
can be customized by combining what you have learned throughout this project

into one template that controls your whole site.

Not only can you modify the templates, but you now have the knowledge from
Projects 2 and 3 to create a completely new template that matches your site design
requirement. But wait, there’s more... check out the help files (press F1 when
Dreamweaver is active) and do a search for the different regions of a template
because you can do much more with templates than you've seen here. To give you
a teaser, think about having the capability of programmatically telling a table row to
alternate colors. And we didn’t even get a chance to touch on the completely new

Nested Templates.

I’'m sure that after you read Projects 2 and 3, the help files that you will be mak-
ing your own templates with will be far superior region conditional statements

than the ones we have explored here. Don’t be afraid to experiment!

Enjoy...

Tip: If you have a dynamic site that was created with a server-side
language such as ASP, PHP, and so on, you are required to use the fol-
lowing code Snippet in the Template file:

<!-- TemplateInfo codeQutsideHTMLIsLocked="true" -->

This code must be typed, or you can use the extension to add the
Snippet to your Snippet panel. The reason for this is that server-side
technologies often add code above the opening <html> tag, and adding
this line ensures this server-side code will be transferred to the tem-
plate-based page(s).

If your template-based page contains no server-side code, you don't
need to add this line. Also note that you can still add server-side code
to template-based files without issue.

Tip: Use the Multiplelf Template Snippets to save yourself some typing
when using these conditional regions.
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