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One-Minute Guide to OpenOffice.org
OpenOffice.org is your free ticket to ride the Microsoft Office train without actually

going anywhere near the station. OpenOffice.org opens all the Microsoft Office formats—
Word, Excel, and PowerPoint. And you can save any file in any of those formats, too. You
can create a new Microsoft text document, spreadsheet, or set of slides without ever using
Microsoft.

Governments, small businesses, schools, or anyone at all Any group or individual
that wants to get work done without spending $500 a pop can benefit enormously from
simply switching to OpenOffice.org.

Handles and goes beyond Microsoft Office  
In addition, OpenOffice.org opens dozens of
other formats. Lotus 1-2-3, GIFs and SVG and
PNG graphics, and handles them beautifully.
Not only do you get the ability to open and edit
all the files Microsoft does, but you get a whole
lot more.

Going from Microsoft Office to 
OpenOffice.org  If you’re an MS Office user,
you’ll still have to do some learning, but you’ll
have lots of “Oh, this is the same” moments.

Professional-level graphics  Plus, with
OpenOffice.org you’ve got a great drawing/
image editing program, Draw, which goes way
beyond the minor tools you get in Microsoft
Office. Draw is an excellent program, simpler
for some than Adobe products, but with lots of
power and features. Export to EPS, SVG, plus over a dozen other graphics formats,
including standards like GIF andJPG.

Get started Just hit Chapter 2, Installation, on page 19, or to learn more, read ‘‘Program
Essentials’’ on page 6. To see what’s changed, see ‘‘What’s New’’ on page 12.

Top Ten Reasons to Use OpenOffice.org
Here are the ten best reasons to switch to OpenOffice.org.

1 OpenOffice.org: Free. Microsoft Office: Rather more; up to $550. Not being
controlled by whatever Microsoft wants to do with pricing, distribution, licensing,
and world domination in general: Priceless.

2 Government agencies publish forms in Word and Excel format. Universities require
that students submit papers in Word format. Elementary schools publish their school
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lunch menus in Word format, for heaven’s sake. Who’s going to pay $550 to read a
lunch menu? Just get OpenOffice.org. Even if you don’t need most of the features, it
means you can read everything in the closed Microsoft world without living in it.

3 Ever have problems with backward compatibility? You’ve got Office 97 files around
that you can’t open with the current version of MS Office. No such problem with
OpenOffice.org or StarOffice; they’re more compatible with MS Office than MS
Office is.

4 This just in: It’s official. Bill Gates has enough money. Do you? If you and your
children in elementary school, your children at college, your small business, medium
business, enterprise, educational institution, church, synagogue, library, government
agency, law firm, sports league, volunteer organization, or Summons Service’n’Ice
Cream Parlor have all the money you need, great. But if not, you need the money
more than Bill does. Save it and go with OpenOffice.org instead of other office suites.

5 It’s the best drawing program you’ve never used. It’s got 3D stuff you’ve probably not
come across in Word’s drawing feature, Visio-like connector tools for architectural
and electrical diagrams, cool auto-measuring lines that display the measurement of
any object in the drawing (1-1 or to scale). And fancy text manipulation through
FontWorks. Plus photo editing in all the applications. Go to Guided Tour of Draw:
Vector and Raster Graphics on page 753.

6 No muss, no fuss data sources for mail merge (sending form letters to the 1204 people
in your contacts database), etc. All you need is your customer list, in a text file or
however you want it. The rest is incredibly slick and easy. We’ve included a tutorial
to prove how easy it is; see page 873.

7 UNIX users, get excited. Applix and the other former front office tools lacked a
certain something. Anyone who’s not an enthusiastic LaTeK user is breathing a huge
sigh of relief. Plus UNIX folks can now stay off of Windows 24/7, without a backup
system for running PowerPoint presentations.

8 OpenOffice.org 1.0 files might be the smallest files you ever create. They’re not in a
binary format anymore (like pretty much all the other desktop applications). They’re
XML. So other applications can open and deal with that format. It also means that you
can write and write, and import all sorts of graphics, and your file sizes will still be
miniscule. We wrote some 6.0 Writer documents that approached 80 pages and were
still under 100k. Impress, Draw, and Calc all make really small files too.

9 Whatever annoyances you had regarding StarOffice 5.2, forget it. This release rules.
Really. (We spent about 1200 hours writing the StarOffice 5.2 Companion. This
release is great.)

10 It’s a great principle, and a great reality. Open standards. XML file format. Nobody
has a stranglehold on anyone else. Nobody in Redmond controls anything you do.
This is the way software should be. And is.
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Program Essentials
It’s is a full-featured
office suite that you
can use to create text
documents and Web
pages, spreadsheets,
slide presentations,
and drawings and
images. Its three
main distinguishing
characteristics are
that it handles
(opens and creates)
Microsoft Office
formats, as well as
nearly 200 other
formats; its price is
microscopic
compared to Microsoft Office; and it runs on Linux, Lindows, and Solaris as well as
Microsoft Windows. And for anyone who’s experienced Microsoft’s licensing fees and
regulations, OpenOffice.org is a breath of fresh air on that front too.

Applications and Features
There are four main applications:

• Writer/Web for producing text
documents and Web pages

• Calc for spreadsheets

• Impress for slide presentations

• Draw for professional-quality
drawings (vector graphics) and image
editing (raster graphics)

Built into some or all of the applications
are the following features and add-ons:

• AutoPilots to guide you through
creating new documents and
importing data

• Charts and equations

• Data source connection capabilities for easy mail merges and access to your existing
databases
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• XML file formats for
easy opening by other
applications, plus
extremely small file
sizes

• Easy, high-quality
conversion to and from
Microsoft Office and
other files

• HTML hotlinks from
text or buttons

• Animation in
presentations, plus
animated GIFs

• Available in 23 languages, plus Asian language support

OpenOffice.org 1.0.1 is the current release at the time this book was written.
OpenOffice.org is pretty much the same as StarOffice; OpenOffice.org 1.0 corresponds
roughly to StarOffice 6.0. OpenOffice.org and StarOffice started from the same piece of
code. Since then, Sun has been working on StarOffice, and an organization of open source
programmers, has been working on OpenOffice.org. So there are some differences
between them, but they’re basically the same program.

Additional Release With New Features
Mere hours before sending this book to print, build 643 was released. Key features include
a macro recorder and native PDF. For more information, and to download build 643, see
http://www.openoffice.org/dev_docs/source/643/release_notes.html.

Participating in Creating OpenOffice.org
When was the last time you sent a Microsoft Word feature request to Bill Gates and got
him to put it in?

How You Can Get Involved

OpenOffice.org is open source, which means anyone can develop and add features. If you
want something in the software and you can code, then you can participate. You can also
participate in the QA and documentation process, as well. Go to
http://www.openoffice.org/contributing.html and http://www.openoffice.org/
about.html to learn more.
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Learning About Newly Developed Features
Sign up for the allfeatures@openoffice.org mailing list, at www.openoffice.org.

Differences Between StarOffice and 
OpenOffice.org
StarOffice 6.0 is a commercial product aimed at organizations and consumers while
OpenOffice.org 1.0 is aimed at users of free software, independent developers and the
open source community.

There is an ongoing partnership between Sun and the Open Office community, to develop
OpenOffice.org. Sun pays some of the programmers as well as for the
www.openoffice.org site. Improvements to OpenOffice.org typically are incorporated
into StarOffice where possible, and vice versa, where possible.

Figure 1-1 on page 9 shows the same document in StarOffice and in OpenOffice.org. The
key difference is that while the features are generally the same, anything that’s a third-
party addon in StarOffice, such as the Adabas database or the WordPerfect filter, is
missing or different in OpenOffice.org.

Note – The StarOffice spellchecker is an addon feature, created by a third party. Since this
feature couldn’t be licensed under open source, the OpenOffice.org spellchecker is differ-
ent. You might notice some differences if you use both programs.



Program Essentials  9

Figure 1-1 The same document in StarOffice and OpenOffice.org

The source code available at OpenOffice.org does not consist of all of the StarOffice code.
Usually, the reason for this is that Sun pays to license third party code to include in
StarOffice that which it does not have permission to make available in OpenOffice.org.
Items in StarOffice but not in OpenOffice.org include:

• Certain fonts

• The database component (Adabas D)

• Templates (see www.ooextras.org, www.getopenoffice.org/templates.html/)

• The clip art gallery is much smaller

• Some sorting functionality (Asian versions)

• Certain file filters, including WordPerfect (but they’re working on it)

WordPerfect StarOffice 6 for Windows has WordPerfect filters; these are proprietary to a
third party so could not be included in the open source product. Star Office 6.0 for UNIX
does not have WordPerfect filters included with it. However, a libwpd-based filter has
been written for OpenOffice.org's Writer application. Screenshots and downloads
available at http://libwpd.sf.net.libwpd is a generic library for importing (and
exporting, eventually) WordPerfect files into another application.

Spreadsheet in StarOffice. All formats are
available for both, in the Formats list for the

date format. The same formats for other types,
such as currency, are not available in both.

The same spreadsheet and Cell Attributes
window in OpenOffice.org.
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You’ll also see occasional differences in the layout of windows, such as where a certain
checkbox option appears, but usually not differences in the options available in a window.

All development on platforms beyond Solaris, Linux, and Windows is being done by
OpenOffice.org.

You can find out about features on allfeatures@openoffice.org; to sign up for this or
other mailing lists, go to http://www.openoffice.org/mail_list.html.

OpenOffice.org on Other Platforms
Porting projects—switching OpenOffice.org over to work with other platforms—have
been going on for a while. The one receiving the most attention at the time this book was
written is the Mac OSX porting project. In May 2002 OpenOffice.org released a pre-alpha
“Developer Build” for OpenOffice.org on Mac OSX., targeted at developers familiar with
developing for the Mac OS X platform.At that time, the download was available at
http://porting.openoffice.org/mac/ooo-osx_downloads.html It’s also on the CD
included with this book.

For information on other porting projects, go to http://porting.openoffice.org/

OpenOffice.org Templates and Other Extras
All the templates, etc. in StarOffice don’t come with OpenOffice.org. However, Travis
Bauer’s Web site, www.ooextras.org, has what might be called a plethora of templates
and other “extras.” The OpenOffice.org team has also put together a separate set of
templates. They’re on the CD included with this book.

You can see all template links, including templates created by the authors, at
www.getopenoffice.org/templates.html

Reference Documentation: API and DTD
The OpenOffice.org API is available through www.openoffice.org. Contact that site for
information about joining an OpenOffice.org project.

http://www.openoffice.org/about.html

http://www.openoffice.org/contributing.html

To get the DTD, the definition of the document formats, go to
http://xml.openoffice.org. Go to the Documentation and Resources section, then
follow the link to the DTD.

Developers should also go to http://api.openoffice.org, in particular:

http://api.openoffice.org/source/browse/api/devmanual/
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Switching From Microsoft Office 
Are you a dissatisfied Microsoft Office user? Come on in, the software’s fine.

Ten good reasons  If you haven’t, read Top Ten Reasons to Use OpenOffice.org on
page 4.

Take it out for a spin  Dip your toe in the pool. Use the CD with this book to install
OpenOffice.org and see how you like it. Note: OpenOffice.org has no WordPerfect import
filter at this time, though they’re working on it.

Try converting files  
Once you’ve dipped
your toe in the pool, try
a test import. We’re
pretty sure it’ll go really
well. Just open a
Microsoft Office file by
simply choosing File >
Open and choosing the
right format in the
format dropdown list.

You can also do a mass
import using the
AutoPilot, shown at
right. It’s no-risk
experimentation since it
leaves your Microsoft documents intact, just creating converted copies.

Spend some time with the tutorials Get to know OpenOffice.org.

• Chapter 5, Setup and Tips, on page 95

• Guided Tour of Writer on page 170

• Guided Tour of Web on page 444

• Guided Tour of Calc on page 500

• Guided Tour of Impress on page 636

• Guided Tour of Draw: Vector and Raster Graphics on page 753

• Tutorial: Creating a Data Source on page 873
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What’s New
OpenOffice.org is fairly different from StarOffice 5.2. Key differences are that the unified
desktop is gone, Schedule Mail and StarBase are gone, and the focus groups they did on
usability were taking good notes. There’s more detail on those and other changes in the
following sections.

Compatibility and Migration
StarOffice 5.2, StarOffice 6.0, and OpenOffice.org all play nicely together—you don’t
need to uninstall any of them. Just be sure to uninstall StarOffice 6.0 BETA before you
install a later version of OpenOffice.org.

You can open 5.2 files in OpenOffice.org 1.0, plus save new files back to 5.2. There’s an
AutoPilot for mass import from 5.2.

Migration is pretty good; it doesn’t do everything but does take care of customization and
mail. See Chapter 3, Migrating From StarOffice 5.2 to OpenOffice.org 1.0, on page 43.

Removed Applications and Features
The new version is leaner and trimmer than the somewhat overburdened 5.2 release. This
section gives you a quick overview of what’s out, and how to compensate for a few of the
removals.

What’s Gone or Really Different

They took out:

• The whole integrated desktop thing, including Explorer and Beamer and some
associated features.

• FTP through Explorer.

• Image as a separate application, though most of the features are still present. Just click
on the raster image once or twice in any of the other applications and the image
editing toolbar and menus will appear.

• Mail, though you can export your mail and address book, and connect to an existing
address book like Netscape or Outlook.

• Schedule, including Palm Pilot.

• Creating databases (though you can still connect to a variety of databases through
ODBC, JDBC, etc.).

• Support for creating frames in Web.

• The Pack feature for presentations. It was removed because the files are so small they
don’t need packing. The Impress Player standalone program was also removed.
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Removal of Database Creation Ability, Except Adabas

Instead of creating and maintaining a proprietary StarOffice database format (.sdb), The
current data source connection system works with common database connection standards
like JDBC and databases like dBase.

You can still create database tables, queries and forms, though this varies a bit depending
on the underlying method of data storage.

New Application-Wide Features
Here’s a somewhat detailed list of what’s new. Not a lot is new that will affect how you
use the specific features—it’s more a case of structure and underpinnings that changed to
make the whole experience better.

XML file format  Remember creating Impress and Writer files that were over 2 MB before
you even got going? That’s over. You can create a Writer file that’s a couple kilobytes per
page. Formatting’ll kick it up, but it’s still really impressive. You’ll have to really work
hard to get even a 1 MB file.

SVG and EPS  EPS rendering and reading is better, and you can export drawings to SVG,
Scalable Vector Graphics, an XML-based format.

Font stuff  There are new “metrically compatible” TrueType Microsoft Windows core
fonts. Font substitution is better. You can set up font substitution with a new improved
algorithm that makes the matching better, including across platforms.

Asian font support  It’s got Unicode support, Ruby text, and double-byte character
support.

Image editing features in all applications Click on any GIF or other raster object and
the editing toolbar, formerly only in Image, appears.

Gallery The Gallery of pictures and sounds from 5.2 was moved from the Explorer/
Beamer area to Tools > Gallery. You can add to the existing themes, which you couldn’t
before, and make your own new themes of images and sounds.

Password encryption The XML-based file format also supports password encryption for
text documents and spreadsheets. Passwords are stored as encrypted hash values. When
saving files to the old binary format, passwords aren’t encrypted. However, when you load
a document from a former version, the password will be encrypted again.

Standard address book support You don’t have your old 5.2 address book but you can
connect to the one you use for mail, or other address books. The AutoPilot steps you
through connecting to your address book.

Improved HTML export You can define the text encoding for the HTML export choosing
from a variety of character sets, including Unicode, using the new Character Set dialog
box in the HTML Compatibility dialog box.
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MathML equation support Supports exports and imports of the W3 XML format.

Enhanced cut and paste The Paste button on the Function bar has a drop-down menu
where you choose whether you want to paste in the text or object’s original format or in a
special format. They’re the same options you get when you choose Edit > Paste Special.

Better undo/redo You can undo a lot farther back than before; set up the number of undo
steps by choosing Tools > Options > OpenOffice.org > General.

Writer and Web
Better labels You can modify existing label brands and types and save them as your own
label format; includes the latest Avery label specifications.

Section protection enhanced You can assign different passwords to individual sections.
In previous version, you could only use one password for all sections. Choose Insert >
Section > Format > Section > Protect Record.

Password protection for recording editing changes The Records feature is typically
used to make changes visible when two or more people collaborate on one document.
Choose Edit > Changes > Protect Records.

Improved line numbering  Restart the numbering of lines with every new page. Choose
Tools > Line Numbering.

Negative indents You can set negative (left or right) indents to paragraphs and tables,
and specify the first line indent independently from the left indent of a paragraph. Choose
Format > Paragraph > Indents & Spacing.

For tables you can also set negative values for the alignment from left. This lets you align
tables independently of the page setup margins.

Hyphenation Define the minimal number of characters for hyphenation by choosing
Tools > Options > Language Settings > Writing Aids.

Vertical text Want to write something down the side of your page? You got it. There are
now vertical versions of the three Draw text creation tools, available in Writer through the
Show Drawing Tools menu.

Calc
ROMAN and ARABIC functions Convert a value between 0 and 3999 to a Roman style,
or convert a text that represents a Roman number into a value (between 0 and 3999).

Additional new functions The new functions are:

• MIRR: Calculate the modified internal rate of return for a series of cash flows with
interest rates for investments and reinvestments.

• CELL: Provide information about content, formatting or location of a specific cell.
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• ISPMT: Calculate the interest of a credit or investment with constant redemption
rates.

• Analysis Addin: Provide new analysis functionality and improved Excel import.

Import HTML tables into spreadsheets Insert data from external sources (like linked
areas or WebQueries). Choose Insert > External Data.

Sort options  Specify language- and locale-dependent sort options. The default sort
option depends on the system language setting and locale. Choose Data > Sort > Options.

Matrix arrays Improved complex scientific calculations. The number of elements that
can be used in a matrix array, has been increased. In former versions this number was
limited to 16384 elements per matrix, the new limit is 512k elements.

New print options Suppress output of empty pages: If this option is active, pages that
don't contain cell contents or drawing objects are not printed. Cell attributes (like borders
or background color) are an exception and don't count as content. Print only selected
sheets: If this option is active, choosing All in the print dialog prints only selected sheets.

Improved calculation time and use less memory The maximum string length in
formulas has been increased from 255 bytes to 64KB.

Improved operations  Perform multiple operations with greater flexibility. This feature
now extends to formulas that contain references to other formulas. A multiple operation is
no longer restricted to act only on the formula selected in the dialog box. Instead, cell
addresses that are indirectly referred to are replaced in every formula encountered during
the calculation of a multiple operation.

Improved percentage calculations  The percent sign operator is recognized in formulas
and the result is displayed formatted as a percent value if appropriate. The percent sign
operator divides the preceding subexpression by 100. This helps with Excel conversion.

Improved recognition of English date formats This is in addition to the default formats
set by the system language, when importing a text file into Calc. This enables you to
import formats such as 12-Mar-01 independent of the format used by system language.
Choose File > Open > Text filter.

Improved Import and export of 16-bit Unicode text files Choose File > Open or File >
Save As. and select the Text CSV format.

Improved display of line breaks  Solve the problem of having different line breaks
appear on print and on screen when you select the line break alignment option for cells.
Using this option shows line breaks as they appear in print on-screen.

Hyphenate text in cells  This option is when used with the Line Break wrap option.
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Database Access and Data Source Creation
You can’t create new databases anymore, except with Adabas. You can create data
sources, just hookups to a stored source of data, that connect to something as simple as an
address book, a spreadsheet, or a text file. So yes, you can create new data sources, plus
you can connect via JDBC, etc. to industry standard databases like Oracle. See Chapter
35, Creating and Modifying Data Sources, on page 871.

Connect to data sources instead of making them Instead of creating and maintaining a
proprietary StarOffice database format (.sdb), OpenOffice.org can connect and administer
a wide variety of data sources and provide data access to all components.

Administration  You can also copy tables and queries between data sources, and copy a
query as a table.

Import your StarOffice 5.2 (or earlier) databases  The Database Import AutoPilot will
store your existing StarOffice queries, forms, and reports in the new DataAccess.xml
configuration file. Form documents will be stored as regular documents.

Assign a database table to a combo or list box  Pick up data through a field.

New form events Before reloading: Called before a reload on the form is executed.
Before unloading: Called before the form is unloaded.

Edit table indexes  This component has been completely rewritten. A new Index Design
button on the Table Design toolbar gives you one-click access to Indexes dialog box.

UTF-8 character suite support This support does not extend to ADO data sources
(which don’t have a character set), and dBase data sources.

Draw, Impress, and Image-Editing Features
Rotate meta files Used to be, you couldn’t rotate metafiles, just bitmaps. Now you can.

Maximum size for caching  Set an upper limit (in KB) for the total graphics cache size,
and cache a single graphic object. Choose Tools > Options > OpenOffice.org > General.

Vertical text There are now vertical versions of the three Draw text creation tools,
available in Writer as well through the Show Drawing Tools menu.

Printing options for graphics and gradients  The new options include the following; to
get to them, choose Tools > Options > OpenOffice.org > Print.

• Reduced Transparency: Treat all transparent objects as non-transparent.

• No transparency: Always reduces transparency completely.

• Reduce gradients: Decreases the number of gradient steps for easier printing.

• Reduce bitmaps: Prints transparent bitmaps at the maximum resolution (in dpi).

EPS and SVG export Create both formats by exporting from Draw.
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The OpenOffice.org CD
The CD included with this OpenOffice.org Companion Collection includes not just the
software, but many additional files, created by exceptionally talented and dedicated
members of the OpenOffice.org Open Source community. The contents include:

• Animated introduction to OpenOffice.org

• Reviews of OpenOffice.org in the online media

• The OpenOffice.org Installation and Setup Guide

• Installation files for Solaris, Windows, and Linux operating systems

• Mac OS X Public Beta Distribution

• Additional dictionaries

• First steps with Writer - an animated guide for the first-time user

• Extra documentation

• Samples and templates created by the OpenOffice.org community, including files
from the excellent site http://www.ooextras.org

• OpenOffice.org 1.0.1 Source Code

• Adobe Acrobat Reader

• OpenOffice.org LGPL and SISSL licenses

• Various files related to this CD

Note – Mere hours before sending this book to print, build 643 was released. Key features
include a macro recorder and native PDF. For more information, and to download build
643, see http://www.openoffice.org/dev_docs/source/643/release_notes.html.

Prentice Hall, Solveig Haugland, and Floyd Jones wish to thank in particular Louis
Suarez-Potts, Chris Herrnberger, Josh Berkus, Justin Clift, Sam Hiser, Scott Carr, and
Travis Bauer for their hard work and gracious spirit which enabled us to include their
carefully assembled CD with this book. To learn more about OpenOffice.org, see
http://www.openoffice.org.

Additional extra files and tips are available at http://www.getopenoffice.org.


